Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Autofill aus Datensatz
zurück: brauche hilfe bei vba code mit eingabebox weiter: Tabelle läuft von selbst Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
_Snoopy_
Gast


Verfasst am:
28. Okt 2006, 14:42
Rufname:

Autofill aus Datensatz - Autofill aus Datensatz

Nach oben
       Version: Office XP (2002)

Hi,

da ich mich in Sachen Datum/Uhrzeit in Excel noch nicht so auskenne würde ich mich freuen wenn ihr mir bei folgendem Problem ein paar Tipps geben könntet:

Aus einem Datensatz habe ich in einer Tabelle das Datum und in einer anderen die entsprechende Uhrzeit(Spalten K und M). Die Problematik ist das ich nun für die statistische Auswertung daneben eine Tabelle habe in der oben die Tage von Montag bis Sonntag und nach unten die Uhrzeit durchweg im bestimmten Abstand für 24h angegeben ist (siehe Bild).
Nun soll automatisch aus Spalten K und M der Wochentag(an dem Datum) und die Uhrzeit ausgewertet werden und entsprechend ein "x" in der Spalte rechts daneben eingetragen werden.
Zusammenfassend also aus den Spalten K und M nach Wochentag und Uhrzeit entsprechend die Tabelle daneben befüllt.

[img=http://img284.imageshack.us/img284/9117/unbenanntzg6.th.jpg]
Hübi
Es gibt immer bessere Lösungen, als meine.


Verfasst am:
29. Okt 2006, 17:28
Rufname: Hübi (selten Herbert)
Wohnort: Strausberg


AW: Autofill aus Datensatz - AW: Autofill aus Datensatz

Nach oben
       Version: Office XP (2002)

Hi Snoopy,

meinst du es so
Tabelle1

 KLMNOPQ
2     MoDi
3    00:00  
4Datum Uhrzeit 00:15  
5So 01.01.2006   00:301 
6Mo 02.01.2006 00:30 00:45 2
7Di 03.01.2006 00:45 01:00  
8Mi 04.01.2006   01:15  
9Do 05.01.2006   01:30  
10Fr 06.01.2006   01:451 
11Sa 07.01.2006   02:00  
12So 08.01.2006   02:15  
13Mo 09.01.2006 01:45 02:30  
14Di 10.01.2006 00:45 02:45  
15Mi 11.01.2006   03:00  

Formeln der Tabelle
ZelleFormel
P3=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(A1))*($M$5:$M$35=$O3))
Q3=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(B1))*($M$5:$M$35=$O3))
P4=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(A2))*($M$5:$M$35=$O4))
Q4=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(B2))*($M$5:$M$35=$O4))
P5=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(A3))*($M$5:$M$35=$O5))
Q5=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(B3))*($M$5:$M$35=$O5))
P6=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(A4))*($M$5:$M$35=$O6))
Q6=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(B4))*($M$5:$M$35=$O6))
P7=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(A5))*($M$5:$M$35=$O7))
Q7=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(B5))*($M$5:$M$35=$O7))
P8=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(A6))*($M$5:$M$35=$O8))
Q8=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(B6))*($M$5:$M$35=$O8))
P9=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(A7))*($M$5:$M$35=$O9))
Q9=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(B7))*($M$5:$M$35=$O9))
P10=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(A8))*($M$5:$M$35=$O10))
Q10=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(B8))*($M$5:$M$35=$O10))
P11=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(A9))*($M$5:$M$35=$O11))
Q11=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(B9))*($M$5:$M$35=$O11))
P12=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(A10))*($M$5:$M$35=$O12))
Q12=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(B10))*($M$5:$M$35=$O12))
P13=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(A11))*($M$5:$M$35=$O13))
Q13=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(B11))*($M$5:$M$35=$O13))
P14=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(A12))*($M$5:$M$35=$O14))
Q14=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(B12))*($M$5:$M$35=$O14))
P15=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(A13))*($M$5:$M$35=$O15))
Q15=SUMMENPRODUKT((WOCHENTAG($K$5:$K$35;2)=SPALTE(B13))*($M$5:$M$35=$O15))


Die Formel aus P3 lässt sich problemlos nach unten und zur Seite erweitern.

_________________
Gruß Hübi
[Tipps getestet mit Win XP Prof. SP-2, Office 2000 Premium SP3 / Office 2003 Prof. SP3 / Office Professional 2007 SP1]
_Snoopy_
Gast


Verfasst am:
29. Okt 2006, 18:34
Rufname:

AW: Autofill aus Datensatz - AW: Autofill aus Datensatz

Nach oben
       Version: Office XP (2002)

Das ist an sich genau das was ich meine, vielen Dank.
Habe es gleich mal versucht aber habe überall jetzt 0 als "Ergebnis" drin stehn. Ich weiss nicht ob das damit zusammenhängen kann das in der rechten Spalte ja die Wochentage nur als Text,und nicht direkt als "Wochentag" eingetragen sind und somit nicht verglichen werden können.
Was mich aber noch etwas verwirrt sind in deinen Formeln die Verweise auf
Spalten A und B:

" =SPALTE(A1))*($M$5:$M$35=$O3)) "

An sich sind A und B doch vollkommen ohne Verwendung, oder verstehe ich jetzt etwas nicht richtig?
Hübi
Es gibt immer bessere Lösungen, als meine.


Verfasst am:
29. Okt 2006, 18:56
Rufname: Hübi (selten Herbert)
Wohnort: Strausberg

AW: Autofill aus Datensatz - AW: Autofill aus Datensatz

Nach oben
       Version: Office XP (2002)

Hi,

die Nullen formatierst du z. B. mit dem benutzerdefinierten Zahlenformat 0;;; weg.
SPALTE(A1) liefert 1, Spalte(B1) - 2,....
Wochentag(Datum;2) liefert 1 für Montag, 2 für Dienstag, .... 7 für Sonntag.
Da ich vergleiche und die Formel ziehbar machen wollte, habe ich zu Spalte() gegriffen - reine Bequemlichkeit.

WOCHENTAG($K$5:$K$35;2)=SPALTE(A1) ist gleichbedeutend mit (WOCHENTAG($K$5:$K$35;2)=1,
WOCHENTAG($K$5:$K$35;2)=SPALTE(B1) ist gleichbedeutend mit (WOCHENTAG($K$5:$K$35;2)=2

In welchem Format bei mir die Einträge vorliegen, siehst du an der Ausrichtung in der Zelle: Text steht links, Zahlen rechts.

_________________
Gruß Hübi
[Tipps getestet mit Win XP Prof. SP-2, Office 2000 Premium SP3 / Office 2003 Prof. SP3 / Office Professional 2007 SP1]
_Snoopy_
Gast


Verfasst am:
29. Okt 2006, 19:20
Rufname:


AW: Autofill aus Datensatz - AW: Autofill aus Datensatz

Nach oben
       Version: Office XP (2002)

Das wegformatieren ist kein Problem....aber das bringt ja leider nicht viel da
das Ergebnis IMMER 0 wird....

Ich habs nochmal fix alsBild:
[img=http://img69.imageshack.us/img69/5041/unbenanntbh9.th.jpg]


Formatiert hab ich jetzt die Wochentage im Kopf mit
=TEXT(WOCHENTAG(3;2);"TTTT") (für Montag usw.) damit es nicht mehr nur Text ist,bringt aber nix[/img]
Hübi
Es gibt immer bessere Lösungen, als meine.


Verfasst am:
29. Okt 2006, 19:38
Rufname: Hübi (selten Herbert)
Wohnort: Strausberg

AW: Autofill aus Datensatz - AW: Autofill aus Datensatz

Nach oben
       Version: Office XP (2002)

Hi,

was in Zeile 2 steht ist völlig uninteressant - die kann auch leer bleiben. Sehr wichtig ist aber, dass in Spalte K ein Datum steht (als Zahl), in Spalte M und O die Zeiten ebenfalls als Zahlen stehen - natürlich formatiert mit Datum oder Zeit.
Ich vermute mal, dass die Zeiten in Sp. O bei dir als Text stehen. Genau erkenne ich es auf dem Bild leider nicht.

Zitat:
Formatiert hab ich jetzt die Wochentage im Kopf mit
=TEXT(WOCHENTAG(3;2);"TTTT") (für Montag usw.) damit es nicht mehr nur Text ist,bringt aber nix

Das ist Quatsch, denn mit TEXT() erzeugst du ja bewusst Text und die Fkt. Wochentag() ist auch nicht richtig.

_________________
Gruß Hübi
[Tipps getestet mit Win XP Prof. SP-2, Office 2000 Premium SP3 / Office 2003 Prof. SP3 / Office Professional 2007 SP1]
_Snoopy_
Gast


Verfasst am:
29. Okt 2006, 20:00
Rufname:

AW: Autofill aus Datensatz - AW: Autofill aus Datensatz

Nach oben
       Version: Office XP (2002)

K ist als Datum und M und O sind mit xx:xx als Uhrzeit formatiert.
Das einzige wo ich mir jetzt noch etwas vorstellen kann ist ein Foramierungsfehler in M.
Die Uhrzeiten werden aus einem andern Datenblatt übernommen, das heisst
es werden Daten nach Kriterien überprüft und wenn diese erfüllt sind wird diese Datum in eine dahinterliegende Spalte kopiert...jetzt aber nur formatiert als Uhrzeit ohne die restliche Daumsangabe. Und genau diese Uhrzeit taucht hier in der Spalte M auf.
Aber normalerweise ist das alles ja nun eine Uhrzeit und müsste funktionieren. Habe deine Version seperat mal erstellt und sie funktioniert
tadellos. Es kann jetz an sich nur an der Parameterübergabe liegen meiner Meinung nach-ich werde mal noch bissl probieren. Vielen Dank aber für deine
Mühen, ich weiss es sehr zu schätzen Smile !!
_Snoopy_
Gast


Verfasst am:
29. Okt 2006, 21:03
Rufname:

AW: Autofill aus Datensatz - AW: Autofill aus Datensatz

Nach oben
       Version: Office XP (2002)

Hatte Recht, der Fehler lag/liegt tatsächlich bei der Übergabe, wenn ich es von Hand eingebe funktioniert es nämlich.
Hab aber noch einen Fehler entdeckt:

Wenn man es mal mehr Werte nimmt erhält man in der Spalte vom Samstag
auf einmal bei 00:00 Uhr utopische Werte.

[img=http://img119.imageshack.us/img119/7017/unbenanntsu2.th.jpg]
Hübi
Es gibt immer bessere Lösungen, als meine.


Verfasst am:
29. Okt 2006, 22:38
Rufname: Hübi (selten Herbert)
Wohnort: Strausberg

AW: Autofill aus Datensatz - AW: Autofill aus Datensatz

Nach oben
       Version: Office XP (2002)

Hi,

warum zeigst du nicht die Formel aus U3?
Zitat:
Wenn man es mal mehr Werte nimmt erhält man in der Spalte vom Samstag auf einmal bei 00:00 Uhr utopische Werte.

Das sagt mir fast nichts
Ich erhalte richtige Ergebnisse. Razz

Hast du allerdings den Datum- und Zeit-Bereich (Sp. K und M) vergrößert und nicht alle Datums eingetragen sind, kannst du mal diese Formel probieren.
=SUMMENPRODUKT((WOCHENTAG($K$5:$K$5000;2)=SPALTE(F1))*($K$5:$K$5000>0)*($M$5:$M$5000=$O3))

_________________
Gruß Hübi
[Tipps getestet mit Win XP Prof. SP-2, Office 2000 Premium SP3 / Office 2003 Prof. SP3 / Office Professional 2007 SP1]
_Snoopy_
Gast


Verfasst am:
30. Okt 2006, 11:29
Rufname:


AW: Autofill aus Datensatz - AW: Autofill aus Datensatz

Nach oben
       Version: Office XP (2002)

"=SUMMENPRODUKT((WOCHENTAG($K$5:$K$5000;2)=SPALTE(F1))*($M$5:$M$5000=$O3))"
stand bei Sa drin.
Habe es durch deine andere Formel ersetzt und jetzt is das auch alles ok.
Warum dieses Problem nur bei Samstagen auftauchte ist mir zwar ein Rätsel,
da es an sich nur gezogen ist.

Warum es bei mir nicht funktionierte und überall 0 kamen weiss ich jetzt auch-das Problem war das es keine Uhrzeiten in M waren sondern nur als
"Uhrzeit formatierte" Datums. Also wenn Uhrzeit und Datum trenne funktioniert das dann schon Smile
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Alternative zu Verweis-Formel, wenn Datensatz sehr groß 8 Matilda87 90 05. Aug 2013, 14:29
Matilda87 Alternative zu Verweis-Formel, wenn Datensatz sehr groß
Keine neuen Beiträge Excel Formeln: Hilfe Excelformel Vergleich neuer Datensatz 5 Blondchen 106 11. Jul 2013, 15:03
Tobias.R. Hilfe Excelformel Vergleich neuer Datensatz
Keine neuen Beiträge Excel Formeln: Wert einer Zelle vergleichen Datensatz kopieren 4 MaFra 89 24. Mai 2013, 13:48
Gast Wert einer Zelle vergleichen Datensatz kopieren
Keine neuen Beiträge Excel Formeln: Verweis - Datensatz mit nächstgrößeren 4 Bedingungen 3 FritzFish 103 06. Dez 2012, 10:22
Guenter_Steiner Verweis - Datensatz mit nächstgrößeren 4 Bedingungen
Keine neuen Beiträge Excel Formate: Seriendruckausgabe nur aktueller Datensatz 0 chrimap 183 15. Mai 2012, 10:11
chrimap Seriendruckausgabe nur aktueller Datensatz
Keine neuen Beiträge Excel Formeln: Formel mit Bezug auf senkrechten und waagerechten Datensatz 1 Seegers 189 27. Apr 2012, 01:06
Ellesmitt Formel mit Bezug auf senkrechten und waagerechten Datensatz
Keine neuen Beiträge Excel Formeln: Suche Datensatz, dann Zelle daneben Prüfen, anschließend... 2 C.Excel 311 06. Dez 2011, 16:27
Gast Suche Datensatz, dann Zelle daneben Prüfen, anschließend...
Keine neuen Beiträge Excel Formeln: exel AutoFill Funktion 16 Futurebase 914 24. Jul 2011, 19:39
Gast exel AutoFill Funktion
Keine neuen Beiträge Excel Formeln: Bewerungsmatrix mit Datensatz verknüpfen 4 trifolium 407 02. Feb 2011, 08:54
Gast Bewerungsmatrix mit Datensatz verknüpfen
Keine neuen Beiträge Excel Formeln: Variabler zugriff auf Datensatz anderer Tabelle 1 willy05 386 23. Jul 2010, 09:41
shift-del Variabler zugriff auf Datensatz anderer Tabelle
Keine neuen Beiträge Excel Formeln: Langen Datensatz auf verschiedene Tabellenblätter aufsplitte 5 McFrag 290 09. Dez 2008, 17:03
Klaus-Dieter Langen Datensatz auf verschiedene Tabellenblätter aufsplitte
Keine neuen Beiträge Excel Formeln: Werte anhand lfd. Nr. aus einem Datensatz aussortieren 3 &#966;&#961;& 399 01. Jul 2008, 17:41
&#966;&#961;& Werte anhand lfd. Nr. aus einem Datensatz aussortieren
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Web Editor Forum