Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: -------> Neu: dotNet & Visual Studio Forum <-
Index,Zählenwenn mit Sverweis???
zurück: Problem mit der Index funktion weiter: Erinnerung an betsimmten Datum Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Olaf62
Im Profil kannst Du frei den Rang ändern


Verfasst am:
22. Jun 2007, 11:03
Rufname:
Wohnort: Hannover

Index,Zählenwenn mit Sverweis??? - Index,Zählenwenn mit Sverweis???

Nach oben
       Version: Office XP (2002)

Hallo zusammen,
da ich hier noch relativ neu bin, seien mir Fehler beim hochladen einer Datei bitte verziehen.

Ich möchte in das Tabellenblatt "Kurzübersicht" aus dem Tabellenblatt "Erfassen" die Namen aus B3:B7 übernehmen. Kriterium ist die Anwesenheit in den Spalten C2:G2 aus dem Tabellenblatt "Erfassen".

Die Formel für Zelle B3 in Tabellenblatt "Kurzübersicht" ist:

{=WENN(ZEILEN(Erfassen!$2:2)>ZÄHLENWENN(Erfassen!C:C;Kurzübersicht!$C$2);"";INDEX(Erfassen!B:B;KKLEINSTE(WENN(Erfassen!$C$1:$C$100=Kurzübersicht!$C$2;ZEILE(Erfassen!$1:$100));ZEILE(Erfassen!B2))))}

Das klappt für die erste Spalte (C) auch hervorragend. Danke nochmal an dieser Stelle für die Unterstützung Detlef 42 und Xerxes von gestern.

Es sollen jetzt aber die Spalten D:G dargestellt werden. Dies funktioniert bei o.g. Formel nicht. Einschränkung durch WENN?

Wie kann ich die Formel "flexibel" umbauen?

Bin für jede Hilfe dankbar

Gruß
Olaf



Anwesend.xls
 Beschreibung:

Download
 Dateiname:  Anwesend.xls
 Dateigröße:  26 KB
 Heruntergeladen:  38 mal

efmk
Office-Kenner incl. VBA


Verfasst am:
22. Jun 2007, 11:43
Rufname:


AW: Index,Zählenwenn mit Sverweis??? - AW: Index,Zählenwenn mit Sverweis???

Nach oben
       Version: Office XP (2002)

Hallo Olaf,

siehe anhängende Datei.

gruß
efmk

_________________
„Es ist nicht gesagt, dass es besser wird, wenn es anders wird. Wenn es aber besser werden soll, muss es anders werden.“



Anwesend.xls
 Beschreibung:

Download
 Dateiname:  Anwesend.xls
 Dateigröße:  29 KB
 Heruntergeladen:  48 mal

Olaf62
Im Profil kannst Du frei den Rang ändern


Verfasst am:
22. Jun 2007, 12:18
Rufname:
Wohnort: Hannover

AW: Index,Zählenwenn mit Sverweis??? - AW: Index,Zählenwenn mit Sverweis???

Nach oben
       Version: Office XP (2002)

Hallo "efmk"

danke für deine schnelle Antwort. Vielleicht habe ich mich nicht klar genug ausgedrückt. Das Ergebnis soll in Spalte C2:C100 im Tabellenblatt "Übersicht" gezeigt werden.
Wenn Eingabe "2" in C2 "Übersicht" sollen links daneben die Anwesenden aus "Erfassen" B2:B100 erscheinen. Da das ganze mit der von mir genannten Formel nur für den Bereich "Erfassen" Spalte "B" funktioniert, denke ich, kommen wir mit "SVERWEIS" vielleicht weiter. Ich habe mehrere Varianten probiert, komme aber zu keinem Ergebnis.
Gruß
Olaf
Detlef 42
Tastet . . . sucht . . . und trifft manchmal


Verfasst am:
22. Jun 2007, 16:58
Rufname:
Wohnort: RE

AW: Index,Zählenwenn mit Sverweis??? - AW: Index,Zählenwenn mit Sverweis???

Nach oben
       Version: Office XP (2002)

hallo Olaf,

weis nicht genau ob das Deinem Wunsch ähnlich kommt, hier werden die Namen nach unterschidlichen Spalten (Tagen?) ausgegeben. Je nach Eintragungen.

Tabelle1
 ABCDEFG
1HansMeieraa cd
2OttoMessba cd
3HelmutSchmidtac ad
4GerhardSchröderaa aa
5Willyhossaa ba
6HugoBosscd ba
7BerndHüserca cc
8JussufAbrahamaa cc
9JamalKarsliac ac
10SergeMoskovicdc aa
 
Excel Jeanie Html

Tabelle2
 ABCDEFGH
1VornameNachnameTrainer Trainer:aaus Spaltef
2HelmutSchmidta     
3GerhardSchrödera     
4JamalKarslia     
5SergeMoskovica     
6        
7        
8        
9        
10        
11        
12        
13        
14        
15        
16        
Formeln der Tabelle
A2 : {=WENN(ZEILEN($2:2)>ZÄHLENWENN(INDIREKT("Tabelle1!"&$H$1&"1:$"&$H$1&"1000");$F$1);"";INDEX(Tabelle1!A:A;KKLEINSTE(WENN(INDIREKT("Tabelle1!"&$H$1&"1:$"&$H$1&"1000")=$F$1;ZEILE(Tabelle1!$1:$1000));ZEILE(A1))))}
B2 : {=WENN(ZEILEN($2:2)>ZÄHLENWENN(INDIREKT("Tabelle1!"&$H$1&"1:$"&$H$1&"1000");$F$1);"";INDEX(Tabelle1!B:B;KKLEINSTE(WENN(INDIREKT("Tabelle1!"&$H$1&"1:$"&$H$1&"1000")=$F$1;ZEILE(Tabelle1!$1:$1000));ZEILE(B1))))}
C2 : {=WENN(ZEILEN($2:2)>ZÄHLENWENN(INDIREKT("Tabelle1!"&$H$1&"1:$"&$H$1&"1000");$F$1);"";INDEX(INDIREKT("Tabelle1!"&$H$1&":"&$H$1);KKLEINSTE(WENN(INDIREKT("Tabelle1!"&$H$1&"1:$"&$H$1&"1000")=$F$1;ZEILE(Tabelle1!$1:$1000));ZEILE(C1))))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Excel Jeanie Html


ist das brauchbar?

_________________
Gruß

Detlef

. . . wer nicht fragt bleibt stehen . . .
Gast



Verfasst am:
22. Jun 2007, 17:54
Rufname:

AW: Index,Zählenwenn mit Sverweis??? - AW: Index,Zählenwenn mit Sverweis???

Nach oben
       Version: Office XP (2002)

Hallo Detlef,
deine Formeln klappen super. Hast du die Möglichkeit, bzw. Zeit, mir diese Formel "näher" zu bringen? Denn selbst der längste Weg beginnt mit einem Schritt...

Danke

Gruß
Olaf
Detlef 42
Tastet . . . sucht . . . und trifft manchmal


Verfasst am:
22. Jun 2007, 19:18
Rufname:
Wohnort: RE

AW: Index,Zählenwenn mit Sverweis??? - AW: Index,Zählenwenn mit Sverweis???

Nach oben
       Version: Office XP (2002)

Hallo Olaf,

Dein Ansinnen ist sicherlich zu viel der Ehre für mich. Ich selbst hab überall blaue Flecken von den EXCEL-Ecken an die ich mich stosse. 70 % all meiner Versuche enden so.
Mein Vorgehen eine Formel nachzuvollziehen besteht zuerst, anhand der vorkommenden ";" diese in Teile aufzusplitten. Traue mir jedoch nicht zu, etwas Anderen zu erklären, was ich selbst nur mit Mühe verstehe . . . Informatik muß halt studiert werden. Mehr noch, dieses zu vermitteln.

Wenn Du hierzu nochmal freundlich einen der hier mirtlesenden Experten bittest, wird dir sicherlich geantwrtet.

_________________
Gruß

Detlef

. . . wer nicht fragt bleibt stehen . . .
Gast



Verfasst am:
22. Jun 2007, 19:52
Rufname:


AW: Index,Zählenwenn mit Sverweis??? - AW: Index,Zählenwenn mit Sverweis???

Nach oben
       Version: Office XP (2002)

Hallo Detlef,
keine falsche Bescheidenheit! Aber ist o.k. Werde deinen Rat befolgen.

Danke nochmal

Gruß
Olaf
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Problem mit sverweis 6 Yvi 637 11. Nov 2004, 16:38
ae Problem mit sverweis
Keine neuen Beiträge Excel Formeln: fehlerhafter SVERWEIS 15 Gast 2194 08. Nov 2004, 15:09
Gast fehlerhafter SVERWEIS
Keine neuen Beiträge Excel Formeln: problem mit sverweis 7 alex81 1253 28. Okt 2004, 21:51
ae problem mit sverweis
Keine neuen Beiträge Excel Formeln: Koennte ein Sverweis sein *{=SUMME((MONAT(A1:A7)=E1)*(C1:C7) 2 Gast 1346 25. Okt 2004, 20:15
Gast Koennte ein Sverweis sein *{=SUMME((MONAT(A1:A7)=E1)*(C1:C7)
Keine neuen Beiträge Excel Formeln: Sverweis - nicht alphabetisch 5 Gast 2578 21. Okt 2004, 06:32
Andre1977 Sverweis - nicht alphabetisch
Keine neuen Beiträge Excel Formeln: Problem mit Sverweis 1 Bernett22 1863 19. Okt 2004, 09:32
tom_r Problem mit Sverweis
Keine neuen Beiträge Excel Formeln: Probleme mit SVERWEIS 2 axbaer 865 11. Okt 2004, 21:43
fl618 Probleme mit SVERWEIS
Keine neuen Beiträge Excel Formeln: SVERWEIS, Wert aus der nächsten zelle 9 Dave 5426 11. Okt 2004, 13:50
Dave SVERWEIS, Wert aus der nächsten zelle
Keine neuen Beiträge Excel Formeln: Suche Formel (zählenwenn mit mehreren Krit - Summenprodukt) 17 akm1978 4066 02. Okt 2004, 23:27
Gast Suche Formel (zählenwenn mit mehreren Krit - Summenprodukt)
Keine neuen Beiträge Excel Formeln: Sverweis HELP!!!!!! 2 Black_Samurai 1755 30. Sep 2004, 18:12
Black_Samurai Sverweis HELP!!!!!!
Keine neuen Beiträge Excel Formeln: wenn oder sverweis 2 Bernett22 1253 20. Sep 2004, 09:59
Bernett22 wenn oder sverweis
Keine neuen Beiträge Excel Formeln: SVERWEIS (VLOOKUP) und sortierte Liste 2 Aloha 2067 07. Sep 2004, 18:55
Aloha SVERWEIS (VLOOKUP) und sortierte Liste
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Access Tabellen