Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: -------> Neu: dotNet & Visual Studio Forum <-
Zeilen bedingt ausblenden
Gehe zu Seite 1, 2, 3  Weiter
zurück: Matrizen multipizieren, invertieren und transpunieren weiter: Dateiimport aus anderer Datei für Gültigkeit Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
AngelWare
Laie


Verfasst am:
08. Dez 2007, 14:43
Rufname: Alex
Wohnort: Köln

Zeilen bedingt ausblenden - Zeilen bedingt ausblenden

Nach oben
       Version: Office 97

Hallo erstmal,
ich entwickle grade eine Verwaltung für ein Sparkästchen in unserer Stammkneipe,
nun habe ich folgendes problem, das Sparkästchen hat 98 Fächer, jeder Sparer steht in einer Zeile. Es gibt aber auch Fächer zwischendrin die nicht belegt sind, diese werden in Spalte B (Arbeitsblatt Übersicht) mit einem N gekennzeichnet, was ich aus einem andren Blatt (Belegliste) übernehme. Nun sollen alle Zeilen mit diesem N ausgeblendet werden.
Wird der Wert N in der Belegliste wieder entfernt (bedeutet das Sparkästchen ist Belegt) soll die entsprechende Zeile wieder eingeblendet werden.
Der Bereich für den die Überprüfung gilt ist B3 bis B100 (im Arbeitsblatt Übersicht).

Übersicht

ABCD
2Nr. NameEingezahlt
31 N. Ulrich20,00 €
42 M. Cipper20,00 €
53N 0,00 €
64 P. Leyer20,00 €
75N 20,00 €
86N 20,00 €

Formeln der Tabelle
ZelleFormel
B3=WENN(Belegliste!B5=0;"";Belegliste!B5)
C3=WENN(Belegliste!C5=0;"";Belegliste!C5)
D3=SUMME(H3:BE3)
B4=WENN(Belegliste!B6=0;"";Belegliste!B6)
C4=WENN(Belegliste!C6=0;"";Belegliste!C6)
D4=SUMME(H4:BE4)
A5=A4+1
B5=WENN(Belegliste!B7=0;"";Belegliste!B7)
C5=WENN(Belegliste!C7=0;"";Belegliste!C7)
D5=SUMME(H5:BE5)
A6=A5+1
B6=WENN(Belegliste!B8=0;"";Belegliste!B8)
C6=WENN(Belegliste!C8=0;"";Belegliste!C8)
D6=SUMME(H6:BE6)
A7=A6+1
B7=WENN(Belegliste!B9=0;"";Belegliste!B9)
C7=WENN(Belegliste!C9=0;"";Belegliste!C9)
D7=SUMME(H7:BE7)
A8=A7+1
B8=WENN(Belegliste!B10=0;"";Belegliste!B10)
C8=WENN(Belegliste!C10=0;"";Belegliste!C10)
D8=SUMME(H8:BE8)


Excel Jeanie Html

Belegliste

ABC
4Nr Name
51 N. Ulrich
62 M. Cipper
73N
84 P. Leyer
95N
106N


Excel Jeanie Html

In diesem Fall wüden die Zeilen 5,7 und 8 ausgeblendet.

Für eure Hilfe wäre ich sehr dankbar.
< Peter >
Excel-Moderator, der immer noch dazu lernt


Verfasst am:
08. Dez 2007, 15:24
Rufname: Kommt darauf an wer ruft
Wohnort: Das schönste Land in Deutschlands Gaun


AW: Zeilen bedingt ausblenden - AW: Zeilen bedingt ausblenden

Nach oben
       Version: Office 97

Hallo,

VBA ist nicht so mein Ding, aber probier mal den folgenden VBA-Code der hinter das Modul des Tabellenblattes 'Belegliste' gehört:

Code:
Private Sub Worksheet_Change(ByVal Target As Range)
If Intersect(Target, Range("B:B")) Is Nothing Then Exit Sub
    If Cells(Target.Row, 2) = "N" Then
        Sheets("Übersicht").Rows(Target.Row).EntireRow.Hidden = True
        Else: Sheets("Übersicht").Rows(Target.Row).EntireRow.Hidden = False
End If
End Sub


- mit Alt+F11 den VBA-Editor öffnen
- mit Strg+R den Projekt-Explorer öffnen und aktivieren
- die gewünschte Datei per Doppelklick markieren
- auf das gewünschte Tabellenblatt unterhalb dieser Datei doppelklicken
- in der rechten Fensterhälfte ist das Codefenster dieser Tabelle sichtbar
- dort den Code einfügen
- speichern und den VBA-Editor mit Alt+F4 schliessen

_________________
Gruß
Peter
rumsgurke
ewiger Beginner


Verfasst am:
08. Dez 2007, 15:28
Rufname: André

AW: Zeilen bedingt ausblenden - AW: Zeilen bedingt ausblenden

Nach oben
       Version: Office 97

Ich wills mal versuchen:
Ungetestet
Code:

Private Sub Worksheet_Change(ByVal Target As Range)
For i = 3 To 100
If Range("B" & i).Value = "N" Then
       Rows("i:i").EntireRow.Hidden = True
Else
       Rows("i:i").EntireRow.Hidden = False 
EndIf
Next i
End Sub


Wenns geholfen hat, dann würde ich mich über eine Rückmeldung freuen.
Gruß André

_________________
Um so mehr ich VBA lerne, um so mehr weiß ich, das ich erst sehr wenig davon weiß.
AngelWare
Laie


Verfasst am:
09. Dez 2007, 00:28
Rufname: Alex
Wohnort: Köln

AW: Zeilen bedingt ausblenden - AW: Zeilen bedingt ausblenden

Nach oben
       Version: Office 97

Danke an euch beide habe es hinbekommen.
Sieht jetzt so aus:

Code:
Private Sub Worksheet_Change(ByVal Target As Range)
Application.ScreenUpdating = False
   For i = 3 To 100
      If Worksheets("Übersicht").Range("B" & i).Value = "N" Then
          Worksheets("Übersicht").Rows(i).EntireRow.Hidden = True
      Else
          Worksheets("Übersicht").Rows(i).EntireRow.Hidden = False
      End If
   Next i
Application.ScreenUpdating = True
End Sub
grillkohle
Im Profil kannst Du frei den Rang ändern


Verfasst am:
06. Sep 2010, 16:18
Rufname:


AW: Zeilen bedingt ausblenden - AW: Zeilen bedingt ausblenden

Nach oben
       Version: Office 2003

entschuldigt bitte, wenn ich diesen etwas älteren Thread wieder ausgrabe!

ich hab ziemlich wenig bis gar keine ahnung von vba, habe mich aber gerade an der erläuterung hier entlang gehangelt, da ich ein ähnliches Problem habe.
Es funktioniert auch soweit.
Jedoch treten die Änderungen nur ein, wenn ich eine Zeile lösche oder so.

Lässt sich das so einrichten, dass beim Ändern des relevanten Wertes (im Beispiel oben die Zelle mit dem N) automatische diese Zeile wieder eingeblendet oder entsprechend ausgeblendet wird?

Danke

MfG

grillkohle
EtoPHG
Ich sehe dunkle Zeiten aufziehen...


Verfasst am:
06. Sep 2010, 16:28
Rufname: Hansueli

AW: Zeilen bedingt ausblenden - AW: Zeilen bedingt ausblenden

Nach oben
       Version: Office 97

Hallo grillkohle,

Kannst du mir sagen, wie du in einer ausgeblendeten Zelle etwas eingeben willst?

Besser du umschreibst mal dein Problem genauer!
WAS WO Eingeben
Um das 'Verarbeiten' werden sich die Forumshelfer kümmern
WAS WO Ausgeben.

Gruess Hansueli

_________________
Forenhelfer danken für eine Rückmeldung!
Der Kluge lernt, der Dummkopf erteilt gern Belehrungen. - Anton Tschechow
grillkohle
Im Profil kannst Du frei den Rang ändern


Verfasst am:
06. Sep 2010, 16:40
Rufname:

AW: Zeilen bedingt ausblenden - AW: Zeilen bedingt ausblenden

Nach oben
       Version: Office 2003

also es ist eigentlich wie oben im beispiel

Die zeile soll bei einer leeren(statt "N" oben im beispiel") Zelle in Spalte B ausgeblendet werden.
der relevante wert, bei dem entscheidet wird, ob die zeile angezeigt wird, oder nicht, stammt aus einer formel, der wert wird also von einem anderen tabellenblatt übernommen.

durch eine eingabe auf einem anderen tabellenblatt wird der wert also gesetzt bzw nicht gesetzt. wird diese Eingabe getätigt, soll automatisch die zeile eingeblendet werden. wird für diese zeile keine eingabe getätigt, soll automatisch die zeile ausblendet werden.

ich hoffe, es ist verständlicher geworden!
EtoPHG
Ich sehe dunkle Zeiten aufziehen...


Verfasst am:
06. Sep 2010, 16:44
Rufname: Hansueli

AW: Zeilen bedingt ausblenden - AW: Zeilen bedingt ausblenden

Nach oben
       Version: Office 97

Hallo grillkohle,

Ja das ist jetzt verständlicher. Es fehlen noch die Bedingungen:
Sag uns noch in welchem Bereich des anderen Blatts sich die Zellen wie verändern müssen, so das auf dem Zielblatt durch die Formel die Zeile entweder eingeblendet oder ausgeblendet werde soll.

Gruess Hansueli

_________________
Forenhelfer danken für eine Rückmeldung!
Der Kluge lernt, der Dummkopf erteilt gern Belehrungen. - Anton Tschechow
grillkohle
Im Profil kannst Du frei den Rang ändern


Verfasst am:
06. Sep 2010, 16:53
Rufname:

AW: Zeilen bedingt ausblenden - AW: Zeilen bedingt ausblenden

Nach oben
       Version: Office 2003

Das richtet sich jeweils nach einem Feld, in dem ich ein Drop Down Menü (über Daten => Gültigkeit) eingerichtet habe. Das gleiche Menü taucht 6 mal (daher 6 Zeilen, die bei Bedarf verschwinden sollen) auf. Es gibt einen Menü Punkt, nämlich "Hier Auswählen" (natürlich ohne ""), bei dem die Zeile ausgeblendet werden soll, da dann keine weiteren relevanten Sachen passieren sollen. Dies ist sozusagen auch der Standardwert des Dropdownmenüs.
Wird einer der anderen Werte angenommen, soll die Zeile eingeblendet werden.

Das andere Blatt heißt Eingabe, und dort finden sich diese Dropdownmenüs in den Feldern B34 B40 B46 B52 B58 B64.
Die auszublendenden Zeilen sind die Zeilen 8-13. Dort steht in Spalte B jeweils ein =WENN(Eingabe!B34="Hier Auswählen";"";Eingabe!B34) usw, um zumindest schon einmal das Feld leer zu lassen.
grillkohle
Im Profil kannst Du frei den Rang ändern


Verfasst am:
07. Sep 2010, 13:28
Rufname:

AW: Zeilen bedingt ausblenden - AW: Zeilen bedingt ausblenden

Nach oben
       Version: Office 2003

sry 4 doppelpost

weiß da jemand ne lösung zu? oder fehlen noch angaben?
EtoPHG
Ich sehe dunkle Zeiten aufziehen...


Verfasst am:
07. Sep 2010, 13:45
Rufname: Hansueli

AW: Zeilen bedingt ausblenden - AW: Zeilen bedingt ausblenden

Nach oben
       Version: Office 97

Hallo,

Diesen Code in das Tabellenblatt mit den Dropdowns (Reiter rechtklicken - Code anzeigen und ins leere Fenster kopieren):
Code:
Private Sub Worksheet_Change(ByVal Target As Range)
    If Target.Count > 1 Or _
    Intersect(Target, Range("B34,B40,B46,B52,B58,B64")) Is Nothing Then Exit Sub
    With Worksheets("Übersicht")
        Select Case Target.Address(0, 0)
        Case "B34"
            .Rows(8).Hidden = (Target = "Hier Auswählen")
        Case "B40"
            .Rows(9).Hidden = (Target = "Hier Auswählen")
        Case "B46"
            .Rows(10).Hidden = (Target = "Hier Auswählen")
        Case "B52"
            .Rows(11).Hidden = (Target = "Hier Auswählen")
        Case "B58"
            .Rows(12).Hidden = (Target = "Hier Auswählen")
        Case "B64"
            .Rows(13).Hidden = (Target = "Hier Auswählen")
        End Select
    End With
End Sub

Gruess Hansueli

_________________
Forenhelfer danken für eine Rückmeldung!
Der Kluge lernt, der Dummkopf erteilt gern Belehrungen. - Anton Tschechow
grillkohle
Im Profil kannst Du frei den Rang ändern


Verfasst am:
07. Sep 2010, 13:57
Rufname:

AW: Zeilen bedingt ausblenden - AW: Zeilen bedingt ausblenden

Nach oben
       Version: Office 97

danke, werds gleich ausprobieren!
EtoPHG
Ich sehe dunkle Zeiten aufziehen...


Verfasst am:
07. Sep 2010, 14:11
Rufname: Hansueli

AW: Zeilen bedingt ausblenden - AW: Zeilen bedingt ausblenden

Nach oben
       Version: Office 97

Hi,

...oder etwas kürzer:
Code:
Private Sub Worksheet_Change(ByVal Target As Range)
    If Target.Count > 1 Or _
    Intersect(Target, Range("B34,B40,B46,B52,B58,B64")) Is Nothing Then Exit Sub
    Worksheets("Übersicht").Rows((Target.Row + 2) / 6 + 2).Hidden = (Target = "Hier Auswählen")
End Sub

Gruess Hansueli

_________________
Forenhelfer danken für eine Rückmeldung!
Der Kluge lernt, der Dummkopf erteilt gern Belehrungen. - Anton Tschechow
grillkohle
Im Profil kannst Du frei den Rang ändern


Verfasst am:
08. Sep 2010, 13:50
Rufname:

AW: Zeilen bedingt ausblenden - AW: Zeilen bedingt ausblenden

Nach oben
       Version: Office 97

hi,

besten dank!
funktioniert einwandfrei.

ich habe noch eine weitere Frage:

kann ich diese verschiedenen dropdownmenüs mit drumherum (das sind immer 6 Zeilen mit überschrift und so) auch ausblenden lassen? und zwar je nach dem, welche zahl man angibt?
Also ich möchte 5 drop down menüs haben, dann zeigt auch nur 5 mal dieses menü mit dazugehörigem abschnitt an.

die abschnitte mit den drop down menüs befinden sich ab zeile 32, dann immer 6 zeilen, also der nächste abschnitt beginnt in zeile 38.
Oben in Zelle B1 ist ein Feld, in das ich eintragen möchte, wie viele abschnitte ich sehen kann, also z.B. 2 abschnitte, dann sind die zeilen 32-43 eingeblendet, und die zeilen 44-67 ausgeblendet. Wählt man 3 abschnitte, sind die zeilen 32-49 eingeblendet, und 50-67 ausgeblendet.
müsste doch eig ähnlich laufen, oder?

wär voll cool!
EtoPHG
Ich sehe dunkle Zeiten aufziehen...


Verfasst am:
08. Sep 2010, 14:38
Rufname: Hansueli


AW: Zeilen bedingt ausblenden - AW: Zeilen bedingt ausblenden

Nach oben
       Version: Office 97

Hallo,

Mit Ausblenden der Dropdowns:
Code:
Private Sub Worksheet_Change(ByVal Target As Range)
    If Target.Address = "$B$1" Then
        Range("32:67").EntireRow.Hidden = True
        Range("32:" & 32 + (Val(Target) * 6) - 1).EntireRow.Hidden = False
    End If
    If Target.Count > 1 Or _
    Intersect(Target, Range("B34,B40,B46,B52,B58,B64")) Is Nothing Then Exit Sub
    Worksheets("Übersicht").Rows((Target.Row + 2) / 6 + 2).Hidden = (Target = "Hier Auswählen")
End Sub

Gruess Hansueli

_________________
Forenhelfer danken für eine Rückmeldung!
Der Kluge lernt, der Dummkopf erteilt gern Belehrungen. - Anton Tschechow
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Gehe zu Seite 1, 2, 3  Weiter
Diese Seite Freunden empfehlen

Seite 1 von 3
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: #DIV/0! ausblenden 5 hafisch 4059 11. Okt 2005, 14:56
c0bRa #DIV/0! ausblenden
Keine neuen Beiträge Excel Formeln: Festgelegte (Feier)tage bedingt formatieren 6 kaboe63 806 25. Sep 2005, 22:27
kaboe63 Festgelegte (Feier)tage bedingt formatieren
Keine neuen Beiträge Excel Formeln: Bei dreifachen Werten Zeilen löschen 14 Kosich 819 01. Sep 2005, 14:23
Kosich Bei dreifachen Werten Zeilen löschen
Keine neuen Beiträge Excel Formeln: Wert immer nach 27 Zeilen um 1 erhöhen? (siehe Beispiel !!) 8 homer_134 1617 21. Aug 2005, 13:23
homer_134 Wert immer nach 27 Zeilen um 1 erhöhen? (siehe Beispiel !!)
Keine neuen Beiträge Excel Formeln: Zählen von Einträgen in Zeilen oder Spalten 3 ggaribaldi 1653 27. Jul 2005, 09:23
steve1da Zählen von Einträgen in Zeilen oder Spalten
Keine neuen Beiträge Excel Formeln: Feld ausblenden wenn... 8 Nemi 928 08. Jul 2005, 17:57
ae Feld ausblenden wenn...
Keine neuen Beiträge Excel Formeln: Zeilen mit Wert 0 ausblenden 2 MartinJungwirth 1442 24. Jun 2005, 13:53
MartinJungwirth Zeilen mit Wert 0 ausblenden
Keine neuen Beiträge Excel Formeln: Farbige Zeilen bei verschiedenen Kriterien 10 Nixweis 1244 09. Jun 2005, 13:59
Nixweiß Farbige Zeilen bei verschiedenen Kriterien
Keine neuen Beiträge Excel Formeln: Leere Zeilen mit Formel ausblenden 4 austin1980 2970 21. Apr 2005, 20:33
Günni Leere Zeilen mit Formel ausblenden
Keine neuen Beiträge Excel Formeln: Leere Zeilen vom Kombinationsfeld löschen 5 sifak 1331 19. Apr 2005, 17:11
Hübi Leere Zeilen vom Kombinationsfeld löschen
Keine neuen Beiträge Excel Formeln: Gibt es eine Formel mit der man Zeilen löschen kann? 5 kara ben nemsi 1949 15. Apr 2005, 10:19
Kuwe Gibt es eine Formel mit der man Zeilen löschen kann?
Keine neuen Beiträge Excel Formeln: Vergleichen von Spalten UND Zeilen. 3 mojoe321 1824 15. März 2005, 17:14
Hübi Vergleichen von Spalten UND Zeilen.
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft-Excel Diagramme