Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Will Werte addieren, in Bezug zu zwei anderen Spalten
zurück: Text in andere Tabelle übertragen weiter: definierten zeitraum auf Wochenende und Feiertage überprüfen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Hardy_K_888
Im Profil kannst Du frei den Rang ändern


Verfasst am:
01. Dez 2004, 21:58
Rufname:

Will Werte addieren, in Bezug zu zwei anderen Spalten - Will Werte addieren, in Bezug zu zwei anderen Spalten

Nach oben
       

Hallo,

ich möchte, wie vorhin MrMr, Zahlen addieren, allerdings sollen diese von zwei Bedingungen (in den beiden danebenstehenden Spalten) abhängig addiert werden.
A B C
1 1000 1 1
2 1000 1 1
3 1000 1
4 1000 1 1
5 3000 (Summe, weil in Zeile 3 nur eine Bedingung erfüllt ist)

Das heißt, Spalte A sind die Werte...
und in Spalte B+C sind die Bedingungen, in meinem Fall "1"
Es müssen jeweils in der betrefenden Zeile die Bedingen un den Spalten B+C erfüllt sein, damit der Wert in A mit in die Berechnung einbezogen wird.

Wer kann mir helfen?

Gruß
Hardy_K_888
ae
Mein Name ist Ente


Verfasst am:
01. Dez 2004, 22:31
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg


AW: Will Werte addieren, in Bezug zu zwei anderen Spalten - AW: Will Werte addieren, in Bezug zu zwei anderen Spalten

Nach oben
       

Hallo,
meinst du das so :

 
 ABCDEF
1100011 Kriterium Spalte B1
2100012 Kriterium Spalte C1
310001    
4100011 Summe2000
Formeln der Tabelle
F4 : =SUMMENPRODUKT((B1:B4=F1)*(C1:C4=F2)*A1:A4)
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
Gast



Verfasst am:
02. Dez 2004, 08:13
Rufname:

AW: Will Werte addieren, in Bezug zu zwei anderen Spalten - AW: Will Werte addieren, in Bezug zu zwei anderen Spalten

Nach oben
       

Hallo Andreas,

super Tipp, ich hab's ausprobiert und funktioniert.
Anschließend habe ich noch einmal experimentiert und bin zu folgender
Vereinfachung gelangt:

4000 1 1
1000 1
5 1
1000 1 1
5000

=SUMMENPRODUKT((B1:B4=1)*(C1:C4=1)*A1:A4)

Damit spart man sich dann die Spalten D-F, was die Tabelle ein wenig übersichtlicher gestaltet.

Kannst Du das noch mal überprüfen?

Nochmals besten Dank!

Hardy_K_888
ae
Mein Name ist Ente


Verfasst am:
02. Dez 2004, 12:00
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg


AW: Will Werte addieren, in Bezug zu zwei anderen Spalten - AW: Will Werte addieren, in Bezug zu zwei anderen Spalten

Nach oben
       

Hallo Hardy,
das funktioniert einwandfrei wie du es gelöst hast.
Ich hatte bewusst die Hilfsspalten gewählt falls sich die Kriterien öfters mal ändern.
Ist diesnicht der Fall ist deine Lösung kürzer und funktioniert genau so

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Tageberechnung aus zwei Datumseingaben 15 Gast 19518 29. Dez 2008, 12:42
Dampfbahner Tageberechnung aus zwei Datumseingaben
Keine neuen Beiträge Excel Formeln: Formeln zwischen zwei Excel Datein 0 msis24 927 19. Okt 2004, 13:05
msis24 Formeln zwischen zwei Excel Datein
Keine neuen Beiträge Excel Formeln: Werte aus Liste mit Validation in Zelle 1 Gast 2516 18. Okt 2004, 15:20
icke Werte aus Liste mit Validation in Zelle
Keine neuen Beiträge Excel Formeln: Werte in Zellen?!? 3 Kiamolo 2818 18. Okt 2004, 10:01
Kiamolo Werte in Zellen?!?
Keine neuen Beiträge Excel Formeln: Bestes Resultat in 2 Spalten herausfiltern 9 UAN 928 11. Okt 2004, 18:41
Tim Bestes Resultat in 2 Spalten herausfiltern
Keine neuen Beiträge Excel Formeln: Verweis über mehrere Blättern und Spalten 2 batigol_09 1249 08. Okt 2004, 10:26
batigol_09 Verweis über mehrere Blättern und Spalten
Keine neuen Beiträge Excel Formeln: werte innerhalb eines bestimmten bereichs suchen 3 infantil88 3545 17. Sep 2004, 10:54
Arnim werte innerhalb eines bestimmten bereichs suchen
Keine neuen Beiträge Excel Formeln: Addieren von negativen Zahlen 1 cnettekoven 612 12. Aug 2004, 11:04
lala Addieren von negativen Zahlen
Keine neuen Beiträge Excel Formeln: Trendlinie soll 0 Werte nicht beachten 3 Suchender 1866 05. Aug 2004, 13:23
icke Trendlinie soll 0 Werte nicht beachten
Keine neuen Beiträge Excel Formeln: SVERWEIS mit Bezug auf 2 Spalten - ist das möglich??? HILFE! 2 Frank S. 2561 26. Jul 2004, 19:12
fl618 SVERWEIS mit Bezug auf 2 Spalten - ist das möglich??? HILFE!
Keine neuen Beiträge Excel Formeln: Stunden addieren - aber nicht in Industrieminuten ! 1 bernd41966 4387 15. Jul 2004, 07:39
Jue Stunden addieren - aber nicht in Industrieminuten !
Keine neuen Beiträge Excel Formeln: 2 gleiche Werte suchen+ in andere Spalte schreiben 0 KARL 2175 21. Jun 2004, 12:43
KARL 2 gleiche Werte suchen+ in andere Spalte schreiben
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Word Serienbriefe