Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Einen Vergleich mit mehreren Begriffen(String) durchführen
zurück: LinkedCell als Zellbezug fuer andere Formeln weiter: Formatierung einer Stechkarte Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Kannu
Im Profil kannst Du frei den Rang ändern


Verfasst am:
08. Dez 2004, 11:46
Rufname:

Einen Vergleich mit mehreren  Begriffen(String) durchführen - Einen Vergleich mit mehreren Begriffen(String) durchführen

Nach oben
       

Hi an alle Asse! Smile

Ich möchte eine Zelle mit mehreren Begriffen(Strings) vergleichen. Diese Begriffe stehen bei mir in einer Spalte...jetzt hab ich das mit einer WENN-Schleife versucht (es funktioniert auch), bloss ist das eine ziemlich unpraktische und primitive Lösung für mehr als 60 Datensätze. So müsste ich nämlich die Schleife 50 Mal eintippen und immer wieder den Vergleich mit dem nächsten Wort machen:

=WENN(E8="PT";'C:\[test.xls]Tab1'!$A$1;WENN(E8="PTF";'C:\[test.xls]Tab1'!$A$2;""))

Wie kann man diesen Vorgang automatisieren oder vielleicht intelligenter Idea lösen Question
ae
Mein Name ist Ente


Verfasst am:
08. Dez 2004, 11:51
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg


AW: Einen Vergleich mit mehreren  Begriffen(String) durchfüh - AW: Einen Vergleich mit mehreren Begriffen(String) durchfüh

Nach oben
       

Hallo kannu,
nimm statt einer wenn den sverweis

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
Kannu
Im Profil kannst Du frei den Rang ändern


Verfasst am:
08. Dez 2004, 12:23
Rufname:

AW: Einen Vergleich mit mehreren  Begriffen(String) durchfüh - AW: Einen Vergleich mit mehreren Begriffen(String) durchfüh

Nach oben
       

Hi ae!

Hab mir mal die Funktion sverweis angeschaut...blick da aber leider überhaupt nicht durch!!! Bist du sicher, das diese Funktion die richtige Lösung für mein Problem ist!?

Meine Wörter stehen in einer Spalte (z.B A1:A50), dann hab ich ein Dropdown erstellt, welches auf A1:A50 zugreift. Nun will ich die nebenstehende Zelle so formatieren, dass er einen Vergleich mit dem Begriff aus dem Dropdown macht: z.B 1. falls der Begiff im Kombo PT ist, soll er auf B1 zugreigen 2. Falls der Begriff AQP ist soll auf B2 zugreifen usw.!
ae
Mein Name ist Ente


Verfasst am:
08. Dez 2004, 12:24
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Einen Vergleich mit mehreren  Begriffen(String) durchfüh - AW: Einen Vergleich mit mehreren Begriffen(String) durchfüh

Nach oben
       

Hallo,
so ganz verstehe ich das nicht - wenn du magst sende mir mal ne kleine musterdatei an forum@andreas-entenmann.de

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
ae
Mein Name ist Ente


Verfasst am:
08. Dez 2004, 13:55
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg


AW: Einen Vergleich mit mehreren  Begriffen(String) durchfüh - AW: Einen Vergleich mit mehreren Begriffen(String) durchfüh

Nach oben
       

Für alle MitleserInnen derLösungsansatz.
Der wert aus dem Dropdwon wird zum Suchkriterium

Code:
=WENN(D11="";"";SVERWEIS(D11;'C:\[test.xls]Tab1'!$A$1:$B$5;1;FALSCH))

Die wenn ist nur der Fehlerabgriff falls nochkeine Auswahl getroffen wurde

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Verknüpfen von mehreren Tabellen 18 tobiasu 3579 19. Aug 2005, 11:11
tobiasu Verknüpfen von mehreren Tabellen
Keine neuen Beiträge Excel Formeln: Excel Vergleich einer Zelle mit einer ganzen Spalte 2 spriko 1018 03. Aug 2005, 15:23
spriko Excel Vergleich einer Zelle mit einer ganzen Spalte
Keine neuen Beiträge Excel Formeln: Sverweis mit mehreren Bezügen 13 Lino262 3141 22. Jul 2005, 10:57
Lino262 Sverweis mit mehreren Bezügen
Keine neuen Beiträge Excel Formeln: Vergleich ?? 17 danyboy 1328 22. Apr 2005, 14:19
danyboy Vergleich ??
Keine neuen Beiträge Excel Formeln: Werte aus einer Tabelle nach mehreren Kriterien auswerten 3 Daniel 2902 07. März 2005, 14:15
Hübi Werte aus einer Tabelle nach mehreren Kriterien auswerten
Keine neuen Beiträge Excel Formeln: Sverweis mit mehreren Ergebnissen 2 Holly 1744 19. Feb 2005, 21:23
Arnim Sverweis mit mehreren Ergebnissen
Keine neuen Beiträge Excel Formeln: vergleich mit Wert vor 10min 2 Norbert_B 586 11. Feb 2005, 15:19
Norbert_B vergleich mit Wert vor 10min
Keine neuen Beiträge Excel Formeln: VERGLEICH() nächstgrösseren Wert finden??? 2 xyzdef 1117 07. Feb 2005, 22:58
xyzdef VERGLEICH() nächstgrösseren Wert finden???
Keine neuen Beiträge Excel Formeln: Datum aus mehreren Zellen zusammensetzen. 9 gast2005 5087 25. Dez 2004, 22:33
Kuwe Datum aus mehreren Zellen zusammensetzen.
Keine neuen Beiträge Excel Formeln: SummeWenn mit 2 oder mehreren Bedingungen 1 jones 2000 1135 20. Dez 2004, 15:29
Kuwe SummeWenn mit 2 oder mehreren Bedingungen
Keine neuen Beiträge Excel Formeln: abfrage gestalten mit mehreren bedingungen 3 Gast 1304 15. Dez 2004, 16:58
nugget abfrage gestalten mit mehreren bedingungen
Keine neuen Beiträge Excel Formeln: Vergleich zweier Tabellen 2 Enjoy82 1975 25. Nov 2004, 13:50
Enjoy82 Vergleich zweier Tabellen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Word Serienbriefe