Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Abfrage über die Zuständigkeit in einem PLZ-Gebiet
zurück: ZÄHLENWENNS aktualisieren ohne die Quelldatei zu öffnen weiter: mehrere Werte in eine Zelle übertragen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Lucy77
Gast


Verfasst am:
20. Mai 2008, 12:29
Rufname:

Abfrage über die Zuständigkeit in einem PLZ-Gebiet - Abfrage über die Zuständigkeit in einem PLZ-Gebiet

Nach oben
       Version: Office XP (2002)

Hallo Leute,
ich sitze seit Stunden an einem Problem und hoffe, Ihr könnt mir dabei helfen!

In Spalte A habe ich eine Postleitzahl gegeben und in Spalte B möchte ich den für diese Region zuständigen Anbieter aus einer Stammdatentabelle abgreifen.

____A_______B
1__PLZ__Anbieter
2_03233___An ?
3_03251___An ?
4_03241___An ?
5_04517___An ?
6___…_____ …

Klingt ganz einfach, ist es aber irgendwie nicht

Die Formel in B sollte möglichst kopierbar sein, da es sich um eine MENGE Postleitzahlen handelt!

Der zuständige Anbieter lässt sich aus nachstehender Tabelle abgreifen

_____X______Y_______Z
1_von PLZ_bis PLZ__Anbieter
2__03230__03249___An26
3__03250__03253___An26
4__04000__04469___An34
5__04500__04519___An34
6___…______…_______…

Als Anmerkung: Ein Anbieter ist für mehrere PLZ-Gebiete zuständig, die nicht unbedingt in Beziehung stehen.

Für dieses Beispiel müsste also rauskommen:
B2 = An26
B3 = An26
B4 = An26
B5 = An34

Also ich bin daran schier verzweifelt, aber vielleicht stehe ich auch auf dem berühmtberüchtigten Schlauch.

Achso, das ganze sollte ohne VBA funktionieren!

Vielen Dank im Voraus!

MfG Lucy77
Alto
Im Profil kannst Du frei den Rang ändern


Verfasst am:
20. Mai 2008, 12:47
Rufname:
Wohnort: HH


AW: Abfrage über die Zuständigkeit in einem PLZ-Gebiet - AW: Abfrage über die Zuständigkeit in einem PLZ-Gebiet

Nach oben
       Version: Office XP (2002)

Hallo Lucy,

der einfache SVERWEIS kann u.U. zu Fehler führen, daher hier noch eine Alternative:

Tabelle1

 ABCDEFG
1       
203233An26An26 0323003249An26
303251An26An26 0325003253An26
403241An26An26 0400004469An34
504517An34An26 0450004519An34
604480An34nicht vorhanden    

Formeln der Tabelle
ZelleFormel
B2=SVERWEIS(A2;$E$2:$G$5;3)
C2{=WENN(MAX(($E$2:$E$5<=A2)*($F$2:$F$5>=A2));INDEX($G$1:$G$5;ZEILE($G$2:$G$5));"nicht vorhanden")}
B3=SVERWEIS(A3;$E$2:$G$5;3)
C3{=WENN(MAX(($E$2:$E$5<=A3)*($F$2:$F$5>=A3));INDEX($G$1:$G$5;ZEILE($G$2:$G$5));"nicht vorhanden")}
B4=SVERWEIS(A4;$E$2:$G$5;3)
C4{=WENN(MAX(($E$2:$E$5<=A4)*($F$2:$F$5>=A4));INDEX($G$1:$G$5;ZEILE($G$2:$G$5));"nicht vorhanden")}
B5=SVERWEIS(A5;$E$2:$G$5;3)
C5{=WENN(MAX(($E$2:$E$5<=A5)*($F$2:$F$5>=A5));INDEX($G$1:$G$5;ZEILE($G$2:$G$5));"nicht vorhanden")}
B6=SVERWEIS(A6;$E$2:$G$5;3)
C6{=WENN(MAX(($E$2:$E$5<=A6)*($F$2:$F$5>=A6));INDEX($G$1:$G$5;ZEILE($G$2:$G$5));"nicht vorhanden")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Jeanie Html



Mfg

Alto
Lucy77
Gast


Verfasst am:
20. Mai 2008, 13:30
Rufname:

AW: Abfrage über die Zuständigkeit in einem PLZ-Gebiet - AW: Abfrage über die Zuständigkeit in einem PLZ-Gebiet

Nach oben
       Version: Office XP (2002)

Hey Alto,

vielen Dank für deine schnelle Antwort!

Bei Matrixformeln bin ich auch schon gelandet, die mir auch verschiedene Anbieter ausgeben, aber leider nie die richtigen Razz

Habe deine Formel kopiert und die Bezüge entsprechend geändert und auch mit STRG+SHIFT+RETURN abgeschlossen. Leider gibt sie mir jetzt überall "nicht vorhanden" raus.

Auch der Zellbezug "A2" ändert sich nicht automatisch auf "A3" beim Kopieren.
Er gibt mir dann die Meldung "Teile eines Arrays können nicht geändert werden." raus.

Dieses Problem habe ich auch schon bei all meinen anderen Formelvarianten gehabt.

Hast du noch eine Idee?

MfG Lucy77
Lucy77
Gast


Verfasst am:
20. Mai 2008, 14:03
Rufname:

AW: Abfrage über die Zuständigkeit in einem PLZ-Gebiet - AW: Abfrage über die Zuständigkeit in einem PLZ-Gebiet

Nach oben
       Version: Office XP (2002)

Hey Alto,

ich bin's noch mal. Also, wenn ich deine Tabelle nachbaue und die Spalten mit meinen Daten auffülle funktioniert die Formel einwandfrei. Kopiere ich aber die Formel in meine Ursprungsdatei und passe die Bezüge an, dann tritt Fehler wie oben beschrieben auf.

Also, liegt es von Anfang an irgendwie an meiner Ursprungsdatei?
Aber was kann das sein?

Gruß Lucy77
Lucy77
Gast


Verfasst am:
20. Mai 2008, 14:55
Rufname:

AW: Abfrage über die Zuständigkeit in einem PLZ-Gebiet - AW: Abfrage über die Zuständigkeit in einem PLZ-Gebiet

Nach oben
       Version: Office XP (2002)

Hey Alto,

mir ist gerade aufgefallen, dass deine vorgeschlagene Matrixfunktion immer nur den ersten Anbieter über alle Zeilen ausgiebt. C6 müsste korrekter Weise nämlich AN34 heißen!?

Hast du noch einen Vorschlag auf Lager?

Oder jemand anderes?

MfG Lucy77
Detlef 42
Tastet . . . sucht . . . und trifft manchmal


Verfasst am:
20. Mai 2008, 15:03
Rufname:
Wohnort: RE

AW: Abfrage über die Zuständigkeit in einem PLZ-Gebiet - AW: Abfrage über die Zuständigkeit in einem PLZ-Gebiet

Nach oben
       Version: Office 2k (2000)

Hallo,

ist der Lieferant aus 04517 nicht Nr. 34?

Komisch

Edit: better late than never

_________________
Gruß

Detlef

. . . wer nicht fragt bleibt stehen . . .
Detlef 42
Tastet . . . sucht . . . und trifft manchmal


Verfasst am:
20. Mai 2008, 15:20
Rufname:
Wohnort: RE

AW: Abfrage über die Zuständigkeit in einem PLZ-Gebiet - AW: Abfrage über die Zuständigkeit in einem PLZ-Gebiet

Nach oben
       Version: Office XP (2002)

Teste das mal durch . . .

Tabelle1
 ABCDEFG
1PLZAnb  vonbisAnb
2323326  3230324926
3325126  3250325326
4324126  4000446934
5451734  4500451934
64480nicht vorhanden     
Formeln der Tabelle
B2 : {=WENN(MAX(($E$2:$E$5<=A2)*($F$2:$F$5>=A2));INDEX($G$2:$G$5;VERGLEICH(A2;$E$2:$E$5));"nicht vorhanden")}
B3 : {=WENN(MAX(($E$2:$E$5<=A3)*($F$2:$F$5>=A3));INDEX($G$2:$G$5;VERGLEICH(A3;$E$2:$E$5));"nicht vorhanden")}
B4 : {=WENN(MAX(($E$2:$E$5<=A4)*($F$2:$F$5>=A4));INDEX($G$2:$G$5;VERGLEICH(A4;$E$2:$E$5));"nicht vorhanden")}
B5 : {=WENN(MAX(($E$2:$E$5<=A5)*($F$2:$F$5>=A5));INDEX($G$2:$G$5;VERGLEICH(A5;$E$2:$E$5));"nicht vorhanden")}
B6 : {=WENN(MAX(($E$2:$E$5<=A6)*($F$2:$F$5>=A6));INDEX($G$2:$G$5;VERGLEICH(A6;$E$2:$E$5));"nicht vorhanden")}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Excel Jeanie Html

_________________
Gruß

Detlef

. . . wer nicht fragt bleibt stehen . . .
Lucy77
Gast


Verfasst am:
21. Mai 2008, 09:05
Rufname:


AW: Abfrage über die Zuständigkeit in einem PLZ-Gebiet - AW: Abfrage über die Zuständigkeit in einem PLZ-Gebiet

Nach oben
       Version: Office XP (2002)

Hey Detlef,

habe deine Formel gerade durchlaufen lassen und muss sagen, sie funktioniert tadellos.

Vielen vielen Dank dafür!

Gruß Lucy77
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: doppelte-wenn Abfrage 3 Henrich 4351 12. Jun 2007, 17:59
Knuut doppelte-wenn Abfrage
Keine neuen Beiträge Excel Formeln: sverweis - abfrage erweitern 6 carl 1018 31. Mai 2007, 15:43
Gast sverweis - abfrage erweitern
Keine neuen Beiträge Excel Formeln: Verweisfunktion mit Abfrage von 2 Spalten möglich? 9 Imp 893 10. Mai 2007, 12:54
Gast Verweisfunktion mit Abfrage von 2 Spalten möglich?
Keine neuen Beiträge Excel Formeln: Abfrage über Tabellen & Spalten hinweg 6 gemini2205 911 02. Mai 2007, 21:39
gemini2205 Abfrage über Tabellen & Spalten hinweg
Keine neuen Beiträge Excel Formeln: Problem mit Abfrage von "unsortierten" Zeilen aus 2 Old Man 593 20. Feb 2007, 09:28
Thomas Ramel Problem mit Abfrage von "unsortierten" Zeilen aus
Keine neuen Beiträge Excel Formeln: Excelliste mit Abfrage in einer neuen Liste 2 alexburn 1581 08. Feb 2007, 10:18
alexburn Excelliste mit Abfrage in einer neuen Liste
Keine neuen Beiträge Excel Formeln: Verzwickte Abfrage - Hilfe benötigt 2 Gast 598 10. Okt 2006, 14:25
Gast Verzwickte Abfrage - Hilfe benötigt
Keine neuen Beiträge Excel Formeln: Blattübergreifende Abfrage 4 Kaischi 949 07. Aug 2006, 23:18
Kaischi Blattübergreifende Abfrage
Keine neuen Beiträge Excel Formeln: WENN Abfrage mit einer UND Verknüpfung möglich??? 2 L1veretter 29546 27. Jul 2006, 11:46
L1veretter WENN Abfrage mit einer UND Verknüpfung möglich???
Keine neuen Beiträge Excel Formeln: Abfrage einer Excelzelle nach bestimmten Zeichen 15 This is Real 4509 09. Nov 2005, 16:11
fridgenep Abfrage einer Excelzelle nach bestimmten Zeichen
Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten. Excel Formeln: Eine Art Abfrage ... 29 Gast 2847 27. Okt 2005, 09:07
fridgenep Eine Art Abfrage ...
Keine neuen Beiträge Excel Formeln: Wenn Abfrage 13 SonicOne 924 19. Okt 2005, 19:12
Gast Wenn Abfrage
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML CSS