Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Mehrstellige Zahlen in einzelne Ziffern trennen!
zurück: Pfad absolut weiter: Suchen nach doppelten Zellinhalten (Excel 97) Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
ejg
Einsteiger


Verfasst am:
27. Dez 2004, 18:11
Rufname:

Mehrstellige Zahlen in einzelne Ziffern trennen! - Mehrstellige Zahlen in einzelne Ziffern trennen!

Nach oben
       

Kann man ein Zellenergebnis (z.B. 25 oder 325) in einzelne Ziffern aufteilen? Jede Ziffer soll dann in einer eigenen Zelle stehen!
Beispiel: in A1 steht 325 dann soll nach "Berechnung" in A2 - 3, A3 - 2 und in A4 - 5 stehen.
Gibt es dafür eine Formel? Question Question Question Question

_________________
Grüße und positiven Tag Smile
xpecidy
.:: Excelist ::.


Verfasst am:
27. Dez 2004, 18:13
Rufname:
Wohnort: Dresden


AW: Mehrstellige Zahlen in einzelne Ziffern trennen! - AW: Mehrstellige Zahlen in einzelne Ziffern trennen!

Nach oben
       

Hallo EJG,

jetzt mal so ohne weiteres:

Code:

=WENN(LÄNGE($A$1)>=ZEILE()-1;TEIL($A$1;ZEILE()-1;1);"")
obwohl
=TEIL($A$1;ZEILE()-1;1)

auch langt.


Gruß
Markus

_________________
falls ich mal nicht antworten sollte.. pm an mich


Zuletzt bearbeitet von xpecidy am 27. Dez 2004, 18:18, insgesamt 2-mal bearbeitet
ae
Mein Name ist Ente


Verfasst am:
27. Dez 2004, 18:15
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Mehrstellige Zahlen in einzelne Ziffern trennen! - AW: Mehrstellige Zahlen in einzelne Ziffern trennen!

Nach oben
       

Hallo,
wie wäre es so

Tabelle1
 ABCD
1325325
Formeln der Tabelle
B1 : =TEIL($A1;SPALTE()-1;1)
C1 : =TEIL($A1;SPALTE()-1;1)
D1 : =TEIL($A1;SPALTE()-1;1)
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
Thomas Ramel
Microsoft Excel-MVP


Verfasst am:
27. Dez 2004, 19:38
Rufname: Thom
Wohnort: Glashütten - CH

AW: Mehrstellige Zahlen in einzelne Ziffern trennen! - AW: Mehrstellige Zahlen in einzelne Ziffern trennen!

Nach oben
       

Grüezi ejg

Wenn Du mit den extrahierten Zahlen weiterrechen willst, dann könntest Du auch eine mathematische Lösung in Betracht ziehen:

Tabelle1
 A
1325
23
32
45
Formeln der Tabelle
A2 : =QUOTIENT(A1;100)
A3 : =QUOTIENT(REST(A1;100);10)
A4 : =REST(A1;10)
 

_________________
Mit freundlichen Grüssen

Thomas Ramel
[Vista Ultimate SP-1 / xl2007 SP-2]
Gast



Verfasst am:
27. Dez 2004, 20:07
Rufname:


Re: Mehrstellige Zahlen in einzelne Ziffern trennen! - Re: Mehrstellige Zahlen in einzelne Ziffern trennen!

Nach oben
       

ejg hat folgendes geschrieben:
Kann man ein Zellenergebnis (z.B. 25 oder 325) in einzelne Ziffern aufteilen? Jede Ziffer soll dann in einer eigenen Zelle stehen!
Beispiel: in A1 steht 325 dann soll nach "Berechnung" in A2 - 3, A3 - 2 und in A4 - 5 stehen.
Gibt es dafür eine Formel? Question Question Question Question


DANKE für die bisherigen Formelvorschläge. War bei meiner Frage offenbar zu ungenau. Wie lautet die Formel wenn die Zahl aus einer Berechnung stammt?
1 + 9 + 7 + 8 = 25[/img]
Sorry
Arnim
Im Profil kannst Du frei den Rang ändern


Verfasst am:
27. Dez 2004, 20:44
Rufname:

AW: Mehrstellige Zahlen in einzelne Ziffern trennen! - AW: Mehrstellige Zahlen in einzelne Ziffern trennen!

Nach oben
       

Hallo verehrter Gast,
die letzte Frage erscheint mir auch wieder sehr "ungenau"!
Was willst Du wirklich??
Willst Du die Quersumme einer Zelle?

Gruß Arnim
Gast



Verfasst am:
27. Dez 2004, 22:13
Rufname:

AW: Mehrstellige Zahlen in einzelne Ziffern trennen! - AW: Mehrstellige Zahlen in einzelne Ziffern trennen!

Nach oben
       

Grüezi Gast

Mit den geposteten Formeln geht das Aufsplitten ungeachtet, ob die Zahl in A1 direkt eingegebenwird, oder ob sie durch eine Berechnung zustandekommt.

Oder wolltest Du die Aufsplittung zurück in deine 4 Summanden im Beispiel?
Das wird so einfach nicht funktionieren, da die Summe 25 über verschiedene Summanden erzielt werden kann.
Arnim
Im Profil kannst Du frei den Rang ändern


Verfasst am:
27. Dez 2004, 23:02
Rufname:

AW: Mehrstellige Zahlen in einzelne Ziffern trennen! - AW: Mehrstellige Zahlen in einzelne Ziffern trennen!

Nach oben
       

Ja, so einfach wird das nicht gehen! Razz
Sofern es sich um eine Summe handelt, die so aufgebaut ist: =H10+H12+H13+H14, könnte man ja noch diese Formel in der Zelle als Text editieren und sich den Spaß machen, diesen Text per Formel auseinander zu klabüstern. Heißt die Formel aber =SUMME(H10:H14), dann ist es schon Essig damit.
Er schreibt "Wie lautet die Formel wenn die Zahl aus einer Berechnung stammt?"
Diese Berechnung kann sehr kompliziert sein, nicht nur eine Summe.
Doch dazu äußert er sich nicht und auch, warum man eine Berechnung wieder "entrechnet".

Gruß Arnim
ejg
Einsteiger


Verfasst am:
28. Dez 2004, 12:55
Rufname:

Quersumme einer Zahl bilden - Quersumme einer Zahl bilden

Nach oben
       

Sorry, ich bin ein blutiger Anfänger und weiß nicht welche Angaben notwendig sind um über eine sinnvolle Formel nachzudenken!
Nochmals zur Präzisierung: Ich habe mir eine Excel-Tabelle gemacht, um einfacher/schneller Nummerologie-Berechnungen damit durchführen zu können.
Z.B.: Ich bilde die Quersumme des Geburtsdatums in dem ich jede Zahl davon in eine eigene Zelle eingebe und dann addiere. Von der Summe meist zweistellig ist, ist dann wieder die Quersumme zu bilden (0/5.0/5.1/9/4/8 = 32 = 5). Diese Zahl fließt dann wieder in viele Berechnungen wo ich wieder auf das Quersummen-Problem stoße. (Damit ich mir das manuelle aufsplitten ersparen kann, habe ich mir gedacht, die Excel-Experten haben dafür sicher eine Formel).
Lasst euch durch meine Frage die Freude an Excel – aber besonders am Leben – nicht verderben.
Embarassed ejg

_________________
Grüße und positiven Tag Smile
ae
Mein Name ist Ente


Verfasst am:
28. Dez 2004, 13:03
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Mehrstellige Zahlen in einzelne Ziffern trennen! - AW: Mehrstellige Zahlen in einzelne Ziffern trennen!

Nach oben
       

Hallo,

nur kein Stress - wir werden das Kind schon schaukeln -

mal ins Blaue geraten -

das ganze ist eine Art Lebenszahl die Basis für eine Deutung wird (Tarot, Steine, ..)

will heissen es wird solange die Quersumme gebildet, bis es eine 1 Stellige Zahl gibt ? oder was ist der Maxwert für die Quersumme ??

Ist es richtig, nach dem Geburtstag soll solange aus den 3 Teilwerten Jahr Monat und Tag die Quersumme gebildet werden , bis dieser Maxwert erreicht ist ?

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
ae
Mein Name ist Ente


Verfasst am:
28. Dez 2004, 13:09
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Mehrstellige Zahlen in einzelne Ziffern trennen! - AW: Mehrstellige Zahlen in einzelne Ziffern trennen!

Nach oben
       

Hier mal ein Bsp. wie ich es meine verstanden zu haben

Quersumme
<
 ABCD
1GeburtstagTagMonatJahr
210.07.19631071963
3Quersumme1719
4Summe Quersumme27  
5Quersumme 29  
Formeln der Tabelle
B2 : =TAG(A2)
C2 : =MONAT(A2)
D2 : =JAHR(A2)
B3 : =SUMMENPRODUKT(("0"&TEIL(B2;SPALTE(1:1);1))*1)
C3 : =SUMMENPRODUKT(("0"&TEIL(C2;SPALTE(1:1);1))*1)
D3 : =SUMMENPRODUKT(("0"&TEIL(D2;SPALTE(1:1);1))*1)
B4 : =SUMME(B3:D3)
B5 : =SUMMENPRODUKT(("0"&TEIL(B4;SPALTE(1:1);1))*1)
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
Thomas Ramel
Microsoft Excel-MVP


Verfasst am:
28. Dez 2004, 15:02
Rufname: Thom
Wohnort: Glashütten - CH


AW: Mehrstellige Zahlen in einzelne Ziffern trennen! - AW: Mehrstellige Zahlen in einzelne Ziffern trennen!

Nach oben
       

Grüezi zusammen

Ich war wohl vorhin nicht eingeloggt...

Ich habe ebenfalls an der Quersummenformel gearbeitet und aucheine Lösung gefunden, die direkt eine 1-stellige Quersumme liefert.
Hier die beiden Formeln in B1 und C1:

Tabelle1
 ABC
1123456789459
Formeln der Tabelle
B1 : =SUMMENPRODUKT((0&TEIL(A1;SPALTE(1:1);1))*1)
C1 : =SUMMENPRODUKT((0&TEIL(SUMMENPRODUKT((0&TEIL(A1;SPALTE(1:1);1))*1);SPALTE(1:1);1))*1)
 
_________________
Mit freundlichen Grüssen

Thomas Ramel
[Vista Ultimate SP-1 / xl2007 SP-2]
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Zellen mit Zahlen zählen, sonst nicht zählen - ? 3 Kara ben nemsi 15077 14. Apr 2005, 15:40
kara ben nemsi Zellen mit Zahlen zählen, sonst nicht zählen - ?
Keine neuen Beiträge Excel Formeln: Zahlen nach dem doppelpunkt dividieren 16 Julialia 1813 07. Apr 2005, 15:19
Gast Zahlen nach dem doppelpunkt dividieren
Keine neuen Beiträge Excel Formeln: Zählenwenn Zahlen zwischen 5 und 100 liegen 18 Amethyst 7722 23. Jan 2005, 19:34
Amethyst Zählenwenn Zahlen zwischen 5 und 100 liegen
Keine neuen Beiträge Excel Formeln: Einzelne Zellen miteinander vergleichen. 8 breid 1727 14. Jan 2005, 17:54
breid Einzelne Zellen miteinander vergleichen.
Keine neuen Beiträge Excel Formeln: Excel Formel Zahlen von Text trennen 2 Hauke81 2948 29. Nov 2004, 16:32
derschroe Excel Formel Zahlen von Text trennen
Keine neuen Beiträge Excel Formeln: Druckbereich:nur einzelne Spalten als Druckbereich markieren 3 mufty001 1912 21. Okt 2004, 09:24
mufty001 Druckbereich:nur einzelne Spalten als Druckbereich markieren
Keine neuen Beiträge Excel Formeln: Zahlen aus gemischtem Textfeld isolieren? 4 Newbiee 2731 27. Sep 2004, 22:59
fl618 Zahlen aus gemischtem Textfeld isolieren?
Keine neuen Beiträge Excel Formeln: speziell Zahlen runden für Schulnoten 9 superloll 4938 26. Sep 2004, 18:58
Arnim speziell Zahlen runden für Schulnoten
Keine neuen Beiträge Excel Formeln: überstunden / fehlzeiten berechnen (negative Zahlen!) 4 Gast 3049 30. Aug 2004, 11:51
ae überstunden / fehlzeiten berechnen (negative Zahlen!)
Keine neuen Beiträge Excel Formeln: Addieren von negativen Zahlen 1 cnettekoven 612 12. Aug 2004, 11:04
lala Addieren von negativen Zahlen
Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten. Excel Formeln: Negative Zahlen 1 mika2002 604 06. Aug 2004, 08:15
steve1da Negative Zahlen
Keine neuen Beiträge Excel Formeln: Filter auf ganze Zahlen? 2 Claudio 2643 01. Jul 2004, 14:10
Claudio Filter auf ganze Zahlen?
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML Forum