Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Wenn gleiches Datum...
zurück: Umwandlung eines Bereichs von rel. zu abs. Zellreferenz weiter: Vor- + Nachname sind in einer Zelle, sollen getrennt werdn Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Gekko
Gast


Verfasst am:
03. Feb 2005, 15:24
Rufname:

Wenn gleiches Datum... - Wenn gleiches Datum...

Nach oben
       

Hallo,

ich habe ein Formelproblem unter E2k und kann es leider nicht alleine lösen - wäre nett, wenn mir hier jemand hilft.

In Spalte A steht das Datum, in Spalte B Firmen.

1.1.05 Firma1
2.1.05 Firma1
3.1.05 Firma1
3.1.05 Firma2
4.1.05 Firma1
5.1.05 Firma1
5.1.05 Firma2

Ich möchte jetzt folgendes machen:

wenn in A1:A7 ein gleiches Datum steht und B="Firma2" ...

Danke

cu Gekko
Scelina
Mag den PC, doch mein PC mag mich oft nicht.


Verfasst am:
03. Feb 2005, 22:30
Rufname:
Wohnort: NRW


AW: Wenn gleiches Datum... - AW: Wenn gleiches Datum...

Nach oben
       

hi Gekko,

ich bin mir nicht sicher was du genau willst, aber vielleicht hilft dir mein folgender Versuch weiter
Code:
=WENN(UND(ZÄHLENWENN(A1:A7;"01.01.2005")=7;ZÄHLENWENN(B1:B7;"Firma b")=7);"alle gleich";"verschieden")

Du musst natürlich deine Werte einsetzen.

Schönen Abend noch
Scelina
Gekko
Gast


Verfasst am:
05. Feb 2005, 12:01
Rufname:

AW: Wenn gleiches Datum... - AW: Wenn gleiches Datum...

Nach oben
       

@Scelina

Das ist leider nicht das was ich meinte, aber Danke für Deine Mühe! Ich erkläre es mal anders:

In Spalte A steht das Datum, in Spalte B Firmen, in Spalte C Kilometer.

wenn in der Spalte A1 bis A800 ein gleiches Datum steht und in der betreffenden Spalte B "Firma2" steht, setze den Wert in der entsprechenden Spalte D auf 0

also:

1.1.05 Firma1 8
2.1.05 Firma1 8
3.1.05 Firma1 8
3.1.05 Firma2 6 0
4.1.05 Firma1 8
5.1.05 Firma1 8
5.1.05 Firma2 6 0
6.1.05 Firma2 6
7.1.05 Firma1 8

Würde eigentlich gerne ohne VB auskommen, aber wenn es nicht anders geht...

cu Gekko
Kuwe
Excel-Anwender mit VBA


Verfasst am:
05. Feb 2005, 13:37
Rufname: Uwe

AW: Wenn gleiches Datum... - AW: Wenn gleiches Datum...

Nach oben
       

Hallo Gekko,

wenn die Daten immer so sortiert sind wie von Dir dargestellt,
wäre es z.B. so machbar:
 
 ABCDE
1     
201.01.2005Firma18  
302.01.2005Firma18  
403.01.2005Firma18  
503.01.2005Firma260 
604.01.2005Firma18  
705.01.2005Firma18  
805.01.2005Firma260 
906.01.2005Firma26  
1007.01.2005Firma18  
11     
Formeln der Tabelle
D2 : =WENN(UND(B2="Firma2";A2=BEREICH.VERSCHIEBEN(A2;-1;0));0;"")
D3 : =WENN(UND(B3="Firma2";A3=BEREICH.VERSCHIEBEN(A3;-1;0));0;"")
D4 : =WENN(UND(B4="Firma2";A4=BEREICH.VERSCHIEBEN(A4;-1;0));0;"")
D5 : =WENN(UND(B5="Firma2";A5=BEREICH.VERSCHIEBEN(A5;-1;0));0;"")
D6 : =WENN(UND(B6="Firma2";A6=BEREICH.VERSCHIEBEN(A6;-1;0));0;"")
D7 : =WENN(UND(B7="Firma2";A7=BEREICH.VERSCHIEBEN(A7;-1;0));0;"")
D8 : =WENN(UND(B8="Firma2";A8=BEREICH.VERSCHIEBEN(A8;-1;0));0;"")
D9 : =WENN(UND(B9="Firma2";A9=BEREICH.VERSCHIEBEN(A9;-1;0));0;"")
D10 : =WENN(UND(B10="Firma2";A10=BEREICH.VERSCHIEBEN(A10;-1;0));0;"")
 

_________________
Gruß Uwe
rainberg
Excel-Anwender


Verfasst am:
05. Feb 2005, 15:37
Rufname:

AW: Wenn gleiches Datum... - AW: Wenn gleiches Datum...

Nach oben
       

Hallo Uwe,

warum der Umweg über BEREICH.VERSCHIEBEN?

Das würde doch reichen

Code:
=WENN(UND(B2="Firma2";A1=A2);0;"")
Kuwe
Excel-Anwender mit VBA


Verfasst am:
05. Feb 2005, 21:48
Rufname: Uwe

AW: Wenn gleiches Datum... - AW: Wenn gleiches Datum...

Nach oben
       

Hallooo Rainer,

schön, Dich hier zu treffen. Razz

Und zu Deiner Frage: Ich kann sie Dir nicht beantworten. Question
Du hast ja so recht.
Aber meine Variante sieht doch unheimlich wichtig aus. 8)

_________________
Gruß Uwe
Gast



Verfasst am:
06. Feb 2005, 14:07
Rufname:


AW: Wenn gleiches Datum... - AW: Wenn gleiches Datum...

Nach oben
       

@Uwe Küstner @rainberg

Vielen Dank!

cu Gekko
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Datum - Datum 2 bettyfcu 1050 13. Mai 2005, 10:32
fridgenep Datum - Datum
Keine neuen Beiträge Excel Formeln: restzeit bis zu einem bestimmten Datum 2 Jericho2000 1750 07. Apr 2005, 11:50
Jericho2000 restzeit bis zu einem bestimmten Datum
Keine neuen Beiträge Excel Formeln: Bei einer Wenn-Funktion mit Datum arbeiten!? 5 Neo[der Auserwählte] 2151 31. März 2005, 13:51
fl618 Bei einer Wenn-Funktion mit Datum arbeiten!?
Keine neuen Beiträge Excel Formeln: Datum in Excel Tabelle in Tagen darstellen 2 Unregistered 5102 22. März 2005, 20:49
Gast Datum in Excel Tabelle in Tagen darstellen
Keine neuen Beiträge Excel Formeln: Wenn Datum fast erreicht, Feld Rot 9 JörgK. 2958 21. März 2005, 16:29
JörgK. Wenn Datum fast erreicht, Feld Rot
Keine neuen Beiträge Excel Formeln: Datum in Zelle aktualisieren 2 Gast 1437 07. März 2005, 00:43
ae Datum in Zelle aktualisieren
Keine neuen Beiträge Excel Formeln: Datum rot anzeigen 2 Mimoss 2047 15. Feb 2005, 23:07
AnBo Datum rot anzeigen
Keine neuen Beiträge Excel Formeln: Datum aus mehreren Zellen zusammensetzen. 9 gast2005 5086 25. Dez 2004, 22:33
Kuwe Datum aus mehreren Zellen zusammensetzen.
Keine neuen Beiträge Excel Formeln: Vertragssumme ausr. bez. auf Datum heute und Datum Zukunft 7 Tristan68 1841 25. Nov 2004, 19:48
Arnim Vertragssumme ausr. bez. auf Datum heute und Datum Zukunft
Keine neuen Beiträge Excel Formeln: Datum automatisch berechnen 8 fisler0815 3392 21. Okt 2004, 14:41
icke Datum automatisch berechnen
Keine neuen Beiträge Excel Formeln: Datum 1 Peter3 2568 16. Okt 2004, 21:51
ae Datum
Keine neuen Beiträge Excel Formeln: DATUM -> Tage zählen ? 3 anna-bolika 4451 11. Okt 2004, 16:34
lou38 DATUM -> Tage zählen ?
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Access Tabellen