Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Zellen per VBA nach unten ziehen
zurück: EXCEL und CSV datei weiter: Erst Formeln aktualisieren, dann Makro ausführen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Offen Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
intermde
Gast


Verfasst am:
19. März 2009, 10:14
Rufname:

Zellen per VBA nach unten ziehen - Zellen per VBA nach unten ziehen

Nach oben
       Version: Office XP (2002)

Hallo, habe folgendes VBA geschrieben:

Sub Formeln_PROD_SYSTEM()

Range("A9").Select
ActiveCell.FormulaLocal = _
"=WENN('Import Bistro 1'!B1=" & Chr(34) & "defekt" & Chr(34) & ";'Import Bistro 1'!B1;WENN('Import Bistro 1'!B1=" & Chr(34) & "senden" & Chr(34) & ";'Import Bistro 1'!B1;WENN('Import Bistro 1'!B1=" & Chr(34) & "halten" & Chr(34) & ";'Import Bistro 1'!B1;" & Chr(34) & "" & Chr(34) & ")))"
Range("B9").Select
ActiveCell.FormulaLocal = _
"=WENN(A9=" & Chr(34) & "defekt" & Chr(34) & ";'Import Bistro 1'!c1;wenn(A9=" & Chr(34) & "senden" & Chr(34) & ";'Import Bistro 1'!C1;WENN(A9=" & Chr(34) & "halten" & Chr(34) & ";'Import Bistro 1'!C1;" & Chr(34) & "" & Chr(34) & ")))"
Range("C9").Select
ActiveCell.FormulaLocal = _
"=GLÄTTEN(WENN(A9=" & Chr(34) & "defekt" & Chr(34) & ";RECHTS('Import Bistro 1'!D1;LÄNGE('Import Bistro 1'!D1)-7);WENN(A9=" & Chr(34) & "senden" & Chr(34) & ";RECHTS('Import Bistro 1'!D1;LÄNGE('Import Bistro 1'!D1)-4);WENN(A9=" & Chr(34) & "Halten" & Chr(34) & ";RECHTS('Import Bistro 1'!D1;LÄNGE('Import Bistro 1'!D1)-7);" & Chr(34) & Chr(34) & "))))"
Range("D9").Select
ActiveCell.FormulaLocal = _
"=WENN(A9=" & Chr(34) & "defekt" & Chr(34) & ";LINKS('Import Bistro 1'!E1;LÄNGE('Import Bistro 1'!E1)-4);WENN(A9=" & Chr(34) & "senden" & Chr(34) & ";LINKS('Import Bistro 1'!E1;LÄNGE('Import Bistro 1'!E1)-4);WENN(A9=" & Chr(34) & "halten" & Chr(34) & ";LINKS('Import Bistro 1'!E1;LÄNGE('Import Bistro 1'!E1)-4);" & Chr(34) & "" & Chr(34) & ")))"
Range("E9").Select
ActiveCell.FormulaLocal = _
"=WENN(A9=" & Chr(34) & "senden" & Chr(34) & ";" & Chr(34) & "" & Chr(34) & ";HYPERLINK(" & Chr(34) & "http://10.112.230.99/admin/bistro?rm=dists%2Fdist&sid=9030f6a52ff07fc5002649483f604d82&e=&i=&stats=&p=" & Chr(34) & "&B11&" & Chr(34) & "%2F" & Chr(34) & "&C11&" & Chr(34) & "%2F" & Chr(34) & "&D11&" & Chr(34) & "%2C001&a=" & Chr(34) & ";C9))"
Range("J9").Select
ActiveCell.FormulaLocal = _
"=(WENN(A9=" & Chr(34) & "" & Chr(34) & ";" & Chr(34) & "" & Chr(34) & ";LINKS('Import Bistro 1'!F1;LÄNGE('Import Bistro 1'!F1)-4)*1))"

End Sub

Wie bekomme ich jetzt hin, dass die Zelle A9 - J9 automatisch bis A60-J60 kopiert werden.
Habe es über das Aufzeichnungsmakro versucht. Dieses funktioniert aber nicht:
ActiveCell.Range("A1:J1").Select
Selection.AutoFill Destination:=ActiveCell.Range("A1:J52"), Type:= _
xlFillDefault
ActiveCell.Range("A1:J52").Select

Excel kopiert trotz löschen der vorherigen Bereiche nicht neu rein.
intermde
Gast


Verfasst am:
19. März 2009, 10:15
Rufname:


AW: Zellen per VBA nach unten ziehen - AW: Zellen per VBA nach unten ziehen

Nach oben
       Version: Office XP (2002)

Ich mein natürlich mit kopieren, dass die Zellen nach unten gezogen und die Zellbezüge automatisch erweitert werden.
Mac4
Excel-/VBA-Anwender


Verfasst am:
19. März 2009, 10:28
Rufname:

AW: Zellen per VBA nach unten ziehen - AW: Zellen per VBA nach unten ziehen

Nach oben
       Version: Office XP (2002)

Hi,

Range("A9:A50").FormulaLocal = _
"=WENN('Import Bistro 1'!B1=" & Chr(34) & "defekt" & Chr(34) & ";'Import Bistro 1'!B1;WENN('Import Bistro 1'!B1=" & Chr(34) & "senden" & Chr(34) & ";'Import Bistro 1'!B1;WENN('Import Bistro 1'!B1=" & Chr(34) & "halten" & Chr(34) & ";'Import Bistro 1'!B1;" & Chr(34) & "" & Chr(34) & ")))"

_________________
Gruß aus Köln!
Marc

- Bei angegeben Matrixformeln - zu erkennen an den geschweiften Klammern {}, diese nicht mit eingeben - sie werden zum Formelabschluss mit Strg+Shift+Enter automatisch erzeugt! -
intermde
Gast


Verfasst am:
19. März 2009, 12:00
Rufname:


AW: Zellen per VBA nach unten ziehen - AW: Zellen per VBA nach unten ziehen

Nach oben
       Version: Office XP (2002)

Danke für den Tipp hätt ich selber drauf kommen können,

nur leider geht dieses bei einer Zeile nicht:
Range("E120").Select
ActiveCell.FormulaLocal = _
"=WENN(A120=" & Chr(34) & "senden" & Chr(34) & ";" & Chr(34) & "" & Chr(34) & ";HYPERLINK(" & Chr(34) & "http://10.112.230.119/admin/bistro?rm=dist&sid=9d591405930ca0a647bf21aeabbcf2c9&e=&i=&stats=&p=" & Chr(34) & "&B11&" & Chr(34) & "%2F" & Chr(34) & "&C11&" & Chr(34) & "%2F" & Chr(34) & "&D11&" & Chr(34) & "%2C001&a=" & Chr(34) & ";C120))"

Da hier bei C120 am ende immer der ensprechende Wert genommen wird.. Wenn Ich diese von E120 auf E120:E160 setze bleibt in jeder E Zelle die Abfrage mit C120 stehen und erweitert sich nicht entsprechend.

Oder kann dieses auch gelöst werden, das der C120 auch z.b. mit C120:160 gesetzt werden kann.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Zellen miteinander verlinken 2 holfloser Gast 1527 07. Feb 2005, 10:50
holfloser Gast Zellen miteinander verlinken
Keine neuen Beiträge Excel Formeln: Runden von mehreren Zellen gleichzeitig 2 p_fr1968 3274 26. Jan 2005, 11:20
p_fr1968 Runden von mehreren Zellen gleichzeitig
Keine neuen Beiträge Excel Formeln: zellen verbinden 1 Gast 1414 22. Jan 2005, 01:11
jochenj zellen verbinden
Keine neuen Beiträge Excel Formeln: Einzelne Zellen miteinander vergleichen. 8 breid 1726 14. Jan 2005, 17:54
breid Einzelne Zellen miteinander vergleichen.
Keine neuen Beiträge Excel Formeln: Worte aus einer Zelle in 2 Zellen schreiben 2 Sven79 1322 12. Jan 2005, 01:20
Sven79 Worte aus einer Zelle in 2 Zellen schreiben
Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten. Excel Formeln: Bestimmten Zellen einen Wert zuteilen. 1 tomimmo 2544 03. Dez 2004, 20:35
ae Bestimmten Zellen einen Wert zuteilen.
Keine neuen Beiträge Excel Formeln: Zellen auswerten 4 Cat 1526 11. Nov 2004, 01:20
Gast Zellen auswerten
Keine neuen Beiträge Excel Formeln: Excel Zellen verknüpfen! 1 Gast 2858 10. Nov 2004, 10:41
Gast Excel Zellen verknüpfen!
Keine neuen Beiträge Excel Formeln: 2 oder mehr zellen verbinden, nicht VERKETTEN mit & 5 ALEKS 3246 28. Okt 2004, 10:55
Aleks 2 oder mehr zellen verbinden, nicht VERKETTEN mit &
Keine neuen Beiträge Excel Formeln: Blattschutz: bestimmte Zellen zum Löschen freigeben 6 Christiane 1203 21. Okt 2004, 07:17
lala Blattschutz: bestimmte Zellen zum Löschen freigeben
Keine neuen Beiträge Excel Formeln: Summe verschiedener Zellen mit Suchkreterium (sverweis) 3 Ralli 11135 13. Okt 2004, 23:12
ae Summe verschiedener Zellen mit  Suchkreterium (sverweis)
Keine neuen Beiträge Excel Formeln: Zellen zusammenfassen 4 annett 1318 12. Aug 2004, 11:35
annett Zellen zusammenfassen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: JavaScript