Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Parameterabfrage in Unterformular
zurück: COUNT Probelmatik weiter: xml Datei importieren mit Aktualisierungsoption Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
kassandra
Anfänger


Verfasst am:
22. Feb 2005, 15:11
Rufname:

Parameterabfrage in Unterformular - Parameterabfrage in Unterformular

Nach oben
       

Hallo zusammen
Ich habe ein Formular mit einem ungebundenen Unterformular. Nun möchte ich über einen Button die ausgewählte Abfrage im Unterformular anzeigen. Das klappt auch, nur werden die Parameter zweimal hintereinander abgefragt.

Hier das Stück Code, das Unterformular heisst Abfrage
Code:
Private Sub KundenZivilstand_Click()
On Error GoTo Err_KundenZivilstand_Click
    Dim stDocName As String

    stDocName = "Kundenliste nach Zivilstand"
    Me!Abfragen.SourceObject = "Abfrage." & stDocName
    Me!Text140 = stDocName

Öffne ich die Abfrage Kundenliste nach Zivilstand in einem eigenen Fenster, kommt die Frage nach dem Zivilstand nur einmal. Bitte, hat irgendwer eine Ahnung, wo der Fehler liegt?
Vielen Dank
Claudia
lothi
c#, .Net


Verfasst am:
23. Feb 2005, 13:57
Rufname:
Wohnort: Birgisch

AW: Parameterabfrage in Unterformular - AW: Parameterabfrage in Unterformular

Nach oben
       

Hallo Claudia

Dieser Teil verstehe ich nicht:
Code:
    Me!Abfragen.SourceObject = "Abfrage." & stDocName
Was ist Abfrage das Unterformular?

So wie ich das kenne sollte das so aussehen:
Code:
    Me!Abfrage.SourceObjekt = stDocName
Ohne das Abfrage.

Kann es sein das du das Formular beim schliessen speicherst?
Wenn das so ist, erscheint das nächste mal beim öffnen die Parameterabfrage wegen der gespeicherten Abfrage und das zweite mal bei der zuweisung über den Code.

_________________
Gruss Lothi, der Bastler
Feedback ist die beste Möglichkeit mir zu sagen ob die Antwort geholfen hat!
AC2002, WinXP, Office XP
kassandra
Anfänger


Verfasst am:
09. März 2005, 11:15
Rufname:


AW: Parameterabfrage in Unterformular - AW: Parameterabfrage in Unterformular

Nach oben
       

Vielen Dank für die Antwort.
Abfragen ist der Name des Unterformular, stDocName ist der Name der Abfrage und mit
Code:
    Me!Abfrage.SourceObjekt = stDocName
gibt es eine Fehlermeldung, dass das Objekt nicht gefunden wurde.
Das mit dem Schliessen verstehe ich nun nicht genau, ich schliesse das Formular ja gar nicht, da ich im das geöffneten Formular verschiedene Abfragen im Unterformular anzeigen möchte. Die Parameter sind in der Abfrage selbst gesetzt.
Die erste Aufforderung zur Paramterübergabe kann ich übrigens einfach wegklicken, es werden nur die zweiten Werte übernommen.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Access Tabellen & Abfragen: Befehlsschaltläche bezieht sich auf Unterformular! 12 seppel27 809 15. Aug 2007, 13:07
seppel27 Befehlsschaltläche bezieht sich auf Unterformular!
Keine neuen Beiträge Access Tabellen & Abfragen: Parameterabfrage: Parameter aus Tabelle 1 Gast1860 1138 29. Mai 2007, 20:14
jens05 Parameterabfrage: Parameter aus Tabelle
Keine neuen Beiträge Access Tabellen & Abfragen: Parameterabfrage mit Operatoren 10 jack-y 909 10. Mai 2007, 18:14
jack-y Parameterabfrage mit Operatoren
Keine neuen Beiträge Access Tabellen & Abfragen: Formatierung bei Parameterabfrage 11 Craig Marduk 980 09. Apr 2007, 17:24
Willi Wipp Formatierung bei Parameterabfrage
Keine neuen Beiträge Access Tabellen & Abfragen: Parameterabfrage 5 Gast 608 18. Jan 2007, 12:41
Nouba Parameterabfrage
Keine neuen Beiträge Access Tabellen & Abfragen: Wie kann ich in einer Parameterabfrage einen Wert vorgeben? 4 Kl@vier 1518 30. Aug 2006, 12:17
Kl@vier Wie kann ich in einer Parameterabfrage einen Wert vorgeben?
Keine neuen Beiträge Access Tabellen & Abfragen: Änderung der Datenquelle für ein Unterformular 6 turbochris 4721 06. Mai 2006, 10:56
Willi Wipp Änderung der Datenquelle für ein Unterformular
Keine neuen Beiträge Access Tabellen & Abfragen: Parameterabfrage aus mehreren Feldern 1 plapylus 810 25. Apr 2006, 19:56
jens05 Parameterabfrage aus mehreren Feldern
Keine neuen Beiträge Access Tabellen & Abfragen: Problem mit Parameterabfrage 10 Frankie 700 15. März 2006, 13:20
Frankie Problem mit Parameterabfrage
Keine neuen Beiträge Access Tabellen & Abfragen: Parameterabfrage mit mehreren Suchbegriffen 17 Anke570 8637 19. Jan 2006, 20:26
accessmichel Parameterabfrage mit mehreren Suchbegriffen
Keine neuen Beiträge Access Tabellen & Abfragen: Parameterabfrage mit Zahlen 2 friend 913 09. Jan 2006, 21:34
Gast Parameterabfrage mit Zahlen
Keine neuen Beiträge Access Tabellen & Abfragen: Parameterabfrage 2 friend 582 09. Jan 2006, 21:04
friend Parameterabfrage
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML CSS