Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Max/Min Werte Excel 2000 Formel/Tipp
zurück: Verknüpfung mit ungeöffneten Arbeitsmappen per Auto-Formel weiter: trading Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Unregister
Gast


Verfasst am:
10. März 2005, 13:51
Rufname:

Max/Min Werte Excel 2000 Formel/Tipp - Max/Min Werte Excel 2000 Formel/Tipp

Nach oben
       

Hallo zusammen,

habe folgendes Tabellenbeispiel: (E2k)

Recceived Month / Handling Time (days)
2005-01 / 15
2005-04 / 25
2005-03 / 28
2005-02 / 15
2005-01 / 20
2005-04 / 5
2005-03 / 7
2005-02 / 8
2005-01 / 10
2005-04 / 12
2005-03 / 15
2005-02 / 14
2005-01 / 16
2005-04 / 15
2005-03 / 12
2005-02 /11
2005-01 / 7

Dies steht in zwei spalten.
Da ich nun in einem graphen für die jeweiligen Monate die Min und Max Werte ausrechnen und anzeigen möchte (Börsenchart) möchte ich euch um Hilfe bitten. Habt Ihr irgendeine Idee oder am besten die ultimative Formel dazu?

Tabelle sollte dann so aussehen:
Recceived Month: Maximum Time (days): Minimum Time (days):
2005-01 20 7
2005-02 usw..

Vielen Dank im voraus

Christian
rainberg
Excel-Anwender


Verfasst am:
10. März 2005, 16:25
Rufname:


AW: Max/Min Werte Excel 2000 Formel/Tipp - AW: Max/Min Werte Excel 2000 Formel/Tipp

Nach oben
       

Hallo Christian,

meine Lösung geht davon aus, dass in Spalte A ein Datum im Format "JJJJ-MM" steht.

Tabelle1
 ABCDE
1   MinMax
22005-01152005-01720
32005-04252005-02815
42005-03282005-03728
52005-02152005-04525
62005-0120   
72005-045   
82005-037   
92005-028   
102005-0110   
112005-0412   
122005-0315   
132005-0214   
142005-0116   
152005-0415   
162005-0312   
172005-0211   
182005-017   
Formeln der Tabelle
C2 : =MIN(A:A)
D2 : {=MIN(WENN(($A$2:$A$18=$C2)*($A$2:$A$18&gt;0);$B$2:$B$18))}
E2 : {=MAX(WENN(($A$2:$A$18=$C2)*($A$2:$A$18&gt;0);$B$2:$B$18))}
C3 : =WENN(MAX(A:A)=MAX(C$2:C2);"";KGRÖSSTE(A:A;ZÄHLENWENN(A:A;"&gt;"&C2)))
D3 : {=MIN(WENN(($A$2:$A$18=$C3)*($A$2:$A$18&gt;0);$B$2:$B$18))}
E3 : {=MAX(WENN(($A$2:$A$18=$C3)*($A$2:$A$18&gt;0);$B$2:$B$18))}
C4 : =WENN(MAX(A:A)=MAX(C$2:C3);"";KGRÖSSTE(A:A;ZÄHLENWENN(A:A;"&gt;"&C3)))
D4 : {=MIN(WENN(($A$2:$A$18=$C4)*($A$2:$A$18&gt;0);$B$2:$B$18))}
E4 : {=MAX(WENN(($A$2:$A$18=$C4)*($A$2:$A$18&gt;0);$B$2:$B$18))}
C5 : =WENN(MAX(A:A)=MAX(C$2:C4);"";KGRÖSSTE(A:A;ZÄHLENWENN(A:A;"&gt;"&C4)))
D5 : {=MIN(WENN(($A$2:$A$18=$C5)*($A$2:$A$18&gt;0);$B$2:$B$18))}
E5 : {=MAX(WENN(($A$2:$A$18=$C5)*($A$2:$A$18&gt;0);$B$2:$B$18))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 

Die Formel in C3 lautet richtig:
Code:
=WENN(MAX(A:A)=MAX(C$2:C2);"";KGRÖSSTE(A:A;ZÄHLENWENN(A:A;">"&C2)))
Unregister
Gast


Verfasst am:
10. März 2005, 17:06
Rufname:

Funktioniert nicht - Funktioniert nicht

Nach oben
       

Hallo,

erstmal vielen Dank.

Leider funktioniert es nicht. Ich glaube, da es sich nicht um ein Datumsformat handelt. Es ist Text.

Hoffentlich weißt Du da auch Rat.

Viele Grüsse und Danke nochmal

Christian
Unregister
Gast


Verfasst am:
10. März 2005, 17:21
Rufname:

Re: Max/Min Werte Excel 2000 Formel/Tipp - Re: Max/Min Werte Excel 2000 Formel/Tipp

Nach oben
       

Unregister hat folgendes geschrieben:
Hallo zusammen,

habe folgendes Tabellenbeispiel: (E2k)

Recceived Month / Handling Time (days)
2005-01 / 15
2005-04 / 25
2005-03 / 28
2005-02 / 15
2005-01 / 20
2005-04 / 5
2005-03 / 7
2005-02 / 8
2005-01 / 10
2005-04 / 12
2005-03 / 15
2005-02 / 14
2005-01 / 16
2005-04 / 15
2005-03 / 12
2005-02 /11
2005-01 / 7

Dies steht in zwei spalten.
Da ich nun in einem graphen für die jeweiligen Monate die Min und Max Werte ausrechnen und anzeigen möchte (Börsenchart) möchte ich euch um Hilfe bitten. Habt Ihr irgendeine Idee oder am besten die ultimative Formel dazu?

Tabelle sollte dann so aussehen:
Recceived Month: Maximum Time (days): Minimum Time (days):
2005-01 20 7
2005-02 usw..

Vielen Dank im voraus


Geht leider nicht. Die Matrix funktioniert. Aber die Min max gehen nicht!

Grüsse

Christian
Christian
rainberg
Excel-Anwender


Verfasst am:
10. März 2005, 18:06
Rufname:

AW: Max/Min Werte Excel 2000 Formel/Tipp - AW: Max/Min Werte Excel 2000 Formel/Tipp

Nach oben
       

Hallo Christian,

glauben nützt hier herzlich wenig, aber du solltest doch feststellen können um welches Format es sich handelt, wenn du die Tabelle vorliegen hast.
Ich konnte es nicht, deshalb habe ich nur ein Datumsformat vermutet.

Wenn es nun doch Text ist dann füge eine Hilfsspalte ein und formatiere sie (nur wegen der Optik) benutzerdefiniert "JJJJ-MM" und verfahre wie im Beispiel.

Tabelle1
 ABCDEF
1Hilfsspalte   MinMax
22005-012005-01152005-01720
32005-042005-04252005-02815
42005-032005-03282005-03728
52005-022005-02152005-04525
62005-012005-0120   
72005-042005-045   
82005-032005-037   
92005-022005-028   
102005-012005-0110   
112005-042005-0412   
122005-032005-0315   
132005-022005-0214   
142005-012005-0116   
152005-042005-0415   
162005-032005-0312   
172005-022005-0211   
182005-012005-017   
Formeln der Tabelle
A2 : =DATUM(LINKS(B2;4);RECHTS(B2;2);1)
D2 : =MIN(A:A)
E2 : {=MIN(WENN(($A$2:$A$18=$D2)*($A$2:$A$18&gt;0);$C$2:$C$18))}
F2 : {=MAX(WENN(($A$2:$A$18=$D2)*($A$2:$A$18&gt;0);$C$2:$C$18))}
A3 : =DATUM(LINKS(B3;4);RECHTS(B3;2);1)
D3 : =WENN(MAX(A:A)=MAX(D$2:D2);"";KGRÖSSTE(A:A;ZÄHLENWENN(A:A;"&gt;"&D2)))
E3 : {=MIN(WENN(($A$2:$A$18=$D3)*($A$2:$A$18&gt;0);$C$2:$C$18))}
F3 : {=MAX(WENN(($A$2:$A$18=$D3)*($A$2:$A$18&gt;0);$C$2:$C$18))}
A4 : =DATUM(LINKS(B4;4);RECHTS(B4;2);1)
D4 : =WENN(MAX(A:A)=MAX(D$2:D3);"";KGRÖSSTE(A:A;ZÄHLENWENN(A:A;"&gt;"&D3)))
E4 : {=MIN(WENN(($A$2:$A$18=$D4)*($A$2:$A$18&gt;0);$C$2:$C$18))}
F4 : {=MAX(WENN(($A$2:$A$18=$D4)*($A$2:$A$18&gt;0);$C$2:$C$18))}
A5 : =DATUM(LINKS(B5;4);RECHTS(B5;2);1)
D5 : =WENN(MAX(A:A)=MAX(D$2:D4);"";KGRÖSSTE(A:A;ZÄHLENWENN(A:A;"&gt;"&D4)))
E5 : {=MIN(WENN(($A$2:$A$18=$D5)*($A$2:$A$18&gt;0);$C$2:$C$18))}
F5 : {=MAX(WENN(($A$2:$A$18=$D5)*($A$2:$A$18&gt;0);$C$2:$C$18))}
A6 : =DATUM(LINKS(B6;4);RECHTS(B6;2);1)
D6 : =WENN(MAX(A:A)=MAX(D$2:D5);"";KGRÖSSTE(A:A;ZÄHLENWENN(A:A;"&gt;"&D5)))
A7 : =DATUM(LINKS(B7;4);RECHTS(B7;2);1)
A8 : =DATUM(LINKS(B8;4);RECHTS(B8;2);1)
A9 : =DATUM(LINKS(B9;4);RECHTS(B9;2);1)
A10 : =DATUM(LINKS(B10;4);RECHTS(B10;2);1)
A11 : =DATUM(LINKS(B11;4);RECHTS(B11;2);1)
A12 : =DATUM(LINKS(B12;4);RECHTS(B12;2);1)
A13 : =DATUM(LINKS(B13;4);RECHTS(B13;2);1)
A14 : =DATUM(LINKS(B14;4);RECHTS(B14;2);1)
A15 : =DATUM(LINKS(B15;4);RECHTS(B15;2);1)
A16 : =DATUM(LINKS(B16;4);RECHTS(B16;2);1)
A17 : =DATUM(LINKS(B17;4);RECHTS(B17;2);1)
A18 : =DATUM(LINKS(B18;4);RECHTS(B18;2);1)

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 

Die Formel aus D3 noch mal im Klartext

Code:
=WENN(MAX(A:A)=MAX(D$2:D2);"";KGRÖSSTE(A:A;ZÄHLENWENN(A:A;">"&D2)))
rainberg
Excel-Anwender


Verfasst am:
11. März 2005, 19:37
Rufname:


AW: Max/Min Werte Excel 2000 Formel/Tipp - AW: Max/Min Werte Excel 2000 Formel/Tipp

Nach oben
       

Hallo Christian,

es wäre schön, wenn du dich mal zu meinem zweiten Vorschlag äußern würdest.
Möchte nämlich meine Testtabelle auch wieder mal löschen.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Für EXCEL-PROFIS: Formel für Zahlentreffer 1 onkelbobby 2722 20. Apr 2004, 12:21
Gast Für EXCEL-PROFIS: Formel für Zahlentreffer
Keine neuen Beiträge Excel Formeln: MsgBox in Excel Formel 3 Brandlife 2885 19. Apr 2004, 18:49
Brandlife MsgBox in Excel Formel
Keine neuen Beiträge Excel Formeln: Problem mit WENN Formel 1 Hubert 2799 17. Apr 2004, 23:00
Robsl Problem mit WENN Formel
Keine neuen Beiträge Excel Formeln: Suche Formel für meinen Urlaubsplaner 1 carlos 2875 11. Apr 2004, 22:23
Klaus-Dieter Suche Formel für meinen Urlaubsplaner
Keine neuen Beiträge Excel Formeln: Formel für Leerzeilen 2 Ursula 2167 24. März 2004, 12:31
steve1da Formel für Leerzeilen
Keine neuen Beiträge Excel Formeln: Formel 1 posti 636 20. März 2004, 15:51
Dick Formel
Keine neuen Beiträge Excel Formeln: Formel? 8 MantaC24NE 1355 17. März 2004, 14:40
Sebastian Formel?
Keine neuen Beiträge Excel Formeln: SVERWEIS - Hilfe die Formel klappt nicht !!! 3 sabine99 2359 15. März 2004, 16:19
sabine99 SVERWEIS - Hilfe die Formel klappt nicht !!!
Keine neuen Beiträge Excel Formeln: Mathematische Formel gesucht! 2 Gast 1367 05. März 2004, 01:18
lala Mathematische Formel gesucht!
Keine neuen Beiträge Excel Formeln: Platzhalter in deiner SUMMEPRODUKT formel 5 seraph 3464 03. März 2004, 18:26
seraph Platzhalter in deiner SUMMEPRODUKT formel
Keine neuen Beiträge Excel Formeln: Suche ein Formel 4 Unwissender 2147 20. Feb 2004, 09:45
xpecidy Suche ein Formel
Keine neuen Beiträge Excel Formeln: WENN bzw. SUMMEWENN Formel (Provisionsberechnung) 4 Uli 6094 17. Feb 2004, 09:58
Manfred Bartak WENN bzw. SUMMEWENN Formel (Provisionsberechnung)
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML Editor Forum