Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Vergleichen von Spalten UND Zeilen.
zurück: Suche Formel für mein Probelm weiter: aus mehreren spalten einespalte?? Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
mojoe321
Neuling


Verfasst am:
15. März 2005, 12:39
Rufname:

Vergleichen von Spalten UND Zeilen. - Vergleichen von Spalten UND Zeilen.

Nach oben
       

Hallo,

ich habe folgende Ausgangssituation:

Spalte A mit 5174 Zellen und Spalte B mit 4737 Zellen. Inhalt der Zellen sind Zahlen. Es soll nun verglichen werden, welche Zahl zB. in Spalte A vorhanden aber in Spalte B nicht vorhanden bzw. in B da und in A nicht. Diese soll dann in Spalte C ausgegeben werden.

Danke und mfg
Hübi
Es gibt immer bessere Lösungen, als meine.


Verfasst am:
15. März 2005, 14:04
Rufname: Hübi (selten Herbert)
Wohnort: Strausberg


AW: Vergleichen von Spalten UND Zeilen. - AW: Vergleichen von Spalten UND Zeilen.

Nach oben
       

Hi Mojoe,

als Formellösung mit Hilfsspalten
mojoe
 ABCDE
1Werte 1Werte 2Unikate sortiertnicht in Anicht in B
2113213 
3237 2
43797 
591111119
63377137733
7100133 100
899 77 99
9  99  
10  100  
Formeln der Tabelle
C2 : =KKLEINSTE(D:E;ZEILE(A1))
D2 : =WENN(ZÄHLENWENN(A:A;B2)&gt;=1;"";B2)
E2 : =WENN(ZÄHLENWENN(B:B;A2)&gt;=1;"";A2)
C3 : =KKLEINSTE(D:E;ZEILE(A2))
D3 : =WENN(ZÄHLENWENN(A:A;B3)&gt;=1;"";B3)
E3 : =WENN(ZÄHLENWENN(B:B;A3)&gt;=1;"";A3)
C4 : =KKLEINSTE(D:E;ZEILE(A3))
D4 : =WENN(ZÄHLENWENN(A:A;B4)&gt;=1;"";B4)
E4 : =WENN(ZÄHLENWENN(B:B;A4)&gt;=1;"";A4)
C5 : =KKLEINSTE(D:E;ZEILE(A4))
D5 : =WENN(ZÄHLENWENN(A:A;B5)&gt;=1;"";B5)
E5 : =WENN(ZÄHLENWENN(B:B;A5)&gt;=1;"";A5)
C6 : =KKLEINSTE(D:E;ZEILE(A5))
D6 : =WENN(ZÄHLENWENN(A:A;B6)&gt;=1;"";B6)
E6 : =WENN(ZÄHLENWENN(B:B;A6)&gt;=1;"";A6)
C7 : =KKLEINSTE(D:E;ZEILE(A6))
D7 : =WENN(ZÄHLENWENN(A:A;B7)&gt;=1;"";B7)
E7 : =WENN(ZÄHLENWENN(B:B;A7)&gt;=1;"";A7)
C8 : =KKLEINSTE(D:E;ZEILE(A7))
E8 : =WENN(ZÄHLENWENN(B:B;A8)&gt;=1;"";A8)
C9 : =KKLEINSTE(D:E;ZEILE(A8))
C10 : =KKLEINSTE(D:E;ZEILE(A9))
 

_________________
Gruß Hübi
[Tipps getestet mit Win XP Prof. SP-2, Office 2000 Premium SP3 / Office 2003 Prof. SP3 / Office Professional 2007 SP1]
mojoe321
Neuling


Verfasst am:
15. März 2005, 16:18
Rufname:

AW: Vergleichen von Spalten UND Zeilen. - AW: Vergleichen von Spalten UND Zeilen.

Nach oben
       

Danke erstmal für die schnelle Hilfe, hat funktioniert.

Ein Frage noch: was bedutet das > in der Formel

mfg
Hübi
Es gibt immer bessere Lösungen, als meine.


Verfasst am:
15. März 2005, 17:14
Rufname: Hübi (selten Herbert)
Wohnort: Strausberg


AW: Vergleichen von Spalten UND Zeilen. - AW: Vergleichen von Spalten UND Zeilen.

Nach oben
       

Hi Mojoe,

die Darstellung mit Jeanie schreibt leider das > Zeichen als
Code:
&gt; und das <-Zeichen als &lt;

Hatte leider vergessen, das wie hier drunter zu schreiben - sorry

_________________
Gruß Hübi
[Tipps getestet mit Win XP Prof. SP-2, Office 2000 Premium SP3 / Office 2003 Prof. SP3 / Office Professional 2007 SP1]
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Tabellen Vergleichen 1 eddi40 2209 22. Feb 2005, 17:55
fridgenep Tabellen Vergleichen
Keine neuen Beiträge Excel Formeln: Zellen vergleichen 17 fridgenep 3837 11. Feb 2005, 11:36
fridgenep Zellen vergleichen
Keine neuen Beiträge Excel Formeln: Werte vergleichen und übernehmen 8 10823berlin 2409 08. Feb 2005, 20:40
rainberg Werte vergleichen und übernehmen
Keine neuen Beiträge Excel Formeln: Vergleichen 2 Tabellen mit ausgabe der fehlenden werte 1 Julie 2923 25. Jan 2005, 16:53
fridgenep Vergleichen 2 Tabellen mit ausgabe der fehlenden werte
Keine neuen Beiträge Excel Formeln: Zeilen mit doppelten Werten löschen 6 Sebowsky 1208 06. Jan 2005, 22:26
Sebowsky Zeilen mit doppelten Werten löschen
Keine neuen Beiträge Excel Formeln: 2 Daten miteinander vergleichen, wenn gleich dann Text 1 BennyII 4347 11. Dez 2004, 12:00
ae 2 Daten miteinander vergleichen, wenn gleich dann Text
Keine neuen Beiträge Excel Formeln: Erster Wert aus mehreren Spalten 4 Gast 1922 03. Dez 2004, 10:52
Arnim Erster Wert aus mehreren Spalten
Keine neuen Beiträge Excel Formeln: Vor- und Nachname in 1 Spalte in 2 Spalten aufteilen 2 Gast 2920 26. Nov 2004, 11:48
Gast Vor- und Nachname in 1 Spalte in 2 Spalten aufteilen
Keine neuen Beiträge Excel Formeln: Zählen von Werten aus untersch. Spalten mit 2 Kriterien 2 Sigi 2526 20. Nov 2004, 03:18
Gast Zählen von Werten aus untersch. Spalten mit 2 Kriterien
Keine neuen Beiträge Excel Formeln: ZÄHLENWENN bei 2 Suchkriterien in wechselnden Spalten 10 Rebecca Nau 1909 12. Nov 2004, 11:26
Arnim ZÄHLENWENN bei 2 Suchkriterien in wechselnden Spalten
Keine neuen Beiträge Excel Formeln: Wenn-Bedingung mit mehreren Spalten und Zeile 6 Lusie 2819 02. Nov 2004, 15:57
Lusie Wenn-Bedingung mit mehreren Spalten und Zeile
Keine neuen Beiträge Excel Formeln: Druckbereich:nur einzelne Spalten als Druckbereich markieren 3 mufty001 1912 21. Okt 2004, 09:24
mufty001 Druckbereich:nur einzelne Spalten als Druckbereich markieren
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: PHP JavaScript