Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Datums- und Wochentagsangabe
zurück: aus Excel Daten in Access exportieren weiter: Lagerverwaltung Access Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Brazoswood80
Gast


Verfasst am:
19. Okt 2009, 13:10
Rufname:

Datums- und Wochentagsangabe - Datums- und Wochentagsangabe

Nach oben
       Version: Office 2003

Hallo,

für ein standardisiertes Monatsreporting möchte ich in einer Tagesübersicht das Datum und den Wochentag in Abhängigkeit des Monats automatisch erzeugen lassen. Der Monat soll in einem Feld geschrieben werden (Form: Oktober, November,...) woraufhin sich dann die Kopfzeile der Tagesübersicht automatisch ändert.

Begonnen werden soll mit dem ersten Arbeitstag (keine Berücksichtigung der Feiertage) des Monats. In der Zeile darunter erscheint der Wochentag (Mo, Di,...).

So ungefähr soll es aussehen:

Das Feld zum eingeben

Monat--------------Jahr
November ----------2009

Die Tabelle:


2.11.2009-----3.11.2009-----4.11.2009
Mo----------------Di-------------Mi --> Wochenende nicht mit anzeigen

Ich hoffe, dass das irgendwie geht.

Vielen Dank für eure Hilfe!
Gast



Verfasst am:
19. Okt 2009, 13:28
Rufname:


AW: Datums- und Wochentagsangabe - AW: Datums- und Wochentagsangabe

Nach oben
       Version: Office 2003

Hallo Peter,

wie bekomme ich es hin, dass in A5 der Wochentag steht? Ansonsten genau das was ich wollte.

Danke!
< Peter >
Excel-Moderator, der immer noch dazu lernt


Verfasst am:
19. Okt 2009, 13:33
Rufname: Kommt darauf an wer ruft
Wohnort: Das schönste Land in Deutschlands Gaun

AW: Datums- und Wochentagsangabe - AW: Datums- und Wochentagsangabe

Nach oben
       Version: Office 2003

Hallo,

ich habe mein voriges Posting nochmals gelöscht weil ich einen Fehler in der Formel hatte.

Versuch es mal damit:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEF
1November2009    
2      
3      
402.11.200903.11.200904.11.200905.11.200906.11.200909.11.2009
5MontagDienstagMittwochDonnerstagFreitagMontag

ZelleFormel
A4=WENN(WOCHENTAG(DATUM(B1;MONAT(A1&1);1);2)=7;DATUM(B1;MONAT(A1&1);2);WENN(WOCHENTAG(DATUM(B1;MONAT(A1&1);1);2)=6;DATUM(B1;MONAT(A1&1);3);DATUM(B1;MONAT(A1&1);1)))
B4=WENN(WOCHENTAG(A4)<=5;A4+1;A4+3)
C4=WENN(WOCHENTAG(B4)<=5;B4+1;B4+3)
D4=WENN(WOCHENTAG(C4)<=5;C4+1;C4+3)
E4=WENN(WOCHENTAG(D4)<=5;D4+1;D4+3)
F4=WENN(WOCHENTAG(E4)<=5;E4+1;E4+3)
A5=A4
B5=B4
C5=C4
D5=D4
E5=E4
F5=F4


Die Zelle A5 ist benutzerdefiniert formatiert mit dem Format TTT

_________________
Gruß
Peter
Brazoswood
Neuling


Verfasst am:
19. Okt 2009, 13:39
Rufname:

AW: Datums- und Wochentagsangabe - AW: Datums- und Wochentagsangabe

Nach oben
       Version: Office 2003

Hallo Peter,

sehr schön! Ich habe es jetzt hinbekommen und fürs nächste Jahr funktioniert es auch.

Vielen Dank, das war wirklich eine große Hilfe.
Brazoswood
Neuling


Verfasst am:
19. Okt 2009, 14:33
Rufname:

AW: Datums- und Wochentagsangabe - AW: Datums- und Wochentagsangabe

Nach oben
       Version: Office 2003

Hallo Peter,

jetzt noch eine letzte Frage. Wie kann ich das gleiche "Monatsfeld" nutzen um den Vormonat anzugeben?
In A2 soll bspw. jetzt Oktober (also November-1) angegeben werden?

Danke!
Höttl Wilfried
Im Profil kannst Du frei den Rang ändern


Verfasst am:
19. Okt 2009, 17:02
Rufname: wilfried07
Wohnort: Antau Burgenland


AW: Datums- und Wochentagsangabe - AW: Datums- und Wochentagsangabe

Nach oben
       Version: Office 2003

Hallo!

Schau Dir das einmal an mit 2 Formellösungen.

Datum von Vormonat eingeben und Formel runterziehen.


Arbeitsblatt mit dem Namen 'Datum'
 ABCD
2439Datumspalte ohne Wochenende und Feiertage auflisten   
2440    
2441Di 01.12.2009<<< StartdatumDi 01.12.2009<<< Startdatum
2442Mi 02.12.2009 Mi 02.12.2009 
2443Do 03.12.2009 Do 03.12.2009 
2444Fr 04.12.2009Format TTT TT.MM.JJJJFr 04.12.2009 
2445Mo 07.12.2009 Mo 07.12.2009 
2446Mi 09.12.2009 Mi 09.12.2009 
2447Do 10.12.2009FeiertageDo 10.12.2009 
2448Fr 11.12.2009 Fr 11.12.2009 
2449Mo 14.12.2009Di 08.12.2009Mo 14.12.2009 
2450Di 15.12.2009Fr 25.12.2009Di 15.12.2009 
2451Mi 16.12.2009Sa 26.12.2009Mi 16.12.2009 
2452Do 17.12.2009Mo 28.12.2009Do 17.12.2009 
2453Fr 18.12.2009Di 29.12.2009Fr 18.12.2009 
2454Mo 21.12.2009Mi 30.12.2009Mo 21.12.2009 
2455Di 22.12.2009Fr 01.01.2010Di 22.12.2009 
2456Mi 23.12.2009Mi 06.01.2010Mi 23.12.2009 
2457Do 24.12.2009 Do 24.12.2009 
2458Do 31.12.2009 Do 31.12.2009 
2459Mo 04.01.2010 Mo 04.01.2010 
2460Di 05.01.2010 Di 05.01.2010 
2461Do 07.01.2010 Do 07.01.2010 
2462Fr 08.01.2010 Fr 08.01.2010 
2463Mo 11.01.2010 Mo 11.01.2010 

ZelleFormatWert
A2441TTT TT.MM.JJJJ01.12.2009
B2441TTT TT.MM.JJJJ<<< Startdatum
C2441TTT TT.MM.JJJJ01.12.2009
D2441TTT TT.MM.JJJJ<<< Startdatum

ZelleFormel
A2442{=A2441+MIN(WENN((WOCHENTAG(A2441+ZEILE($1:$25)-1)<6)*ISTNV(VERGLEICH(A2441+ZEILE($1:$25);B$2449:B$2457;0));ZEILE($1:$25)))}
C2442=ARBEITSTAG(C2441;1;B$2449:B$2457)
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.



Gruß
Wilfried
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Datums vergleichen und dann einen Wert wieder geben 4 Rippa 180 02. Sep 2011, 23:14
Gast Datums vergleichen und dann einen Wert wieder geben
Keine neuen Beiträge Excel Formeln: Zahlen des Datums addieren 1 offiboy 395 19. Jan 2011, 19:58
WF Zahlen des Datums addieren
Keine neuen Beiträge Excel Formeln: per Formel: Auswahl eines passenden Datums aus einer Liste 1 jür 186 23. Okt 2010, 00:30
{Boris} per Formel: Auswahl eines passenden Datums aus einer Liste
Keine neuen Beiträge Excel Formeln: Excel spezielle Datums Formel 2 Radeon55 201 28. Sep 2010, 11:38
Gast Excel spezielle Datums Formel
Keine neuen Beiträge Excel Formeln: Ermitteln des Datums vom ersten Montag im Monat 7 Barnyg 1517 13. Sep 2010, 12:47
FP Ermitteln des Datums vom ersten Montag im Monat
Keine neuen Beiträge Excel Formeln: Rechnen mit mehreren Datums 2 controlljule 179 13. Jun 2010, 18:55
controlljule Rechnen mit mehreren Datums
Keine neuen Beiträge Excel Formeln: Bereich eines Datums im Summenprodukt 1 Thomash.83 189 10. Mai 2010, 17:06
steve1da Bereich eines Datums im Summenprodukt
Keine neuen Beiträge Excel Formeln: 2 Datums miteinaander vergleichen 4 Dummy_1 806 02. Feb 2010, 20:47
HermannZ 2 Datums miteinaander vergleichen
Keine neuen Beiträge Excel Formeln: Anzahl Daten ( Datums) kleiner heute 1 Campino86 1237 28. Aug 2009, 06:27
Thomas Ramel Anzahl Daten ( Datums) kleiner heute
Keine neuen Beiträge Excel Formeln: Datums"werte" vergleichen? 2 Skarabae 397 25. Aug 2008, 11:18
Skarabae Datums"werte" vergleichen?
Keine neuen Beiträge Excel Formeln: neue Tabelle aus Datums erstellen und Werte addieren 3 Mexa 506 29. Mai 2008, 15:02
Magic neue Tabelle aus Datums erstellen und Werte addieren
Keine neuen Beiträge Excel Formeln: Gruppierung von Datums und dann Summer errechnen 4 Alexa21 2306 25. Feb 2008, 18:59
Alexa21 Gruppierung von Datums und dann Summer errechnen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: PHP Forum