Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Wochenenddaten
zurück: Dateinamen in Excel automatisch anzeigen weiter: Zeilen einfügen und Formeln mit übernehmen. Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Brian20
Gast


Verfasst am:
31. Okt 2009, 20:27
Rufname:

Wochenenddaten - Wochenenddaten

Nach oben
       Version: Office XP (2002)

Hallo,

Ich bräuchte eine Liste in der alle Fr.Sa.So (also die Wochenendtage) in einer Spalte Stellen und die ich durch ein zentrales Jahresfeld anpassen kann, besonderes Jahr sind dabei die Schaltjahre.

Wenn irgendwie möglich wäre es super wenn nur das Datum von bis in den Zellen stehen würde als Datum von Freitag bis datum von Sonntag (2.4 bis 4.4)

Wäre wirklich dringend vielen Dank

Brian
BoskoBiati
Im Profil kannst Du frei den Rang ändern


Verfasst am:
31. Okt 2009, 20:58
Rufname: Bosko


AW: Wochenenddaten - AW: Wochenenddaten

Nach oben
       Version: Office XP (2002)

Hey Brian,

Du hast Dich in den Thread von Robin reingehängt, ohne überhaupt auszuprobieren, was die Formeln machen, sonst würdest Du nicht Behauptungen aufstellen, die nicht stimmen:
Zitat:
Habe mir mal eure Formeln genauer angesehen, funktiionieren ja klasse aber nur solange kein Schaltjahr wie 2012 ist dann sind die Daten falsch.

Die Formeln von Dennis sind einfach Spitze und sollten Deine Aufgabe lösen, sofern Du sie angepaßt kriegst.

_________________
Gruß

Bosko

Ich würde mich freuen zu erfahren, ob ich helfen konnte.
Brian20
Gast


Verfasst am:
31. Okt 2009, 21:17
Rufname:

AW: Wochenenddaten - AW: Wochenenddaten

Nach oben
       Version: Office XP (2002)

Hallo Bosko also ich habe die Formeln angepasst und im Original ausprobiert, ich bekomme trotzdem im August und im Jahr 2012 falsche ergebnisse

Brian
BoskoBiati
Im Profil kannst Du frei den Rang ändern


Verfasst am:
31. Okt 2009, 22:41
Rufname: Bosko

AW: Wochenenddaten - AW: Wochenenddaten

Nach oben
       Version: Office XP (2002)

Hallo Brian,

und woher weißt Du das?
Ich habe die Daten überprüft und sie stimmen.
Tabelle1

 ABCDE
1Jahr2009 01.08.09Sa
2Monat8 02.08.09So
3 07.08.09Fr
4 08.08.09Sa
5 09.08.09So
6 14.08.09Fr
7 15.08.09Sa
8 16.08.09So
9 21.08.09Fr
10 22.08.09Sa
11 23.08.09So
12 28.08.09Fr
13 29.08.09Sa
14 30.08.09So

Formeln der Tabelle
ZelleFormel
D1=DATUM(B1;B2;1)-MAX(REST(DATUM(B1;B2;1)-7;7);REST(DATUM(B1;B2;1)-8;7);REST(DATUM(B1;B2;1)-9;7))+6
E1=D1
D2=WENN(D1="";"";WENN(MONAT(WENN(WOCHENTAG(D1)=1;D1+5;D1+1))<>$B$2;"";WENN(WOCHENTAG(D1)=1;D1+5;D1+1)))
E2=D2
D3=WENN(D2="";"";WENN(MONAT(WENN(WOCHENTAG(D2)=1;D2+5;D2+1))<>$B$2;"";WENN(WOCHENTAG(D2)=1;D2+5;D2+1)))
E3=D3


Excel Jeanie Html

Tabelle1

 ABCDE
1Jahr2012 03.02.12Fr
2Monat2 04.02.12Sa
3 05.02.12So
4 10.02.12Fr
5 11.02.12Sa
6 12.02.12So
7 17.02.12Fr
8 18.02.12Sa
9 19.02.12So
10 24.02.12Fr
11 25.02.12Sa
12 26.02.12So

Formeln der Tabelle
ZelleFormel
D1=DATUM(B1;B2;1)-MAX(REST(DATUM(B1;B2;1)-7;7);REST(DATUM(B1;B2;1)-8;7);REST(DATUM(B1;B2;1)-9;7))+6
E1=D1
D2=WENN(D1="";"";WENN(MONAT(WENN(WOCHENTAG(D1)=1;D1+5;D1+1))<>$B$2;"";WENN(WOCHENTAG(D1)=1;D1+5;D1+1)))
E2=D2


Excel Jeanie Html

Tabelle1

 ABCDE
1Jahr2012 02.03.12Fr
2Monat3 03.03.12Sa
3 04.03.12So
4 09.03.12Fr
5 10.03.12Sa
6 11.03.12So
7 16.03.12Fr
8 17.03.12Sa
9 18.03.12So
10 23.03.12Fr
11 24.03.12Sa
12 25.03.12So
13 30.03.12Fr
14 31.03.12Sa

Formeln der Tabelle
ZelleFormel
D1=DATUM(B1;B2;1)-MAX(REST(DATUM(B1;B2;1)-7;7);REST(DATUM(B1;B2;1)-8;7);REST(DATUM(B1;B2;1)-9;7))+6
E1=D1
D2=WENN(D1="";"";WENN(MONAT(WENN(WOCHENTAG(D1)=1;D1+5;D1+1))<>$B$2;"";WENN(WOCHENTAG(D1)=1;D1+5;D1+1)))
E2=D2


Excel Jeanie Html

Möglicherweise stimmen Deine Datumseinstellungen in Excel nicht.

_________________
Gruß

Bosko

Ich würde mich freuen zu erfahren, ob ich helfen konnte.
Peter1964
Gast


Verfasst am:
01. Nov 2009, 00:04
Rufname:

AW: Wochenenddaten - AW: Wochenenddaten

Nach oben
       Version: Office XP (2002)

Hi, da gibst ja schon einiges, gibts das ganze auch ohne Monat, sodas ich die Fr-so übere ein ganze Jahr in einer spalte habe, und dann hätte ich da noch was ganz kniffliges für die genies unter euch, ich möchte den 1 Wochenende zb im April bestimmen, soll heissen wenn fr der 1,2 oder 3 ist ja alles baer wenn der Fr zb der 31 März ist dann wäre das das erste Aprilwochende bzw wenn Fr der 30 märz ist.

das wäre der oiberhammer.

Peter
Zero
Formeln, Diagramme und ein bisschen VBA


Verfasst am:
01. Nov 2009, 00:43
Rufname: Dennis
Wohnort: NDS


AW: Wochenenddaten - AW: Wochenenddaten

Nach oben
       Version: Office XP (2002)

Hi

Für das erste Problem mußt du nicht viel ändern.
Das 2. ist dann eher noch etwas einfacher.

Arbeitsblatt mit dem Namen 'Tabelle2'
 ABCDEFGHIJ
1Jahr2009 02.01.2009Fr Jahr200930.01.2009Fr
2   03.01.2009Sa Monat231.01.2009Sa
3   04.01.2009So   01.02.2009So
4   09.01.2009Fr     
5   10.01.2009Sa     
6   11.01.2009So     
7   16.01.2009Fr     
8   17.01.2009Sa     
9   18.01.2009So     
10   23.01.2009Fr     
11   24.01.2009Sa     
12   25.01.2009So     
13   30.01.2009Fr     

ZelleFormel
D1=DATUM(B1;1;1)-MAX(REST(DATUM(B1;1;1)-7;7);REST(DATUM(B1;1;1)-8;7);REST(DATUM(B1;1;1)-9;7))+6
D2=WENN(D1="";"";WENN(JAHR(WENN(WOCHENTAG(D1)=1;D1+5;D1+1))<>$B$1;"";WENN(WOCHENTAG(D1)=1;D1+5;D1+1)))
I1=DATUM(H1;H2;1)+WAHL(WOCHENTAG(DATUM(H1;H2;1);2);4;3;2;1;0;-1;-2)
I2=I1+1

_________________
Gruß zero
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Wochenenddaten 6 Robin26 321 31. Okt 2009, 20:31
< Peter > Wochenenddaten
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Access Tabellen