Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Sortierfunktion wenn Daten via Makro kommen?
zurück: angelegte Range für Diagramm verwenden weiter: Excel Datei öffnen aus aktuellem Pfad Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
ralf-k
Gast


Verfasst am:
05. Apr 2010, 23:59
Rufname:

Sortierfunktion wenn Daten via Makro kommen? - Sortierfunktion wenn Daten via Makro kommen?

Nach oben
       Version: Office 97

Hallo Excel-Experten,

ich arbeite mit einem Excel-Dokument, welches aus einem Datenblatt und 24 Erfassungsblättern besteht. Die Erfassungsblätter beziehen aufgrund der eingegebenen Artikelnummer in Spalte "A" die weiteren Daten via den Formeln, welche das angefügten Makro einfügt, vom Datenblatt.

Code:
Sub Formeln_einfügen()
'
    ActiveCell.Range("A1:G1").Select
    Selection.Borders(xlDiagonalDown).LineStyle = xlNone
    Selection.Borders(xlDiagonalUp).LineStyle = xlNone
    With Selection.Borders(xlEdgeLeft)
        .LineStyle = xlContinuous
        .Weight = xlThin
        .ColorIndex = xlAutomatic
    End With
    With Selection.Borders(xlEdgeTop)
        .LineStyle = xlContinuous
        .Weight = xlThin
        .ColorIndex = xlAutomatic
    End With
    With Selection.Borders(xlEdgeBottom)
        .LineStyle = xlContinuous
        .Weight = xlThin
        .ColorIndex = xlAutomatic
    End With
    With Selection.Borders(xlEdgeRight)
        .LineStyle = xlContinuous
        .Weight = xlThin
        .ColorIndex = xlAutomatic
    End With
    With Selection.Borders(xlInsideVertical)
        .LineStyle = xlContinuous
        .Weight = xlThin
        .ColorIndex = xlAutomatic
    End With
    With Selection.Borders(xlInsideHorizontal)
'        .LineStyle = xlContinuous
'        .Weight = xlThin
 '       .ColorIndex = xlAutomatic
    End With
    ActiveCell.Range("A1:E1").Select
    Selection.NumberFormat = "General"
    ActiveCell.Offset(0, 5).Range("A1:B1").Select
    Selection.NumberFormat = "#,##0.00 $"
    ActiveCell.Offset(0, -4).Range("A1").Select
    ActiveCell.FormulaR1C1 = "=VLOOKUP(RC1,Artikelliste!R7C1:R3000C7,3,FALSE)"
    ActiveCell.Offset(0, 2).Range("A1").Select
    ActiveCell.FormulaR1C1 = "=VLOOKUP(RC1,Artikelliste!R7C1:R3000C7,4,FALSE)"
    ActiveCell.Offset(0, 1).Range("A1").Select
    ActiveCell.FormulaR1C1 = "EINZEL"
    With ActiveCell.Characters(Start:=1, Length:=6).Font
        .Name = "Arial"
        .FontStyle = "Standard"
        .Size = 10
        .Strikethrough = False
        .Superscript = False
        .Subscript = False
        .OutlineFont = False
        .Shadow = False
        .Underline = xlUnderlineStyleNone
        .ColorIndex = xlAutomatic
    End With
    ActiveCell.Select
    With Selection.Validation
        .Delete
        .Add Type:=xlValidateList, AlertStyle:=xlValidAlertStop, Operator:= _
        xlBetween, Formula1:="=Verpackung"
        .IgnoreBlank = True
        .InCellDropdown = True
        .InputTitle = "Verpackungsgröße"
        .ErrorTitle = "falsche Daten"
        .InputMessage = "Bitte wähle die Verpackungsgröße aus."
        .ErrorMessage = "Bitte überprüfe die eingegebenen Daten."
        .ShowInput = True
        .ShowError = True
    End With
    ActiveCell.Offset(0, 1).Range("A1").Select
    ActiveCell.FormulaR1C1 = _
        "=IF(RC5=""EINZEL"",VLOOKUP(RC1,Artikelliste!R7C1:R3000C7,6,FALSE),VLOOKUP(RC1,Artikelliste!R7C1:R3000C7,5,FALSE))"
    ActiveCell.Offset(0, 1).Range("A1").Select
    ActiveCell.FormulaR1C1 = "=IF(ISNA(RC[-4]*RC[-1]),0,RC[-4]*RC[-1])"
    ActiveCell.Offset(1, -6).Range("A1").Select
End Sub


Sicherlich ist das Makro nicht die einfachste Version, aber ich bin da nicht so gut, aber es funktioniert.
Die Erfassungsblätter sind jetzt noch mal in einzelne Bereiche unterteilt:

Seite 1 Kaffeeinsel (2)

&nbsp;ABCDEFG
1In v e n t u r &nbsp; &nbsp; &nbsp;p e r&nbsp;&nbsp;&nbsp;
2&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
3Niederlassung:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
4Abteilungsleiter:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
5&nbsp;&nbsp;Datum:&nbsp;&nbsp;
6Warengruppe:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
7Lagerplatz:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
8ArtikelnummerWarenbezeichnungAnzahlLiefergr&ouml;&szlig;eEinheitEK-Preis EinheitEK-Preis gesamt
9Ansager:&nbsp;&nbsp;&nbsp;&nbsp;
10Aufschreiber:&nbsp;
11Nachrechner:&nbsp;
12Gesamtsumme Seite 1&nbsp;&nbsp;&nbsp;0,00 €
13Regal 1&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
14&nbsp;#NV&nbsp;#NVEINZEL#NV0,00 €
15&nbsp;#NV&nbsp;#NVEINZEL#NV0,00 €
16&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
17&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
18&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
19&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
20Regal 2&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
21&nbsp;#NV&nbsp;#NVEINZEL#NV0,00 €
22&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
23&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
24&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
25Regal 3&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
26&nbsp;#NV&nbsp;#NVEINZEL#NV0,00 €
27&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
28&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
29&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
30&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
31&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;

Formeln der Tabelle
ZelleFormel
F12=SUMME(G14:G2171)
B14=SVERWEIS($A14;Artikelliste!$A$7:$G$3000;3;FALSCH)
D14=SVERWEIS($A14;Artikelliste!$A$7:$G$3000;4;FALSCH)
F14=WENN($E14="EINZEL";SVERWEIS($A14;Artikelliste!$A$7:$G$3000;6;FALSCH);SVERWEIS($A14;Artikelliste!$A$7:$G$3000;5;FALSCH))
G14=WENN(ISTNV(C14*F14);0;C14*F14)
B15=SVERWEIS($A15;Artikelliste!$A$7:$G$3000;3;FALSCH)
D15=SVERWEIS($A15;Artikelliste!$A$7:$G$3000;4;FALSCH)
F15=WENN($E15="EINZEL";SVERWEIS($A15;Artikelliste!$A$7:$G$3000;6;FALSCH);SVERWEIS($A15;Artikelliste!$A$7:$G$3000;5;FALSCH))
G15=WENN(ISTNV(C15*F15);0;C15*F15)
B21=SVERWEIS($A21;Artikelliste!$A$7:$G$3000;3;FALSCH)
D21=SVERWEIS($A21;Artikelliste!$A$7:$G$3000;4;FALSCH)
F21=WENN($E21="EINZEL";SVERWEIS($A21;Artikelliste!$A$7:$G$3000;6;FALSCH);SVERWEIS($A21;Artikelliste!$A$7:$G$3000;5;FALSCH))
G21=WENN(ISTNV(C21*F21);0;C21*F21)
B26=SVERWEIS($A26;Artikelliste!$A$7:$G$3000;3;FALSCH)
D26=SVERWEIS($A26;Artikelliste!$A$7:$G$3000;4;FALSCH)
F26=WENN($E26="EINZEL";SVERWEIS($A26;Artikelliste!$A$7:$G$3000;6;FALSCH);SVERWEIS($A26;Artikelliste!$A$7:$G$3000;5;FALSCH))
G26=WENN(ISTNV(C26*F26);0;C26*F26)


Excel Tabellen im Web darstellen &gt;&gt; <a> Excel Jeanie HTML 4 </a>

(&nbsp; - überall dort ist eigentlich alles leer, weiß nicht, wo das her kommt)

In den einzelnen Bereichen können von 1-ca. 250 Artikel stehen. Für ein leichteres Arbeiten (Finden der Artikel) würde ich nun gerne in den jeweiligen Bereichen die Artikel - nach Spalte "B" = Name der Artikel - alphabetisch sortieren. Leider geht das nicht mit der Sortierfunktion von Excel.

Gibt es eine Möglichkeit, wie ich das trotzdem bewerkstelligen kann? Hoffe, dass ihr mir da weiterhelfen könnt.

Vielen Dank für die Hilfe
Ralf
Klaus-Dieter
Schwerpunktinteresse: VBA und UserForms


Verfasst am:
06. Apr 2010, 10:13
Rufname: Klaus
Wohnort: Sassenburg


AW: Sortierfunktion wenn Daten via Makro kommen? - AW: Sortierfunktion wenn Daten via Makro kommen?

Nach oben
       Version: Office 97

Hallo Ralf,

Zitat:
(&nbsp; - überall dort ist eigentlich alles leer, weiß nicht, wo das her kommt)


Du musst vor dem Einstellen des Beitrags die Schaltfläche Jeanie Vorschau drücken. Dann passiert das nicht.

Zu deiner Frage: in eine Liste gehören keine Zwischenüberschriften, dann klappt es auch mit dem Sortieren. Die Regalbezeichnung könnte genau so gut auch in einer Spalte stehen!

_________________
Viele Grüße
Klaus-Dieter
Lösungsvorschläge sind, wenn es keinen anders lautenden Hinweis gibt, von mir getestet.
Yoga ist besser, als rumsitzen und gar nichts machen.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Formel nur benutzen wenn Daten im bestimmten Feld vorhanden. 1 Nemi 1831 22. Aug 2005, 13:27
fridgenep Formel nur benutzen wenn Daten im bestimmten Feld vorhanden.
Keine neuen Beiträge Excel Formeln: Liste bei Daten G�ltigkeit 2 Niklas Caspers 930 03. Jul 2005, 23:12
Niklas Caspers Liste bei Daten G�ltigkeit
Keine neuen Beiträge Excel Formeln: Sereinbrief in Word, Daten aus Excel 4 Rolf-Peter Fuß 2561 15. Jun 2005, 17:02
Günni Sereinbrief in Word, Daten aus Excel
Keine neuen Beiträge Excel Formeln: Autom. Übernahme von Daten einer Zelle bei Datumswechsel 4 frei-bo 1985 13. Mai 2005, 10:58
frei-bo Autom. Übernahme von Daten einer Zelle bei Datumswechsel
Keine neuen Beiträge Excel Formeln: Makro fürs Sortieren 2 nhs47800 1951 11. Mai 2005, 09:47
nhs Makro fürs Sortieren
Keine neuen Beiträge Excel Formeln: Daten aus anderem Tabellenblatt übernehmen 5 Grubi 2120 05. Mai 2005, 21:52
Grubi Daten aus anderem Tabellenblatt übernehmen
Keine neuen Beiträge Excel Formeln: Dienstplan erstellen aus liste (DB) daten übernehmen :S 1 torsten25nrw 2986 15. Apr 2005, 18:35
fl618 Dienstplan erstellen aus liste (DB) daten übernehmen :S
Keine neuen Beiträge Excel Formeln: Zeile einfügen mit Formel oder Makro? 2 original-m 2246 21. Feb 2005, 08:09
original-m Zeile einfügen mit Formel oder Makro?
Keine neuen Beiträge Excel Formeln: daten sortieren 8 Gast 2141 10. Feb 2005, 15:00
Andy Knecht daten sortieren
Keine neuen Beiträge Excel Formeln: Autom. Filter zeigt Daten, die nicht gezeigt werden sollten 7 Aloha 1373 10. Feb 2005, 09:35
Thomas Ramel Autom. Filter zeigt Daten, die nicht gezeigt werden sollten
Keine neuen Beiträge Excel Formeln: Daten in einer Zelle trennen 2 bsailer 7161 07. Jan 2005, 13:39
bsailer Daten in einer Zelle trennen
Keine neuen Beiträge Excel Formeln: Daten in Wertebereich zusammenfassen und zählen 2 gallahad 1866 22. Dez 2004, 13:04
steve1da Daten in Wertebereich zusammenfassen und zählen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Word VBA