Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Größte Anzahl gleicher Zeichenfolge in einer Spalte v. links
Gehe zu Seite Zurück  1, 2
zurück: *T*Formel weiter: Mehrer Tabellenblätter in eins u. Änderung übernehmen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Offen Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Gammaloop
Im Profil kannst Du frei den Rang ändern


Verfasst am:
01. Jun 2010, 07:10
Rufname: Otto

AW: Größte Anzahl gleicher Zeichenfolge in einer Spalte v. l - AW: Größte Anzahl gleicher Zeichenfolge in einer Spalte v. l

Nach oben
       Version: Office 2003

das alle das selbe ergebnis haben stimmt ja nicht ganz
allerdings sehe ich auch gerade das das problem mit dem wiederkehrenden wort innerhalb eines textes gar nicht ausgemerzt hab.... wtf###

und zu punkto daten hast du recht, die sehen nicht wirklich so aus
ich würde ja gerne einen teil hier hochladen und hab mir extra das aktuellste excel jeanie add in runtergeladen
das allerdings zeigt mir beim ausführen den lauffehler 1004 an und bricht ab
mal schauen warum meine kiste da rummurkst...
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
01. Jun 2010, 18:43
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände


AW: Größte Anzahl gleicher Zeichenfolge in einer Spalte v. l - AW: Größte Anzahl gleicher Zeichenfolge in einer Spalte v. l

Nach oben
       Version: Office 2007

Zitat:
das alle das selbe ergebnis haben stimmt ja nicht ganz

Doch, es ist jedes Mal der Max-Wert.

Die 100 würde ich mal probieren zu ersetzen durch entweder die Länge des längsten Textes oder die Länge des Suchbegriffes.

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Gammaloop
Im Profil kannst Du frei den Rang ändern


Verfasst am:
01. Jun 2010, 21:30
Rufname: Otto

AW: Größte Anzahl gleicher Zeichenfolge in einer Spalte v. l - AW: Größte Anzahl gleicher Zeichenfolge in einer Spalte v. l

Nach oben
       Version: Office 2003

hallo shift-del

danke für deine anregung aber irgendwie überforderst du mich damit
jedenfalls weiß ich nicht wo du hinaus willst
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
01. Jun 2010, 21:47
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände

AW: Größte Anzahl gleicher Zeichenfolge in einer Spalte v. l - AW: Größte Anzahl gleicher Zeichenfolge in einer Spalte v. l

Nach oben
       Version: Office 2003

In deinem letzten Beispiel war der längste Text 18 Zeichen lang.

Dann ersetze in der Formel die 100 durch 18.

Code:
=SUMMENPRODUKT(--(ISTZAHL(FINDEN(TEIL($G$1;1;ZEILE($1:$18));A1))))

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Gammaloop
Im Profil kannst Du frei den Rang ändern


Verfasst am:
01. Jun 2010, 22:09
Rufname: Otto

AW: Größte Anzahl gleicher Zeichenfolge in einer Spalte v. l - AW: Größte Anzahl gleicher Zeichenfolge in einer Spalte v. l

Nach oben
       Version: Office 2003

dann würde die suche mit einem wort mit 5 buchstaben länge ergeben das ein wort mit dem selben zeichenstring IMMER 18 buchstaben lang ist...
ich glaub dem ist nicht so
Gammaloop
Im Profil kannst Du frei den Rang ändern


Verfasst am:
01. Jun 2010, 22:29
Rufname: Otto


AW: Größte Anzahl gleicher Zeichenfolge in einer Spalte v. l - AW: Größte Anzahl gleicher Zeichenfolge in einer Spalte v. l

Nach oben
       Version: Office 2003

=WENN(LÄNGE(A1)-LÄNGE(WECHSELN(GROSS(A1);GROSS($E$1);""))=LÄNGE($E$1);LÄNGE($E$1);SUMMENPRODUKT(--(ISTZAHL(SUCHEN(TEIL($E$1;1;ZEILE($1:$100));A1)))))

schön ist die formel aber nicht gerade...
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Gehe zu Seite Zurück  1, 2
Diese Seite Freunden empfehlen

Seite 2 von 2
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Formel für eine Spalte festlegen 6 annabell 897 01. Apr 2005, 11:19
annabell Formel für eine Spalte festlegen
Keine neuen Beiträge Excel Formeln: Gefundenen Wert aus Spalte A in D1... 3 Gundel 1328 27. Jan 2005, 00:09
Gast Gefundenen Wert aus Spalte A in D1...
Keine neuen Beiträge Excel Formeln: Verknüpfung auf bestimme Spalte, den letzten Wert zurückgebe 4 Thiemo 1531 17. Jan 2005, 19:32
KARL Verknüpfung auf bestimme Spalte, den letzten Wert zurückgebe
Keine neuen Beiträge Excel Formeln: Will Werte addieren in Bezug zu einer anderen Spalte 8 MrMr 2236 08. Jan 2005, 14:50
xyzdef Will Werte addieren in Bezug zu einer anderen Spalte
Keine neuen Beiträge Excel Formeln: Suche Formel, welche Spalte nur bis zum akt. Datum berechnet 7 Sveny 1609 04. Jan 2005, 21:45
Sveny Suche Formel, welche Spalte nur bis zum akt. Datum berechnet
Keine neuen Beiträge Excel Formeln: Filterergebnis in neue Spalte 0 Gast99999 614 21. Dez 2004, 16:20
Gast99999 Filterergebnis in neue Spalte
Keine neuen Beiträge Excel Formeln: links und rechts ausrichten ? 0 nummer 13 ohne käse 700 21. Dez 2004, 01:03
nummer 13 ohne käse links und rechts ausrichten ?
Keine neuen Beiträge Excel Formeln: Vor- und Nachname in 1 Spalte in 2 Spalten aufteilen 2 Gast 2920 26. Nov 2004, 11:48
Gast Vor- und Nachname in 1 Spalte in 2 Spalten aufteilen
Keine neuen Beiträge Excel Formeln: Anzahl bei 2 Bedingungen aus Tabelle berechnen 6 Satanico 1723 21. Okt 2004, 14:48
Satanico Anzahl bei 2 Bedingungen aus Tabelle berechnen
Keine neuen Beiträge Excel Formeln: Dynamisches Erweitern einer Spalte mit Formel 11 Case 1011 11. Okt 2004, 08:43
Case Dynamisches Erweitern einer Spalte mit Formel
Keine neuen Beiträge Excel Formeln: Einfärben einer Spalte bei bestimmten Vorzeichen 3 itmeli 813 16. Aug 2004, 13:25
itmeli Einfärben einer Spalte bei bestimmten Vorzeichen
Keine neuen Beiträge Excel Formeln: ANZAHL in einer bestimmten Schriftfarbe formatierter Zellen 12 curious 1933 21. Jun 2004, 13:56
Gast ANZAHL in einer bestimmten Schriftfarbe formatierter Zellen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML Forum