Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Geburtstag
Gehe zu Seite 1, 2  Weiter
zurück: Bedingte Formatierung weiter: logische Verknüpfung Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
sabizuab
Im Profil kannst Du frei den Rang ändern


Verfasst am:
14. Jun 2005, 13:27
Rufname:

Geburtstag - Geburtstag

Nach oben
       

Hallo,

in der Schule haben wir folgende Aufgabe als Homework bekommen:


Ausgehend von meinem Geburtstag (04.02.1978) sollen wir 100 Jahre in die Zukunft "blicken".

Dann soll berechnet werden, an wievielen Montagen, Dienstagen, Mittwochen, etc, ich Geburtstag haben werde.

Dabei müssen die Schaltjahre berücksichtigt werden.

Wer kann helfen?

Vielen Dank!

cu

Sabizuab
Willie
Im Profil kannst Du frei den Rang ändern


Verfasst am:
14. Jun 2005, 13:48
Rufname:
Wohnort: Ingolstadt


AW: Geburtstag - AW: Geburtstag

Nach oben
       

Hi sabizuab,

Ich bin mir sicher, dass die echten Excelprofis eine elegantere Lösung finden werden. Aber es geht auch so:

GeburtstagAlterWochentagAnzahl
04.02.19781=TEXT(WOCHENTAG(A2;1);"TTTT")=ZÄHLENWENN(C:C;"Montag")
04.02.19792=TEXT(WOCHENTAG(A3;1);"TTTT")=ZÄHLENWENN(C:C;"Dienstag")
Die Zellen A2 bis C3 markieren und bis zum Alter "100" runterziehen. Die Zählenwennformel für jeden Tag anpassen.

Gruß

Willie
c0bRa
Excel-Moderator


Verfasst am:
14. Jun 2005, 14:04
Rufname: c0bRa
Wohnort: BY

AW: Geburtstag - AW: Geburtstag

Nach oben
       

hio...

hier direkt ohne 100 zeilen, geburtsdatum in A1;)
{=SUMMENPRODUKT((WOCHENTAG(DATUM(JAHR($A$1)+ZEILE($A$1:$A$100);MONAT($A$1);TAG($A$1));1)*1=1)*1)}

Achtung Matrixformel!!! Umrandende {} nicht mit eingeben, sondern Formel nach Eingabe mit Strg+Shift+Enter abschliessen!

die rote 1 durch 2-7 für di mi do fr sa so verwenden 1= montag Smile

_________________
Ich hoffe, dass ich dir helfen konnte...
Vergiss das Feedback nicht
c0bRa            
"A programmer is just a tool which converts caffeine into code..." CA152F09AC16D043695AC070477488C9A8C9C24D20706
Willie
Im Profil kannst Du frei den Rang ändern


Verfasst am:
14. Jun 2005, 14:34
Rufname:
Wohnort: Ingolstadt

AW: Geburtstag - AW: Geburtstag

Nach oben
       

Hallo cobra,

ich wusste ja, dass einer mit einer eleganteren Lösung kommt ;)

Aber steht die 1 nicht für Sonntag? Habs X-mal überprüft und komme immer auf verschobene Anzahlen im Vergleich zu meiner Lösung.

Und nochwas komisches: Die Formel funktioniert auch ohne dass man die Matrixformel benutzt? Is das OK?

Gruß

Willie
c0bRa
Excel-Moderator


Verfasst am:
14. Jun 2005, 15:13
Rufname: c0bRa
Wohnort: BY


AW: Geburtstag - AW: Geburtstag

Nach oben
       

ja sorry... hab mich verschrieben... die 1 steht für sonntag, nicht für montag...

hätte wochentag(...;2) nehmen müsen dann passts....
rainberg
Excel-Anwender


Verfasst am:
14. Jun 2005, 17:47
Rufname:

AW: Geburtstag - AW: Geburtstag

Nach oben
       

Hallo Cobra,

mal abgesehen davon, dass du dich verschrieben hast, rechnet deine Formel teilweise falsch.
Der Fehler ist, dass sie den Wochentag im Geburtsjahr nicht mit rechnet und dafür den Wochentag im 101-ten Jahr mit rechnet.
Habe in meiner Formel -1 hinzugefügt und um die Formel kopierbar zu machen, ZEILE(A1) eingesetzt.
Übrigens, bei SUMMENPRODUKT sind die geschweiften Klammern nicht nötig, da es sich auch ohne diese um eine Matrixformel handelt.


Tabelle1
 ABCD
117.05.197514So14
2 14Mo14
3 15Di15
4 14Mi14
5 15Do15
6 13Fr14
7 15Sa14
8   Cobra
Formeln der Tabelle
B1 : =SUMMENPRODUKT((WOCHENTAG(DATUM(JAHR(A$1)-1+ZEILE($1:$100);MONAT(A$1);TAG(A$1));1)=ZEILE(A1))*1)
D1 : =SUMMENPRODUKT((WOCHENTAG(DATUM(JAHR($A$1)+ZEILE($A$1:$A$100);MONAT($A$1);TAG($A$1));1)*1=1)*1)
B2 : =SUMMENPRODUKT((WOCHENTAG(DATUM(JAHR(A$1)-1+ZEILE($1:$100);MONAT(A$1);TAG(A$1));1)=ZEILE(A2))*1)
D2 : =SUMMENPRODUKT((WOCHENTAG(DATUM(JAHR($A$1)+ZEILE($A$1:$A$100);MONAT($A$1);TAG($A$1));1)*1=2)*1)
B3 : =SUMMENPRODUKT((WOCHENTAG(DATUM(JAHR(A$1)-1+ZEILE($1:$100);MONAT(A$1);TAG(A$1));1)=ZEILE(A3))*1)
D3 : =SUMMENPRODUKT((WOCHENTAG(DATUM(JAHR($A$1)+ZEILE($A$1:$A$100);MONAT($A$1);TAG($A$1));1)*1=3)*1)
B4 : =SUMMENPRODUKT((WOCHENTAG(DATUM(JAHR(A$1)-1+ZEILE($1:$100);MONAT(A$1);TAG(A$1));1)=ZEILE(A4))*1)
D4 : =SUMMENPRODUKT((WOCHENTAG(DATUM(JAHR($A$1)+ZEILE($A$1:$A$100);MONAT($A$1);TAG($A$1));1)*1=4)*1)
B5 : =SUMMENPRODUKT((WOCHENTAG(DATUM(JAHR(A$1)-1+ZEILE($1:$100);MONAT(A$1);TAG(A$1));1)=ZEILE(A5))*1)
D5 : =SUMMENPRODUKT((WOCHENTAG(DATUM(JAHR($A$1)+ZEILE($A$1:$A$100);MONAT($A$1);TAG($A$1));1)*1=5)*1)
B6 : =SUMMENPRODUKT((WOCHENTAG(DATUM(JAHR(A$1)-1+ZEILE($1:$100);MONAT(A$1);TAG(A$1));1)=ZEILE(A6))*1)
D6 : =SUMMENPRODUKT((WOCHENTAG(DATUM(JAHR($A$1)+ZEILE($A$1:$A$100);MONAT($A$1);TAG($A$1));1)*1=6)*1)
B7 : =SUMMENPRODUKT((WOCHENTAG(DATUM(JAHR(A$1)-1+ZEILE($1:$100);MONAT(A$1);TAG(A$1));1)=ZEILE(A7))*1)
D7 : =SUMMENPRODUKT((WOCHENTAG(DATUM(JAHR($A$1)+ZEILE($A$1:$A$100);MONAT($A$1);TAG($A$1));1)*1=7)*1)
 
c0bRa
Excel-Moderator


Verfasst am:
15. Jun 2005, 08:19
Rufname: c0bRa
Wohnort: BY

AW: Geburtstag - AW: Geburtstag

Nach oben
       

hab die formel gestern auch nur auf die schnelle gemacht, die matrix mach ich eigentlich immer rum, wenn eine funktion drin ist, die einen bereich abtastet, wie hier die funktion ZEILE($A$1:$A$100). aber ich werd demnächst mit matrix versuchen ein bissl sparsamer umzugehen ;)

c0bRa
Willie
Im Profil kannst Du frei den Rang ändern


Verfasst am:
15. Jun 2005, 09:12
Rufname:
Wohnort: Ingolstadt

AW: Geburtstag - AW: Geburtstag

Nach oben
       

Hallo zusammen,

nachdem das doch jetzt einige Diskussion ausgelöst hat, nochmal zur eigentlichen Aufgabe. Der Tag der Geburt beziehe ich nicht mit ein, da die Aufgabenstellung sagt:
"Ausgehend vom 04.02.1978 100 Jahre in die Zukunft..."
Also bin ich davon ausgegangen, dass der 1. Geburtstag der 1. Tag ist und der 100. Geburtstag der letzte Tag. Also 100 Werte!

Die Lösung ist demnach:
Mo: 15//Di: 14//Mi: 14//Do: 14//Fr: 14//Sa: 14//So: 14

Sollte der 04.02.1978 doch dazugezählt werden sollen, dann ist der Samstag 15 mal vorhanden.

Mein Lösungsweg ist auf jeden Fall funktionstüchtig und liefert die richtigen Werte. Hab extra alle Tage im Windowskalender zur Sicherheit nachgezählt ;)

Gruß

Willie
c0bRa
Excel-Moderator


Verfasst am:
15. Jun 2005, 09:24
Rufname: c0bRa
Wohnort: BY

AW: Geburtstag - AW: Geburtstag

Nach oben
       

hio...

Willie hat folgendes geschrieben:
Mo: 15//Di: 14//Mi: 14//Do: 14//Fr: 14//Sa: 14//So: 14

in summe = 99
sicher dass es passt? ;)

bei mir käme noch ein donnerstag hinzu, wenn du 100 werte haben willst exklusive deinem geburtsdatum im jahre 1978...

c0bRa
Willie
Im Profil kannst Du frei den Rang ändern


Verfasst am:
15. Jun 2005, 09:30
Rufname:
Wohnort: Ingolstadt

AW: Geburtstag - AW: Geburtstag

Nach oben
       

Hi cobra,

hast recht, ich bin zu dämlich zum abtippen meiner Ergebnisse Rolling Eyes

Ich hab auch 15 Donnerstage. Sry Confused

Danke für den Hinweis.

Gruß

Willie
rainberg
Excel-Anwender


Verfasst am:
15. Jun 2005, 10:25
Rufname:

AW: Geburtstag - AW: Geburtstag

Nach oben
       

Hallo Willie,

so ganz bin ich aber mit deinem Ergebnis nicht einverstanden, siehe selbst.

Zusatz:

Habe gerade gelesen, dass du den Geburtstag nicht mit einbezogen hast, dann hast du allerdings recht. Very Happy

Tabelle1
 HIJK
104.02.1978714So
204.02.1979115Mo
304.02.1980214Di
404.02.1981414Mi
504.02.1982515Do
604.02.1983613Fr
704.02.1984715Sa
804.02.19852  
904.02.19863  
1004.02.19874  
1104.02.19885  
1204.02.19897  
1304.02.19901  
1404.02.19912  
1504.02.19923  
1604.02.19935  
1704.02.19946  
1804.02.19957  
1904.02.19961  
2004.02.19973  
2104.02.19984  
2204.02.19995  
2304.02.20006  
2404.02.20011  
2504.02.20022  
2604.02.20033  
2704.02.20044  
2804.02.20056  
2904.02.20067  
3004.02.20071  
3104.02.20082  
3204.02.20094  
3304.02.20105  
3404.02.20116  
3504.02.20127  
3604.02.20132  
3704.02.20143  
3804.02.20154  
3904.02.20165  
4004.02.20177  
4104.02.20181  
4204.02.20192  
4304.02.20203  
4404.02.20215  
4504.02.20226  
4604.02.20237  
4704.02.20241  
4804.02.20253  
4904.02.20264  
5004.02.20275  
5104.02.20286  
5204.02.20291  
5304.02.20302  
5404.02.20313  
5504.02.20324  
5604.02.20336  
5704.02.20347  
5804.02.20351  
5904.02.20362  
6004.02.20374  
6104.02.20385  
6204.02.20396  
6304.02.20407  
6404.02.20412  
6504.02.20423  
6604.02.20434  
6704.02.20445  
6804.02.20457  
6904.02.20461  
7004.02.20472  
7104.02.20483  
7204.02.20495  
7304.02.20506  
7404.02.20517  
7504.02.20521  
7604.02.20533  
7704.02.20544  
7804.02.20555  
7904.02.20566  
8004.02.20571  
8104.02.20582  
8204.02.20593  
8304.02.20604  
8404.02.20616  
8504.02.20627  
8604.02.20631  
8704.02.20642  
8804.02.20654  
8904.02.20665  
9004.02.20676  
9104.02.20687  
9204.02.20692  
9304.02.20703  
9404.02.20714  
9504.02.20725  
9604.02.20737  
9704.02.20741  
9804.02.20752  
9904.02.20763  
10004.02.20775  
Formeln der Tabelle
I1 : =WOCHENTAG(H1)
J1 : =ZÄHLENWENN(I:I;ZEILE())
J2 : =ZÄHLENWENN(I:I;ZEILE())
J3 : =ZÄHLENWENN(I:I;ZEILE())
J4 : =ZÄHLENWENN(I:I;ZEILE())
J5 : =ZÄHLENWENN(I:I;ZEILE())
J6 : =ZÄHLENWENN(I:I;ZEILE())
J7 : =ZÄHLENWENN(I:I;ZEILE())
 


Zuletzt bearbeitet von rainberg am 15. Jun 2005, 10:34, insgesamt einmal bearbeitet
c0bRa
Excel-Moderator


Verfasst am:
15. Jun 2005, 10:34
Rufname: c0bRa
Wohnort: BY

AW: Geburtstag - AW: Geburtstag

Nach oben
       

exklusive 04.02.1978 inklusive 04.02.2078 Smile

dann passts ;)
Willie
Im Profil kannst Du frei den Rang ändern


Verfasst am:
15. Jun 2005, 10:36
Rufname:
Wohnort: Ingolstadt

AW: Geburtstag - AW: Geburtstag

Nach oben
       

Hallo rainberg,

der Unterschied zwischen unseren Lösungen ist folgender:

1) Du beginnst mit dem 04.02.1978. Das ist ein Samstag. Diesen berücksichtige ich nicht.
2) Dein letzter Geburtstag ist der 04.02.2077, sein 99. Geburtstag. Sein 100. Geburtstag ist ein Freitag.

Deshalb hast du einen Samstag mehr (04.02.1978) und einen Freitag weniger (04.02.2078). Du betrachtest die Geburtstage 0-99 und ich die Geburtstage von 1-100.

Gruß

Willie
rainberg
Excel-Anwender


Verfasst am:
15. Jun 2005, 10:48
Rufname:

AW: Geburtstag - AW: Geburtstag

Nach oben
       

Alles klar ihr beiden, hatte mich bereits korrigiert.
c0bRa
Excel-Moderator


Verfasst am:
15. Jun 2005, 10:52
Rufname: c0bRa
Wohnort: BY


AW: Geburtstag - AW: Geburtstag

Nach oben
       

was mich nun noch interessiert...

welches datum nimmt die formel, wenn das geburtsdatum z.b. der 29.02.1980 ist? den 28.02. oder den 01.03.? weil fehlerwert liefert die funktion trotz allem nicht...

c0bRa
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Gehe zu Seite 1, 2  Weiter
Diese Seite Freunden empfehlen

Seite 1 von 2
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Geburtstag ermitteln 2 Micha** 97 25. Jul 2013, 11:43
Micha** Geburtstag ermitteln
Keine neuen Beiträge Excel VBA (Makros): Geburtstag suchen 0 maka13156 97 17. Dez 2012, 08:28
maka13156 Geburtstag suchen
Keine neuen Beiträge Excel Formeln: Geburtstag errechnen lassen, aber wie? 6 tosi1199 187 15. Dez 2012, 06:12
Gast Geburtstag errechnen lassen, aber wie?
Keine neuen Beiträge Excel Hilfe: geburtstag(kind) anzeigen 5 andreas k. 3507 02. März 2012, 11:42
Gast geburtstag(kind) anzeigen
Keine neuen Beiträge Excel VBA (Makros): Geburtstag finden 2 ExcelTüftler 791 03. Aug 2011, 09:04
volkerk Geburtstag finden
Keine neuen Beiträge Excel Formeln: Versanddatum aus Geburtstag errechnen 7 ggbaruka 388 27. Jun 2011, 12:18
ggbaruka Versanddatum aus Geburtstag errechnen
Keine neuen Beiträge Excel VBA (Makros): Geburtstag prüfen 7 Thomas89 694 19. Nov 2010, 17:47
Thomas89 Geburtstag prüfen
Keine neuen Beiträge Excel Formeln: Geburtstag mit automatik 5 Simba 1294 18. Mai 2010, 20:37
Simba Geburtstag mit automatik
Keine neuen Beiträge Excel VBA (Makros): MsgBox bei Geburtstag 13 Peter Schaboi 2119 20. Dez 2009, 20:50
Gast MsgBox bei Geburtstag
Keine neuen Beiträge Excel Formeln: in xx Tagen geburtstag 33 Ey-Ko 3216 14. Dez 2009, 09:21
Gast in xx Tagen geburtstag
Keine neuen Beiträge Excel Formeln: Alter aus Geburtstag errechnen 2 Gast 1280 07. Nov 2009, 12:28
Gast Alter aus Geburtstag errechnen
Keine neuen Beiträge Excel Hilfe: Zählen wieviele Leute in Welchem Monat geburtstag haben 6 Andre F. 2516 21. Jul 2009, 23:33
Andre F. Zählen wieviele Leute in Welchem Monat geburtstag haben
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Word VBA