Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
volltextsuche + Ausgabe der position
zurück: "Auto"-Zusammenfassung weiter: Bedingte Formatierung mit Oder Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Gast



Verfasst am:
26. Jun 2005, 02:22
Rufname:

volltextsuche + Ausgabe der position - volltextsuche + Ausgabe der position

Nach oben
       

Hallo zusammen,

habe da ein kleines Problem:

ich habe eine recht große Tabelle erstellt, in der jeweils 3
nebeneinanderliegende zellen zusammengehören.

in der jeweils rechten zelle gebe ich einige daten ein (text).
die linke und die mittlere zelle enthalten jeweils nur ein- bis dreistellige zahlen.

nunmehr möchte ich ins sheet eine funktion einbauen, die alle zellen nach
einer bestimmten zeichenfolge (z.B. einem Namen) durchsucht und dann
den inhalt der beiden zellen links daneben ausspuckt, wobei
mehrfachtreffer auch separat aufgelistet werden sollen.


hat da jemand eine idee, wie sich das realisieren ließe?


Gruß

Fugu
rainberg
Excel-Anwender


Verfasst am:
26. Jun 2005, 05:47
Rufname:


AW: volltextsuche + Ausgabe der position - AW: volltextsuche + Ausgabe der position

Nach oben
       

Hallo Fugu,

anbei ein Vorschlag mit Hilfsspalte.
Die Verwendung einer Hilfsspalte erspart die Verwendung von Matrixformeln, welche bei großen Datenmengen sehr viel Rechenzeit benötigen.

Die angegebenen Formeln kannst du nach Bedarf nach unten ziehen.

Daten
 ABCD
1HilfsspalteWert1Wert2Text
2 341358Text 13
3 99093Text 3
41593191Text 10
5 273214Text 14
62934689Text 10
73640879Text 10
8 624351Text 12
9 86132Text 13
10 49485Text 7
11 375234Text 5
12 996178Text 11
13 247788Text 12
14 119759Text 3
Formeln der Tabelle
A2 : =WENN(D2=Auswertung!$D$1;MAX(Daten!A$1:A1)+1;"")
 

Auswertung
 ABCD
1Wert1Wert2Suche: Text 10
2593191  
3934689  
4640879  
5    
6    
Formeln der Tabelle
A2 : =WENN(ISTNV(SVERWEIS(ZEILE(A1);Daten!$A:$D;SPALTE()+1;0));"";SVERWEIS(ZEILE(A1);Daten!$A:$D;SPALTE()+1;0))
B2 : =WENN(ISTNV(SVERWEIS(ZEILE(B1);Daten!$A:$D;SPALTE()+1;0));"";SVERWEIS(ZEILE(B1);Daten!$A:$D;SPALTE()+1;0))
 
Gast



Verfasst am:
27. Jun 2005, 07:33
Rufname:

AW: volltextsuche + Ausgabe der position - AW: volltextsuche + Ausgabe der position

Nach oben
       

Hallo,

schonmal besten Dank für den Vorschlag....

bei meinen beschränkten excel-kenntnissen hats ne weile gedauert,
bis ich überhaupt verstanden habe wies in etwa funktioniert.
jedoch beginnt das problem schon bei der prüfung.

hier habe ich mich etwas ungünstig ausgedrückt denke ich. Die Funktion
liefert nur dann "true", wenn volle übereinstimmung herrscht, nicht jedoch
wenn der gesuchte string irgendwo in einem text enthalten ist.

Bsp - Text in der ersten Spalte ist: Ich bin Fugu
Suchbegriff "Fugu" soll "true" liefern.

gibts da einen Ansantz, welcher abhilfe schafft?

Prinzipiell lässt sich das ganze natürlich relativ umständlich durch die
volltextsuche regeln, indem man einfach die spalten per suchen bzw.
weitersuchen ansteuert....die auflistung der treffer wäre aber eine
erleichterung im sinne der benutzerfreundlichkeit.


Gruß,
Fugu
rainberg
Excel-Anwender


Verfasst am:
27. Jun 2005, 08:24
Rufname:

AW: volltextsuche + Ausgabe der position - AW: volltextsuche + Ausgabe der position

Nach oben
       

Hallo Fugu,

anbei Vorschlag 2

Daten
 ABCD
1HilfsspalteWert1Wert2Text
21341358schlechter Fugu
3 99093Text 3
4 593191Text 10
52273214Ich bin Fugu
6 934689Text 10
7 640879Text 10
8 624351Text 12
9 86132Text 13
10349485Fugu ist gut
11 375234Text 5
12 996178Text 11
13 247788Text 12
14 119759Text 3
Formeln der Tabelle
A2 : =WENN(ISTFEHLER(FINDEN(Auswertung!$D$1;Daten!D2));"";MAX(A$1:A1)+1)
 

Auswertung
 ABCD
1Wert1Wert2Suche: Fugu
2341358  
3273214  
449485  
Formeln der Tabelle
A2 : =WENN(ISTNV(SVERWEIS(ZEILE(A1);Daten!$A:$D;SPALTE()+1;0));"";SVERWEIS(ZEILE(A1);Daten!$A:$D;SPALTE()+1;0))
B2 : =WENN(ISTNV(SVERWEIS(ZEILE(B1);Daten!$A:$D;SPALTE()+1;0));"";SVERWEIS(ZEILE(B1);Daten!$A:$D;SPALTE()+1;0))
 
Gast



Verfasst am:
27. Jun 2005, 08:50
Rufname:

AW: volltextsuche + Ausgabe der position - AW: volltextsuche + Ausgabe der position

Nach oben
       

Klasse!

hatte ein wenig mit anderen abfragen herumgespielt, bin aber immer an
der funktionalität der hilfsspalte gescheitert.

hatte hier versucht:
=SUCHEN(Auswertung!D3;D4;1) - liefert also "1" bei treffer

und dann in der Auswertung:
=WENN(ISTZAHL(Daten!A2);Daten!B2;"") - liefert gewünschten Wert.

Jedoch hab ichs nicht auf die Reihe bekommen, die Ausgabe zu
komprimieren, also die "Treffer" direkt hintereinander auszugeben.
Hier hätte dann auch die Auswertung meine knapp 10.000 Zeilen
umfasst, welche man nach etwaigen angaben hätte durchsuchen müssen.
Nur interessehalber für den "Lerneffekt", wie etwa hätte ich dort vorgehen
können (sofern sie noch Zeit haben, das Problem an sich ist ja gelöst).

Ihre Lösung funktioniert also bestens, werde die ganze Tabelle nunmehr
nur auf die 3 relevanten spalten reduzieren (müssen), damit sich die
formeln einfach "runterkopieren" lassen. hatte diese 3 spalten vorher der
übersichtlichkeit halber nebeneinander in länge von jeweils 150 Zeilen
fortgeführt. dies sollte jedoch kein problem darstellen, da sich niemand
mehr den datensatz selbst anschauen muss, sobald er einmal eingegeben
ist.

An dieser Stelle meinen besten Dank

Gruß,
Fugu
rainberg
Excel-Anwender


Verfasst am:
27. Jun 2005, 11:19
Rufname:

AW: volltextsuche + Ausgabe der position - AW: volltextsuche + Ausgabe der position

Nach oben
       

Hallo Fugu,

deine Formel

=SUCHEN(Auswertung!D3;D4;1)

gibt zwar eine Zahl zurück, aber eben eine Zahl die für eine weitere Auswertung nicht wirklich nützlich ist.

Man könnte zwar anhand dieser Zahl(n) auf den Zeilenindex oder auf die Zelladresse schließen, aber das ist nur mit einer mehr oder weniger komplizierten Matrixformel möglich.
Zum gleichen Ergebnis könntest du mit einer Matrixformel kommen, wenn du auf die Hilfsspalte verzichtest und den Suchstring gleich in Spalte D auswertest.
Aber beides tue ich mir nicht an, da ich die Formeln auch nicht gleich aus dem Handgelenk schütteln kann und diese Art der Auswertung sowieso Unsinn ist. Ich schrieb es ja schon bei großen Datenmengen (und das trifft auf deinen Fall zu) benötigen Matrixformneln unerträglich lange Rechenzeiten.
Ich verwende für solche Lösungen immer eine oder auch mehrere Hilfsspalten.
Sollten diese stören, kann man sie ja auch ausblenden.
Übrigens braucht die Hilfsspalte nicht unbedingt Spalte A sein, es kann jede beliebige Spalte der Tabelle dafür verwendet werden, nur kann man dann in der Auswertung nicht mehr mit SVERWEIS() arbeiten, sondern man muss u.a. dafür die Kombination INDEX() und VERGLEICH() einsetzen.
Schau dir beide Funktionen mal in der OH an, sie sind dort gut beschrieben.

Zum Schluß noch ein Hinweis:

Dein Problem wäre auch sehr gut mit einer Pivot-Tabelle zu lösen, wobei ich dir aber nicht helfen kann. Schau dir dazu mal diesen Link an

http://www.online-excel.de/excel/singsel.php?f=69
Gast



Verfasst am:
27. Jun 2005, 13:19
Rufname:


AW: volltextsuche + Ausgabe der position - AW: volltextsuche + Ausgabe der position

Nach oben
       

Ich seh' schon, mit Excel ist so einiges möglich. Muss mich da mal
ganz langsam vorantasten. Die Hilfsspalten stören nicht weiterm habe
die präsentierte Lösung übernommen und es funktioniert bestens.

Vielen Dank für die ausführlichen erläuterungen.


Gruß,
Fugu
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Ausgabe eines Ergebnis wenn mehrere Bedingungen erfüllt sind 5 Jasmoa 476 14. Feb 2008, 11:12
< Peter > Ausgabe eines Ergebnis wenn mehrere Bedingungen erfüllt sind
Keine neuen Beiträge Excel Formeln: Suche Formel für Ausgabe sachen !!! 1 lars.muc 589 22. Okt 2007, 17:31
Jan3 Suche Formel für Ausgabe sachen !!!
Keine neuen Beiträge Excel Formeln: Ausgabe von Daten bei suche. 4 Alex92 278 24. Sep 2007, 18:48
jelllo Ausgabe von Daten bei suche.
Keine neuen Beiträge Excel Formeln: Dynamische Position einer Formel 4 Boory 587 20. Sep 2007, 14:05
Boory Dynamische Position einer Formel
Keine neuen Beiträge Excel Formeln: Ausgabe mehrerer Daten bei einem "Suchbegriff" 3 ARNE 400 06. Jul 2007, 13:03
ARNE Ausgabe mehrerer Daten bei einem "Suchbegriff"
Keine neuen Beiträge Excel Formeln: WENN Funktion Ausgabe als Text obwohl nur Zahlen 5 Maaadin 819 14. Mai 2007, 02:43
Nokman WENN Funktion Ausgabe als Text obwohl nur Zahlen
Keine neuen Beiträge Excel Formeln: Hilfe für Formel mit Prozent Ausgabe 4 papaschlumpf75 3933 08. Feb 2007, 12:43
Gast Hilfe für Formel mit Prozent Ausgabe
Keine neuen Beiträge Excel Formeln: bei maximalwerte, ausgabe von zeile und spalte 3 Goeldi 479 01. Feb 2007, 18:49
< Peter > bei maximalwerte, ausgabe von zeile und spalte
Keine neuen Beiträge Excel Formeln: Position eines Matrixwertes bestimmen 3 Detlef 42 905 21. Dez 2006, 21:01
Detlef 42 Position eines Matrixwertes bestimmen
Keine neuen Beiträge Excel Formeln: Abfrage in 2 Zellen, Ausgabe in der 3. 29 Reve 1817 28. Aug 2006, 00:07
First Revenant Abfrage in 2 Zellen, Ausgabe in der 3.
Keine neuen Beiträge Excel Formeln: Ausgabe bestimmter Werte mit zwei Bedinungen 9 Prester 787 17. Jul 2006, 14:12
ransi Ausgabe bestimmter Werte mit zwei Bedinungen
Keine neuen Beiträge Excel Formeln: Ausgabe von falschen Wochentagen 3 etbei 708 08. Jun 2006, 10:49
etbei Ausgabe von falschen Wochentagen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML CSS