Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Werte einer Tabelle auslesen
zurück: Meldung Verknüpfungen zu anderen Datenquellen weiter: Festes Datum verwenden Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
bobi
Gast


Verfasst am:
28. Jun 2005, 14:04
Rufname:

Werte einer Tabelle auslesen - Werte einer Tabelle auslesen

Nach oben
       

Hallo,

ich habe folgendes Problem:

Ich habe eine Tabelle mit 4 Spalten. Die Werte in den Spalten 1 bis 3 sollen jeweils mit einem SVERWEIS (oder anders?) aus einem entsprechenden Eingabefeld ausgelesen werden. Es soll der Wert aus Spalte 4 ausgegeben werden, der in der Zeile steht, in der alle 3 Werte mit den jeweiligen Eingabefeldern übereinstimmen. Wie geht das?

Bsp.:

In meinen Eingabefelder steht

Eingabefeld 1: B
Eingabefeld 2: 1
Eingabefeld 3: 1

und ich habe folgende Wertetabelle:

Spalte 1 Spalte 2 Spalte 3 Spalte 4 (Ausgabespalte)
A 0 1 1
A 0 2 2
A 1 1 3
A 1 2 4
B 0 1 5
B 0 2 6
B 1 1 7
B 1 2 8

dann müsste ich mit der Formel, die ich suche den Wert 7 aus Spalte 4 auslesen!!

Also, wer kann helfen?!
Willie
Im Profil kannst Du frei den Rang ändern


Verfasst am:
28. Jun 2005, 14:10
Rufname:
Wohnort: Ingolstadt


AW: Werte einer Tabelle auslesen - AW: Werte einer Tabelle auslesen

Nach oben
       

Hallo bobi,

ich glaub du suchst das hier:

http://www.office-loesung.de/viewtopic.php?p=163982&highlight=#163982

Gruß

Willie
bobi
Gast


Verfasst am:
28. Jun 2005, 15:07
Rufname:

klappt noch nicht - klappt noch nicht

Nach oben
       

Hallo,

der Lösungsvorschlag war schon nah dran, aber ich bekomme kein Formelergebnis (#Wert!). Die Teilergebnisse, die ich mit F9 geprüft habe funktionieren allerdings. Das einzeige was mich gewundert hat, ist das alle drei ausgelesenen Werte aus den Eingabefeldern hier aneinander geschrieben sind. Immerhin stehen sie ja alle drei in unterschiedlichen Zellen.

Was kann ich noch tun...?

Vielen Dank schon einmal
Arnim
Im Profil kannst Du frei den Rang ändern


Verfasst am:
28. Jun 2005, 23:43
Rufname:

AW: Werte einer Tabelle auslesen - AW: Werte einer Tabelle auslesen

Nach oben
       

Hallo,
zwei Lösungsvorschlage:
1. Füge eine Hilfsspalte (hier Spalte A) ein, die Du anschließend ausblenden kannst.
Formel in A6:
=WENN((B6=C$1)*(C6=C$2)*(D6=C$3);1;"")
und kopiere sie soweit benötigt herunter.
In E2 dann die Formel:
=SVERWEIS(1;A:E;5;0)
2. Ohne Hilfsspalte:
Matrixformel in E2:
=INDEX(E:E;VERGLEICH(C1&C2&C3;B1:B29&C1:C29&D1:D29;0))
Eingabe dieser Formel mit Tastenkombination "Strg"+"Shift(Umschalt)"+"Enter"
Hast Du eine sehr große Tabelle, würde ich Dir zur ersten Lösung raten. Denn Matrixformeln beeinträchtigen die Rechengeschwindigkeit.
 
 ABCDEF
1 Feld1B Ausgabe: 
2 Feld21 7 
3 Feld31   
4      
5HSSpalte1Spalte2Spalte3Spalte4 
6 A011 
7 A022 
8 A113 
9 A124 
10 B015 
11 B026 
121B117 
13 B128 
14      
 


Gruß Arnim
bobi
Gast


Verfasst am:
29. Jun 2005, 13:36
Rufname:


AW: Werte einer Tabelle auslesen - AW: Werte einer Tabelle auslesen

Nach oben
       

Hallo und vielen Dank.

Das klappt wunderbar.

Grüße
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Werte aus Liste raussuchen 8 KARL 1217 30. Apr 2014, 18:10
Holger1968 Werte aus Liste raussuchen
Keine neuen Beiträge Excel Formeln: Dateinamen für zu öffnende Tabelle in Zelle vorgeben, wie? 4 excessor 1698 24. Jan 2005, 22:52
A.Knecht Dateinamen für zu öffnende Tabelle in Zelle vorgeben, wie?
Keine neuen Beiträge Excel Formeln: Will Werte addieren in Bezug zu einer anderen Spalte 8 MrMr 2236 08. Jan 2005, 14:50
xyzdef Will Werte addieren in Bezug zu einer anderen Spalte
Keine neuen Beiträge Excel Formeln: größten wert auslesen und woanders um 50 erhöhen 1 GE 1220 20. Dez 2004, 12:51
icke größten wert auslesen und woanders um 50 erhöhen
Keine neuen Beiträge Excel Formeln: Anzahl identischer Werte 2 Toledo 2627 04. Dez 2004, 01:19
Toledo Anzahl identischer Werte
Keine neuen Beiträge Excel Formeln: Wert aus einer anderen Tabelle holen 2 =KB=Shorty 4867 17. Nov 2004, 21:22
=KB=Shorty Wert aus einer anderen Tabelle holen
Keine neuen Beiträge Excel Formeln: Werte aus bestimmten Bereich anzeigen 3 timo 2343 27. Okt 2004, 12:56
fridgenep Werte aus bestimmten Bereich anzeigen
Keine neuen Beiträge Excel Formeln: Anzahl bei 2 Bedingungen aus Tabelle berechnen 6 Satanico 1723 21. Okt 2004, 14:48
Satanico Anzahl bei 2 Bedingungen aus Tabelle berechnen
Keine neuen Beiträge Excel Formeln: In Exel gleiche Zeilen finden und andere Werte importieren 0 Timo 3157 13. Okt 2004, 14:46
Timo In Exel gleiche Zeilen finden und andere Werte importieren
Keine neuen Beiträge Excel Formeln: werte innerhalb eines bestimmten bereichs suchen 3 infantil88 3545 17. Sep 2004, 10:54
Arnim werte innerhalb eines bestimmten bereichs suchen
Keine neuen Beiträge Excel Formeln: Tabelle einer Internetseite auslesen 1 Andy_beginner 1931 14. Jul 2004, 23:19
Manfred Bartak Tabelle einer Internetseite auslesen
Keine neuen Beiträge Excel Formeln: Werte zählen 1 Helle67 1116 29. Jun 2004, 01:38
fridgenep Werte zählen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Excel-Formeln