Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Verschiedene Zeilen aus Tabelle in Spalte "verschieben&
zurück: doppelte Einträge markieren / Einträge Vergleichen weiter: Formel erweitern (Sortieren und Leerzellen ignorieren) Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Offen Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
paperwings
Im Profil kannst Du frei den Rang ändern


Verfasst am:
28. Okt 2010, 16:24
Rufname:

Verschiedene Zeilen aus Tabelle in Spalte "verschieben& - Verschiedene Zeilen aus Tabelle in Spalte "verschieben&

Nach oben
       Version: Office 2007

Hallo zusammen!

Ich werde euch wohl nun ab und zu mal mit komischen excel-Fragen bespassen und hoffe, das geht ok Very Happy Da ist halt dann die Formulierungssache... Embarassed Vielleicht versteht ihr mich ja trotz allem...

Und zwar geht es um folgendes:

Ich habe eine Liste mit Titeln, Autoren und Verlagen in ganz vielen Zeilen (manchmal ein paar Tausend).

Wie schaffe ich es, die Autoren (und Co-Autoren) in die Spalte neben den Titel (die einzelnen Titel sind ja ganz einfach rauszufiltern.) zu bekommen?

Leider ist sogar ein Schrägstrich zwischen den Namen zwingend. Keine Ahnung ob das überhaupt möglich ist.

Hier ein Bild, so wie ichs mir vorstelle: Spalte A und B müsste dann schlussendlich wie Spalte D und E aussehen... http://gbimg.org/p.php?q=hNVob (Bin ich zu blöd um ein Bild einzufügen? Dann halt URL *g)

Danke für die eventuelle Hilfe und Grüsse Smile
ChristianL
Excel-Kenner (ohne VBA)


Verfasst am:
28. Okt 2010, 19:58
Rufname: Christian


AW: Verschiedene Zeilen aus Tabelle in Spalte "verschie - AW: Verschiedene Zeilen aus Tabelle in Spalte "verschie

Nach oben
       Version: Office 2007

Hallo,

ein Ansatz mit 2 Hilfsspalten:

Tabelle1

 ABCDEF
1    TitelAutor/Co-Autor
2      
3TitelTitel11 Titel1Autor1, Autor2, Co-Autor1
4AutorAutor11, Autor1Titel2Autor3
5AutorAutor21, Autor1, Autor2Titel3Autor4, Autor5
6Co-AutorCo-Autor11, Autor1, Autor2, Co-Autor1Titel4Autor6, Autor7, Autor8, Co-Autor2
7VerlagVerlag1  Titel5Autor9, Co-Autor3
8TitelTitel22 Titel6Autor10, Co-Autor4
9AutorAutor32, Autor3  
10VerlagVerlag2    
11TitelTitel33   
12AutorAutor43, Autor4  
13AutorAutor53, Autor4, Autor5  
14TitelTitel44   
15AutorAutor64, Autor6  
16AutorAutor74, Autor6, Autor7  
17AutorAutor84, Autor6, Autor7, Autor8  
18Co-AutorCo-Autor24, Autor6, Autor7, Autor8, Co-Autor2  
19TitelTitel55   
20AutorAutor95, Autor9  
21Co-AutorCo-Autor35, Autor9, Co-Autor3  
22VerlagVerlag3    
23TitelTitel66   
24AutorAutor106, Autor10  
25Co-AutorCo-Autor46, Autor10, Co-Autor4  

Formeln der Tabelle
ZelleFormel
C3=WENN(A3="Titel";ZÄHLENWENN($A$3:A3;A3);WENN(ISTZAHL(SUCHEN("autor";A3));C2;""))
D3=WENN(ISTZAHL(SUCHEN("autor";A3));D2&", "&B3;"")
E3=WENN(ZEILE(A1)>MAX(C:C);"";INDEX(B:B;VERGLEICH(ZEILE(A1);C:C;0)))
F3=WENN(E3="";"";WECHSELN(VERWEIS(2;1/($C$3:$C$30000=SVERWEIS(E3;B:C;2;0));$D$3:$D$30000);", ";"";1))


Excel Jeanie Html

_________________
MfG Christian
paperwings
Im Profil kannst Du frei den Rang ändern


Verfasst am:
29. Okt 2010, 16:51
Rufname:

AW: Verschiedene Zeilen aus Tabelle in Spalte "verschie - AW: Verschiedene Zeilen aus Tabelle in Spalte "verschie

Nach oben
       Version: Office 2007

Hallo Christian

Vielen Dank für die Formeln!

Werds am Montag auf der Arbeit ausprobieren! Wink Hoffentlich klappt das... Wär echt der Hammer!
Gast



Verfasst am:
01. Nov 2010, 13:52
Rufname:

AW: Verschiedene Zeilen aus Tabelle in Spalte "verschie - AW: Verschiedene Zeilen aus Tabelle in Spalte "verschie

Nach oben
       Version: Office 2007

Hallo!

Also, ich hab das jetzt mal ausprobiert und zur hälfte hats auch geklappt. *freu*

Allerdings mag mich excel in der letzten spalte wohl nicht.

Da sich meine excelkenntnisse aber auf ein mindestmass beschränken, kann ich die formeln auch nur bedingt nachvollziehen bzw. auseinander nehmen und weiss darum nicht was ich falsch gemacht hab..?

Hier nochmal ein Bild von der "Originaltabelle":

http://gbimg.org/p.php?q=lo9kG
paperwings
Im Profil kannst Du frei den Rang ändern


Verfasst am:
01. Nov 2010, 13:53
Rufname:

AW: Verschiedene Zeilen aus Tabelle in Spalte "verschie - AW: Verschiedene Zeilen aus Tabelle in Spalte "verschie

Nach oben
       Version: Office 2007

Whoops...der Gast war ich.. sorry.
ChristianL
Excel-Kenner (ohne VBA)


Verfasst am:
01. Nov 2010, 21:59
Rufname: Christian

AW: Verschiedene Zeilen aus Tabelle in Spalte "verschie - AW: Verschiedene Zeilen aus Tabelle in Spalte "verschie

Nach oben
       Version: Office 2007

Hallo,

was willst Du verketten und was ist TO und die anderen Kürzel?
Genauer beschreiben!

_________________
MfG Christian
paperwings
Im Profil kannst Du frei den Rang ändern


Verfasst am:
02. Nov 2010, 10:01
Rufname:


AW: Verschiedene Zeilen aus Tabelle in Spalte "verschie - AW: Verschiedene Zeilen aus Tabelle in Spalte "verschie

Nach oben
       Version: Office 2007

Hallöchen

Ach, sorry.. Ich bin so zerstreut..

Also TO steht für den Titel und CA (Autor) bzw A (auch Autor oder Co-Autor) (von dem man im aktuellen Bild nichts sieht, der aber auch vorkommen kann)

Ich müsste dann in einer Spalte die TOs (Titel) und in der anderen die CA oder A's (Autoren) haben.. (Wie im Startposting im Link)

E/ES (Verlag) usw. in Spalte A müsste nicht beachtet werden

Hat ja alles soweit funktioniert bis auf die Autorenspalte (Spalte F).. nur weiss ich nicht, wo der fehler liegt... Embarassed Ich hab die Formeln genau so Kopiert und da wo zb. "Titel" stand "TO" reingeschrieben

Spalte C sieht bei mir so aus:
=WENN(A3="TO";ZÄHLENWENN($A$3:A3;A3);WENN(ISTZAHL(SUCHEN("CA";A3));C2;""))

Spalte D
=WENN(ISTZAHL(SUCHEN("CA";A3));D2&", "&B3;"")

Spalte E
=WENN(ZEILE(A1)>MAX(C:C);"";INDEX(B:B;VERGLEICH(ZEILE(A1);C:C;0)))

Spalte F
=WENN(E3="";"";WECHSELN(VERWEIS(2;1/($C$3:$C$30000=SVERWEIS(E3;B:C;2;0));$D$3:$D$30000);", ";"";1))


Ich würd ja dieses Jeaniedingen benutzen aber auf Arbeit ist das bissl kritisch und daheim hab ich grad kein internet :/
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Indirekt & Vergeich 10 fridgenep 638 23. Sep 2004, 11:57
fridgenep Indirekt & Vergeich
Keine neuen Beiträge Excel Formeln: Formel für Spalten und Zeilen 17 Gast 2737 15. Sep 2004, 14:11
steve1da Formel für Spalten und Zeilen
Keine neuen Beiträge Excel Formeln: werte in neue tabelle mit neuen spalten kopieren 1 Timo 1723 03. Sep 2004, 07:37
ae werte in neue tabelle  mit neuen spalten kopieren
Keine neuen Beiträge Excel Formeln: automatisches Ausblenden von Zeilen durch Formel 6 SeRo 1276 31. Aug 2004, 15:24
Thomas Ramel automatisches Ausblenden von Zeilen durch Formel
Keine neuen Beiträge Excel Formeln: Daten aus einer Spalte in eine Zeile bringen 8 Hobbitz 2695 26. Aug 2004, 19:49
Arnim Daten aus einer Spalte in eine Zeile bringen
Keine neuen Beiträge Excel Formeln: Einfärben einer Spalte bei bestimmten Vorzeichen 3 itmeli 813 16. Aug 2004, 13:25
itmeli Einfärben einer Spalte bei bestimmten Vorzeichen
Keine neuen Beiträge Excel Formeln: mal wieder: letzte ausgefüllte Zelle in Spalte 4 Gast 3785 14. Aug 2004, 11:57
Gast mal wieder: letzte ausgefüllte Zelle in Spalte
Keine neuen Beiträge Excel Formeln: Mit Formel Werte einer Spalte überprüfen 4 redknoxx 1170 30. Jul 2004, 16:39
redknoxx Mit Formel Werte einer Spalte überprüfen
Keine neuen Beiträge Excel Formeln: Wie kann ich prüfen, ob Wert in Spalte nur einmal vorkommt? 1 gast 2985 16. Jul 2004, 12:27
peb Wie kann ich prüfen, ob Wert in Spalte nur einmal vorkommt?
Keine neuen Beiträge Excel Formeln: Überprüfe Existenz einer Tabelle 1 Fabalicious 632 27. Apr 2004, 17:22
Thomas Ramel Überprüfe Existenz einer Tabelle
Keine neuen Beiträge Excel Formeln: Datensätze aufgrund von Suchkriterium in neue Tabelle kopier 10 Nicole 1355 11. Apr 2004, 22:14
Johannes 1212 Datensätze aufgrund von Suchkriterium in neue Tabelle kopier
Keine neuen Beiträge Excel Formeln: Mehrere Zeilen Verknüpfen 3 BeneFunk 937 05. März 2004, 16:28
Sebastian Mehrere Zeilen Verknüpfen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Project