Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Problem mit einigen Artikeln in Berichten
Gehe zu Seite 1, 2  Weiter
zurück: Felder im Bereich gezielt ausblenden weiter: Text- und Bezeichnungsfeld über VBA ändern Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Ulli81
Gast


Verfasst am:
29. Jun 2005, 13:20
Rufname:

Problem mit einigen Artikeln in Berichten - Problem mit einigen Artikeln in Berichten

Nach oben
       

HalliHallo,
bei meinem letzten Beitrag (Bericht nimmt einige Artikel nicht an!) hat mir leider keiner geantwortet Crying or Very sad
Habe das Problem bis jetzt auch selber nicht lösen können, darum hoffe ich, dass mir hier jemand helfen kann.
Und hier das Problem. Ich habe ein Formular "Bestellungen" wo ein Listenfeld mit allen Bestellungen ist. Durch DoppelKlick auf einer dieser Bestellungen im Listenfeld öffnet er mir den Bericht und übernimmt die Artikel von den Tabellen Auftrag und Auftragsposition. Bis jetzt hat auch alles super geklappt. Aber wenn Artikel in einer Bestellung sind, wo die ArtikelNr Leerzeichen und/oder Buchstaben hat, z.B.: 29 2 djek, dann bleibt der Bericht, der durch DoppelKlick geöffnet wird, komplett leer. Wenn die ArtikelNr aber nur Zahlen hat, z.B. so: 199302, dann klappt alles 100%.

Kann mir da keiner helfen? Question
Bin schon am Verzweifeln.

mfG Ulli
jens05
Moderator


Verfasst am:
29. Jun 2005, 14:31
Rufname:
Wohnort: ~~~~~


AW: Problem mit einigen Artikeln in Berichten - AW: Problem mit einigen Artikeln in Berichten

Nach oben
       

Hallo,
wie sieht dein Code zum öffnen aus?

vielleicht fehlen die Hochkommas
Code:
    ... Artikelnummer = '" & Me!Listenfeld "'"

_________________
mfg jens05 Wink
Ulli81
Gast


Verfasst am:
29. Jun 2005, 14:38
Rufname:

AW: Problem mit einigen Artikeln in Berichten - AW: Problem mit einigen Artikeln in Berichten

Nach oben
       

Hallo,

das hab ich mir auch schon gedacht und hab bisschen mit den Hochkommas versucht, aber hat nicht geklappt. Hier die SQL-Abfrage.
Code:
    SQL = "SELECT Auftragsposition.AuftragsNr, " & _
                 "Auftragsposition.LieferantenNr, " & _
                 "Auftragsposition.ReferenzNr, " & _
                 "Auftragsposition.AbrufNr, " & _
                 "Auftragsposition.Datum, " & _
                 "Lieferanten.Lieferantenname, " & _
                 "Lieferanten.Ansprechpartner, " & _
                 "Lieferanten.Abteilung, " & _
                 "Lieferanten.Telefonnummer, " & _
                 "Lieferanten.Faxnummer " & _
          "FROM   Lieferanten " & _
                 "INNER JOIN Auftragsposition " & _
                 "ON Lieferanten.LieferantenNr = Auftragsposition.LieferantenNr " & _
          "WHERE  Auftragsposition.AuftragsNr=" & Me!Ergebnis.Column(0) & ";"
Willi Wipp
Moderator


Verfasst am:
29. Jun 2005, 16:11
Rufname:
Wohnort: Raum Wiesbaden

Re: Problem mit einigen Artikeln in Berichten - Re: Problem mit einigen Artikeln in Berichten

Nach oben
       

Hi Ulli81,

na dann versuch es doch mal so wie jens05 es vorgeschlagen hat
Code:
    SQL = "SELECT Auftragsposition.AuftragsNr, " & _
                 "Auftragsposition.LieferantenNr, " & _
                 "Auftragsposition.ReferenzNr, " & _
                 "Auftragsposition.AbrufNr, " & _
                 "Auftragsposition.Datum, " & _
                 "Lieferanten.Lieferantenname, " & _
                 "Lieferanten.Ansprechpartner, " & _
                 "Lieferanten.Abteilung, " & _
                 "Lieferanten.Telefonnummer, " & _
                 "Lieferanten.Faxnummer " & _
          "FROM   Lieferanten " & _
                 "INNER JOIN Auftragsposition " & _
                 "ON Lieferanten.LieferantenNr = Auftragsposition.LieferantenNr " & _
          "WHERE  Auftragsposition.AuftragsNr='" & Me!Ergebnis.Column(0) & "';"

_________________
Eine kurze Rueckmeldung waere nett
SL Willi Wipp

(Anleitung fuer das Anhaengen von Dateien: Klicke links auf [www], Gaeste muessen sich dafuer anmelden)
Ulli81
Gast


Verfasst am:
29. Jun 2005, 23:21
Rufname:


AW: Problem mit einigen Artikeln in Berichten - AW: Problem mit einigen Artikeln in Berichten

Nach oben
       

Hallo Willi,
okay habe das Verstanden mit den Doppelpostings. War halt nur verzweifelt, deswegen habe ich ein neues Thema draus gemacht.
Sorry, denke ich nächstes Mal dran.
Zu meinem Problem nochmal, das klappt leider nicht mit den Hochstrichen.
Ich dachte mir vielleicht das es an der "Datensatzherkunft" eventuell liegt, da hier ja sogesehen die Artikel aufgelistet werden.
Hier mal der Code des Datensatzherkunftes:
Code:
SELECT Artikel.ArtikelNr, Auftrag.EinzelpreisVPE, Auftrag.Menge, Artikel.ArtikelBeschreibung
FROM   Artikel
       INNER JOIN (temp
                   INNER JOIN Auftrag
                   ON temp.AuftragsNr=Auftrag.AuftragsNr)
       ON Artikel.ArtikelNr=Auftrag.ArtikelNr;

Hier kann man doch aber keine Hochstriche einfügen oder irre ich mich da?

mfG ulli
Willi Wipp
Moderator


Verfasst am:
30. Jun 2005, 12:12
Rufname:
Wohnort: Raum Wiesbaden

Re: Problem mit einigen Artikeln in Berichten (II) - Re: Problem mit einigen Artikeln in Berichten (II)

Nach oben
       

Hi Ulli81,

warum sollte man da Hochstriche einfuegen?
Solange SQL mit Feldern (von Tabellen) arbeitet, kennt es den Datentyp.
Sobald man aber den SQL-String selbst zusammen baut und dabei Konstanten einfuegt,
muss der Datentyp der Konstanten mit dennen des Feldes uebereinstimmen.
Das gleiche gilt, wenn man sich auf ein Feld auf einem Formular bezieht.
Also muss man bei einem Feld vom Datentyp Text dafuer sorgen,
dass eine String-Konstante fuer den Vergleich verwendet wird.
Daher musst Du die Hochstriche einsetzen, wenn Du Konstanten in einem SQL-String verwendest.

Aber versuch Dir einfach mal den zusammengebauten String anzuschauen
Code:
    Debug.Print SQL$

_________________
Eine kurze Rueckmeldung waere nett
SL Willi Wipp

(Anleitung fuer das Anhaengen von Dateien: Klicke links auf [www], Gaeste muessen sich dafuer anmelden)


Zuletzt bearbeitet von Willi Wipp am 07. Jul 2005, 17:34, insgesamt einmal bearbeitet
Ulli81
Gast


Verfasst am:
30. Jun 2005, 15:20
Rufname:

AW: Problem mit einigen Artikeln in Berichten - AW: Problem mit einigen Artikeln in Berichten

Nach oben
       

Hi Willi Wipp,

klar, verstehe was Du meinst mit den Hochstrichen. Hab einen Denkfehler gehabt. Ich dachte, dass man "sagen" muss, dass eine ArtikelNr, die z.B. so aussieht:384 DJW 42, dass es zusammengehört, indem man da irgendwo die Hochstriche einbaut.
Kannst Du mir bitte sagen, wo ich den Code
Code:
    Debug.Print SQL$
einbauen soll?
Sorry, bin noch ein Anfänger. Rolling Eyes
mfG Ulli
Nachtrag: Ulli81 am 30. Jun 2005 um 15:27 hat folgendes geschrieben:
Ach ja, wenn ich so einen Bericht mit den bestimmten ArtikelNr habe, und ich in die Entwurfsansicht und zurück gehe, dann meckert er:
Zitat:
Datentypen in Kriterienausdruck unverträglich.
Der meckert nur bei Bestellungen mit den bestimmten ArtikelNr.
Willi Wipp
Moderator


Verfasst am:
30. Jun 2005, 16:32
Rufname:
Wohnort: Raum Wiesbaden

Re: Problem mit einigen Artikeln in Berichten (III) - Re: Problem mit einigen Artikeln in Berichten (III)

Nach oben
       

Hi Ulli81,
das
Code:
    Debug.Print SQL$
setzt Du nachdem Du den String SQL$ zusammengesetzt hast.
Das bewirkt die Ausgabe des Strings im Direktfenster (Strg+G; Testfenster).
Da kannst Du ihn dann kopieren und hier reinstellen bzw. in einer neuen Abfrage ausprobieren.

Und wir waren Alle mal Anfaenger und hier hat das wohl auch keiner vergessen.

Wegen dem anderen Problem (Entwurfsansicht und zurueck):
Ich gehe davon aus Du hast in allen Tabellen den gleichen Datentyp fuer das Feld.
Ich denke es haengt vielleicht einfach mit dem obigen Problem zusammen.

_________________
Eine kurze Rueckmeldung waere nett
SL Willi Wipp

(Anleitung fuer das Anhaengen von Dateien: Klicke links auf [www], Gaeste muessen sich dafuer anmelden)
Ulli81
Gast


Verfasst am:
11. Jul 2005, 11:51
Rufname:

AW: Problem mit einigen Artikeln in Berichten - AW: Problem mit einigen Artikeln in Berichten

Nach oben
       

Ulli81 am 01. Jul 2005 um 12:42 hat folgendes geschrieben:
Hallo Willi,
hab das da versucht einzusetzen, hat aber nicht geklappt, dann hab ich das wieder weggenommen. Hört sich vielleicht blöd an, jetzt klappt das gar nicht mehr.
Der zeigt mir Laufzeitfehler '3265': Element in dieser Auflistung nicht gefunden.
Code:
    db.QueryDefs.Delete "temp"

Das heftige ist, bei der Sicherheitskopie funktioniert das auch nicht. Warum hängt das eine mit den Anderem zusammen. Verstehe hier nichts mehr. Sad

mfG Ulli

Ulli81 am 07. Jul 2005 um 12:28 hat folgendes geschrieben:
Hallo Willi,

meine Datenbank läuft wieder. Habe das mit dem
Code:
    Debug.Print SQL$
Aber helfen tut das nicht wirklich.
Im Direktfenster wird dann folgendes angezeigt:
Code:
SELECT Auftragsposition.AuftragsNr, Auftragsposition.LieferantenNr,
       Auftragsposition.ReferenzNr, Lieferanten.AbrufNr,
       Auftragsposition.Datum, Lieferanten.Lieferantenname,
       Lieferanten.Ansprechpartner, Lieferanten.Abteilung,
       Lieferanten.Telefonnummer, Lieferanten.Faxnummer
FROM   Lieferanten
       INNER JOIN Auftragsposition
       ON Lieferanten.LieferantenNr = Auftragsposition.LieferantenNr
WHERE  Auftragsposition.AuftragsNr=102;

mfG Ulli

Kann mir da keiner helfen?

mfG Ulli
Willi Wipp
Moderator


Verfasst am:
13. Jul 2005, 18:06
Rufname:
Wohnort: Raum Wiesbaden

Re: Problem mit einigen Artikeln in Berichten (IV) - Re: Problem mit einigen Artikeln in Berichten (IV)

Nach oben
       

Hi Ulli81,

sorry aber ich sehe am Ende keine Hochkommas
und die sind notwendig wenn das Feld AuftragsNr vom Datentyp Text ist.
Code:
    '...
          "WHERE  Auftragsposition.AuftragsNr='" & Me!Ergebnis.Column(0) & "';"

_________________
Eine kurze Rueckmeldung waere nett
SL Willi Wipp

(Anleitung fuer das Anhaengen von Dateien: Klicke links auf [www], Gaeste muessen sich dafuer anmelden)
Ulli81_
Gast


Verfasst am:
13. Jul 2005, 23:37
Rufname:

AW: Problem mit einigen Artikeln in Berichten - AW: Problem mit einigen Artikeln in Berichten

Nach oben
       

Hi Willi,
kämpfe immer noch am selbem Problem.
AuftragsNr ist vom Datentyp Zahl. Hab das trotzdem einfach mal ausprobiert, aber vergeblich.
Fehler 3464:
Datentypen in Kriterienausdruck unverträglich.
Liegt das Problem aber auch an dieser Abfrage?
Er findet ja so gesehen den Auftrag. Er lässt alle "bestellten Artikel" im Bericht einfach dann weg, wenn mind. ein Artikel bestellt wurde, dessen ArtikelNr z.B. so ist: 234 5JF.
Dann lässt er auch die Artikel weg, deren ArtikelNr nur aus Zahlen besteht.
Hab ich zwar schonmal erwähnt, aber ich weiss nicht mehr woran das sonst liegen könnte.
Ich hätte echt vielleicht gedacht, dass es an dem Datensatzherkunft liegt:
Code:
SELECT Artikel.ArtikelNr, Auftrag.EinzelpreisVPE, Auftrag.Menge,
       Artikel.ArtikelBeschreibung
FROM   Artikel
       INNER JOIN (temp
                   INNER JOIN Auftrag
                   ON temp.AuftragsNr=Auftrag.AuftragsNr)
       ON Artikel.ArtikelNr=Auftrag.ArtikelNr;

Das ist halt mit so'ner Abfrage realisiert worden.
Vielleicht in VB nochmal eine andere SQL-Klausel schreiben, wo man auf die bestimmten ArtikelNr eingehen kann?
Echt vielen Dank für Deine Geduld.

mfG Ulli
Willi Wipp
Moderator


Verfasst am:
14. Jul 2005, 12:10
Rufname:
Wohnort: Raum Wiesbaden

Re: Problem mit einigen Artikeln in Berichten (V) - Re: Problem mit einigen Artikeln in Berichten (V)

Nach oben
       

Hi Ulli81,

hast Du etwa unterschiedliche Datentypen fuer Deine ArtikelNr in den Tabellen definiert?
Wie kannst Du denn sonst 234 5JF in einem Feld vom Datentyp Zahl (Long) speichern?

_________________
Eine kurze Rueckmeldung waere nett
SL Willi Wipp

(Anleitung fuer das Anhaengen von Dateien: Klicke links auf [www], Gaeste muessen sich dafuer anmelden)
Ulli81
Access-Einsteiger


Verfasst am:
15. Jul 2005, 02:16
Rufname:
Wohnort: Salzgitter

AW: Problem mit einigen Artikeln in Berichten - AW: Problem mit einigen Artikeln in Berichten

Nach oben
       

Hi Willi,

AuftragsNr ist als Long und ArtikelNr als Text deklariert, so muss es ja auch sein, oder?
Wenn ich Artikel mit verschiedenen Zeichen in der ArtikelNr bestelle, dann werden diese auch in die Tabelle Auftrag gepackt, reibungslos.
Der Bericht bezieht sich ja auf Tabelle Auftrag und Auftragsposition. Da gibt's die Probleme, weil er da irgendwie mit diesen ArtikelNr nicht klar kommt. Deswegen hab ich diesen oberen Select-Befehl mal anschaulich gemacht, vielleicht passt da ja was nicht.

Vielen Dank Willi

mfG Ulli
Willi Wipp
Moderator


Verfasst am:
15. Jul 2005, 12:33
Rufname:
Wohnort: Raum Wiesbaden

Re: Problem mit einigen Artikeln in Berichten (VI) - Re: Problem mit einigen Artikeln in Berichten (VI)

Nach oben
       

Hi Ulli81,

bist Du sicher, dass Du in den beiden Tabellen Auftragsposition und Artikel
das Feld ArtikelNr als Text deklariert hast?

_________________
Eine kurze Rueckmeldung waere nett
SL Willi Wipp

(Anleitung fuer das Anhaengen von Dateien: Klicke links auf [www], Gaeste muessen sich dafuer anmelden)
Ulli81
Access-Einsteiger


Verfasst am:
15. Jul 2005, 12:59
Rufname:
Wohnort: Salzgitter


AW: Problem mit einigen Artikeln in Berichten - AW: Problem mit einigen Artikeln in Berichten

Nach oben
       

Hi Willi,

ja bin ich. Hab sicherheitshalber nochmal nachgeguckt. Die waren vorher als Long deklariert. Hab das dann zwischendurch mal geändert auf Text. ArtikelNr ist in der Tabelle Artikel der Primary Key, kann es eventuell daran liegen?

mfG Ulli
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Gehe zu Seite 1, 2  Weiter
Diese Seite Freunden empfehlen

Seite 1 von 2
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Access Tabellen & Abfragen: Anzeige von nur einigen Daten 1 Homer13 386 31. Jul 2007, 17:27
rita2008 Anzeige von nur einigen Daten
Keine neuen Beiträge Access Formulare: Einfaches Ausführen bei mehreren Berichten/Macros 9 Globber 600 14. Apr 2007, 13:30
Willi Wipp Einfaches Ausführen bei mehreren Berichten/Macros
Keine neuen Beiträge Access Berichte: Probleme beim Ausdruck von Berichten 2 michaelb12 892 06. Apr 2006, 16:52
michaelb12 Probleme beim Ausdruck von Berichten
Keine neuen Beiträge Access Berichte: Gruppierung in Berichten 2 Gast 815 03. Apr 2006, 16:05
Gast Gruppierung in Berichten
Keine neuen Beiträge Access Formulare: Bilder in Formularen und Berichten 1 swingkid 805 24. Feb 2006, 05:47
Funny Bilder in Formularen und Berichten
Keine neuen Beiträge Access Berichte: Aus anderen Berichten Werte auslesen 1 datahell 801 07. Jan 2006, 20:22
Gast10 Aus anderen Berichten Werte auslesen
Keine neuen Beiträge Access Tabellen & Abfragen: Access-Abfrage mit "nicht erlaubten Artikeln" 0 redbull 501 29. Okt 2005, 17:37
redbull Access-Abfrage mit "nicht erlaubten Artikeln"
Keine neuen Beiträge Access Formulare: Sperren von Berichten etc. 3 Tobi..... 505 07. Sep 2005, 13:38
Highlander Sperren von Berichten etc.
Keine neuen Beiträge Access Berichte: zeilenumbruch in berichten 2 gerhardg 996 27. Jul 2005, 22:25
Gast zeilenumbruch in berichten
Keine neuen Beiträge Access Berichte: Eportieren von Berichten nach Excel 0 futzi-ka 601 13. Jul 2005, 11:09
futzi-ka Eportieren von Berichten nach Excel
Keine neuen Beiträge Access Berichte: Verknüpfung von Berichten mit Tabellen möglich? 6 Hal123 694 03. Jun 2005, 13:05
Hal123 Verknüpfung von Berichten mit Tabellen möglich?
Keine neuen Beiträge Access Berichte: Rechnen in Berichten 4 Gast 5363 12. Apr 2005, 13:45
sebix Rechnen in Berichten
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Expression Web Forum