Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Makros mit Excel 4.0 (KEIN VBA)
zurück: Probleme mit der IF-Formel weiter: Wenn Formel Problem Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Pinsel63
VBA-Neuling


Verfasst am:
06. Dez 2010, 23:05
Rufname: Struppi
Wohnort: Görlitz

Makros mit Excel 4.0 (KEIN VBA) - Makros mit Excel 4.0 (KEIN VBA)

Nach oben
       Version: Office 2003

Hallo an alle Experten,
in einem Dialogfeld wird ein Monat ausgewählt. Dadurch wird ja im Dialogfeld eine entsprechende Zahl hinterlegt.
In dem Makro möchte ich nun erreichen, dass bei einer bestimmten Zahl (bestimmter ausgewählte Monat) zu einem dazugehörigen Mkro gesprungen wird, ansonsten soll die nächste Abfrage erfolgen.

Wer kann mir helfen?

Hier das Makro:

Makro1

A
1Stamm()
2=ECHO(FALSCH)
3=AKTIVIEREN("Makro1")
4AUSWÄHLEN(J7)
5INHALTE.LÖSCHEN()
6=AUSWÄHLEN(J7)
7=WENN(AKTIVE.ZELLE()=1;A8;A13)
8=AUSWÄHLEN(J13)
9=WENN(AKTIVE.ZELLE()=13;GEHEZU(Dez());GEHEZU(A10))
10=WENN(AKTIVE.ZELLE()=12;GEHEZU(Nov());GEHEZU(A11))
11=WENN(AKTIVE.ZELLE()="11";GEHEZU(Okt());GEHEZU(A12))
12=WENN(AKTIVE.ZELLE()=10;GEHEZU(Sep());GEHEZU(A13))
13=AUSWÄHLEN(J13)
14=INHALTE.LÖSCHEN()
15=WENN(DIALOGFELD(DiaStamm)=FALSCH;RÜCKSPRUNG())
16=AKTIVIEREN("Makro1")
17=AUSWÄHLEN(J11)
18=KOPIEREN()
19=AKTIVIEREN("Zusammenfassung")
20=AUSWÄHLEN(Zusammenfassung!O3)
21=INHALTE.EINFÜGEN(3)
22=AKTIVIEREN("Makro1")
23=AUSWÄHLEN(J16)
24=KOPIEREN()
25=AKTIVIEREN("Zusammenfassung")
26=AUSWÄHLEN(Zusammenfassung!O4)
27=INHALTE.EINFÜGEN(3)
28=AKTIVIEREN("Makro1")
29=AUSWÄHLEN(J19)
30=KOPIEREN()
31=AKTIVIEREN("Zusammenfassung")
32=AUSWÄHLEN(Zusammenfassung!O7)
33=INHALTE.EINFÜGEN(3)
34=RÜCKSPRUNG()
35
36Dez()
37=ECHO(FALSCH)
38=AUSWÄHLEN($J$11)
39=KOPIEREN()
40=AKTIVIEREN("Dezember")
41=AUSWÄHLEN(Dezember!C5)
42=INHALTE.EINFÜGEN(3)
43=RÜCKSPRUNG()
44
45Nov()
46=ECHO(FALSCH)
47=AUSWÄHLEN($J$11)
48=KOPIEREN()
49=AKTIVIEREN("November")
50=AUSWÄHLEN(November!C5)
51=INHALTE.EINFÜGEN(3)
52=AKTIVIEREN("Dezember")
53=AUSWÄHLEN(Dezember!C5)
54=INHALTE.EINFÜGEN(3)
55=RÜCKSPRUNG()
56
57Okt()
58=ECHO(FALSCH)
59=AUSWÄHLEN($J$11)
60=KOPIEREN()
61=AKTIVIEREN("Oktober")
62=AUSWÄHLEN(Oktober!$C$5)
63=INHALTE.EINFÜGEN(3)
64=AKTIVIEREN("November")
65=AUSWÄHLEN(November!$C$5)
66=INHALTE.EINFÜGEN(3)
67=AKTIVIEREN("Dezember")
68=AUSWÄHLEN(Dezember!$C$5)
69=INHALTE.EINFÜGEN(3)
70=RÜCKSPRUNG()
71
72Sep()
73=ECHO(FALSCH)
74=AUSWÄHLEN($J$11)
75=KOPIEREN()
76=AKTIVIEREN("September")
77=AUSWÄHLEN(September!$C$5)
78=INHALTE.EINFÜGEN(3)
79=AKTIVIEREN("Oktober")
80=AUSWÄHLEN(Oktober!$C$5)
81=INHALTE.EINFÜGEN(3)
82=AKTIVIEREN("November")
83=AUSWÄHLEN(November!$C$5)
84=INHALTE.EINFÜGEN(3)
85=AKTIVIEREN("Dezember")
86=AUSWÄHLEN(Dezember!$C$5)
87=INHALTE.EINFÜGEN(3)
88=RÜCKSPRUNG()
89
90Aug()
91=ECHO(FALSCH)
92=AUSWÄHLEN($J$11)
93=KOPIEREN()
94=AKTIVIEREN("August")
95=AUSWÄHLEN(August!$C$5)
96=INHALTE.EINFÜGEN(3)
97=AKTIVIEREN("September")
98=AUSWÄHLEN(September!$C$5)
99=INHALTE.EINFÜGEN(3)
100=AKTIVIEREN("Oktober")
101=AUSWÄHLEN(Oktober!$C$5)
102=INHALTE.EINFÜGEN(3)
103=AKTIVIEREN("November")
104=AUSWÄHLEN(November!$C$5)
105=INHALTE.EINFÜGEN(3)
106=AKTIVIEREN("Dezember")
107=AUSWÄHLEN(Dezember!$C$5)
108=INHALTE.EINFÜGEN(3)
109=RÜCKSPRUNG()
110

Formeln der Tabelle
ZelleFormel
A2=ECHO(FALSCH)
A3=AKTIVIEREN("Makro1")
A6=AUSWÄHLEN(J7)
A7=WENN(AKTIVE.ZELLE()=1;A8;A13)
A8=AUSWÄHLEN(J13)
A9=WENN(AKTIVE.ZELLE()=13;GEHEZU(Dez());GEHEZU(A10))
A10=WENN(AKTIVE.ZELLE()=12;GEHEZU(Nov());GEHEZU(A11))
A11=WENN(AKTIVE.ZELLE()="11";GEHEZU(Okt());GEHEZU(A12))
A12=WENN(AKTIVE.ZELLE()=10;GEHEZU(Sep());GEHEZU(A13))
A13=AUSWÄHLEN(J13)
A14=INHALTE.LÖSCHEN()
A15=WENN(DIALOGFELD(DiaStamm)=FALSCH;RÜCKSPRUNG())
A16=AKTIVIEREN("Makro1")
A17=AUSWÄHLEN(J11)
A18=KOPIEREN()
A19=AKTIVIEREN("Zusammenfassung")
A20=AUSWÄHLEN(Zusammenfassung!O3)
A21=INHALTE.EINFÜGEN(3)
A22=AKTIVIEREN("Makro1")
A23=AUSWÄHLEN(J16)
A24=KOPIEREN()
A25=AKTIVIEREN("Zusammenfassung")
A26=AUSWÄHLEN(Zusammenfassung!O4)
A27=INHALTE.EINFÜGEN(3)
A28=AKTIVIEREN("Makro1")
A29=AUSWÄHLEN(J19)
A30=KOPIEREN()
A31=AKTIVIEREN("Zusammenfassung")
A32=AUSWÄHLEN(Zusammenfassung!O7)
A33=INHALTE.EINFÜGEN(3)
A34=RÜCKSPRUNG()
A37=ECHO(FALSCH)
A38=AUSWÄHLEN($J$11)
A39=KOPIEREN()
A40=AKTIVIEREN("Dezember")
A41=AUSWÄHLEN(Dezember!C5)
A42=INHALTE.EINFÜGEN(3)
A43=RÜCKSPRUNG()
A46=ECHO(FALSCH)
A47=AUSWÄHLEN($J$11)
A48=KOPIEREN()
A49=AKTIVIEREN("November")
A50=AUSWÄHLEN(November!C5)
A51=INHALTE.EINFÜGEN(3)
A52=AKTIVIEREN("Dezember")
A53=AUSWÄHLEN(Dezember!C5)
A54=INHALTE.EINFÜGEN(3)
A55=RÜCKSPRUNG()
A58=ECHO(FALSCH)
A59=AUSWÄHLEN($J$11)
A60=KOPIEREN()
A61=AKTIVIEREN("Oktober")
A62=AUSWÄHLEN(Oktober!$C$5)
A63=INHALTE.EINFÜGEN(3)
A64=AKTIVIEREN("November")
A65=AUSWÄHLEN(November!$C$5)
A66=INHALTE.EINFÜGEN(3)
A67=AKTIVIEREN("Dezember")
A68=AUSWÄHLEN(Dezember!$C$5)
A69=INHALTE.EINFÜGEN(3)
A70=RÜCKSPRUNG()
A73=ECHO(FALSCH)
A74=AUSWÄHLEN($J$11)
A75=KOPIEREN()
A76=AKTIVIEREN("September")
A77=AUSWÄHLEN(September!$C$5)
A78=INHALTE.EINFÜGEN(3)
A79=AKTIVIEREN("Oktober")
A80=AUSWÄHLEN(Oktober!$C$5)
A81=INHALTE.EINFÜGEN(3)
A82=AKTIVIEREN("November")
A83=AUSWÄHLEN(November!$C$5)
A84=INHALTE.EINFÜGEN(3)
A85=AKTIVIEREN("Dezember")
A86=AUSWÄHLEN(Dezember!$C$5)
A87=INHALTE.EINFÜGEN(3)
A88=RÜCKSPRUNG()
A91=ECHO(FALSCH)
A92=AUSWÄHLEN($J$11)
A93=KOPIEREN()
A94=AKTIVIEREN("August")
A95=AUSWÄHLEN(August!$C$5)
A96=INHALTE.EINFÜGEN(3)
A97=AKTIVIEREN("September")
A98=AUSWÄHLEN(September!$C$5)
A99=INHALTE.EINFÜGEN(3)
A100=AKTIVIEREN("Oktober")
A101=AUSWÄHLEN(Oktober!$C$5)
A102=INHALTE.EINFÜGEN(3)
A103=AKTIVIEREN("November")
A104=AUSWÄHLEN(November!$C$5)
A105=INHALTE.EINFÜGEN(3)
A106=AKTIVIEREN("Dezember")
A107=AUSWÄHLEN(Dezember!$C$5)
A108=INHALTE.EINFÜGEN(3)
A109=RÜCKSPRUNG()

Excel Jeanie Html

_________________
Viele Grüsse, Pinsel63

Es gibt keinen Fortschritt ohne eine Bejahung des Bestehenden.
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
06. Dez 2010, 23:11
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände


AW: Makros mit Excel 4.0 (KEIN VBA) - AW: Makros mit Excel 4.0 (KEIN VBA)

Nach oben
       Version: Office 2003

Hallo

Das VBA-Forum ist nebenan.

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Pinsel63
VBA-Neuling


Verfasst am:
06. Dez 2010, 23:13
Rufname: Struppi
Wohnort: Görlitz

AW: Makros mit Excel 4.0 (KEIN VBA) - AW: Makros mit Excel 4.0 (KEIN VBA)

Nach oben
       Version: Office 2003

Es ist ja eben KEIN VBA.
_________________
Viele Grüsse, Pinsel63

Es gibt keinen Fortschritt ohne eine Bejahung des Bestehenden.
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
06. Dez 2010, 23:20
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände


AW: Makros mit Excel 4.0 (KEIN VBA) - AW: Makros mit Excel 4.0 (KEIN VBA)

Nach oben
       Version: Office 2003

Zitat:
Es ist ja eben KEIN VBA.

Das Forum heißt Excel VBA (Makros).
Untertitel Programmierung, VBA, Objektmodell, Makros.

Cool

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Wahrheitswert, wenn finden istzahl<>0 in mehreren Bere 6 MMue 695 17. Okt 2011, 19:53
MMue Wahrheitswert, wenn finden istzahl<>0 in mehreren Bere
Keine neuen Beiträge Excel Formeln: =SUMMEWENN(G4:G125;"<0";G4:G125+H4:H125)????? 8 flowergirl 198 24. Mai 2011, 21:51
flowergirl =SUMMEWENN(G4:G125;"<0";G4:G125+H4:H125)?????
Keine neuen Beiträge Excel Formeln: Zahl am nächsten an 0 14 Scotty7 1027 03. März 2011, 12:46
Scotty7 Zahl am nächsten an 0
Keine neuen Beiträge Excel Formeln: Formel Wenn <0 4 0815roy 183 13. Nov 2010, 12:59
Gast Formel Wenn <0
Keine neuen Beiträge Excel Formeln: Formelergebniss 0 wird von Excel nicht al 0 erkannt 6 BitteumHilfe 1638 01. Nov 2010, 07:18
Gast Formelergebniss 0 wird von Excel nicht al 0 erkannt
Keine neuen Beiträge Excel Formeln: 13 Spalten, wenn eine <>0 dann 1 5 biker3105 292 14. Sep 2010, 12:13
biker3105 13 Spalten, wenn eine <>0 dann 1
Keine neuen Beiträge Excel Formeln: negative werte (<0) immer als 0 darstellen 3 exel greenhorn 2736 07. Mai 2010, 12:24
exel greenhorn negative werte (<0) immer als 0 darstellen
Keine neuen Beiträge Excel Formeln: ANZAHL für jede x-te Zeile >0 6 Battman 805 07. Nov 2009, 14:26
Battman ANZAHL für jede x-te Zeile >0
Keine neuen Beiträge Excel Formeln: Zelleninhalt in 0,25 - Schritten runden 2 andersson 5296 03. Sep 2009, 14:47
andersson Zelleninhalt in 0,25 - Schritten runden
Keine neuen Beiträge Excel Formeln: Makros exportieren aus Excel 2003 2 Spitzmaus 2643 08. März 2009, 20:04
Sptizmaus Makros exportieren aus Excel 2003
Keine neuen Beiträge Excel Formeln: =WENN(E9>0;SUMME(C1;c(D9));0) oder sowas 2 Gast 504 02. Feb 2009, 16:49
neopa =WENN(E9>0;SUMME(C1;c(D9));0) oder sowas
Keine neuen Beiträge Excel Formeln: Formeln umschreiben für OOo 3.0 8 Eulanda 692 21. Jan 2009, 00:36
Eulanda Formeln umschreiben für OOo 3.0
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Expression Web