Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Monatslisten erstellen mit grauen Samstagen und Sonntagen
zurück: Suche dringends eine Excel- formel weiter: SVERWEIS und Co. Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
hasenstall
Absolut lernwillig


Verfasst am:
24. Jul 2005, 23:13
Rufname:
Wohnort: Taunusstein

Monatslisten erstellen mit grauen Samstagen und Sonntagen - Monatslisten erstellen mit grauen Samstagen und Sonntagen

Nach oben
       

Version 2002 und 2003
Hallo, ich muss des Öfteren Monatslisten erstellen. Ich mache das dann so, dass ich das erste Datum manuell eingebe und in die nächste Zeile eine Formel, sinngemäß Zelle über plus 1. Diese Formel kopiere ich mir dann nach Belieben Wenn ich dann eine andere Liste erstellen muss, brauche ich nur das erste Datum zu ändern, der Rest funktioniert automatisch.
Aber ich wil, dass die Zellen für die Samstage und Sonntage grau hinterlegt sind. Das kriege ich einfach nicht hin. Wer hat eine Idee?
Danke schon mal. Ich bin übrigens das erste Mal hier und bin mal gespannt.
Gruß Gabi
hasenstall
Absolut lernwillig


Verfasst am:
24. Jul 2005, 23:48
Rufname:
Wohnort: Taunusstein


AW: Monatslisten erstellen mit grauen Samstagen und Sonntage - AW: Monatslisten erstellen mit grauen Samstagen und Sonntage

Nach oben
       

Hallo, die Lösung gibts in diesem Forum bereits. Habe sie eben gefunden. Also könnt ihr meine Frage wieder rausnehmen.
Also ich finde das hier echt super. Was habe ich schon herumgedoktert mit diesem Problem und hier ist es wunderbar beschrieben.
Super
hasenstall
Absolut lernwillig


Verfasst am:
25. Jul 2005, 00:06
Rufname:
Wohnort: Taunusstein

AW: Monatslisten erstellen mit grauen Samstagen und Sonntage - AW: Monatslisten erstellen mit grauen Samstagen und Sonntage

Nach oben
       

Hallo, da bin ich schon wieder. Ich sollte erst genauer lesen. Mein Problem ist noch nicht ganz erledigt. Ich kann jetzt die Zellen mit den Datumsangaben einfärben. Das ist schon mal wunderbar, aber wie bekomme ich auch die leere Nachbarzelle farbig, wie das so bei Kalendern üblich ist?
Also brauch ich Euch Profis doch noch mal.
Tschüss und danke
Gruß Gabi
ae
Mein Name ist Ente


Verfasst am:
25. Jul 2005, 06:57
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Monatslisten erstellen mit grauen Samstagen und Sonntage - AW: Monatslisten erstellen mit grauen Samstagen und Sonntage

Nach oben
       

Hallo Gabi,
das liegt an der Art und Weise wie du markierst -

angenommen die Tage stehen in Spalte A - Du möchtest aber die Spalte A bis zB E markiert haben wenn es ein Wochenende ist -

In meine Beispiel war die Markierung von A1 bis E11 - dann Format bedingte Formatierung -
Achte dabei auf den gemischten Bezug !

Tabelle1
 ABCDE
101.07.2005    
202.07.2005    
303.07.2005    
404.07.2005    
505.07.2005    
606.07.2005    
707.07.2005    
808.07.2005    
909.07.2005    
1010.07.2005    
1111.07.2005    
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A11. / Formel ist =WOCHENTAG($A1)=7Abc
A12. / Formel ist =WOCHENTAG($A1)=1Abc
B11. / Formel ist =WOCHENTAG($A1)=7Abc
B12. / Formel ist =WOCHENTAG($A1)=1Abc
C11. / Formel ist =WOCHENTAG($A1)=7Abc
C12. / Formel ist =WOCHENTAG($A1)=1Abc
D11. / Formel ist =WOCHENTAG($A1)=7Abc
D12. / Formel ist =WOCHENTAG($A1)=1Abc
E11. / Formel ist =WOCHENTAG($A1)=7Abc
E12. / Formel ist =WOCHENTAG($A1)=1Abc
A21. / Formel ist =WOCHENTAG($A2)=7Abc
A22. / Formel ist =WOCHENTAG($A2)=1Abc
B21. / Formel ist =WOCHENTAG($A2)=7Abc
B22. / Formel ist =WOCHENTAG($A2)=1Abc
C21. / Formel ist =WOCHENTAG($A2)=7Abc
C22. / Formel ist =WOCHENTAG($A2)=1Abc
D21. / Formel ist =WOCHENTAG($A2)=7Abc
D22. / Formel ist =WOCHENTAG($A2)=1Abc
E21. / Formel ist =WOCHENTAG($A2)=7Abc
E22. / Formel ist =WOCHENTAG($A2)=1Abc
A31. / Formel ist =WOCHENTAG($A3)=7Abc
A32. / Formel ist =WOCHENTAG($A3)=1Abc
B31. / Formel ist =WOCHENTAG($A3)=7Abc
B32. / Formel ist =WOCHENTAG($A3)=1Abc
C31. / Formel ist =WOCHENTAG($A3)=7Abc
C32. / Formel ist =WOCHENTAG($A3)=1Abc
D31. / Formel ist =WOCHENTAG($A3)=7Abc
D32. / Formel ist =WOCHENTAG($A3)=1Abc
E31. / Formel ist =WOCHENTAG($A3)=7Abc
E32. / Formel ist =WOCHENTAG($A3)=1Abc
A41. / Formel ist =WOCHENTAG($A4)=7Abc
A42. / Formel ist =WOCHENTAG($A4)=1Abc
B41. / Formel ist =WOCHENTAG($A4)=7Abc
B42. / Formel ist =WOCHENTAG($A4)=1Abc
C41. / Formel ist =WOCHENTAG($A4)=7Abc
C42. / Formel ist =WOCHENTAG($A4)=1Abc
D41. / Formel ist =WOCHENTAG($A4)=7Abc
D42. / Formel ist =WOCHENTAG($A4)=1Abc
E41. / Formel ist =WOCHENTAG($A4)=7Abc
E42. / Formel ist =WOCHENTAG($A4)=1Abc
A51. / Formel ist =WOCHENTAG($A5)=7Abc
A52. / Formel ist =WOCHENTAG($A5)=1Abc
B51. / Formel ist =WOCHENTAG($A5)=7Abc
B52. / Formel ist =WOCHENTAG($A5)=1Abc
C51. / Formel ist =WOCHENTAG($A5)=7Abc
C52. / Formel ist =WOCHENTAG($A5)=1Abc
D51. / Formel ist =WOCHENTAG($A5)=7Abc
D52. / Formel ist =WOCHENTAG($A5)=1Abc
E51. / Formel ist =WOCHENTAG($A5)=7Abc
E52. / Formel ist =WOCHENTAG($A5)=1Abc
A61. / Formel ist =WOCHENTAG($A6)=7Abc
A62. / Formel ist =WOCHENTAG($A6)=1Abc
B61. / Formel ist =WOCHENTAG($A6)=7Abc
B62. / Formel ist =WOCHENTAG($A6)=1Abc
C61. / Formel ist =WOCHENTAG($A6)=7Abc
C62. / Formel ist =WOCHENTAG($A6)=1Abc
D61. / Formel ist =WOCHENTAG($A6)=7Abc
D62. / Formel ist =WOCHENTAG($A6)=1Abc
E61. / Formel ist =WOCHENTAG($A6)=7Abc
E62. / Formel ist =WOCHENTAG($A6)=1Abc
A71. / Formel ist =WOCHENTAG($A7)=7Abc
A72. / Formel ist =WOCHENTAG($A7)=1Abc
B71. / Formel ist =WOCHENTAG($A7)=7Abc
B72. / Formel ist =WOCHENTAG($A7)=1Abc
C71. / Formel ist =WOCHENTAG($A7)=7Abc
C72. / Formel ist =WOCHENTAG($A7)=1Abc
D71. / Formel ist =WOCHENTAG($A7)=7Abc
D72. / Formel ist =WOCHENTAG($A7)=1Abc
E71. / Formel ist =WOCHENTAG($A7)=7Abc
E72. / Formel ist =WOCHENTAG($A7)=1Abc
A81. / Formel ist =WOCHENTAG($A8)=7Abc
A82. / Formel ist =WOCHENTAG($A8)=1Abc
B81. / Formel ist =WOCHENTAG($A8)=7Abc
B82. / Formel ist =WOCHENTAG($A8)=1Abc
C81. / Formel ist =WOCHENTAG($A8)=7Abc
C82. / Formel ist =WOCHENTAG($A8)=1Abc
D81. / Formel ist =WOCHENTAG($A8)=7Abc
D82. / Formel ist =WOCHENTAG($A8)=1Abc
E81. / Formel ist =WOCHENTAG($A8)=7Abc
E82. / Formel ist =WOCHENTAG($A8)=1Abc
A91. / Formel ist =WOCHENTAG($A9)=7Abc
A92. / Formel ist =WOCHENTAG($A9)=1Abc
B91. / Formel ist =WOCHENTAG($A9)=7Abc
B92. / Formel ist =WOCHENTAG($A9)=1Abc
C91. / Formel ist =WOCHENTAG($A9)=7Abc
C92. / Formel ist =WOCHENTAG($A9)=1Abc
D91. / Formel ist =WOCHENTAG($A9)=7Abc
D92. / Formel ist =WOCHENTAG($A9)=1Abc
E91. / Formel ist =WOCHENTAG($A9)=7Abc
E92. / Formel ist =WOCHENTAG($A9)=1Abc
A101. / Formel ist =WOCHENTAG($A10)=7Abc
A102. / Formel ist =WOCHENTAG($A10)=1Abc
B101. / Formel ist =WOCHENTAG($A10)=7Abc
B102. / Formel ist =WOCHENTAG($A10)=1Abc
C101. / Formel ist =WOCHENTAG($A10)=7Abc
C102. / Formel ist =WOCHENTAG($A10)=1Abc
D101. / Formel ist =WOCHENTAG($A10)=7Abc
D102. / Formel ist =WOCHENTAG($A10)=1Abc
E101. / Formel ist =WOCHENTAG($A10)=7Abc
E102. / Formel ist =WOCHENTAG($A10)=1Abc
A111. / Formel ist =WOCHENTAG($A11)=7Abc
A112. / Formel ist =WOCHENTAG($A11)=1Abc
B111. / Formel ist =WOCHENTAG($A11)=7Abc
B112. / Formel ist =WOCHENTAG($A11)=1Abc
C111. / Formel ist =WOCHENTAG($A11)=7Abc
C112. / Formel ist =WOCHENTAG($A11)=1Abc
D111. / Formel ist =WOCHENTAG($A11)=7Abc
D112. / Formel ist =WOCHENTAG($A11)=1Abc
E111. / Formel ist =WOCHENTAG($A11)=7Abc
E112. / Formel ist =WOCHENTAG($A11)=1Abc
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
ae
Mein Name ist Ente


Verfasst am:
25. Jul 2005, 07:02
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Monatslisten erstellen mit grauen Samstagen und Sonntage - AW: Monatslisten erstellen mit grauen Samstagen und Sonntage

Nach oben
       

Hallo Gabi,
ergänzend wäre noch zu sagen in der Rubrik Tipps und Tricks findest eine Feiertagsdatei
Wenn Du diese in Deine Tabelle miteinbaust kannst auch die Feiertage gleich vorab so belegen bzw. hervorheben

Hier mal ein Auszug aus ner Datei die ich erstellt habe

Dezember
 AB
2422.12.2005 
2523.12.2005 
2624.12.2005Heilig Abend
2725.12.20051. Weihnachtstag
2826.12.20052. Weihnachtstag
2927.12.2005 
3028.12.2005 
Formeln der Tabelle
A24 : =WENN(A23="";"";WENN(MONAT(A23+1)=MONAT($A$1);A23+1;""))
B24 : =WENN(ISTFEHLER(SVERWEIS(A24;Feiertage!$A$2:$C$32;1;FALSCH));"";SVERWEIS(Dezember!A24;Feiertage!$A$2:$D$32;4;FALSCH))
A25 : =WENN(A24="";"";WENN(MONAT(A24+1)=MONAT($A$1);A24+1;""))
B25 : =WENN(ISTFEHLER(SVERWEIS(A25;Feiertage!$A$2:$C$32;1;FALSCH));"";SVERWEIS(Dezember!A25;Feiertage!$A$2:$D$32;4;FALSCH))
A26 : =WENN(A25="";"";WENN(MONAT(A25+1)=MONAT($A$1);A25+1;""))
B26 : =WENN(ISTFEHLER(SVERWEIS(A26;Feiertage!$A$2:$C$32;1;FALSCH));"";SVERWEIS(Dezember!A26;Feiertage!$A$2:$D$32;4;FALSCH))
A27 : =WENN(A26="";"";WENN(MONAT(A26+1)=MONAT($A$1);A26+1;""))
B27 : =WENN(ISTFEHLER(SVERWEIS(A27;Feiertage!$A$2:$C$32;1;FALSCH));"";SVERWEIS(Dezember!A27;Feiertage!$A$2:$D$32;4;FALSCH))
A28 : =WENN(A27="";"";WENN(MONAT(A27+1)=MONAT($A$1);A27+1;""))
B28 : =WENN(ISTFEHLER(SVERWEIS(A28;Feiertage!$A$2:$C$32;1;FALSCH));"";SVERWEIS(Dezember!A28;Feiertage!$A$2:$D$32;4;FALSCH))
A29 : =WENN(A28="";"";WENN(MONAT(A28+1)=MONAT($A$1);A28+1;""))
B29 : =WENN(ISTFEHLER(SVERWEIS(A29;Feiertage!$A$2:$C$32;1;FALSCH));"";SVERWEIS(Dezember!A29;Feiertage!$A$2:$D$32;4;FALSCH))
A30 : =WENN(A29="";"";WENN(MONAT(A29+1)=MONAT($A$1);A29+1;""))
B30 : =WENN(ISTFEHLER(SVERWEIS(A30;Feiertage!$A$2:$C$32;1;FALSCH));"";SVERWEIS(Dezember!A30;Feiertage!$A$2:$D$32;4;FALSCH))
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A241. / Formel ist =ODER(WOCHENTAG(A24)=1;WOCHENTAG(A24)=7)Abc
A242. / Formel ist =SVERWEIS(A24;feiertage;3;FALSCH)="x"Abc
B241. / Formel ist =ODER(WOCHENTAG(B24)=1;WOCHENTAG(B24)=7)Abc
B242. / Formel ist =SVERWEIS(B24;feiertage;3;FALSCH)="x"Abc
A251. / Formel ist =ODER(WOCHENTAG(A25)=1;WOCHENTAG(A25)=7)Abc
A252. / Formel ist =SVERWEIS(A25;feiertage;3;FALSCH)="x"Abc
B251. / Formel ist =ODER(WOCHENTAG(B25)=1;WOCHENTAG(B25)=7)Abc
B252. / Formel ist =SVERWEIS(B25;feiertage;3;FALSCH)="x"Abc
A261. / Formel ist =ODER(WOCHENTAG(A26)=1;WOCHENTAG(A26)=7)Abc
A262. / Formel ist =SVERWEIS(A26;feiertage;3;FALSCH)="x"Abc
B261. / Formel ist =ODER(WOCHENTAG(B26)=1;WOCHENTAG(B26)=7)Abc
B262. / Formel ist =SVERWEIS(B26;feiertage;3;FALSCH)="x"Abc
A271. / Formel ist =ODER(WOCHENTAG(A27)=1;WOCHENTAG(A27)=7)Abc
A272. / Formel ist =SVERWEIS(A27;feiertage;3;FALSCH)="x"Abc
B271. / Formel ist =ODER(WOCHENTAG(B27)=1;WOCHENTAG(B27)=7)Abc
B272. / Formel ist =SVERWEIS(B27;feiertage;3;FALSCH)="x"Abc
A281. / Formel ist =ODER(WOCHENTAG(A28)=1;WOCHENTAG(A28)=7)Abc
A282. / Formel ist =SVERWEIS(A28;feiertage;3;FALSCH)="x"Abc
B281. / Formel ist =ODER(WOCHENTAG(B28)=1;WOCHENTAG(B28)=7)Abc
B282. / Formel ist =SVERWEIS(B28;feiertage;3;FALSCH)="x"Abc
A291. / Formel ist =ODER(WOCHENTAG(A29)=1;WOCHENTAG(A29)=7)Abc
A292. / Formel ist =SVERWEIS(A29;feiertage;3;FALSCH)="x"Abc
B291. / Formel ist =ODER(WOCHENTAG(B29)=1;WOCHENTAG(B29)=7)Abc
B292. / Formel ist =SVERWEIS(B29;feiertage;3;FALSCH)="x"Abc
A301. / Formel ist =ODER(WOCHENTAG(A30)=1;WOCHENTAG(A30)=7)Abc
A302. / Formel ist =SVERWEIS(A30;feiertage;3;FALSCH)="x"Abc
B301. / Formel ist =ODER(WOCHENTAG(B30)=1;WOCHENTAG(B30)=7)Abc
B302. / Formel ist =SVERWEIS(B30;feiertage;3;FALSCH)="x"Abc
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
hasenstall
Absolut lernwillig


Verfasst am:
26. Jul 2005, 00:49
Rufname:
Wohnort: Taunusstein


AW: Monatslisten erstellen mit grauen Samstagen und Sonntage - AW: Monatslisten erstellen mit grauen Samstagen und Sonntage

Nach oben
       

Hallo Andreas,
ich habe es eben ausprobiert. Es hat geklappt. Endlich, weiß ich wie das geht !!!!!!!!!!!!!!!!!
Danke auch für den Tip mit der Feiertagsdatei.
Dieses Forum ist klasse. In die PC Go brauch ich jetzt nicht mehr zu schauen.
Lieben Gruß
Gabi
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Bowling Würfe erstellen 3 IanFleming 1007 23. Feb 2007, 01:16
fridgenep Bowling Würfe erstellen
Keine neuen Beiträge Excel Formeln: Liste erstellen ohne bestimmte Werte 6 st@ni 1947 20. Sep 2006, 13:53
st@ni Liste erstellen ohne bestimmte Werte
Keine neuen Beiträge Excel Formeln: Urlaubsplan erstellen 2 Nicole_77 8701 14. Sep 2006, 13:12
< Peter > Urlaubsplan erstellen
Keine neuen Beiträge Excel Formeln: Erstellen einer Auswertungstabelle für Fussballspiele 1 darkface 1438 08. Sep 2006, 20:32
Hübi Erstellen einer Auswertungstabelle für Fussballspiele
Keine neuen Beiträge Excel Formeln: automatisches x erstellen 4 MRBoy1998 703 08. Sep 2006, 14:48
ae automatisches x erstellen
Keine neuen Beiträge Excel Formeln: Diagramm erstellen, dass sich auf mehrere Blätter einer Date 1 annaringe 5667 04. Jul 2006, 15:00
Alto Diagramm erstellen, dass sich auf mehrere Blätter einer Date
Keine neuen Beiträge Excel Formeln: Rechnungsnummer aus Datum erstellen 1 konzZzumi 2725 02. Mai 2006, 15:54
< Peter > Rechnungsnummer aus Datum erstellen
Keine neuen Beiträge Excel Formeln: Brief/Fax erstellen... 4 sisqonrw 3041 22. Apr 2006, 13:41
sisqonrw Brief/Fax erstellen...
Keine neuen Beiträge Excel Formeln: Projektplan erstellen ohne Diagramm nutzen zu müssen 2 BK 14140 10. Apr 2006, 21:23
Gast Projektplan erstellen ohne Diagramm nutzen zu müssen
Keine neuen Beiträge Excel Formeln: Aus einer Rangliste eine geordnete rangliste erstellen 7 Tutzi76 16794 21. März 2006, 17:08
ae Aus einer Rangliste eine geordnete rangliste erstellen
Keine neuen Beiträge Excel Formeln: Mittels 2 Tabellen eine Übersicht erstellen 11 atwin97 1305 05. Okt 2005, 09:55
atwin97 Mittels 2 Tabellen eine Übersicht erstellen
Keine neuen Beiträge Excel Formeln: Bitte helft mir, es ist **Urlaubstabelle erstellen*** 5 Gast 3848 29. März 2005, 14:58
ae Bitte helft mir, es ist **Urlaubstabelle erstellen***
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Word VBA