Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Summe ohne doppelte Werte
zurück: Pflichtfelder weiter: Umgekehrte Reihenfolge Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
real-heinz
Excel-Versteher mit dünnen VBA-Kenntnissen


Verfasst am:
03. Mai 2011, 13:13
Rufname: Heinz

Summe ohne doppelte Werte - Summe ohne doppelte Werte

Nach oben
       Version: Office 2003

Hallo Forum,

folgendes -ansich recht unspektakuläres- Problem. Aber ich komme nicht weiter:

In einer kleinen Tabelle werden Werte im Bereich B1:B5 aufgrund der Eingabe im Bereich A1:A5 mittels SVERWEIS berechnet. Diese Werte in Spalte B sollen in B6 summiert werden, jedoch ohne doppelte Einträge. D.h. wenn im Bereich A1:A5 ein Eingabewert mehrfach vorkommt, soll der in Spalte B berechnete Wert nur einmal in die Summenbildung einfließen.

Habe schon mit HÄUFIGKEIT, VERGLEICH, WENN, SUMMEWENN und Verschachtelungen operiert - ohne Erfolg. Kann mir jemand helfen? Danke!
neopa
(kleingeschrieben!) oder Werner .. ,- ...


Verfasst am:
03. Mai 2011, 13:33
Rufname: Werner
Wohnort: zu Hause


AW: Summe ohne doppelte Werte - AW: Summe ohne doppelte Werte

Nach oben
       Version: Office 2003

Hallo Heinz,

so:
Code:
=SUMMENPRODUKT((VERGLEICH(A1:A5;A1:A5;)=ZEILE(1:5))*B1:B5)

_________________
Gruß Werner
.. , - ...
WF
nur Formeln - null VBA


Verfasst am:
03. Mai 2011, 13:34
Rufname: WF
Wohnort: Düsseldorf

Summe ohne Doppler: excelformeln.de - Summe ohne Doppler: excelformeln.de

Nach oben
       Version: Office 2003

siehe unsere:
http://www.excelformeln.de/formeln.html?welcher=64

Salut WF
WF
nur Formeln - null VBA


Verfasst am:
03. Mai 2011, 14:00
Rufname: WF
Wohnort: Düsseldorf

prima Variante - prima Variante

Nach oben
       Version: Office 2003

Hi Werner,

bei Leerzellen geht's aber in die Hose - dann:
{=SUMME((WENN(A1:A99="";0;VERGLEICH(A1:A99;A1:A99;))=ZEILE(1:99))*B1:B99)}

Oder hast Du da ne arrayfreie Lösung ?

WF
neopa
(kleingeschrieben!) oder Werner .. ,- ...


Verfasst am:
03. Mai 2011, 14:07
Rufname: Werner
Wohnort: zu Hause


AW: Summe ohne doppelte Werte - AW: Summe ohne doppelte Werte

Nach oben
       Version: Office 2003

Hallo Walter,

ich würde dann meine Formel ein klein wenig erweitern:

Code:
=SUMMENPRODUKT((VERGLEICH(""&A1:A99;""&A1:A99;)=ZEILE(1:99))*B1:B99)

oder analog mit {}:
Code:
{=SUMME((VERGLEICH(""&A1:A99;""&A1:A99;)=ZEILE(1:99))*B1:B99)}

_________________
Gruß Werner
.. , - ...
WF
nur Formeln - null VBA


Verfasst am:
03. Mai 2011, 14:22
Rufname: WF
Wohnort: Düsseldorf

sehr schön - sehr schön

Nach oben
       Version: Office 2003

hab ich bei uns gebracht siehe news:
http://www.excelformeln.de/news2.html

WF
neopa
(kleingeschrieben!) oder Werner .. ,- ...


Verfasst am:
03. Mai 2011, 14:29
Rufname: Werner
Wohnort: zu Hause

AW: Summe ohne doppelte Werte - AW: Summe ohne doppelte Werte

Nach oben
       Version: Office 2003

Hallo Walter,

hab soeben nochmal Dein Beispiel: http://www.excelformeln.de/formeln.html?welcher=64 nachgebaut und Deine Lösungsformel in E1 und meine alternativen Formelvorschläge in E2:E3 hier zusammengestellt:

 ABCDE
1AuftragVolumen Summe:17600
200011500 Summe:17600
300024000 Summe:17600
400011500   
500032700   
600043300   
700024000   
800056100   
900011500   
1000056100   
11     

Formeln der Tabelle
ZelleFormel
E1{=SUMME(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A1;;;ZEILE(1:99));A1:A99)=1;B1:B99))}
E2=SUMMENPRODUKT(N(VERGLEICH(""&A1:A99;""&A1:A99;)=ZEILE(1:99));B1:B99)
E3{=SUMME((VERGLEICH(""&A2:A99;""&A2:A99;)=ZEILE(1:98))*B2:B99)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Jeanie Html

_________________
Gruß Werner
.. , - ...
neopa
(kleingeschrieben!) oder Werner .. ,- ...


Verfasst am:
03. Mai 2011, 14:36
Rufname: Werner
Wohnort: zu Hause

AW: Summe ohne doppelte Werte - AW: Summe ohne doppelte Werte

Nach oben
       Version: Office 2003

Hallo Walter,

da haben sich unsere beiden Beiträge zeitlich etwas überschnitten. Du müsstest in excelformeln.de noch eine kleine Korrektur vornehmen, denn SUMMENPRODUKT() kann ja in der "*" Variante ja nicht mit Textwerten umgehen. Deshalb mein Vorschlag von vorhin mit der ";"-Variante.
Code:
=SUMMENPRODUKT(N(VERGLEICH(""&A1:A99;""&A1:A99;)=ZEILE(1:99));B1:B99)


Oder in der "*"-Variante dann alternativ so:
Code:
=SUMMENPRODUKT((VERGLEICH(""&A2:A99;""&A2:A99;)=ZEILE(1:98))*B2:B99)

_________________
Gruß Werner
.. , - ...
WF
nur Formeln - null VBA


Verfasst am:
03. Mai 2011, 14:45
Rufname: WF
Wohnort: Düsseldorf

hab ich übernommen - hab ich übernommen

Nach oben
       Version: Office 2003

Hi Werner,

und nur die erste Variante - die zweite ergibt Murks, wenn außer der Überschrift weiterer Text vorkommt.

Salut WF
neopa
(kleingeschrieben!) oder Werner .. ,- ...


Verfasst am:
03. Mai 2011, 14:53
Rufname: Werner
Wohnort: zu Hause

AW: Summe ohne doppelte Werte - AW: Summe ohne doppelte Werte

Nach oben
       Version: Office 2003

Hallo Walter,

das ist natürlich auch richtig, wobei ein solcher Fall ja sicherlich auch nur mehr theoretischer Natur wäre.

_________________
Gruß Werner
.. , - ...
real-heinz
Excel-Versteher mit dünnen VBA-Kenntnissen


Verfasst am:
03. Mai 2011, 15:45
Rufname: Heinz

Nun ja - Nun ja

Nach oben
       Version: Office 2003

... vielen herzlichen Dank von mir schonmal für diese Lösungen. Das referenzierte Beispiel ist ja auch im Grunde genau das, was ich suche. Anscheinend aber doch nicht ganz so einfach wie gedacht.. ? Funktionieren auch alle grundsätzlich. Was mir aufgefallen ist:

1) Nur beim Benutzen von BEREICH.VERSCHIEBEN wird in Spalte A eine leere Zelle ignoriert; die beiden anderen Varianten rechnen erst wieder richtig, wenn der Wert in Spalte B auch fehlt. Aber das ist für mich kein Problem, da Spalte B sich bei mir mit SVERWEIS aus Kriterium Spalte A befüllt und so bei leerer Zelle in A ohnehin leer bleibt

Aber:
2) Nachdem ich die Zellbezüge angepasst habe (bei mir stehen die Kriterien-Werte in A82 bis A101 und summiert werden die Werte in D82 bis D101) ergeben alle Formeln (gleich ob als Matrix oder nicht) = 0 Rolling Eyes

Und Text kommt bei mir gar nicht vor...

Dat jibbet doch nich - So stehe ich nun vor einem Rätsel
WF
nur Formeln - null VBA


Verfasst am:
03. Mai 2011, 15:52
Rufname: WF
Wohnort: Düsseldorf

"theoretischer Natur" versus Praxis - "theoretischer Natur" versus Praxis

Nach oben
       Version: Office 2003

Hi Werner,

unsere Seite wird an Arbeitstagen ca. 5.500 bis 6.000 mal aufgerufen.
Da sitzt dann die Chefsekretärin Heidi Müller, die von Excel so viel Ahnung hat, wie ich vom Häkeln.
Der ist natürlich absolut klar, dass sie den Bereichsanfang auf A3 bis ?? erhöhen muss, wenn die Überschrift 2 Zeilen umfasst. Dass ZEILE weiterhin mit 1 beginnt, weiß sie sowieso.

WF
WF
nur Formeln - null VBA


Verfasst am:
03. Mai 2011, 16:02
Rufname: WF
Wohnort: Düsseldorf

ZEILE ist ein Zähler - ZEILE ist ein Zähler

Nach oben
       Version: Office 2003

Hi,

und MUSS mit 1 beginnen !
=SUMMENPRODUKT(1*(VERGLEICH(""&D82:D101;""&D82:D101;)=ZEILE(1:20));E82:E101)

Salut WF
real-heinz
Excel-Versteher mit dünnen VBA-Kenntnissen


Verfasst am:
03. Mai 2011, 16:53
Rufname: Heinz


AW: Summe ohne doppelte Werte - AW: Summe ohne doppelte Werte

Nach oben
       Version: Office 2003

Vielen Dank!
Bereiche an Überschriften anpassen ist schon klar; der entscheidende Hinweis war, dass ZEILE ein Zähler ist. Das wusste ich nicht.

Ich löse soetwas normalerweise mit ner Schleife in VBA, nur ging das hier aus div. Gründen an der Arbeitsmappe nicht. Aber das kann ja auch ne Formel... Nur ich nicht... Manchmal sieht man eben den Wald vor lauter Bäumen nicht

Aber jetzt ist alles gut.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: =summe mit runden kombinieren 4 daniel 1655 15. Feb 2005, 15:36
Daniel =summe mit runden kombinieren
Keine neuen Beiträge Excel Formeln: Doppelte Daten entfernen 1 Sabine1980 2206 08. Feb 2005, 18:19
Thomas Ramel Doppelte Daten entfernen
Keine neuen Beiträge Excel Formeln: Summe in Spalte 2 Tiroler 724 28. Jan 2005, 18:12
Tiroler Summe in Spalte
Keine neuen Beiträge Excel Formeln: Vergleichen 2 Tabellen mit ausgabe der fehlenden werte 1 Julie 2923 25. Jan 2005, 16:53
fridgenep Vergleichen 2 Tabellen mit ausgabe der fehlenden werte
Keine neuen Beiträge Excel Formeln: Werte aus Projekttabelle 1 automatisch in Tabelle 2 + 3 ? 7 DerDoktor 3771 15. Jan 2005, 14:41
DerDoktor Werte aus Projekttabelle 1 automatisch in Tabelle 2 + 3 ?
Keine neuen Beiträge Excel Formeln: Will Werte addieren, in Bezug zu zwei anderen Spalten 3 Hardy_K_888 1971 02. Dez 2004, 12:00
ae Will Werte addieren, in Bezug zu zwei anderen Spalten
Keine neuen Beiträge Excel Formeln: Werte aus 3 Spalten nebeneinander in 1 Spalte 2 Aloha 2697 02. Nov 2004, 23:31
Gast Werte aus 3 Spalten nebeneinander in 1 Spalte
Keine neuen Beiträge Excel Formeln: Koennte ein Sverweis sein *{=SUMME((MONAT(A1:A7)=E1)*(C1:C7) 2 Gast 1362 25. Okt 2004, 20:15
Gast Koennte ein Sverweis sein *{=SUMME((MONAT(A1:A7)=E1)*(C1:C7)
Keine neuen Beiträge Excel Formeln: Werte aus Liste mit Validation in Zelle 1 Gast 2516 18. Okt 2004, 15:20
icke Werte aus Liste mit Validation in Zelle
Keine neuen Beiträge Excel Formeln: Werte in Zellen?!? 3 Kiamolo 2818 18. Okt 2004, 10:01
Kiamolo Werte in Zellen?!?
Keine neuen Beiträge Excel Formeln: Uhrzeiten adieren und je nach Summe Pausen abziehen 6 Zokanta 2437 30. Sep 2004, 11:48
Zokanta Uhrzeiten adieren und je nach Summe Pausen abziehen
Keine neuen Beiträge Excel Formeln: Trendlinie soll 0 Werte nicht beachten 3 Suchender 1866 05. Aug 2004, 13:23
icke Trendlinie soll 0 Werte nicht beachten
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft-Excel Diagramme