Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Werte auslesen und getrennt darstellen (oder so) ??
zurück: dynamischer Datenbankbereich weiter: Quadratsumme ?? Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Gast



Verfasst am:
19. Aug 2005, 15:48
Rufname:

Werte auslesen und getrennt darstellen (oder so) ?? - Werte auslesen und getrennt darstellen (oder so) ??

Nach oben
       

Hallo Excelgemeinde,

ich muß für folgendes Problem eine Lösung finden:

Ich habe die Spalten B und C, G und H , L und M, sowie Zeilen 7 bis 38. In denen stehen die unten teilweise abgebildeten Daten. Nun will ich das mir ein Makro oder eine Formel den prozentualen Durchschnittswert der DG 1 sowie der DG 2 usw. bis DG 5 als jeweils einzelnen Wert darstellt. Dieser Wert jeder DG soll dann in eine Extra Zelle geschrieben werden und gleichzeitig eine Ampel steuern (Ampel hab ich schon). Nun habe ich schon selbst versucht das zu erstellen, bin jedoch mit Formeln bzw. Makro aufzeichnen nicht weiter gekommen. Es kam nicht mal annähernd was verwertbares raus.

B C
DG Früh
4 79,77%
4 71,16%
2 70,32%
2 66,31%
2 70,36%
4 72,17%
4 77,56%
3 55,22%
3 51,31%
1 57,10%
1 65,38%
1 70,18%
3 84,25%
3 80,20%
2 68,69%
2 70,82%
5 50,86%
5 78,58%
(Mist, ich kriege die Darstellung der Daten nicht besser hin)

Bitte heft mir bei meinem Problem, bin für jeden Lösungsansatz dankbar.

Danke, und


bis denne


Inge
Inge
ewiger Neuling


Verfasst am:
19. Aug 2005, 15:50
Rufname:


AW: Werte auslesen und getrennt darstellen (oder so) ?? - AW: Werte auslesen und getrennt darstellen (oder so) ??

Nach oben
       

Entschuldigung, hatte vergessen mich einzuloggen Confused



Bis denne


Inge
fridgenep
Gast


Verfasst am:
19. Aug 2005, 15:56
Rufname:

AW: Werte auslesen und getrennt darstellen (oder so) ?? - AW: Werte auslesen und getrennt darstellen (oder so) ??

Nach oben
       

Hallo Inge,

Hier die Auswertung für DG -"1",

entsprechend anpassen:

Code:
=SUMMENPRODUKT((A2:A30=1)*(B2:B30))/ZÄHLENWENN(A2:A30;1)
rainberg
Excel-Anwender


Verfasst am:
19. Aug 2005, 16:08
Rufname:

AW: Werte auslesen und getrennt darstellen (oder so) ?? - AW: Werte auslesen und getrennt darstellen (oder so) ??

Nach oben
       

Hallo Inge,

oder direkt mit der Funktion MITTELWERT()

Tabelle1
 ABCDE
1DGFrüh Auswertung 
2479,77% 164,22%
3471,16% 269,30%
4270,32% 367,75%
5266,31% 475,17%
6270,36% 564,72%
7472,17%   
8477,56%   
9355,22%   
10351,31%   
11157,10%   
12165,38%   
13170,18%   
14384,25%   
15380,20%   
16268,69%   
17270,82%   
18550,86%   
19578,58%   
Formeln der Tabelle
E2 : {=MITTELWERT(WENN(A$2:A$19=D2;$B$2:$B$19))}
E3 : {=MITTELWERT(WENN(A$2:A$19=D3;$B$2:$B$19))}
E4 : {=MITTELWERT(WENN(A$2:A$19=D4;$B$2:$B$19))}
E5 : {=MITTELWERT(WENN(A$2:A$19=D5;$B$2:$B$19))}
E6 : {=MITTELWERT(WENN(A$2:A$19=D6;$B$2:$B$19))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Inge
ewiger Neuling


Verfasst am:
19. Aug 2005, 16:12
Rufname:


AW: Werte auslesen und getrennt darstellen (oder so) ?? - AW: Werte auslesen und getrennt darstellen (oder so) ??

Nach oben
       

Hallo fridgenep,

habe die Spalten angepasst und es funktioniert erst mal. Ich muß die DG 1 jedoch in den Spalten B, G und L suchen und aus den dazugehörenden Prozentzahlen der Spalte C, H und M den Wert ermitteln.
Das schaffe ich nicht Confused Question Question


Danke soweit erst mal und


bis denne


Inge
fridgenep
Gast


Verfasst am:
19. Aug 2005, 16:19
Rufname:

AW: Werte auslesen und getrennt darstellen (oder so) ?? - AW: Werte auslesen und getrennt darstellen (oder so) ??

Nach oben
       

Hallo Inge,

dann so:

Code:
=(SUMMENPRODUKT((B2:B30=1)*(C2:C30))+SUMMENPRODUKT((G2:G30=1)*(H2:H30))+SUMMENPRODUKT((L2:L30=1)*(M2:M30)))/(ZÄHLENWENN(L2:L30;1)+ZÄHLENWENN(B2:B30;1)+ZÄHLENWENN(G2:G30;1))
Gast



Verfasst am:
19. Aug 2005, 16:27
Rufname:

AW: Werte auslesen und getrennt darstellen (oder so) ?? - AW: Werte auslesen und getrennt darstellen (oder so) ??

Nach oben
       

Danke für die schnelle Hilfe,

ich habe mich für die Formel von fridgenep entschieden. Hab sie angepasst und sie funktioniert.


Also dann

DANKE und bis denne


Inge Very Happy Very Happy
rainberg
Excel-Anwender


Verfasst am:
19. Aug 2005, 17:12
Rufname:

AW: Werte auslesen und getrennt darstellen (oder so) ?? - AW: Werte auslesen und getrennt darstellen (oder so) ??

Nach oben
       

Hallo Inge & fridgenep,

habe das Ganze mal mit Mittelwert nachvollzogen und dabei die Formel von fridgenep an die tatsächlichen Zeilenanzahl angepasst.
Fragt mich nicht warum, aber in einem Falle rechnet diese Formel falsch.
In H21 der Beweis.

Tabelle1
 BCDEFGHIJKLM
2479,77%   480,77%   481,77%
3471,16%   472,16%   473,16%
4270,32%   271,32%   272,32%
5266,31%   267,31%   268,31%
6270,36%   271,36%   272,36%
7472,17%   473,17%   474,17%
8477,56%   478,56%   479,56%
9355,22%   356,22%   357,22%
10351,31%   352,31%   353,31%
11157,10%   158,10%   159,10%
12165,38%   166,38%   167,38%
13170,18%   171,18%   172,18%
14384,25%   385,25%   386,25%
15380,20%   381,20%   382,20%
16268,69%   269,69%   270,69%
17270,82%   271,82%   272,82%
18550,86%   551,86%   552,86%
19578,58%   579,58%   580,58%
20            
21165,22%65,22%   76,17%     
22270,30%70,30%         
23368,75%68,75%         
24476,17%75,87%         
25565,72%65,72%         
Formeln der Tabelle
C21 : {=(MITTELWERT(WENN(B$2:B$19=B21;C$2:C$19))+MITTELWERT(WENN(G$2:G$19=B21;H$2:H$19))+MITTELWERT(WENN(L$2:L$19=B21;M$2:M$19)))/3}
D21 : =(SUMMENPRODUKT((B2:B19=B21)*(C2:C19))+SUMMENPRODUKT((G2:G19=B21)*(H2:H19))+SUMMENPRODUKT((L2:L19=B21)*(M2:M19)))/(ZÄHLENWENN(L2:L19;B21)+ZÄHLENWENN(B2:B19;B21)+ZÄHLENWENN(G2:G19;B21))
H21 : =MITTELWERT(C2:C3;C7:C8;H2:H3;H7:H8;M2:M3;M7:M8)

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 

Wo liegt hier der Fehler ???
Arnim
Im Profil kannst Du frei den Rang ändern


Verfasst am:
19. Aug 2005, 17:49
Rufname:

AW: Werte auslesen und getrennt darstellen (oder so) ?? - AW: Werte auslesen und getrennt darstellen (oder so) ??

Nach oben
       

Hallo Rainer,
wenn die Zellbezüge in fridgenep's Formel absolut gesetzt werden, klappt es! Smile

=(SUMMENPRODUKT((B$2:B$19=B21)*(C$2:C$19))+SUMMENPRODUKT((G$2:G$19=B21)*(H$2:H$19))+SUMMENPRODUKT((L$2:L$19=B21)*(M$2:M$19)))/(ZÄHLENWENN(L$2:L$19;B21)+ZÄHLENWENN(B$2:B$19;B21)+ZÄHLENWENN(G$2:G$19;B21))

Gruß Arnim
rainberg
Excel-Anwender


Verfasst am:
19. Aug 2005, 18:00
Rufname:


AW: Werte auslesen und getrennt darstellen (oder so) ?? - AW: Werte auslesen und getrennt darstellen (oder so) ??

Nach oben
       

Hallo Arnim,

danke.

@alle Anderen
bitte nicht mitlesen, vergesst was ich geschrieben habe, vielleicht war es doch etwas warm. Evil or Very Mad

Gruß
Rainer
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Datum in Excel Tabelle in Tagen darstellen 2 Unregistered 5101 22. März 2005, 20:49
Gast Datum in Excel Tabelle in Tagen darstellen
Keine neuen Beiträge Excel Formeln: Max/Min Werte Excel 2000 Formel/Tipp 5 Unregister 6687 11. März 2005, 19:37
rainberg Max/Min Werte Excel 2000 Formel/Tipp
Keine neuen Beiträge Excel Formeln: Rahmendienstplan auslesen 2 KHJakobs 2434 10. März 2005, 12:16
KHJakobs Rahmendienstplan auslesen
Keine neuen Beiträge Excel Formeln: Werte aus einer Tabelle nach mehreren Kriterien auswerten 3 Daniel 2901 07. März 2005, 14:15
Hübi Werte aus einer Tabelle nach mehreren Kriterien auswerten
Keine neuen Beiträge Excel Formeln: Leerzeichen in Formel darstellen 2 Toxic 1342 17. Feb 2005, 23:25
Toxic Leerzeichen in Formel darstellen
Keine neuen Beiträge Excel Formeln: Doppelte Werte 1 inu 1566 11. Feb 2005, 18:01
fl618 Doppelte Werte
Keine neuen Beiträge Excel Formeln: Zahlen Werte übertragen in eine neue Mappe ? 4 Haschi 2160 03. Feb 2005, 13:45
Haschi Zahlen Werte übertragen in eine neue Mappe ?
Keine neuen Beiträge Excel Formeln: größten wert auslesen und woanders um 50 erhöhen 1 GE 1220 20. Dez 2004, 12:51
icke größten wert auslesen und woanders um 50 erhöhen
Keine neuen Beiträge Excel Formeln: Zählen, so dass doppelte Werte nur einmal gezählt werden 2 Volkmann 2258 30. Nov 2004, 17:18
Volkmann Zählen, so dass doppelte Werte nur einmal gezählt werden
Keine neuen Beiträge Excel Formeln: Werte aus Tabelle zurückgebn 1 Spoonler 2266 22. Nov 2004, 15:54
ae Werte aus Tabelle zurückgebn
Keine neuen Beiträge Excel Formeln: Werte vergleichen 4 hoerbi 2971 10. Nov 2004, 20:45
hoerbi Werte vergleichen
Keine neuen Beiträge Excel Formeln: Projektkosten übersichtlich im Monatsauflauf darstellen 3 Miri 1817 24. Aug 2004, 10:40
Thomas Ramel Projektkosten übersichtlich im Monatsauflauf darstellen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Expression Web Forum