Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Kalender mit Formel(n) herstellen
Gehe zu Seite Zurück  1, 2, 3  Weiter
zurück: Aufteilung in Führerscheinklassen weiter: 2 Spalten zusammenfassen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
dive-instr
Im Profil kannst Du frei den Rang ändern


Verfasst am:
17. Jul 2013, 23:00
Rufname:

AW: Kalender mit Formel(n) herstellen - AW: Kalender mit Formel(n) herstellen

Nach oben
       Version: Office 2010

Eich will nicht die Daten alle untereinander haben, sondern die Wochentage.
Wochentage sind Montag, Dienstag, Mittwoch, Donnerstag, freitag, Samstag und Sonntag
hiob
armer wissbegieriger user


Verfasst am:
17. Jul 2013, 23:09
Rufname: losmo


Re: AW: Kalender mit Formel(n) herstellen - Re: AW: Kalender mit Formel(n) herstellen

Nach oben
       Version: Office 2010

dive-instr - 17. Jul 2013, 23:00 hat folgendes geschrieben:
... ich will nicht die Daten alle untereinander haben, sondern die Wochentage.
Wochentage sind Montag, Dienstag, Mittwoch, Donnerstag, freitag, Samstag und Sonntag


dive-instr - 17. Jul 2013, 22:30 hat folgendes geschrieben:
danke für die Antwort.
...
Ich will ..., dass die Tabelle folgendermassen auschaut:
A1: 2014 (Jahr)
A3: Mo, B3 Di, C3:Mi, D3:Do, E3:Fr: F3:Sa; G3:So
....
Alles Klar?


hi, du solltest wirklich ein beispiel posten weil: A3, B3, C3, D3, F3 und G3 sind nebeneinander

_________________
hiobs botschaft gespickt mit
halbgarem hintergrundwissen
dive-instr
Im Profil kannst Du frei den Rang ändern


Verfasst am:
18. Jul 2013, 07:07
Rufname:

AW: Kalender mit Formel(n) herstellen - AW: Kalender mit Formel(n) herstellen

Nach oben
       Version: Office 2010

Hallo zusammen
Hier nun die Datei

Hoffe, das hilft, dass mein Deutsch verstanden wird Wink

Beim Januar habe ich alle Zellen sichtbar
Beim Februar sind die Zellen ausgeblendet, damit man einen Eindruck erhält, wie das am Schluss ausschauen soll.

Wenn ich nun bei der Monatsübersicht das Jahr wechseln will, soll es alle Monate anpassen. Die Jahresübersicht funktioniert ja schon, die wird dann auch gleich angepasst....



Agenda 2014.zip
 Beschreibung:

Download
 Dateiname:  Agenda 2014.zip
 Dateigröße:  21.79 KB
 Heruntergeladen:  12 mal


Agenda 2014.zip
 Beschreibung:

Download
 Dateiname:  Agenda 2014.zip
 Dateigröße:  21.79 KB
 Heruntergeladen:  11 mal

Runo
Excel-Durchschnitt (wenig VBA)


Verfasst am:
18. Jul 2013, 08:28
Rufname: Andreas
Wohnort: Lohr a. Main

AW: Kalender mit Formel(n) herstellen - AW: Kalender mit Formel(n) herstellen

Nach oben
       Version: Office 2010

Hi dive-instr,

könntest du analog der Jahresübersicht aufbauen:

Monatsübersicht

 ABCDEFGH
12013       
2JANUAR       
31111111Monat
4MoDiMiDoFrSaSoWochentag
5 010203040506Tag Datum
9        
101111111 
11MoDiMiDoFrSaSo 
1207080910111213 
13        

Formeln der Tabelle
ZelleFormel
A5=WENN(WOCHENTAG("1.1."&$A$1;2)=SPALTE(A:A);"1.1."&$A$1;"")
B5=WENN(A5<>"";A5+1;WENN(WOCHENTAG("1.1."&$A$1;2)=SPALTE(B:B);WERT("1.1."&$A$1);""))
C5=WENN(B5<>"";B5+1;WENN(WOCHENTAG("1.1."&$A$1;2)=SPALTE(C:C);WERT("1.1."&$A$1);""))
D5=WENN(C5<>"";C5+1;WENN(WOCHENTAG("1.1."&$A$1;2)=SPALTE(DVery Happy);WERT("1.1."&$A$1);""))
E5=WENN(D5<>"";D5+1;WENN(WOCHENTAG("1.1."&$A$1;2)=SPALTE(E:E);WERT("1.1."&$A$1);""))
F5=WENN(E5<>"";E5+1;WENN(WOCHENTAG("1.1."&$A$1;2)=SPALTE(F:F);WERT("1.1."&$A$1);""))
G5=WENN(F5<>"";F5+1;WENN(WOCHENTAG("1.1."&$A$1;2)=SPALTE(G:G);WERT("1.1."&$A$1);""))


Monatsübersicht

 ABCDEFG
1207080910111213

Formeln der Tabelle
ZelleFormel
A12=G5+1
B12=A12+1
C12=B12+1
D12=C12+1
E12=D12+1
F12=E12+1
G12=F12+1


Excel Jeanie Html

Format der Tageszellen: TT

mfg Andreas

_________________
Office 2002/2010
Wenn du einem anderen den Berg hinaufhilfst, besteigst du ihn gleichzeitig selbst.
hiob
armer wissbegieriger user


Verfasst am:
18. Jul 2013, 10:10
Rufname: losmo


AW: Kalender mit Formel(n) herstellen - AW: Kalender mit Formel(n) herstellen

Nach oben
       Version: Office 2010

hi, anhand deiner vorgabe könnte man das so lösen..:

Arbeitsblatt mit dem Namen 'Monatsübersicht'
 ABCDEFG
12013
2Januar
31111111
4MoDiMiDoFrSaSo
5 010203040506
6       
7       
8       
9       
101111111
11MoDiMiDoFrSaSo
1207080910111213
13       
14       
15       
16       
171111111
18MoDiMiDoFrSaSo
1914151617181920
20       
21       
22       
23       
241111111
25MoDiMiDoFrSaSo
2621222324252627
27       
28       
29       
30       
311111111
32MoDiMiDoFrSaSo
3328293031   
34       
35       
36       
37       
381111111
39       
40       
41       
42       
43       
44       

ZelleFormel
A2=DATUM(A1;A3;1)
B3=A3
C3=B3
D3=C3
E3=D3
F3=E3
G3=F3
A5=WENN(WOCHENTAG($A$2;2)=SPALTE(A$1);$A$2;"")
B5=WENN(A5<>"";A5+1;WENN(WOCHENTAG($A$2;2)=SPALTE(B$1);$A$2;""))
C5=WENN(B5<>"";B5+1;WENN(WOCHENTAG($A$2;2)=SPALTE(C$1);$A$2;""))
D5=WENN(C5<>"";C5+1;WENN(WOCHENTAG($A$2;2)=SPALTE(D$1);$A$2;""))
E5=WENN(D5<>"";D5+1;WENN(WOCHENTAG($A$2;2)=SPALTE(E$1);$A$2;""))
F5=WENN(E5<>"";E5+1;WENN(WOCHENTAG($A$2;2)=SPALTE(F$1);$A$2;""))
G5=WENN(F5<>"";F5+1;WENN(WOCHENTAG($A$2;2)=SPALTE(G$1);$A$2;""))
A10=A3
B10=A10
C10=B10
D10=C10
E10=D10
F10=E10
G10=F10
A12=MAX(A5:G5)+1
B12=A12+1
C12=B12+1
D12=C12+1
E12=D12+1
F12=E12+1
G12=F12+1
A17=A10
B17=A17
C17=B17
D17=C17
E17=D17
F17=E17
G17=F17
A19=MAX(A12:G12)+1
B19=A19+1
C19=B19+1
D19=C19+1
E19=D19+1
F19=E19+1
G19=F19+1
A24=A17
B24=A24
C24=B24
D24=C24
E24=D24
F24=E24
G24=F24
A26=MAX(A19:G19)+1
B26=A26+1
C26=B26+1
D26=C26+1
E26=D26+1
F26=E26+1
G26=F26+1
A31=A24
B31=A31
C31=B31
D31=C31
E31=D31
F31=E31
G31=F31
A33=WENN(G26="";"";WENN(MONAT(G26+1)=MONAT(G26);G26+1;""))
B33=WENN(A33="";"";WENN(MONAT(A33+1)=MONAT(A33);A33+1;""))
C33=WENN(B33="";"";WENN(MONAT(B33+1)=MONAT(B33);B33+1;""))
D33=WENN(C33="";"";WENN(MONAT(C33+1)=MONAT(C33);C33+1;""))
E33=WENN(D33="";"";WENN(MONAT(D33+1)=MONAT(D33);D33+1;""))
F33=WENN(E33="";"";WENN(MONAT(E33+1)=MONAT(E33);E33+1;""))
G33=WENN(F33="";"";WENN(MONAT(F33+1)=MONAT(F33);F33+1;""))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

_________________
hiobs botschaft gespickt mit
halbgarem hintergrundwissen
dive-instr
Im Profil kannst Du frei den Rang ändern


Verfasst am:
19. Jul 2013, 16:06
Rufname:

AW: Kalender mit Formel(n) herstellen - AW: Kalender mit Formel(n) herstellen

Nach oben
       Version: Office 2010

Hiob,!!!! Du bist mein Gott!!!

Danke Dir herzlich, das ist nun genau das, was mir einige Abende Kopfzerbrechen gemacht hat.
Danke!
Hajo_Zi
unerwünschte Person


Verfasst am:
21. Jul 2013, 14:27
Rufname:
Wohnort: Straubing

Re: AW: Kalender mit Formel(n) herstellen - Re: AW: Kalender mit Formel(n) herstellen

Nach oben
       Version: Office 2010

silex1 - 17. Jul 2013, 22:34 hat folgendes geschrieben:
Hallo Detlef,

...war ein Scherz! Wink

Auch die Seite von Beverly ist super
http://excel-inn.de/

...jedoch sind es leider Dissidenten...aber trotzallem...ihre hilfreichen Seiten haben sie jedem zur Verfügung gestellt, ebenso kostenfrei wie dieses Forum es tut. Wink

https://de.wikipedia.org/wiki/Dissident
Der Begriff Dissident (vom lateinischen dissidere für „nicht übereinstimmen“, „getrennt sein“ oder „widersprechen“) oder Systemkritiker bezeichnet einen Andersdenkenden, der seine von der Regierungslinie oder -politik abweichende Meinung öffentlich ausspricht.

Du hast wohl mit Deiner Feststellung in Bezug auf meine Person Recht. Ich wurde vom Forumsbetreiber aufgefordert, nicht mehr zu schreiben.

Gruß Hajo
hiob
armer wissbegieriger user


Verfasst am:
21. Jul 2013, 21:29
Rufname: losmo

Re: AW: Kalender mit Formel(n) herstellen - Re: AW: Kalender mit Formel(n) herstellen

Nach oben
       Version: Office 2010

Hajo_Zi - 21. Jul 2013, 14:27 hat folgendes geschrieben:
silex1 - 17. Jul 2013, 22:34 hat folgendes geschrieben:
Hallo Detlef,

...war ein Scherz! Wink

Auch die Seite von Beverly ist super
http://excel-inn.de/

...jedoch sind es leider Dissidenten...aber trotzallem...ihre hilfreichen Seiten haben sie jedem zur Verfügung gestellt, ebenso kostenfrei wie dieses Forum es tut. Wink

https://de.wikipedia.org/wiki/Dissident
Der Begriff Dissident (vom lateinischen dissidere für „nicht übereinstimmen“, „getrennt sein“ oder „widersprechen“) oder Systemkritiker bezeichnet einen Andersdenkenden, der seine von der Regierungslinie oder -politik abweichende Meinung öffentlich ausspricht.

Du hast wohl mit Deiner Feststellung in Bezug auf meine Person Recht. Ich wurde vom Forumsbetreiber aufgefordert, nicht mehr zu schreiben.

Gruß Hajo


und warum jetzt des..?

_________________
hiobs botschaft gespickt mit
halbgarem hintergrundwissen
schauan
Excel-Kenner+VBA


Verfasst am:
21. Jul 2013, 22:10
Rufname:

AW: Kalender mit Formel(n) herstellen - AW: Kalender mit Formel(n) herstellen

Nach oben
       Version: Office 2010

Hallo,

schaue mal hier:
http://www.xltips.de/Downloads/Kalenderfrei2.zip

_________________
Grüße, SchauAn
Excel 97 - 2013
hiob
armer wissbegieriger user


Verfasst am:
21. Jul 2013, 23:04
Rufname: losmo

Re: AW: Kalender mit Formel(n) herstellen - Re: AW: Kalender mit Formel(n) herstellen

Nach oben
       Version: Office 2010

schauan - 21. Jul 2013, 22:10 hat folgendes geschrieben:
Hallo,

schaue mal hier:
http://www.xltips.de/Downloads/Kalenderfrei2.zip


hi, schauan André, über G5 müssen wir aber schon noch reden, oder..?

Arbeitsblatt mit dem Namen 'Kalender frei'
 EFGHIJKL
4  Januar
5  012345
6MO  29162330
7DI  310172431
8MI  4111825 
9DO  5121926 
10FR  6132027 
11SA  7142128 
12SO 18152229 

ZelleFormel
G5=WENN(ANZAHL(G6:G12)>3;1;0)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

_________________
hiobs botschaft gespickt mit
halbgarem hintergrundwissen
hiob
armer wissbegieriger user


Verfasst am:
22. Jul 2013, 16:54
Rufname: losmo

Re: AW: Kalender mit Formel(n) herstellen - Re: AW: Kalender mit Formel(n) herstellen

Nach oben
       Version: Office 2010

hddiesel - 22. Jul 2013, 16:40 hat folgendes geschrieben:
Hallo Hiob,

Nullwerte ausblenden, dürfte kein Problem sein.
Ein benutzerdefiniertes Zellformat:
0;;
dürfe hier genügen!


hi, danke für den tipp, ich kenn den schon (und auch André und seinen kalender), was ich meine: das ausblenden oder verstecken der null ist nicht das problem... es kann nur keine null herauskommen. hier ist doch die frage 0 oder 1, aber die frage müßte ja lauten 52, 53 oder 1...

_________________
hiobs botschaft gespickt mit
halbgarem hintergrundwissen
hddiesel
Anfänger Nein, Profi Nein, Lernfähig Ja.


Verfasst am:
22. Jul 2013, 17:15
Rufname: Karl
Wohnort: Deutschland

AW: Kalender mit Formel(n) herstellen - AW: Kalender mit Formel(n) herstellen

Nach oben
       Version: Office 2010

Hallo Hiob,

Spaß bei Seite!

in G5
=KÜRZEN((DATUM(A2;1;1)-DATUM(JAHR(DATUM(A2;1;1)+3-REST(DATUM(A2;1;1)-2;7));1;REST(DATUM(A2;1;1)-2;7)-9))/7)

in H5
=WENN(ANZAHL(H6:H12)>0;WENN(G5>1;1;G5+1);"")

Denke, kann man noch etwas Kürzen, aber die KW Angaben passen!

Nachtrag:
A4 auf A2 korrigiert.
denn A4 erhält den Wert von A2

_________________
Gruß
Karl

BS: Windows 7, 64-Bit, Service Pack 1,
Mainboard: Gigabyte GA-X48-DS4 (rev.1.3), CPU: Intel Core 2 Q9400 2.33GHz
Speicher: DDR2, 8192 MBytes, Grafik: NVIDIA GeForce GTX 280, 1024 MBytes, Mouse: Logitech MX Revolution.

MS Office XP(2002)
hiob
armer wissbegieriger user


Verfasst am:
22. Jul 2013, 17:34
Rufname: losmo

Re: AW: Kalender mit Formel(n) herstellen - Re: AW: Kalender mit Formel(n) herstellen

Nach oben
       Version: Office 2010

hddiesel - 22. Jul 2013, 17:15 hat folgendes geschrieben:
Hallo Hiob,

Spaß bei Seite!

in G5
=KÜRZEN((DATUM(A2;1;1)-DATUM(JAHR(DATUM(A2;1;1)+3-REST(DATUM(A2;1;1)-2;7));1;REST(DATUM(A2;1;1)-2;7)-9))/7)

in H5
=WENN(ANZAHL(H6:H12)>0;WENN(G5>1;1;G5+1);"")

Denke, kann man noch etwas Kürzen, aber die KW Angaben passen!

Nachtrag:
A4 auf A2 korrigiert.
denn A4 erhält den Wert von A2


hi, ich glaube ich habe mich missverständlich ausgedrückt...:, aber lassen wir das... zumal hier reicht..:

Code:
=KÜRZEN((G4-DATUM(JAHR(G4+3-REST(G4-2;7));1;REST(G4-2;7)-9))/7)


reicht

_________________
hiobs botschaft gespickt mit
halbgarem hintergrundwissen
hddiesel
Anfänger Nein, Profi Nein, Lernfähig Ja.


Verfasst am:
22. Jul 2013, 17:35
Rufname: Karl
Wohnort: Deutschland

AW: Kalender mit Formel(n) herstellen - AW: Kalender mit Formel(n) herstellen

Nach oben
       Version: Office 2010

Hallo,

hier die Korrektur:

_________________
Gruß
Karl

BS: Windows 7, 64-Bit, Service Pack 1,
Mainboard: Gigabyte GA-X48-DS4 (rev.1.3), CPU: Intel Core 2 Q9400 2.33GHz
Speicher: DDR2, 8192 MBytes, Grafik: NVIDIA GeForce GTX 280, 1024 MBytes, Mouse: Logitech MX Revolution.

MS Office XP(2002)



KalenderFrei2-Korrektur KW.zip
 Beschreibung:

Download
 Dateiname:  KalenderFrei2-Korrektur KW.zip
 Dateigröße:  15.43 KB
 Heruntergeladen:  10 mal

hiob
armer wissbegieriger user


Verfasst am:
22. Jul 2013, 17:43
Rufname: losmo


ist doch alles gut...;-) - ist doch alles gut...;-)

Nach oben
       Version: Office 2010

hddiesel - 22. Jul 2013, 17:35 hat folgendes geschrieben:
Hallo,

hier die Korrektur:


hi, hier die korrektur der korrektur...:

Arbeitsblatt mit dem Namen 'Kalender frei'
 EFGHIJKL
4  Januar
5  12345 
6MO  7142128 
7DI 18152229 
8MI 29162330 
9DO 310172431 
10FR 4111825  
11SA 5121926  
12SO 6132027  
13        

ZelleFormel
G5=KÜRZEN((G4-DATUM(JAHR(G4+3-REST(G4-2;7));1;REST(G4-2;7)-9))/7)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

_________________
hiobs botschaft gespickt mit
halbgarem hintergrundwissen
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Gehe zu Seite Zurück  1, 2, 3  Weiter
Diese Seite Freunden empfehlen

Seite 2 von 3
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Formel gesucht!!! Part II 1 Kimbolaysen 596 10. Mai 2004, 13:23
xyzdef Formel gesucht!!! Part II
Keine neuen Beiträge Excel Formeln: hife wenn formel?, zahlen codieren komm nicht weiter 2 Gast 1804 07. Mai 2004, 11:22
Gast hife wenn formel?, zahlen codieren komm nicht weiter
Keine neuen Beiträge Excel Formeln: WENN IDENTISCH Formel oder so 5 JanJ 2398 01. Mai 2004, 19:12
Amethyst WENN IDENTISCH Formel oder so
Keine neuen Beiträge Excel Formeln: suche ne formel mit bestimmten abhängigkeiten 6 pipi 3131 26. Apr 2004, 13:39
pipi suche ne formel mit bestimmten abhängigkeiten
Keine neuen Beiträge Excel Formeln: Für EXCEL-PROFIS: Formel für Zahlentreffer 1 onkelbobby 2722 20. Apr 2004, 12:21
Gast Für EXCEL-PROFIS: Formel für Zahlentreffer
Keine neuen Beiträge Excel Formeln: Formel über Blätter 7 akm197 bzw akm1978 2613 08. Apr 2004, 12:38
peb Formel über Blätter
Keine neuen Beiträge Excel Formeln: wenn formel wird zu lang und nicht mehr anerkannt 2 merdin 1602 31. März 2004, 07:34
steve1da wenn formel wird zu lang und nicht mehr anerkannt
Keine neuen Beiträge Excel Formeln: Formel Gesucht 5 Gast 2309 22. März 2004, 07:39
peb Formel Gesucht
Keine neuen Beiträge Excel Formeln: Formel Tabellenübergreifend? 3 Gast 2320 16. März 2004, 09:39
Dick Formel Tabellenübergreifend?
Keine neuen Beiträge Excel Formeln: suche excel formel: 1 philologe 2001 04. März 2004, 14:16
steve1da suche excel formel:
Keine neuen Beiträge Excel Formeln: Suche Formel für die Berechnung eines Punktesystems 3 Akira Yuki 2411 29. Feb 2004, 00:28
xpecidy Suche Formel für die Berechnung eines Punktesystems
Keine neuen Beiträge Excel Formeln: Datum in Formel 4 Dr.I.M.Friendly 895 11. Feb 2004, 10:26
Dr.I.M.Friendly Datum in Formel
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Web Editor Forum