Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Problem mit Add-Ins: Laufzeitfehler 5941
zurück: *T*Problem mit Inhaltverzeichnis weiter: Alle Optionen dauerhaft sichtbar machen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Hugimeier
Im Profil kannst Du frei den Rang ändern


Verfasst am:
24. Sep 2013, 10:55
Rufname:

Problem mit Add-Ins: Laufzeitfehler 5941 - Problem mit Add-Ins: Laufzeitfehler 5941

Nach oben
       Version: Office 2007

Hallo zusammen,

ich habe wahlweise folgende Word2010 oder 2003 Templates in ein Dokument eingelesen: Submission and Authoring in ACS Paragon Plus

(Über Word-Optionen -> Add-Ins -> Word-Add-Ins -> und dann die Dokumentvorlage angefügt und auf automatisch aktualisieren geklickt.
(Steht auch so beschrieben in dem Readme, welches unter obigem link zu finden ist).

Wenn ich dann unter Add-Ins eine der Vorlagen verwenden will, wie zB "Insert One Column Table", kommt bei mir folgender Fehler:
Zitat:
Laufzeitfehler 5941 - das angeforderte Element ist nicht in der Sammlung vorhanden
Im Debug Modus sieht das dann so aus:
Code:
Sub Insert_2column_Tab()
' Insert_2column_Tab Macro
' Macro recorded 06/28/02 by Curt Steger
    Selection.TypeParagraph
    Selection.Style = ActiveDocument.Styles("normal")
    Selection.InsertBreak Type:=wdSectionBreakContinuous
    If ActiveWindow.View.SplitSpecial <> wdPaneNone Then
        ActiveWindow.Panes(2).Close
    End If
    If ActiveWindow.ActivePane.View.Type = wdNormalView Or _
       ActiveWindow.ActivePane.View.Type = wdOutlineView Or _
       ActiveWindow.ActivePane.View.Type = wdMasterView Then
        ActiveWindow.ActivePane.View.Type = wdPageView
    End If
Dabei ist die Zeile "Selection.Style = ActiveDocument.Styles("normal")" gelb markiert .

Andere Add-Ins, die nur auf Formatvorlagen (Schriftarten etc) zugreifen funktionieren....aber alles andere, was ich zum erstellen von Tabellen und Grafiken benötige klappt nicht.

Was mache ich falsch oder wie kann man das Problem beheben??

Vielen Dank für die Hilfe!
MarkMH_K
z.Z. gaanz unregelmäßig online


Verfasst am:
24. Sep 2013, 18:55
Rufname: Markus
Wohnort: Köln rrh


AW: Problem mit Add-Ins: Laufzeitfehler 5941 - AW: Problem mit Add-Ins: Laufzeitfehler 5941

Nach oben
       Version: Office 2007

Hi,

ersetze "normal" durch "Standard".
Allerdings: das Makro ist ein aufgezeichnetes, das unnötigen Ballast herumschleppt. Es arbeitet außerdem mit Selection, was gar nicht so gut ist. In welchem Zusammenhang verwendest Du das?

HTH.

Markus
Hugimeier
Im Profil kannst Du frei den Rang ändern


Verfasst am:
24. Sep 2013, 21:15
Rufname:

AW: Problem mit Add-Ins: Laufzeitfehler 5941 - AW: Problem mit Add-Ins: Laufzeitfehler 5941

Nach oben
       Version: Office 2007

Hallo Mark,

vielen Dank, das hat das Problem scheinbar gelöst. Klappte bei den ersten beiden Versuchen wunderbar!!

Ich benutze die Makros/Templates für eine wissenschaftliche Veröffentlichung. Die Templates sind von dem Verlag gestellt. Und dadurch, dass ich keine Ahnung davon habe, bastele ich lieber nichts daran herum ;)

Vielen Dank nochmal. Falls es weitere Probleme gibt, melde ich mich.
Hugimeier
Im Profil kannst Du frei den Rang ändern


Verfasst am:
25. Sep 2013, 09:55
Rufname:


AW: Problem mit Add-Ins: Laufzeitfehler 5941 - AW: Problem mit Add-Ins: Laufzeitfehler 5941

Nach oben
       Version: Office 2007

Noch eine Anmerkung: Zwar kann ich nun Tabellen einfügen, allerdings gehören in die Tabellen noch zwei waagerechte Linien, nämlich über und unter die erste Zeile...die macht er irgendwie noch nicht...
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Word VBA Programmierung (Makros): Laufzeitfehler 5981 Office 2003/2010 6 nrg007 314 22. Jul 2013, 17:56
nrg007 Laufzeitfehler 5981 Office 2003/2010
Keine neuen Beiträge Word VBA Programmierung (Makros): Probleme mit Laufzeitfehler 1004 bei PasteSpecial-Methode 2 wincheck 175 13. Feb 2013, 12:05
wincheck Probleme mit Laufzeitfehler 1004 bei PasteSpecial-Methode
Keine neuen Beiträge Word VBA Programmierung (Makros): Laufzeitfehler 5 0 P.Brausel 190 05. Dez 2012, 11:09
P.Brausel Laufzeitfehler 5
Keine neuen Beiträge Word VBA Programmierung (Makros): Laufzeitfehler 70, Makroabbruch implementieren, uvm. 33 Listiger Hase 885 23. Aug 2012, 15:15
HermannL Laufzeitfehler 70, Makroabbruch implementieren, uvm.
Keine neuen Beiträge Word VBA Programmierung (Makros): Error 5941 3 hammersack 299 05. Jun 2012, 09:27
powerzone3000 Error 5941
Keine neuen Beiträge Word VBA Programmierung (Makros): Run-time error 5941 nur bei Word Vorlagen 1 Lumpazi 804 09. Mai 2012, 20:32
Lumpazi Run-time error 5941 nur bei Word Vorlagen
Keine neuen Beiträge Word VBA Programmierung (Makros): Vba - Laufzeitfehler 424, objekt erforderlich? 3 Marc Kletz 1301 19. Jan 2012, 16:37
Isabelle :-) Vba - Laufzeitfehler 424, objekt erforderlich?
Keine neuen Beiträge Word Serienbriefe: Rückgabelimit bei Stored Procedure Aufruf ? (Laufzeitfehler) 0 Gizmo4ever 388 01. Sep 2011, 21:28
Gizmo4ever Rückgabelimit bei Stored Procedure Aufruf ? (Laufzeitfehler)
Keine neuen Beiträge Word VBA Programmierung (Makros): Mehrere Bilder umbenennen, Laufzeitfehler 53 8 sussy 588 28. Aug 2011, 21:49
sussy Mehrere Bilder umbenennen,  Laufzeitfehler 53
Keine neuen Beiträge Word VBA Programmierung (Makros): Laufzeitfehler 4605 7 Eric87 2848 26. Okt 2010, 12:42
CHF Laufzeitfehler 4605
Keine neuen Beiträge Word Formate: Syntaxfehler Laufzeitfehler 3075 0 stan_1958 497 23. Apr 2010, 20:03
stan_1958 Syntaxfehler Laufzeitfehler 3075
Keine neuen Beiträge Word VBA Programmierung (Makros): Laufzeitfehler 5273 12 Kâssândrâe 1190 30. Jul 2009, 16:15
Kâssândrâe Laufzeitfehler 5273
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML Editoren Forum