Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Zeilen zählen die 2 Bedingungen erfüllen
zurück: Mix aus SUMMEWENN und Matrix Formel weiter: Täglich 3 Monate auswerten Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Kaniee
Gast


Verfasst am:
24. Feb 2014, 23:55
Rufname:

Zeilen zählen die 2 Bedingungen erfüllen - Zeilen zählen die 2 Bedingungen erfüllen

Nach oben
       Version: Office 2010

Hallo,

ich bin gerade auf einer Funktion, die mir hilft die Zeilen zu zählen, die 2 Bedingungen erfüllen.
Ich versuche es an einem Beispiel deutlich zu machen:
Ich habe eine Liste von Personen und habe in Spalte D ihr Geschlecht angegeben und in Spalte E ihre Haarfarbe. Jetzt möchte ich an einem anderen Ort nachzählen, wie viele blonde Frauen sich in der Liste befinden. Und zwar ohne eine extra Spalte anzulegen und ohne einen Filter aktivieren zu müssen.

Hat mir jemand einen Tipp?

Gruß
Kaniee
Klaus-Dieter
Schwerpunktinteresse: VBA und UserForms


Verfasst am:
25. Feb 2014, 00:36
Rufname: Klaus
Wohnort: Sassenburg


AW: Zeilen zählen die 2 Bedingungen erfüllen - AW: Zeilen zählen die 2 Bedingungen erfüllen

Nach oben
       Version: Office 2010

Hallo,

versuche es einmal mit Summenprodukt:

 DEFGHIJ
1GeschlechtHaarfarbe   wm
2mrot  blond20
3mbraun  braun11
4mschwarz  schwarz03
5wrot  rot10
6wblond     
7mschwarz     
8wbraun     
9wblond     
10mschwarz     

Formeln der Tabelle
ZelleFormel
I2=SUMMENPRODUKT(($D2:$D10=I$1)*($E2:$E10=$H2))
J2=SUMMENPRODUKT(($D2:$D10=J$1)*($E2:$E10=$H2))
I3=SUMMENPRODUKT(($D3:$D11=I$1)*($E3:$E11=$H3))
J3=SUMMENPRODUKT(($D3:$D11=J$1)*($E3:$E11=$H3))
I4=SUMMENPRODUKT(($D4:$D12=I$1)*($E4:$E12=$H4))
J4=SUMMENPRODUKT(($D4:$D12=J$1)*($E4:$E12=$H4))
I5=SUMMENPRODUKT(($D5:$D13=I$1)*($E5:$E13=$H5))
J5=SUMMENPRODUKT(($D5:$D13=J$1)*($E5:$E13=$H5))


Excel Jeanie Html

_________________
Viele Grüße
Klaus-Dieter
Lösungsvorschläge sind, wenn es keinen anders lautenden Hinweis gibt, von mir getestet.
Yoga ist besser, als rumsitzen und gar nichts machen.
Kaniee
Gast


Verfasst am:
26. Feb 2014, 00:20
Rufname:

AW: Zeilen zählen die 2 Bedingungen erfüllen - AW: Zeilen zählen die 2 Bedingungen erfüllen

Nach oben
       Version: Office 2010

Vielen Dank!

Das ist genau das, was ich gesucht habe und es funktioniert wunderbar, auch wenn ich nicht ganz verstehe wie Very Happy

Danke für die schnelle Antwort.

Gruß
Kaniee
HKindler
ambitionierter Amateur


Verfasst am:
26. Feb 2014, 10:05
Rufname:


AW: Zeilen zählen die 2 Bedingungen erfüllen - AW: Zeilen zählen die 2 Bedingungen erfüllen

Nach oben
       Version: Office 2010

Hi Kaniee,

ab Excel 2007 funktioniert auch ZÄHLENWENNS. Ist mMn etwas einfacher zu verstehen als SUMMENPRODUKT, allerdings auch nicht so flexibel.

 DEFGHIJ
1GeschlechtHaarfarbe   wm
2mrot  blond20
3mbraun  braun11
4mschwarz  schwarz03
5wrot  rot11
6wblond     
7mschwarz     
8wbraun     
9wblond     
10mschwarz     

ZelleFormel
I2=ZÄHLENWENNS($D$2:$D$10;I$1;$E$2:$E$10;$H2)
J2=ZÄHLENWENNS($D$2:$D$10;J$1;$E$2:$E$10;$H2)
I3=ZÄHLENWENNS($D$2:$D$10;I$1;$E$2:$E$10;$H3)
J3=ZÄHLENWENNS($D$2:$D$10;J$1;$E$2:$E$10;$H3)
I4=ZÄHLENWENNS($D$2:$D$10;I$1;$E$2:$E$10;$H4)
J4=ZÄHLENWENNS($D$2:$D$10;J$1;$E$2:$E$10;$H4)
I5=ZÄHLENWENNS($D$2:$D$10;I$1;$E$2:$E$10;$H5)
J5=ZÄHLENWENNS($D$2:$D$10;J$1;$E$2:$E$10;$H5)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Bei Klaus-Dieter hat sich übrigens noch ein Fehler eingeschlichen. Statt =SUMMENPRODUKT(($D2:$D10=I$1)*($E2:$E10=$H2)) müsste es korrekt =SUMMENPRODUKT(($D2:$D$10=I$1)*($E2:$E$10=$H2)) lauten.

_________________
Gruß,
Helmut

----------------------------
Windows 7 / Office 2010
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Frage für eine Formel Arbeitstage zählen. 2 Brösel 1014 16. Dez 2004, 20:08
Gast Frage für eine Formel Arbeitstage zählen.
Keine neuen Beiträge Excel Formeln: abfrage gestalten mit mehreren bedingungen 3 Gast 1303 15. Dez 2004, 16:58
nugget abfrage gestalten mit mehreren bedingungen
Keine neuen Beiträge Excel Formeln: Uhrzeit zählen 1 Wilfried 997 03. Dez 2004, 12:33
ae Uhrzeit zählen
Keine neuen Beiträge Excel Formeln: Zählen von Werten aus untersch. Spalten mit 2 Kriterien 2 Sigi 2526 20. Nov 2004, 03:18
Gast Zählen von Werten aus untersch. Spalten mit 2 Kriterien
Keine neuen Beiträge Excel Formeln: Formel für das zählen aller x in einer Spalte 1 joefaser 2003 18. Nov 2004, 23:08
ae Formel für das zählen aller x in einer Spalte
Keine neuen Beiträge Excel Formeln: Wie verbinde ich Formeln in Abhängigkeit von Bedingungen 3 BigMicha 517 03. Nov 2004, 18:26
BigMicha Wie verbinde ich Formeln in Abhängigkeit von Bedingungen
Keine neuen Beiträge Excel Formeln: Gelbe Zellen zählen! 6 Axis_Sonnenflieger 4453 27. Okt 2004, 14:50
Axis_Sonnenflieger Gelbe Zellen zählen!
Keine neuen Beiträge Excel Formeln: Anzahl bei 2 Bedingungen aus Tabelle berechnen 6 Satanico 1723 21. Okt 2004, 14:48
Satanico Anzahl bei 2 Bedingungen aus Tabelle berechnen
Keine neuen Beiträge Excel Formeln: DATUM -> Tage zählen ? 3 anna-bolika 4451 11. Okt 2004, 16:34
lou38 DATUM -> Tage zählen ?
Keine neuen Beiträge Excel Formeln: Problem mit WENN-Formel - ich bräuchte zu viele Bedingungen 6 Florian 1187 05. Okt 2004, 12:37
Florian Problem mit WENN-Formel - ich bräuchte zu viele Bedingungen
Keine neuen Beiträge Excel Formeln: Formel für Spalten und Zeilen 17 Gast 2737 15. Sep 2004, 14:11
steve1da Formel für Spalten und Zeilen
Keine neuen Beiträge Excel Formeln: Kann ich Zeilen "einfrieren"? 1 Chrisi 1115 08. Sep 2004, 13:01
fl618 Kann ich Zeilen "einfrieren"?
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: MS Frontpage