Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Folgen zählen in Excel
zurück: Datenüberprüfung Feld soll immer Dropdownpfeil anzeigen weiter: *T*Re: Eigenes Ribbon-Control im Editiermodus disabled Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Locher
Gast


Verfasst am:
10. Apr 2014, 07:42
Rufname:

Folgen zählen in Excel - Folgen zählen in Excel

Nach oben
       Version: Office 2010

Hallo,

ich habe in einer Reihe einige Zellen mit dem Text „O“ und einige Zellen mit dem Text „S“. Die „O“ und „S“ sind in zufälliger Reihenfolge und dazwischen sind noch einige leere Zellen. Ich würde gerne wissen wie oft es vorkommt, dass erst ein „O“ kommt und in der nächsten Zelle ein „S“. Die leeren Zellen sollen dabei nicht beachtet werden. Also es soll auch zählen, wenn „O“, leer, leer, „S“ auftritt.
Optimalerweise würden noch die Anzahl der leeren Zellen zwischen den „O“ und „S“ angezeigt werden.
Ich hoffe Ihr versteht was Ich meine und könnt mir mit einer Funktion Helfen
FCH
Im Profil kannst Du frei den Rang ändern


Verfasst am:
10. Apr 2014, 09:21
Rufname: Jürgen


AW: Folgen zählen in Excel - AW: Folgen zählen in Excel

Nach oben
       Version: Office 2010

Hi Locher,

mit einer Funktion alleine wird das nix. Da brauchst du Hilfsspalten. Wenn da wirklich nur S, O und Leer vorkommt, teste das mal:

Arbeitsblatt mit dem Namen 'Tabelle2'
 ABCDE
1O/SS auf OLeer dazw.Summe S auf OAnz. Leer
2S0034
3 00  
4O00  
5 00  
6S11  
7O00  
8S10  
9O00  
10 00  
11O00  
12 00  
13 00  
14 00  
15S13  
16 00  
17S00  

ZelleFormel
B2=WENNFEHLER((VERWEIS(2;1/(A$1:A1="O");ZEILE(A$1:A1))>VERWEIS(2;1/(A$1:A1="S");ZEILE(A$1:A1)))*(A2="S");0)
C2=WENNFEHLER(MAX((VERWEIS(2;1/(A$1:A1="");ZEILE(A$1:B1))-VERWEIS(2;1/(A$1:A1="O");ZEILE(A$1:B1)))*(B2=1);0);0)
D2=SUMME(B2:B17)
E2=SUMME(C2:C17)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Gruß
Jürgen
Locher
Gast


Verfasst am:
10. Apr 2014, 11:08
Rufname:

AW: Folgen zählen in Excel - AW: Folgen zählen in Excel

Nach oben
       Version: Office 2010

Das mit dem S auf O klappt super, danke schon mal dafür.

Mit der Anzahl der leeren Zeilen habe ich aber jetzt ein Problem. Ich habe meine Liste kopiert und in der Mappe 2 Verknüpft. An der Verknüpfung will die Funktion benutzen. Das Problem dabei ist, dass die leeren Zellen aus der Originalliste jetzt mit 0 ersetzt wurden. Kann man deine C"-Funktion so verändern, dass die 0 ignoriert werden? Oder gibt es vielleicht eine möglichkeit, dass man eine Liste verknüpft ohne dass dabei die leeren Zellen in einer 0 gewandelt werden?
Locher
Gast


Verfasst am:
10. Apr 2014, 11:21
Rufname:

AW: Folgen zählen in Excel - AW: Folgen zählen in Excel

Nach oben
       Version: Office 2010

Das mit dem S auf O klappt super, danke schon mal dafür.

Mit der Anzahl der leeren Zeilen habe ich aber jetzt ein Problem. Ich habe meine Liste kopiert und in der Mappe 2 Verknüpft. An der Verknüpfung will die Funktion benutzen. Das Problem dabei ist, dass die leeren Zellen aus der Originalliste jetzt mit 0 ersetzt wurden. Kann man deine C"-Funktion so verändern, dass die 0 ignoriert werden? Oder gibt es vielleicht eine möglichkeit, dass man eine Liste verknüpft ohne dass dabei die leeren Zellen in einer 0 gewandelt werden?
FCH
Im Profil kannst Du frei den Rang ändern


Verfasst am:
10. Apr 2014, 11:50
Rufname: Jürgen

AW: Folgen zählen in Excel - AW: Folgen zählen in Excel

Nach oben
       Version: Office 2010

Hi Locher,

mal ungetestet:

=WENNFEHLER(MAX((VERWEIS(2;1/(A$1:A1=0);ZEILE(A$1:B1))-VERWEIS(2;1/(A$1:A1="O");ZEILE(A$1:B1)))*(B2=1);0);0)

Gruß
Jürgen
Locher
Gast


Verfasst am:
10. Apr 2014, 12:00
Rufname:


AW: Folgen zählen in Excel - AW: Folgen zählen in Excel

Nach oben
       Version: Office 2010

Funktioniert!
Ein rießengroßen Dankeschön Jürgen Smile
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Office 2010 Forum: Zellenfarbe in Zeile zählen 4 MXStar 849 26. Feb 2012, 19:33
MXStar Zellenfarbe in Zeile zählen
Keine neuen Beiträge Office 2010 Forum: Wörter zählen (Zitate) 0 Arne33 1031 30. Mai 2011, 15:06
Arne33 Wörter zählen (Zitate)
Keine neuen Beiträge Office 2010 Forum: Anzahl gleicher Zeichen zählen 0 offivemuck 1250 20. Mai 2011, 10:35
offivemuck Anzahl gleicher Zeichen zählen
Keine neuen Beiträge Office 2007 Forum: Erste Seite NICHT als Seite zählen 1 Hyrican 4116 09. Okt 2008, 00:30
BarbaraH Erste Seite NICHT als Seite zählen
Keine neuen Beiträge Fragen & Anregungen zum Office Forum: Beiträge im Forum zählen 6 Klafu 605 10. Sep 2007, 12:27
urs Beiträge im Forum zählen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Web Editor Forum