Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: -------> Neu: dotNet & Visual Studio Forum <-
kann man "#wert" ausblenden??
zurück: Summe mehrerer Felder bilden ohne Null weiter: Tabelle sortieren, trotz verbundenen Zellen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Runkelrübe
Gast


Verfasst am:
14. Apr 2006, 16:53
Rufname:

kann man "#wert" ausblenden?? - kann man "#wert" ausblenden??

Nach oben
       

Hallo zusammen,

in manchen meiner zellen steht "#WERT", weil die funktion die dieses zelle hat nicht ausgeführt werden kann.
Gibt es eine Formel oder einstellung, die das "#WERT" "unsichtbar" werden lässt?


danke für die hilfe

Mit freundlichen Grüßen

die Runkelrübe
< Peter >
Excel-Moderator, der immer noch dazu lernt


Verfasst am:
14. Apr 2006, 17:03
Rufname: Kommt darauf an wer ruft
Wohnort: Das schönste Land in Deutschlands Gaun


AW: kann man "#wert" ausblenden?? - AW: kann man "#wert" ausblenden??

Nach oben
       

Hallo,

versuch es mal so:

=WENN(ISTFEHLER(Deine_Formel);"";Deine_Formel)

_________________
Gruß
Peter
Runkelrübe
Gast


Verfasst am:
14. Apr 2006, 17:13
Rufname:

AW: kann man "#wert" ausblenden?? - AW: kann man "#wert" ausblenden??

Nach oben
       

danke schön

funktioniert super

nochmals vielen dank

und schönes osterfest noch

Mit freundlichen Grüßen

die runkelrübe
palmer
Excel-Kenner mit einigen VBA-Kenntnissen


Verfasst am:
23. Okt 2007, 23:28
Rufname:

AW: kann man "#wert" ausblenden?? - AW: kann man "#wert" ausblenden??

Nach oben
       Version: Office 2003

Hallo zusammen,


ich habe ein ähnliches Problem mit einer verschachtelten Formel.

Meine Ursprungsformel (diese funktioniert erstmal beinahe einwandfrei):

=WENN($D34>0;MIN(WENN(Berechnungen!$F$12:$F$3000=$A34;WENN(Berechnungen!$G$12:$G$3000=$D34;Berechnungen!$B$12:$B$3000)));"")

Mit dieser Formel wird lediglich aus einer großen Datenmenge (Tabelle Berechnungen) diverse Werte heraus gefiltert und in einem anderen Tabellenblatt dargestellt. Wie gesagt, diese Formel funktioniert, solange ein korrekter Wert ermittelt werden kann. Tritt ein Fehler auf, dann erscheint „#NV“. Dieses möchte ich ausblenden.

Folgendermaßen habe die obige Formel umgewandelt (nach entsprechender Anweisung „=WENN(ISTFEHLER(Deine_Formel);"";Deine_Formel)“):

=WENN(ISTFEHLER(WENN($D32>0;MIN(WENN(Berechnungen!$F$12:$F$3000=$A32;WENN(Berechnungen!$G$12:$G$3000=$D32;Berechnungen!$B$12:$B$3000)));""));"";(WENN($D32>0;MIN(WENN(Berechnungen!$F$12:$F$3000=$A32;WENN(Berechnungen!$G$12:$G$3000=$D32;Berechnungen!$B$12:$B$3000)));"")))

Diese Formel funktioniert jetzt nicht mehr. Die Fehler, wie z.B. „#NV“, werden jetzt zwar ausgeblendet, jedoch funktioniert meine nachfolgende verschachtelte Formel nicht mehr. Hier scheitert es schon bei der zweiten „Wenn-Bedingung“.

Was mache ich falsch???

Danke

Gruß
Andreas
urs
Zahlenschubser, Excel ohne VBA


Verfasst am:
24. Okt 2007, 07:53
Rufname:
Wohnort: Oldenburg i.O.


AW: kann man "#wert" ausblenden?? - AW: kann man "#wert" ausblenden??

Nach oben
       

Guten Morgen,

m.E. kann die Matrixformel den Fehler #NV nur dann zeigen, wenn dieses #NV im selektierten Zellbereich der Spalte B auftaucht, in dem nach dem MIN gesucht wird. Vielleicht schaust Du mal in Spalte B, ob das Problem dort gelöst werden kann. Sonst hilft vermutlich auch diese Matrixformelvariante
Code:
{=WENN(D39>0;MIN(WENN(($F$12:$F$3000=A39)*($G$12:$G$3000=D39)*ISTZAHL($B$12:$B$3000);$B$12:$B$3000));"")}

_________________
urs grüßt
palmer
Excel-Kenner mit einigen VBA-Kenntnissen


Verfasst am:
24. Okt 2007, 09:59
Rufname:

AW: kann man "#wert" ausblenden?? - AW: kann man "#wert" ausblenden??

Nach oben
       

Hallo Urs,

danke für Deine schnelle Antwort.
Deine Lösung löst das Problem leider auch nicht. Er bringt den gleichen Fehler. Der Fehler tritt an der gleichen Stelle auf.
Es richtig, dass an einer bestimmten Stelle das „#NV“ auftritt und somit die fehlerhafte Ausgabe erscheint. Der Fehler tritt an der folgende Stelle auf:

Code:
….MIN(WENN(Berechnungen!$F$12:$F$3000=$A32…



Das Feld A32 enthält keinen Wert und somit kann hier schon kein Filter gesetzt werden und alle weiteren Abläufe der Formel bringen dann kein Ergebnis bzw. als Endergebnis das „#NV“.

Nur zur Erläuterung:
Ich versuche aus der Tabelle Berechnungen Maximumwerte eines jeden Tages eines Monats heraus zu filtern. Hierbei habe ich für jeden Tag 96 Werte (alle 15 Minuten).
Die Maximalwerte werden korrekterweise für jeden Kalendertag richtig ausgewertet, auch wenn der Monat nur mal 30 Tage hat. Hier setze ich folgende Formel an:

Code:
=WENN(ISTNV($A32);"";MAX(WENN(Berechnungen!$H$12:$H$3000=$A32;Berechnungen!$I$12:$I$3000)))

hierbei steht A32 für ein Datum (z.B. 21.09.)

Mit meiner fehlerhaften Formel möchte ich jeden für den jeweiligen Kalendertag (der steht in der Spalte A) die Uhrzeit des Maximums an dem entsprechenden Kalendertag suchen. Das funktioniert soweit ja auch, nur dass dann in den Zeilen wo der Kalendertag fehlt, also z.B. der 31. Tag, mein Fehler auftritt.
Die Funktion ISTNV kann ich aber leider nicht anwenden, da ja identische Werte an anderen Kalendertagen auftreten könnten, wodurch dann die falsche Uhrzeit gesetzt wird.

Ich habe auch mal daran gedacht, den Wert jeder Zelle per VBA-Code auszulesen und dann bei einem Fehler diesen auszublenden. Auch damit wäre mir geholfen.

Vielen Dank
Gruß Andreas
urs
Zahlenschubser, Excel ohne VBA


Verfasst am:
24. Okt 2007, 10:41
Rufname:
Wohnort: Oldenburg i.O.

AW: kann man "#wert" ausblenden?? - AW: kann man "#wert" ausblenden??

Nach oben
       

Hi,

dann gelten meine obigen Ausführungen zu Spalte B wohl für Spalte A. Dort muss m.E. der Fehlerwert #NV auftreten, sonst dürfte die Formel den Fehler nicht melden. Ich habe allerdings noch nicht alles verstanden Confused

edit: Ich habe versucht die Tabelle nachzubilden. Es gelingt mir nicht mit Deinen Angaben. Vielleicht stellst Du mal einen Ausschnitt hier rein.

_________________
urs grüßt
Gast



Verfasst am:
24. Okt 2007, 13:08
Rufname:

AW: kann man "#wert" ausblenden?? - AW: kann man "#wert" ausblenden??

Nach oben
       Version: Office 2003

Hallo Urs,

hier mal ein Versuch die Daten dazustellen:

So sieht Ergebnistabelle mit den Formeln aus:
Spalte A
24.09.
25.09.
26.09.
27.09.
28.09.
29.09.
30.09.
#NV

Spalte B
4,272
5,258
5,888
6,150
6,467
5,242
4,646

Spalte C
23:00
22:00
21:30
22:00
01:30
03:30
00:00
#NV

Die fehlerhafte Formel in meiner Ergebnis-Tabelle lautet wie folgt (z.B. Ermittlung der Uhrzeit für den 30.09. in Spalte C):
Zitat:
=WENN($B34>0;MIN(WENN(Berechnungen!$H$12:$H$3000=$A34;WENN(Berechnungen!$I$12:$I$3000=$B34;Berechnungen!$B$12:$B$3000)));"")


In Spalte B sieht die Formel folgendermaßen aus:
Code:
=WENN(ISTNV($A34);"";MAX(WENN(Berechnungen!$H$12:$H$3000=$A34;Berechnungen!$I$12:$I$3000)))


Hier sieht man auch den Wert in Spalte A nach dem 30.09 (#NV). In meiner Excel-Tabelle ist dieser Wert nicht sichtbar. Dazu gibt es in der Spalte A folgende Formel:
Code:
=WENN(MONAT(A32+2)>MONAT(A5);NV();A32+2)


Hier ein Auszug aus der Tabelle Berechnungen:

Spalte A
30.09.2007 22:00
30.09.2007 22:15
30.09.2007 22:45
30.09.2007 23:00
30.09.2007 23:15
30.09.2007 23:30
30.09.2007 23:45

Spalte H
30.09.2007
30.09.2007
30.09.2007
30.09.2007
30.09.2007
30.09.2007
30.09.2007
30.09.2007

Spalte I
1,379
1,338
1,059
2,205
1,594
1,581
1,939
2,774



Vielen Dank
Gruß Andreas
urs
Zahlenschubser, Excel ohne VBA


Verfasst am:
24. Okt 2007, 20:50
Rufname:
Wohnort: Oldenburg i.O.

AW: kann man "#wert" ausblenden?? - AW: kann man "#wert" ausblenden??

Nach oben
       

Hallo Andreas,

ich bin auch an diesem Versuch, das nachzubilden, gescheitert. Ich fürchte, das wird nix, ohne es zu "sehen".
Tabelle anhängen
Jeannie

_________________
urs grüßt
palmer
Excel-Kenner mit einigen VBA-Kenntnissen


Verfasst am:
25. Okt 2007, 13:15
Rufname:

AW: kann man "#wert" ausblenden?? - AW: kann man "#wert" ausblenden??

Nach oben
       

Hallo Urs,

vielen Dank für Deine Mühen.
Ich hänge jetzt mal die komplette Excel-Datei als ZIP mit an.

Hierin sind drei Tabellenblätter.
Blatt Daten enthält die reinen Rohdaten. Diese dienen als Berechnungsgrundlage.
Im Blatt Berechnungen werden die eigentlichen Berechnungen aus den Rohdaten durchgeführt.

Anschließend wird das Ergebnis im Blatt Tabelle gefiltert, angezeigt und später dann ausgedruckt. In diesem Tabellenblatt sind diese Fehler enthalten.


Vielen Dank
Gruß Andreas



Berechnungen.zip
 Beschreibung:

Download
 Dateiname:  Berechnungen.zip
 Dateigröße:  336.38 KB
 Heruntergeladen:  177 mal

urs
Zahlenschubser, Excel ohne VBA


Verfasst am:
25. Okt 2007, 15:18
Rufname:
Wohnort: Oldenburg i.O.

AW: kann man "#wert" ausblenden?? - AW: kann man "#wert" ausblenden??

Nach oben
       

Hi,

das hast Du ja elegant gelöst - ein NV wird via bedingter Formatierung ausgeblendet... Rolling Eyes Versuche mal dies
Code:
{=WENN(ISTZAHL($B35);MIN(WENN(Berechnungen!$H$12:$H$3000=$A35;WENN(Berechnungen!$I$12:$I$3000=$B35;Berechnungen!$B$12:$B$3000)));"")}

_________________
urs grüßt
palmer
Excel-Kenner mit einigen VBA-Kenntnissen


Verfasst am:
25. Okt 2007, 16:01
Rufname:

AW: kann man "#wert" ausblenden?? - AW: kann man "#wert" ausblenden??

Nach oben
       

Hallo Urs,

es wieder das gleiche. Das erste Wenn nach MIN läuft dann schon nicht mehr.

Ich überprüfe, das anhand des Feldes C32 mittels der Formelauswertung. Da sollte als Ergebnis "1:30" drin stehen. Sobald ich die Formel abändern, z.B. nach Deinem letzten Vorschlag erscheint "0:00" und ein Hinweis darauf, dass die Formel falsch sei.

Es ist zum Verzweifeln.

Danke

Gruß
Andreas
urs
Zahlenschubser, Excel ohne VBA


Verfasst am:
25. Okt 2007, 16:23
Rufname:
Wohnort: Oldenburg i.O.

AW: kann man "#wert" ausblenden?? - AW: kann man "#wert" ausblenden??

Nach oben
       

Dir ist schon bewusst, dass Du da Matrixformeln nutzt? Und Du weißt damit umzugehen?
{} nicht eingeben
Formel mit Strg+Shift+Enter abschließen

_________________
urs grüßt
palmer
Excel-Kenner mit einigen VBA-Kenntnissen


Verfasst am:
25. Okt 2007, 17:39
Rufname:


AW: kann man "#wert" ausblenden?? - AW: kann man "#wert" ausblenden??

Nach oben
       

Hallo Urs,

das ist mir jetzt aber peinlich. Es tut mir leid, dass ich Dir so viel Mühe gemacht habe. Aber diese Option mit STRG+SHIFT+ENTER kannte ich tatsächlich nicht.

Ich glaube, ich fange noch mal mit einem Excel-Grundkurs an.
Trotzdem vielen Dank.

Gruß
Andreas
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Bekomme Fehler #Wert nicht weg 9 Cerberus 1217 21. Feb 2005, 23:46
Cerberus Bekomme Fehler #Wert nicht weg
Keine neuen Beiträge Excel Formeln: Wert in einer Matrix suchen und den Nachbarwert zurückgeben 1 michl 3091 08. Feb 2005, 12:06
steve1da Wert in einer Matrix suchen und den Nachbarwert zurückgeben
Keine neuen Beiträge Excel Formeln: VERGLEICH() nächstgrösseren Wert finden??? 2 xyzdef 1114 07. Feb 2005, 22:58
xyzdef VERGLEICH() nächstgrösseren Wert finden???
Keine neuen Beiträge Excel Formeln: Wert nur einmal anzeigen 3 User001 21377 04. Feb 2005, 15:18
rainberg Wert nur einmal anzeigen
Keine neuen Beiträge Excel Formeln: Wert *-1 = ########## 4 acki-bm 685 04. Feb 2005, 09:40
Thomas Ramel Wert *-1  = ##########
Keine neuen Beiträge Excel Formeln: #WERT! ausblenden 2 acki-bm 1526 20. Jan 2005, 14:06
acki-bm #WERT!   ausblenden
Keine neuen Beiträge Excel Formeln: Wert einmal vergeben 3 Jony123 1112 13. Jan 2005, 11:47
ae Wert einmal vergeben
Keine neuen Beiträge Excel Formeln: Ergebnis ausblenden 4 klient 1004 03. Jan 2005, 12:37
klient Ergebnis ausblenden
Keine neuen Beiträge Excel Formeln: Wert wird nicht angezeigt 10 NixWisserin 1124 01. Jan 2005, 23:06
NixWisserin Wert wird nicht angezeigt
Keine neuen Beiträge Excel Formeln: größten wert auslesen und woanders um 50 erhöhen 1 GE 1216 20. Dez 2004, 12:51
icke größten wert auslesen und woanders um 50 erhöhen
Keine neuen Beiträge Excel Formeln: Tabellenbläter Wert aufstellen 13 Gast 1129 15. Dez 2004, 17:40
webnaex Tabellenbläter Wert aufstellen
Keine neuen Beiträge Excel Formeln: Formel mit "festem" Wert kopieren 2 sebbi 1925 08. Dez 2004, 20:36
sebbi Formel mit "festem" Wert kopieren
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Excel Tipps