Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Fehler 430 - Klasse unterstützt Automatisierung nicht
zurück: Formular wird auf anderem Rechner nicht angezeigt weiter: Tag und Monat verdreht Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
RudiV
Im Profil kannst Du frei den Rang ändern


Verfasst am:
19. Apr 2006, 15:38
Rufname:

Fehler 430 - Klasse unterstützt Automatisierung nicht - Fehler 430 - Klasse unterstützt Automatisierung nicht

Nach oben
       

Hallo zusammen,

per VB-code erstelle ich mir in access Pivot-diagramme, deren Werte ich aus einer sql-Datenbank bekomme.
Wiel ich die diagramme auch drucken will lasse ich mir aus den pivot-Diagrammen Bilddateien erstellen. Mit dem befehl
Code:
    Me![Dia].Form.ChartSpace.ExportPicture strFileName, "GIF", intWidth, intHeight
hat das bislang immer geklappt.
jetzt arbeite ich aber an einem anderen REchner (Win XP, Access 2003 mit SP 2) und beim Ausführen genau dieses Export-Befehls erhalte ich die Meldung
Zitat:
FEhler 430: Klasse unterstützt keine Automatisierung oder unterstützt erwartete Schnittstelle nicht
Confused
hat jemand eine Idee woran das liegen könnte???
Also biblioteken habe ich folgende eingebunden:
    Visual Basic for Applications
    Microsoft Access 11.0 object library
    Microsoft Office web components 11.0
    Microsoft Excel 11.0 Object library
    Microsoft ActiveX Data Objects 2.8 Library
    Microsoft Office 11.0 Object Library
    Microsoft Web Components Wizards
    OLE Automation
Ich wäre echt super dankbar wenn mir jemand helfen könnte wie ich das problem hier irgendwie weg kriege!!!
Vielen dank schon mal & viele Grüße,
Rudi
Holger-USA
Gast


Verfasst am:
22. Nov 2008, 22:09
Rufname:


AW: Fehler 430 - Klasse unterstützt Automatisierung nicht - AW: Fehler 430 - Klasse unterstützt Automatisierung nicht

Nach oben
       Version: Office 2003

Hat hier keiner eine Ahnung was das Problem sein koennte? Ich habe naemlich genau das gleiche und komme trotz tagelanger Recherche nicht weiter.

Vielen Dank schon mal fuer die Mitarbeit.

Viele Gruesse,
Holger
steffen0815
VBA-Programmierer


Verfasst am:
23. Nov 2008, 17:34
Rufname:

AW: Fehler 430 - Klasse unterstützt Automatisierung nicht - AW: Fehler 430 - Klasse unterstützt Automatisierung nicht

Nach oben
       

Hallo,
Zitat:
Hat hier keiner eine Ahnung was das Problem sein koennte?
Ja das ist nicht so einfach Confused . Das ist ein Fehler, welchen keiner "nachbauen" kann.
Es scheint ein ganz spezielles Installationsproblem zu sein.
An welchem Rechner tritt es auf? Welches Access ist installiert?
Einziger Hinweis, welchen ich im Netz gefunden habe, ist eine fehlerhafte MDAC-Installation.
Versuche den Fehler einzugrenzen, nutze z.B. mal ein anderes Format.

_________________
Gruß Steffen
Quitschie1986
Neuling


Verfasst am:
11. Okt 2012, 13:29
Rufname:


AW: Fehler 430 - Klasse unterstützt Automatisierung nicht - AW: Fehler 430 - Klasse unterstützt Automatisierung nicht

Nach oben
       Version: Office 2007

Das Thema ist zwar schon alt,
aber vielleicht hat jemand das gleiche Problem.
Ich hatte die gleiche Fehlermeldung und konnte diese beheben,
indem ich in den VB-Code geöffnet habe, dann im Menü Extras --> Verweise
die Haken bei den Verweisen entfernt habe, Fenster geschlossen, erneut geöffnet und
die Verweise wieder gesetzt habe.
Scheint ein internes Excel Problem zu sein.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Access Tabellen & Abfragen: Fehler in Update: Fehler beim Kompilieren -> Methode n. g 1 Mindjogger 590 14. März 2008, 17:51
Mindjogger Fehler in Update: Fehler beim Kompilieren -> Methode n. g
Keine neuen Beiträge Access Tabellen & Abfragen: Oracle-Tablle einbinden - Reservierter Fehler (-7748); 4 PeterPan 4665 28. Feb 2008, 19:11
Nouba Oracle-Tablle einbinden - Reservierter Fehler (-7748);
Keine neuen Beiträge Access Tabellen & Abfragen: Fehler abfangen, wenn Datenbank nicht da 5 bentakle 1107 08. Feb 2008, 12:50
Da Oansa Fehler abfangen, wenn Datenbank nicht da
Keine neuen Beiträge Access Tabellen & Abfragen: mehrere Kriterien abfragen - Fehler wenn kein Wert vorgegebe 5 tommy22 813 07. Nov 2007, 23:50
JörgG mehrere Kriterien abfragen - Fehler wenn kein Wert vorgegebe
Keine neuen Beiträge Access Tabellen & Abfragen: DB-Frage liefert Fehler: Falsche Anzahl an Argumenten 3 susi_777 1813 01. Nov 2007, 00:20
Nouba DB-Frage liefert Fehler: Falsche Anzahl an Argumenten
Keine neuen Beiträge Access Tabellen & Abfragen: Automatisierung und Auswertungen 0 Grimi 394 20. Okt 2007, 16:59
Grimi Automatisierung und Auswertungen
Keine neuen Beiträge Access Tabellen & Abfragen: Access - Fehler bei Unterformular und SQL LEFT JOIN 1 kontextfrei 1527 01. Okt 2007, 18:03
kontextfrei Access - Fehler bei Unterformular und SQL LEFT JOIN
Keine neuen Beiträge Access Tabellen & Abfragen: Tabellenerstellungsabfrage Fehler! 5 ..::MaTzE::.. 599 19. Jun 2007, 15:07
Nouba Tabellenerstellungsabfrage Fehler!
Keine neuen Beiträge Access Tabellen & Abfragen: Fehler bei Geburtstagsabfrage wenn kein Geburtsdatum erfasst 2 adamth 1015 11. Jun 2007, 22:18
adamth Fehler bei Geburtstagsabfrage wenn kein Geburtsdatum erfasst
Keine neuen Beiträge Access Tabellen & Abfragen: Wo ist der Fehler???? 1 RobBase 587 16. Aug 2006, 10:09
viny Wo ist der Fehler????
Keine neuen Beiträge Access Tabellen & Abfragen: Fehler in der selectanweisung Hilfe!!!!!!!!!!!!!! 6 vbatobi 891 18. Apr 2006, 13:24
chris1337 Fehler in der selectanweisung Hilfe!!!!!!!!!!!!!!
Keine neuen Beiträge Access Tabellen & Abfragen: Fehler in Löschabfrage!! 4 BorisDieKlinge 1623 12. Apr 2006, 13:17
BorisDieKlinge Fehler in Löschabfrage!!
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: CSS Forum