Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Bedingte Formatierung bei Balkendiagramm
zurück: Umlaute weiter: Problem mit formel Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Rolfi1
Gast


Verfasst am:
23. Apr 2006, 16:16
Rufname:

Bedingte Formatierung bei Balkendiagramm - Bedingte Formatierung bei Balkendiagramm

Nach oben
       

Hallo,
ist es möglich, die bedingte Formatierung einer Spalte in das Balkendiagramm dieser Spalte zu übernehmen?
Beispiel: Spalte A enthält verschiedene Werte. Wenn der Wert 100 auftaucht, wird die Zelle rot. Im Balkendiagramm soll der Balken dieser Zelle auch rot werden.
Vielen Dank im Voraus für Eure Hilfe.
Gruß
Rolfi
< Peter >
Excel-Moderator, der immer noch dazu lernt


Verfasst am:
23. Apr 2006, 17:39
Rufname: Kommt darauf an wer ruft
Wohnort: Das schönste Land in Deutschlands Gaun


AW: Bedingte Formatierung bei Balkendiagramm - AW: Bedingte Formatierung bei Balkendiagramm

Nach oben
       

Hallo Rolfi,

schauen wir mal ob ich dich richtig verstanden habe.

In Spalte A die Ursprungswerte. In Spalte B und C die aufgeführten Formeln. Markiere die Spalten B und C und erzeuge ein Balkendiagramm. Klicke den Balken an der die Werte über 100 anzeigt und gib ihm das gewünschte Farbmuster. Du kannst anschliessend über Datenreihe formatieren - Optionen die Überlappung auf 100 und den Abstand auf 0 setzen.

 
  
 ABC
1Wert  
26060#NV
3120#NV120
43030#NV
5100#NV100
Formeln der Tabelle
B2 : =WENN(A2<100;A2;NV())
C2 : =WENN(A2>100;A2;NV())
B3 : =WENN(A3<100;A3;NV())
C3 : =WENN(A3>100;A3;NV())
B4 : =WENN(A4<100;A4;NV())
C4 : =WENN(A4>100;A4;NV())
B5 : =WENN(A5<100;A5;NV())
C5 : =WENN(A5>=100;A5;NV())
 
 

_________________
Gruß
Peter
Rolfi1
Gast


Verfasst am:
23. Apr 2006, 19:20
Rufname:

AW: Bedingte Formatierung bei Balkendiagramm - AW: Bedingte Formatierung bei Balkendiagramm

Nach oben
       

Hallo Peter,
nein, das trifft es leider nicht.
Ich möchte im Diagramm alle Werte angezeigt haben, also bei 50 Werten in Spalte A auch 50 Balken. Haben Werte den Betrag 100, soll diese Säule rot sein. Z.B.: ist der 10. von 50 Werten 100, soll die 10. von 50 Säulen rot sein.
Gruß
Rolfi
< Peter >
Excel-Moderator, der immer noch dazu lernt


Verfasst am:
23. Apr 2006, 19:32
Rufname: Kommt darauf an wer ruft
Wohnort: Das schönste Land in Deutschlands Gaun

AW: Bedingte Formatierung bei Balkendiagramm - AW: Bedingte Formatierung bei Balkendiagramm

Nach oben
       

Hallo Rolfi,

das Diagramm das sich aus meinem kleinen Beispiel ergibt sieht so aus:



Die Balken mit Werten über 100 werden rot angezeigt. Ich habe zwar bloss ein Beispiel mit 4 Werten gemacht, aber ich kann im Moment noch nicht erkennen warum sich das nicht mit deiner Absicht deckt.

Bildanzeige optimiert. fridgenep

_________________
Gruß
Peter
Rolfi1
Gast


Verfasst am:
23. Apr 2006, 19:58
Rufname:


AW: Bedingte Formatierung bei Balkendiagramm - AW: Bedingte Formatierung bei Balkendiagramm

Nach oben
       

Hallo Peter,
ja, mein Diagramm sieht auch so aus, nur, es sind 2 Balken rot, obwohl nur 1x der Wert 100 auftritt. Weder die Werte > noch < 100 sollen rot sein, sondern nur Werte 100.
Gruß
Rolfi
< Peter >
Excel-Moderator, der immer noch dazu lernt


Verfasst am:
23. Apr 2006, 20:09
Rufname: Kommt darauf an wer ruft
Wohnort: Das schönste Land in Deutschlands Gaun

AW: Bedingte Formatierung bei Balkendiagramm - AW: Bedingte Formatierung bei Balkendiagramm

Nach oben
       

Hallo Rolfi,

wenn nur die Balken rot sein sollen die genau den Wert 100 haben, dann ändere die Formel doch einfach so ab:

 
  
 ABC
1Wert  
260#NV60
3120#NV120
430#NV30
5100100#NV
Formeln der Tabelle
B2 : =WENN(A2=100;A2;NV())
C2 : =WENN(A2<>100;A2;NV())
B3 : =WENN(A3=100;A3;NV())
C3 : =WENN(A3<>100;A3;NV())
B4 : =WENN(A4=100;A4;NV())
C4 : =WENN(A4<>100;A4;NV())
B5 : =WENN(A5=100;A5;NV())
C5 : =WENN(A5<>100;A5;NV())
 
 

_________________
Gruß
Peter
Rolfi1
Gast


Verfasst am:
23. Apr 2006, 20:41
Rufname:

AW: Bedingte Formatierung bei Balkendiagramm - AW: Bedingte Formatierung bei Balkendiagramm

Nach oben
       

Hallo Peter,
Wahnsinn !!!!! Super !!!! Küßchen !!!!
Schönen abend noch
Gruß
Rolfi
boni
Gast


Verfasst am:
29. Apr 2011, 18:37
Rufname:

AW: Bedingte Formatierung bei Balkendiagramm - AW: Bedingte Formatierung bei Balkendiagramm

Nach oben
       Version: Office 2003

hallo Peter
habe ein änliches problem
bei mir sollen aber die namen(Werte) die Balken Farbe bestimmen.
also Rot,Gelb,Grün.

ich habe ca. 500 Werte(namen) die alle unterschiedlich sind.
sie müssen diese Rot,Gelb,Grün Klasiefizierung bekommen.

von diesen 500 werten stelle ich nur top zehn da (zur Zeit sind sie natürlich einfarbig).
diese top 10 ändern sich natürlich jeden monat

gibt es da eine ideeeee?

danke
bonaca
Im Profil kannst Du frei den Rang ändern


Verfasst am:
30. Apr 2011, 08:50
Rufname:

AW: Bedingte Formatierung bei Balkendiagramm - AW: Bedingte Formatierung bei Balkendiagramm

Nach oben
       

beitrag unter "Boni" ist meiner Very Happy
< Peter >
Excel-Moderator, der immer noch dazu lernt


Verfasst am:
30. Apr 2011, 09:01
Rufname: Kommt darauf an wer ruft
Wohnort: Das schönste Land in Deutschlands Gaun

AW: Bedingte Formatierung bei Balkendiagramm - AW: Bedingte Formatierung bei Balkendiagramm

Nach oben
       

Hallo,

mir ist nicht klar auf was du genau hinaus willst.

Zitat:
ich habe ca. 500 Werte(namen)


Namen wie Alfred, Anton, Peter oder Namen die über Einfügen - Namen definiert worden sind?

500 Namen und drei Farben - Welche Namen bekommen welche Farben?

Zitat:
von diesen 500 werten stelle ich nur top zehn da (zur Zeit sind sie natürlich einfarbig).


Das klingt so als ob du schon eine entsprechende Datei hast.

Es wäre sinnvoll wenn du eine entsprechende Beispielsdatei hochladen könntest damit man man das direkt am Original beschreiben und ansehen kann.

Hier findest du eine Anleitung zum Hochladen von Dateien.

Einen Tabellenausschnitt (mit anonymisierten Beispielsdaten) kannst du mit der Jeanie oder dem Addin Tab2HTML posten.

_________________
Gruß
Peter
Samj
Gast


Verfasst am:
08. Aug 2012, 14:22
Rufname:

Beschriftung bei bedingter Formatierung von Balkendiagrammen - Beschriftung bei bedingter Formatierung von Balkendiagrammen

Nach oben
       

Hallo,

Der gezeigte Ansatz funktioniert wunderbar (eigentlich logisch, aber muss halt drauf kommen).

Die Frage ist nun: Wie kann ich es so einrichten, dass er automatisch auch nur die wirkliche
Beschriftung bei den Balken einfügt und keine Doppelbeschriftungen (#NV und 18,3 z.B.)
Samj
Gast


Verfasst am:
08. Aug 2012, 16:43
Rufname:


AW: Bedingte Formatierung bei Balkendiagramm - AW: Bedingte Formatierung bei Balkendiagramm

Nach oben
       

Hab's selbst gelöst bekommen:

1. NV() ind den Formeln zu " " geändert (-> Wert 0 wurde im Diagramm beschriftet)
2. Zahlenformat der Beschriftung geändert zu "[=0]"";Standard" (-> nur noch Werte größer null werden beschriftet)

So schnell kann's gehen. Vielleicht hilft's ja jemandem weiter, der das gleiche Problem hat.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Bedingte Formatierung 5 Test007 741 15. Mai 2006, 08:24
< Peter > Bedingte Formatierung
Keine neuen Beiträge Excel Formeln: Bedingte Formatierung 8 Snewi 1129 09. Mai 2006, 21:13
Bonny Bedingte Formatierung
Keine neuen Beiträge Excel Formeln: bedingte Formatierung im nachbar Feld verändern 6 sisqonrw 1462 15. Apr 2006, 19:53
sisqonrw bedingte Formatierung im nachbar Feld verändern
Keine neuen Beiträge Excel Formeln: bedingte Formatierung mit Checkbox 5 Gast 2361 08. März 2006, 17:37
Zimbomann bedingte Formatierung mit Checkbox
Keine neuen Beiträge Excel Formeln: Formel oder Formatierung ?Zahlen in Tausend anzeigen? 5 tomate 9774 11. Feb 2006, 11:00
tomate Formel oder Formatierung ?Zahlen in Tausend anzeigen?
Keine neuen Beiträge Excel Formeln: MAX-Formel (bedingte Formatierung) 6 Tanja1980 5651 14. Jan 2006, 16:50
ae MAX-Formel (bedingte Formatierung)
Keine neuen Beiträge Excel Formeln: Bedingte Formatierung (Sonntage) 7 Gast 1138 08. Dez 2005, 15:07
fridgenep Bedingte Formatierung (Sonntage)
Keine neuen Beiträge Excel Formeln: Bedingte Formatierung -Fristüberwachung 4 xmichax 1863 22. Nov 2005, 20:18
xmichax Bedingte Formatierung -Fristüberwachung
Keine neuen Beiträge Excel Formeln: Summe nach bedingter Formatierung 4 les 1126 20. Sep 2005, 13:39
Thomas Ramel Summe nach bedingter Formatierung
Keine neuen Beiträge Excel Formeln: bedingte Formatierung 3 G.Koch 749 19. Sep 2005, 14:13
fridgenep bedingte Formatierung
Keine neuen Beiträge Excel Formeln: bedingte Formatierung ganze Zeile enfärben 2 skyblue 2516 06. Sep 2005, 12:41
skyblue bedingte Formatierung ganze Zeile enfärben
Keine neuen Beiträge Excel Formeln: bedingte Formatierung 5 Gonyzo 841 02. Sep 2005, 14:11
Willie bedingte Formatierung
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Word VBA