WORD 2010 - gespeicherte Textmarke verschwindet

Moderator: ModerationP

WORD 2010 - gespeicherte Textmarke verschwindet

Beitragvon KeGe » 09. Aug 2018, 10:44

Hallo,

sowas hatte ich noch nie:

Ein leeres Dokument. Ich setze eine Textmarke rein und speichere es. Textmarke ist brav da, wo sie sein soll.
Schließe ich das Dokument und öffne es wieder, ist die Textmarke weg.

Hat jemand eine Idee, woran das liegen könnte?

Ratlose Grüße von Kerstin
Benutzeravatar
KeGe
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 140
Registriert: 28. Jan 2014, 08:33

Re: WORD 2010 - gespeicherte Textmarke verschwindet

Beitragvon theoS » 09. Aug 2018, 13:26

Beginnt der Name mit einem _ ?
theo s.
Benutzeravatar
theoS
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 4251
Registriert: 19. Apr 2008, 00:14

Re: WORD 2010 - gespeicherte Textmarke verschwindet

Beitragvon KeGe » 10. Aug 2018, 06:29

Hallo Theo,

nein. Der Name der Textmarke ist "Antrag".

Ich versteh es nicht... :(

Gruß, Kerstin
Benutzeravatar
KeGe
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 140
Registriert: 28. Jan 2014, 08:33

Re: WORD 2010 - gespeicherte Textmarke verschwindet

Beitragvon halweg » 10. Aug 2018, 08:38

Was markiert die Textmarke? Was ist drumrum?
Ist das Ganze auf anderen Systemen reproduzierbar?
Office 2002, 2010; Windows 7, 10
Benutzeravatar
halweg
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 427
Registriert: 21. Okt 2010, 08:04
Wohnort: Dresden

Re: WORD 2010 - gespeicherte Textmarke verschwindet

Beitragvon KeGe » 10. Aug 2018, 10:21

Hallo,

es ist eine reine Textmarke, kein als Textmarke festgelegter Text.
Das Dokument ist leer. Nur die Textmarke "Antrag". Es ist ein Makro hinterlegt.

Ich habe versucht, das Dokument neu zu erstellen. Es trat der gleiche Effekt wieder auf.

Ich hab mir dann so beholfen, dass ich ein anderes, existierendes und funktionierendes (!) Dokument genommen und unter anderem Namen gespeichert habe.
Auch dieses Doc ist leer und enthält nur eine Textmarke und ein (bis auf ein paar Bezeichnungen identisches!) Makro. Aber hiermit gab und gibt es keine Probleme.

Das Problem ist also nicht gelöst, sondern nur umgangen, aber ich kann wenigstens erstmal weiter arbeiten.
Danke fürs Mitdenken. Falls jemandem einfällt, woran es liegen könnte, trotzdem her damit. :D

Viele Grüße, und schönes Wochenende!
Kerstin

Nachtrag: die Frage der Reproduzierbarkeit konnte ich nicht testen, da hier keiner die nötigen Zugriffe hat.
Benutzeravatar
KeGe
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 140
Registriert: 28. Jan 2014, 08:33

Re: WORD 2010 - gespeicherte Textmarke verschwindet

Beitragvon theoS » 10. Aug 2018, 13:29

Dann lad doch mal dieses mysteriöse Dok hoch.
Wenn außer der TM nichts drin ist, kannst du ja.
theo s.
Benutzeravatar
theoS
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 4251
Registriert: 19. Apr 2008, 00:14

Re: WORD 2010 - gespeicherte Textmarke verschwindet

Beitragvon KeGe » 29. Aug 2018, 10:43

Hallo Theo und Alle,

nachdem das Problem heute wieder massiv bei einem Dokument auftritt, lade ich eine anonymisierte Version dieses Dokuments hoch.
Es ist ein kurzes Makro hinterlegt, welches in verschiedenen Konstellationen jeweils einen bestimmten Text einfügen soll.

Die Textmarke "Text" ist das einzige, was im Dokument steht. Wenn es passiert wie bei mir, ist sie auch weg, wenn Ihr das Doc öffnet.
Ich bin gespannt - vor allem aber, ob jemand dahinter kommt, woran das liegt.

Ach ja, ich arbeite mit Word 2010, aber dem Dateiformat *.doc, weil unser Anwenderprogramm nur diese Dateien verarbeiten kann.

Danke schonmal und viele Grüße,
Kerstin

verschindende Textmarke.doc
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Benutzeravatar
KeGe
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 140
Registriert: 28. Jan 2014, 08:33

Re: WORD 2010 - gespeicherte Textmarke verschwindet

Beitragvon halweg » 29. Aug 2018, 11:02

Wenn ich in das Dokument eine leere Textmarke einfüge ,in .doc speichere und wieder aufrufe, ist diese tatsächlich weg.
Wenn ich mit Word 2010 ein neues Dokument erstelle, eine leere Textmarke einfüge, dieses als .doc speichere und wieder aufrufe, bleibt die Textmarke erhalten. Es scheint also etwas an dem Dokument zu sein, vielleicht eine ehemalige Vorlage (.dot)?
Du kannst also entweder
- die Textmarke über ein neues Dokument einfügen oder
- die leere Textmarke irgendwo mitten im Text verstecken, dann bleibt sie erhalten.
Office 2002, 2010; Windows 7, 10
Benutzeravatar
halweg
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 427
Registriert: 21. Okt 2010, 08:04
Wohnort: Dresden

Re: WORD 2010 - gespeicherte Textmarke verschwindet

Beitragvon KeGe » 29. Aug 2018, 11:04

Hi,

danke schonmal! Das probier ich dann gleich aus. Komischer Effekt.

Das Dokument war nie eine .dot, es wurde aus "Datei neu" mit einem leeren Blatt erstellt.

Viele Grüße, Kerstin
Benutzeravatar
KeGe
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 140
Registriert: 28. Jan 2014, 08:33

Re: WORD 2010 - gespeicherte Textmarke verschwindet

Beitragvon theoS » 29. Aug 2018, 15:01

Workarround?
Mach einen zweiten Absatz in das Dokument, dann bleibt zumindest bei mir die Marke bestehen.
Witzigerweise verschwindet die TM, wenn sie direkt am Anfang des allerersten Absatzes steht, wenn man danach z.B. in den zweiten Absatz was einfügt und die Absatzmarke löscht....
wenn aber Text dahinter steht, sei es auch nur ein Leezeichen, bleibt sie.
Also, das kannst du auch machen. Mach ein Leerzeichen dahinter. :mrgreen:
theo s.
Benutzeravatar
theoS
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 4251
Registriert: 19. Apr 2008, 00:14

Re: WORD 2010 - gespeicherte Textmarke verschwindet

Beitragvon KeGe » 30. Aug 2018, 05:44

Hallo Theo,

das ist ein guter Tip! Mit dem Leerzeichen. Das ist gut praktikabel, so werde ich das machen.

die leere Textmarke irgendwo mitten im Text verstecken, dann bleibt sie erhalten

Das hilft mir leider nicht, weil ich ja keinen Text in dem Dokument habe. Und das mit dem neu erstellen habe ich auch nicht hinbekommen, sie war immer weg.
Das Verrückte ist ja, dass es manchmal durchaus funktioniert hat.

Woran es letzten Endes liegt, wird man wohl nicht heraus bekommen.
Ich füge jetzt ein Leerzeichen ein, damit ist das Problem umgangen.

Danke Euch!
Viele Grüße, Kerstin
Benutzeravatar
KeGe
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 140
Registriert: 28. Jan 2014, 08:33

Re: WORD 2010 - gespeicherte Textmarke verschwindet

Beitragvon halweg » 30. Aug 2018, 08:39

Ich hatte mich erst gewundert, dass Theo meinen Tipp, die Textmarke nicht allein im Dokument stehen zu lassen, wiederholt, aber offensichtlich brauchte es des Hinweises, dass da bereits schon eine Absatzmarke oder ein Leerzeichen genügt.
Was mich aber interessieren würde: Wozu eine Textmarke in einem leeren Dokument? Was kann die Textmarke, was man nicht auch mit anderen Mitteln erreichen könnte?
Zuletzt geändert von halweg am 30. Aug 2018, 09:34, insgesamt 1-mal geändert.
Office 2002, 2010; Windows 7, 10
Benutzeravatar
halweg
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 427
Registriert: 21. Okt 2010, 08:04
Wohnort: Dresden

Re: WORD 2010 - gespeicherte Textmarke verschwindet

Beitragvon theoS » 30. Aug 2018, 09:07

halweg hat geschrieben:Ich hatte mich erst gewundert, dass Theo meinen Tipp, die Textmarke nicht allein im Dokument stehen zu lassen, wiederholt, aber offensichtlich brauchte es des Hinweises, dass da bereits schon eine Absatzmarke oder ein Lesezeichen genügt.
Was mich aber interessieren würde: Wozu eine Textmarke in einem leeren Dokument? Was kann die Textmarke, was man nicht auch mit anderen Mitteln erreichen könnte?

Das hast du dann aber sehr kryptisch formuliert. Das hätte ich aus deiner Antwort nicht rausgelesen :-)

Verstehe ich auch nicht so ganz, denn wenn die TM ganz am Anfang des Doks steht, kann man ja das gewünschte auch im Range einfügen. Vermute aber, dass da ein Programm drauf zugreift und die TM erwartet.
theo s.
Benutzeravatar
theoS
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 4251
Registriert: 19. Apr 2008, 00:14

Re: WORD 2010 - gespeicherte Textmarke verschwindet

Beitragvon KeGe » 31. Aug 2018, 08:24

Was mich aber interessieren würde: Wozu eine Textmarke in einem leeren Dokument? Was kann die Textmarke, was man nicht auch mit anderen Mitteln erreichen könnte?


Verstehe ich auch nicht so ganz, denn wenn die TM ganz am Anfang des Doks steht, kann man ja das gewünschte auch im Range einfügen.


Hallo,

gute Frage.
Mein Dilemma ist allgemein, dass ich VBA nie gelernt habe und mir mühsam alles nebenbei aneignen muss. Das im laufenden Betrieb, wo Dokumente funktionieren müssen, weil Dutzende Leute täglich damit arbeiten.

Ich muss sagen, mir ist gar nicht der Gedanke gekommen, eine andere Lösung als mit der Textmarke zu suchen - weil ich gar nicht wusste, dass es eine andere gibt. Wenigstens mit Textmarken kenn ich mich mittlerweile ganz gut aus.

kann man ja das gewünschte auch im Range einfügen

Kannst Du mir erklären, wie das geht? Dann hätte ich nebenbei gleich noch was gelernt, das ist ja immer gut.

Viele Grüße, Kerstin
Benutzeravatar
KeGe
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 140
Registriert: 28. Jan 2014, 08:33

Re: WORD 2010 - gespeicherte Textmarke verschwindet

Beitragvon DerHoepp » 31. Aug 2018, 08:59

Moin Kerstin,

Kannst Du mir erklären, wie das geht?

Dazu müsste man eigentlich wissen, was du vorhast. Aus der Außensicht macht es eben kein Sinn, in einem leeren Dokument eine Textmarke vorzuhalten. Du kannst einfach in das ansonsten leere Dokument schreiben. Und das sowohl händisch, als auch per VBA.

Also bleibt halwegs Frage:
Wozu eine Textmarke in einem leeren Dokument? Was kann die Textmarke, was man nicht auch mit anderen Mitteln erreichen könnte?


Viele Grüße
derHöpp
DerHoepp
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 7141
Registriert: 14. Mai 2013, 11:08

Nächste

Zurück zu Word Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste