Mittelwert X Jahre aufgrund von X Jahren Vergangenheit

Moderator: ModerationP

Mittelwert X Jahre aufgrund von X Jahren Vergangenheit

Beitragvon Arne84 » 06. Okt 2017, 14:17

Liebe Excelfreaks :-)

Ich hoffe ihr könnt mir helfen. Ich stehe gerade auf dem Schlauch und komme nicht weiter. Es könnte auch daran liegen, dass Freitag ist und die Luft raus ist.

Folgendes Problem:

Ich möchte den Mittelwert für X Jahre berechnen lassen aufgrund der letzten X Jahre wobei Excel X Jahre zurückrechnet von Heute an. Oder Anders dargestellt:

Tabellenblatt 1:

Spalte A B C

A Arbeitsjahre / Inflation 38 2,20%
B Arbeitsjahre / Inflation 41 2,30%

Tabellenblatt 2 Inflationsrate:

A B

Jahr Rate
1951 7,8%
1952 2,1%
1953 -1,7%
1954 0,4%
1955 1,4%
1956 2,8%
1957 2,0%
1958 2,3%
1959 0,6%
1960 1,6%
1961 2,5%
1962 2,8%
1963 3,0%
1964 2,4%
1965 3,2%
1966 3,3%
1967 1,9%
1968 1,6%
1969 1,8%

Tabellenblatt 2 ist nur ein Auszug. Ich möchte einfach, dass bei Tabellenblatt 1 Spalte C der Mittelwert aus Tabellenblatt 2 Inflation Spalte B für die letzten 38 Jahre aus Tabellenblatt 1 genommen wird von heutigen Datum z.B. 2017 und dann 38 Jahre zurück ( 2017 - 1979 ). Und der Mittelwert soll sich automatisch anpassen, wenn ich die Anzahl der Jahre ändere auf 20 oder 40 oder oder oder....

Habt ihr eine Idee wie man das hinbekommen könnte? Ich denke Wahrscheinlich wieder zu kompliziert....

Vielen Dank für eure Unterstützung

:-)
Arne84
 

Re: Mittelwert X Jahre aufgrund von X Jahren Vergangenheit

Beitragvon hiob » 06. Okt 2017, 14:29

Hallo, so z.B.:
=MITTELWERT(B2:INDEX($B$2:$B$100;F2)) in F2 steht die Zahl der Jahre...
hiobs botschaft gespickt mit
halbgarem hintergrundwissen
Benutzeravatar
hiob
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 4810
Registriert: 14. Jun 2010, 09:36

Re: Mittelwert X Jahre aufgrund von X Jahren Vergangenheit

Beitragvon neopa » 06. Okt 2017, 14:37

Hallo Arne,

wenn in D1 die Anzahl X der letzten Jahre eingeben wird, dann in E1 allgemein so:

=MITTELWERT(INDEX(B:B;ZEILE(INDEX(A:A;VERGLEICH(MAX(JAHR(HEUTE())-D1;A2);A:A)))):INDEX(B:B;VERGLEICH(JAHR(HEUTE())-1;A:A)))
Gruß Werner
.. , - ...
neopa
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 9611
Registriert: 03. Mai 2008, 15:57
Wohnort: zu Hause in C


Zurück zu Excel Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: sonne5 und 12 Gäste