Alternative zu Zählenwenns?

Moderator: ModerationP

Alternative zu Zählenwenns?

Beitragvon natitris » 13. Jan 2018, 15:17

Hallo!

Ich führe für meinen Musikverein eine Anwesenheitsliste, die ich gerne immer gemäß dem heutigen Datum aktualisiert haben möchte.
Dabei möchte ich auch mehrere Zeilen nach einem Kriterium durchsuchen und zählen lassen:

=ZÄHLENWENN(H17:BI25;"A")/(ZÄHLENWENNS(H17:BI25;"*";$H$2:$BI$2;"<="&HEUTE())-ZÄHLENWENNS(H17:BI25;"-";$H$2:$BI$2;"<="&HEUTE()))

Konkret funktioniert folgende Formel nicht, da die Bereiche ja nicht gleich groß sind:
=ZÄHLENWENNS(H17:BI25;"*";$H$2:$BI$2;"<="&HEUTE())

Summenprodukt hätte ich auch probiert, aber das Ergebnis (0) stimmt auch nicht:
=SUMMENPRODUKT((H17:BI25="*")*($H$2:$BI$2="<="&HEUTE()))

Welche Alternativen gibt es noch?

Vielen Danke im Voraus!
Zuletzt geändert von natitris am 17. Jan 2018, 12:57, insgesamt 1-mal geändert.
natitris
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 4
Registriert: 13. Jan 2018, 14:45

Re: Alternative zu Zählenwenns?

Beitragvon Hajo_Zi » 13. Jan 2018, 15:19

Hochgeladene Bilder können zwar als solche in Excel importiert werden, sind jedoch bei der Lösung von Problemen nicht sehr hilfreich, da man die eigentlichen Daten nicht ohne große und zeitraubende Umwege direkt in die Tabelle übertragen kann.
<a href="http://www.excel-ist-sexy.de/bilder-statt-datei/" target="_blank" title="Bild in Datei">Schau mal hier</a>
Eine hochgeladene Arbeitsmappe erhöht die Wahrscheinlichkeit, dass Du eine Lösung für Dein Problem erhältst.
Erstelle folglich bitte eine Demomappe, aus der deine Aufgabenstellung klar erkennbar ist und lade diese Mappe mit einem aussagekräftigen Dateinamen hoch.
Der Name einer hochgeladenen Mappe wird im Beitrag automatisch angezeigt, sodass es bei Verwendung von aussagekräftigen Namen leichter fällt, sie später im Ablageordner wiederzufinden und sie gedanklich einem bestimmten Thema zuzuordnen. Namen wie Muster*, Test*, Mappe*, Beispiel*, Fehler*, Kalender*, UserForm* usw. sind so allgemein, dass eine Zuordnung zu einem Thema unmöglich gemacht wird.
Es sollte ein aussagekräftiger Name sein.
Wenn du an Stelle einer Demomappe deine Originalmappe hochladen willst, diese aber sensible Daten enthält, solltest du diese Daten anonymisieren bzw. pseudonymisieren.
Falls Du den Download des Forums nicht benutzen möchtest beachte bitte: von unsicheren Servern file-upload lade ich keine Datei herunter (lt. Einschätzung meines Virenprogramms)

Gruß Hajo
Signatur
Bitte Version angeben. Bei keiner Angabe gehe ich von meinen Angaben aus.
Office 2016 Plus - 32 Bit.
Da die Mailbenachrichtigung bei mir nicht geht. Weitere Antworten dem Zufall überlassen.
Falls lange keine Antwort kommt, PN.
Benutzeravatar
Hajo_Zi
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 3527
Registriert: 31. Jan 2004, 18:26
Wohnort: Straubing

Re: Alternative zu Zählenwenns?

Beitragvon neopa » 13. Jan 2018, 17:31

Hallo,

ungetestet so =SUMMENPRODUKT((H17:BI25<>"")*($H$2:$BI$2="<="&HEUTE()))
Gruß Werner
.. , - ...
neopa
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 9927
Registriert: 03. Mai 2008, 15:57
Wohnort: zu Hause in C

Re: Alternative zu Zählenwenns?

Beitragvon BoskoBiati » 14. Jan 2018, 09:02

Hi,

warum nicht so:

Code: Alles auswählen
=SUMMENPRODUKT((H17:BI25<>"")*($H$2:$BI$2<=HEUTE()))
Gruß

Bosko

Ich würde mich freuen zu erfahren, ob ich helfen konnte.
BoskoBiati
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 8170
Registriert: 26. Jul 2009, 21:46

Re: Alternative zu Zählenwenns?

Beitragvon neopa » 14. Jan 2018, 14:05

Hallo Edgar,

Du hast völlig Recht. Ich hatte den zweiten Teil der Formel im Kopf zwar auch abgeändert aber irgendwie muss ich dies vergessen haben vor dem Absenden auch wirklich zu tun.
Gruß Werner
.. , - ...
neopa
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 9927
Registriert: 03. Mai 2008, 15:57
Wohnort: zu Hause in C

Re: Alternative zu Zählenwenns?

Beitragvon natitris » 17. Jan 2018, 01:46

Hallo nochmal!

Danke für eure Hilfe!
Hat geklappt!
Ich versteh nur nicht ganz, warum es mit <>"" funktioniert und mit ="*" nicht…wo liegt da der unterschied?

Und ich hab dann erkannt, dass eigentlich für eine Gesamtübersicht meiner Tabelle nur nur jene Zellen, die einen beliebigen Text enthalten gezählt werden dürfen…
Code: Alles auswählen
=ZÄHLENWENN(H12:BH94;"A")/(SUMMENPRODUKT((H12:BI94<>"")*($H$2:$BI$2<=HEUTE()))-SUMMENPRODUKT((H12:BI94="-")*($H$2:$BI$2<=HEUTE())))


oder kann es sein, dass Zellen, deren Ergebnis #DIV/0 ist, meine aktuelle Funktion durcheinanderbringen?
da gibt es im Bereich H12:BI94 nämlich mehrere…
Zuletzt geändert von natitris am 17. Jan 2018, 12:58, insgesamt 1-mal geändert.
natitris
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 4
Registriert: 13. Jan 2018, 14:45

Re: Alternative zu Zählenwenns?

Beitragvon RPP63 » 17. Jan 2018, 07:43

Moin!
Der Asterisk * funktioniert halt nicht überall.

Du hast jetzt 400 Kb Forenspeicherplatz "verplempert".
Das entspricht ca. 30-40 Demodateien.
Lösche bitte Deine Screenshots und lade eine aufs wesentliche gekürzte .xlsx hoch.

Gruß Ralf
Benutzeravatar
RPP63
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 9784
Registriert: 19. Okt 2012, 17:41
Wohnort: mitten im Pott

Re: Alternative zu Zählenwenns?

Beitragvon BoskoBiati » 17. Jan 2018, 08:43

Hi,

1. eliminiere die #Div/0, indem Du eine Fehlerroutine in die entsprechenden Formeln einbaust.
2. SUMMENPRODUKT kann nicht mit Wildcards arbeiten, das geht dann nur über z.B. Istzahl(suchen(....
Gruß

Bosko

Ich würde mich freuen zu erfahren, ob ich helfen konnte.
BoskoBiati
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 8170
Registriert: 26. Jul 2009, 21:46

Re: Alternative zu Zählenwenns?

Beitragvon natitris » 17. Jan 2018, 19:04

Hallo nochmal!

Könnt ihr mir ein konkretes Beispiel zur Lösung geben?
Ich check nicht, wie ich eine Fehlerroutine einbaue…

Es geht um Zelle E4 - dort soll der Anteil der anwesenden MusikerInnen (A) berechnet werden.
vgl. E26 - nur gibt es dort keine Zelle, die #DIV/0 enthält - bei der Formel in Zelle E4 jedoch schon…
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
natitris
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 4
Registriert: 13. Jan 2018, 14:45


Zurück zu Excel Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: HabNochKeinen und 25 Gäste