makro summieren

Moderator: ModerationP

makro summieren

Beitragvon gast1234123412341234 » 16. Jan 2018, 09:35

hallo zusammen,
ich bin ein absoluter vba einsteiger. Ich möchte summen bilden wenn bestimmte wert übereinstimmen:

A B C
ab 1 9
ab 2
ab 6

ac 7 8
ac 1
ad 2 11
ad 9

ab 8 15
ab 7


Also in Spalte A steht eine Bezeichnung in Spalte B stehen Werte in Spalte C solle das Ergebnis stehen wie im Beispiel.

Also ich hab eine Tabelle mit Spalte A und B und Spalte C soll durch das Makro ausgefüllt werden. Das Makro soll eine Summe bilden und in die erste Spalte neben der gleichbleibenden Bedingung schreiben solange der Text in B untereinandergeschrieben gleich bleibt. (Siehe oben)

ich glaube ist kein Hexenwerk aber ich bekomme es leider nicht hin.

Vielen dank schonmal
gast1234123412341234
 

Re: makro summieren

Beitragvon Klaus-Dieter » 16. Jan 2018, 10:25

Hallo,

dazu brauchst du kein Makro. Das kann man mit der Standardfunktion Teilergebnis wunderbar lösen. Siehe Beispieldatei.
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Viele Grüße
Klaus-Dieter
Lösungsvorschläge sind, wenn es keinen anders lautenden Hinweis gibt, von mir getestet.
Künstliche Intelligenz ist besser als natürliche Dummheit.
Benutzeravatar
Klaus-Dieter
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 17220
Registriert: 27. Nov 2003, 23:03
Wohnort: Sassenburg

Re: makro summieren

Beitragvon Gast » 16. Jan 2018, 10:55

Vielen Dank für die Antwort!
Gast
 

Re: makro summieren

Beitragvon hddiesel » 16. Jan 2018, 12:58

Hallo Gast,

wenn du mit deinen Daten in der Zeile 2 beginnst, dann folgende Formel in C2 und nach Unten ziehen.
Code: Alles auswählen
=WENN($A1<>$A2;SUMME($B$2:$B$200)-(SUMME($B$1:$B1)+SUMME($C3:$C$200));"")
Mit freundlichen Grüssen
Karl

BS: Windows 10_64-Bit, MS Office Professional Plus 2016_32-Bit
Benutzeravatar
hddiesel
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 3158
Registriert: 17. Feb 2006, 11:40
Wohnort: Deutschland


Zurück zu Excel Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: chakko, Deep-Mirror, lupo1, Michiael, steve1da, Twiti und 18 Gäste