Wochentag berechnen FORMEL

Moderator: ModerationP

Wochentag berechnen FORMEL

Beitragvon Chris29041986 » 02. Dez 2020, 11:54

Hallo,

vielleicht kann mir jemand weiter helfen, ich habe folgende Formel um mir "Montag - Freitag" die Anzahl der Zellen mit bestimmten Text ausrechnen zu lassen:
Code: Alles auswählen
=SUMMENPRODUKT((O11:AS11=$DP$11:$DP$500)*(WOCHENTAG($O$7:$AS$7;2)<=5))


O11:AS11 = Text
DP11:DP500 = Filter für den zu zählenden Text in den Zellen z.B. "Heinz"
O7:AS7 = Inhalt der Zellen: z.B. 01.02.2021 / Format: Datum

diese funktioniert auch sehr gut, allerdings habe ich jetzt das Problem das wenn z.B. in den letzten 3 Zellen von O7:AS7 kein Datum steht und die Zelle leer ist wird mir die Formel mit #WERT! angezeigt.

Kennt jemand evtl. eine Lösung wie ich es hinbekommen kann ohne die leeren Zellen aus O7:AS7 entfernen zu müssen, da diese sich je nach Monat oder Jahr auch mal ändern können so das z.B. nur 2 Zellen leer sind eine oder gar keine.
Kann man der Formel sagen das sie die leeren Zellen ignorieren soll?

Gerne stelle ich auch ein Excel-Muster zur Verfügung da es sich jetzt schon sehr kompliziert anhört.

Mit freundlichen Grüßen
Chris
Windows 10 Home / Microsoft Office Professional Plus 2016 (64-Bit)
Benutzeravatar
Chris29041986
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 337
Registriert: 26. Mär 2014, 10:09

Re: Wochentag berechnen FORMEL

Beitragvon steve1da » 02. Dez 2020, 11:59

Hola,

wenn die Zellen wirklich leer sind erscheint kein #WERT. Ich rate mal: da steht eine Formel in der Zelle.

Gruß,
steve1da
Benutzeravatar
steve1da
Moderator
 
Beiträge: 30813
Registriert: 24. Sep 2003, 10:54

Re: Wochentag berechnen FORMEL

Beitragvon Chris29041986 » 02. Dez 2020, 12:05

Hi steve1da,

ja genau da steht eine Formel "Verknüpfung mit einer anderen Tabelle" Wenn in der Tabelle ein Datum steht wird das Datum angezeigt, wenn dort kein Datum steht zeigt die Formel "" bzw. keinen Eintrag.

sowas: =WENN('Datensätze Worksheet 01'!AD17;'Datensätze Worksheet 01'!AD17;"")

Grüße
Chris
Windows 10 Home / Microsoft Office Professional Plus 2016 (64-Bit)
Benutzeravatar
Chris29041986
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 337
Registriert: 26. Mär 2014, 10:09

Re: Wochentag berechnen FORMEL

Beitragvon steve1da » 02. Dez 2020, 12:30

Hola,

änder das in:
=WENN('Datensätze Worksheet 01'!AD17;'Datensätze Worksheet 01'!AD17;0)
ab. Die 0 kannst du ausblenden wenn du magst:
https://support.microsoft.com/de-de/off ... eitert.,(0)%20in%20Zellen%20einzublenden.

Gruß,
steve1da
Benutzeravatar
steve1da
Moderator
 
Beiträge: 30813
Registriert: 24. Sep 2003, 10:54

Re: Wochentag berechnen FORMEL

Beitragvon shift-del » 02. Dez 2020, 12:32

Moin

=SUMMENPRODUKT(--(O11:AS11=$DP$11:$DP$500);--(WOCHENTAG($O$7:$AS$7;2)<=5))
Ungetestet.
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Benutzeravatar
shift-del
Moderator
 
Beiträge: 21379
Registriert: 25. Jan 2009, 22:54
Wohnort: Ehemaliges Fabrikgelände

Re: Wochentag berechnen FORMEL

Beitragvon Chris29041986 » 02. Dez 2020, 12:40

danke für die Antworten, melde mich noch mal wenn ich es ausprobiert habe :)

Edit:
@steve1da:
das abändern von "" auf 0 hat es gebracht :) hab dann einfach über Bedingte Formatierungen den Inhalt 0 auf Hintergrundfarbe gesetzt, so ist diese auch ausgeblendet.

@shift-del:
das abändern der Formel hat mir immer noch #WERT! angezeigt.

Vielen Dank für eure Hilfe!

Grüße
Chris
Windows 10 Home / Microsoft Office Professional Plus 2016 (64-Bit)
Benutzeravatar
Chris29041986
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 337
Registriert: 26. Mär 2014, 10:09

Re: Wochentag berechnen FORMEL

Beitragvon HKindler » 02. Dez 2020, 13:40

Hi,
Chris29041986 hat geschrieben:hab dann einfach über Bedingte Formatierungen den Inhalt 0 auf Hintergrundfarbe gesetzt, so ist diese auch ausgeblendet.

Gib den Zellen besser das Zellformat "TT.MM.JJJJ;;;@" oder "[=0]"";TT.MM.JJJJ" Bei der ersten Variante werden negative Werte und 0-Werte unterdrückt, bei der zweiten Variante werden nur 0-Werte unterdrückt.

Wieso das besser ist? Eine bedingte Formatierung kostet erstens relativ viel Rechenzeit (siehe https://www.online-excel.de/excel//singsel.php?f=172) und zweitens musst du beim Ändern der Hintergrundfarbe daran denken die bedingte Formatierung auch anzupassen.
Gruß,
Helmut

----------------------------
Windows 10 Enterprise (64 Bit) / Office 365 ProPlus (32 Bit)
Benutzeravatar
HKindler
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 5338
Registriert: 04. Jul 2013, 09:02

Re: Wochentag berechnen FORMEL

Beitragvon Chris29041986 » 02. Dez 2020, 22:37

Danke Helmut, hab es abgeändert, die Aussage das bedingte Formatierungen viel Rechenzeit benötigen war mir nicht wirklich bewusst.

Grüße
Chris
Windows 10 Home / Microsoft Office Professional Plus 2016 (64-Bit)
Benutzeravatar
Chris29041986
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 337
Registriert: 26. Mär 2014, 10:09


Zurück zu Excel Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: Grace13, volti und 4 Gäste