Abfrage Ergebnis

Moderator: ModerationP

Abfrage Ergebnis

Beitragvon schlauerstromer » 30. Sep 2019, 07:36

Bei meiner Abfrage kommt es zu einem komischen Fehler.

Ich berechne den Ertrag aus [Verkaufspreis]-[Einkaufspreis] in einer Abfrage

Das funktioniert soweit sehr gut. Allerdings kommt es ab und an vor, dass das Ergebnis falsch angezeigt wird

Datensatz 1: 40,00 € - 30,00 € = 10,00 €
Datensatz 2: 40,00 € - 40,00 € = 0,00 €
Datensatz 3: 40,00 € - 40,00 € = 0,00 €


klicke ich jetzt in das Ergebnisfeld von Datensatz 3 wird aus der "0,00 €" die Zahl "1,70323E-14".
Verlasse ich das Feld steht wieder die 0,00€ darin.

Klicke ich auf Datensatz 2 in das Ergebnisfeld bleibt der Wert unverändert auf "0,00 €"

Was übersehe ich da? Kennt jemand das Verhalten?
schlauerstromer
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 11
Registriert: 30. Okt 2008, 13:36

Re: Abfrage Ergebnis

Beitragvon KlausMz » 30. Sep 2019, 07:40

Hallo,
welche Datentypen sind für die beiden Felder in der Tabelle eingestellt ?

PS;
Das ist kein Fehler, das sind Ungenauigkeiten die sich durch das Fließkommasystem ergeben. Daher die Frage nach den Datentypen.
Die angezeigte Zahl "1,70323E-14" sieht ja in gewohnter Darstellung so aus:
0,0000000000000170323 und der Unterschie ist eigentlich nur unschön, aber (fast) ohne Bedeutung.
Gruß
Klaus . . . . . Feedback wäre wünschenswert.
Ich möchte bitte keine unaufgeforderten PN. Fragen bitte im Forum.
Benutzeravatar
KlausMz
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 39169
Registriert: 06. Okt 2003, 15:09
Wohnort: Irgendwo in der Pfalz


Zurück zu Access Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 6 Gäste