Index und vergleich mit mehrere Treffer verarbeiten

Moderator: ModerationP

Index und vergleich mit mehrere Treffer verarbeiten

Beitragvon Andreas D. » 13. Jan 2019, 16:09

Hallo,
Ich habe eine Tabelle mit Lehrgängen die ich je Person mit 1(ja) 0 (nein) dokumentiert habe:
B1 B2 B3 B4
A1 Lehrgang1 Lehrgang 2 Lehrgang3 Lehrgang 4
A2 Anton 1 0 0 1

Anton hat also Lehrgang 1 und 4 erledigt aber Lehrgang 2 und 3 noch nicht gemacht!
Ich würde jetzt gerne die noch zu erledigenden Lehrgänge in eine Zelle (Beispiel B6) Auflisten!
Also: in Zelle B6 steht dann: Lehrgang 2 / Lehrgang3
Ich habe das ganze mit INDEX und Vergleich versucht damit finde ich aber immer nur die erste "0"
Beispiel:
Code: Alles auswählen
=INDEX(B1:E1;1;VERGLEICH(0;B2:E2;0))

Ergebis leider nur: Lehrgang 2
Da ich viele Personen habe müsste es zu herunterziehen sein!
Ich komme alleine nicht drauf habe schon ewig gesessen. . . .
Vielen Dank für Eure Hilfe
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Andreas D.
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 101
Registriert: 14. Jan 2008, 11:09
Wohnort: BSA

Re: Index und vergleich mit mehrere Treffer verarbeiten

Beitragvon steve1da » 13. Jan 2019, 16:11

Benutzeravatar
steve1da
Moderator
 
Beiträge: 28533
Registriert: 24. Sep 2003, 10:54

Re: Index und vergleich mit mehrere Treffer verarbeiten

Beitragvon Andreas D. » 13. Jan 2019, 16:14

Danke. . . . genau diese habe ich beim Googlen auch schon gesehen, konnte sie aber für mich nicht entspr. umwandeln
Andreas D.
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 101
Registriert: 14. Jan 2008, 11:09
Wohnort: BSA

Re: Index und vergleich mit mehrere Treffer verarbeiten

Beitragvon steve1da » 13. Jan 2019, 16:22

Hola,

muss das alles unbedingt in eine Zelle? Bei xls gehe ich davon aus, dass du noch Excel 2003 oder älter benutzt?

Gruß,
steve1da
Benutzeravatar
steve1da
Moderator
 
Beiträge: 28533
Registriert: 24. Sep 2003, 10:54

Re: Index und vergleich mit mehrere Treffer verarbeiten

Beitragvon Andreas D. » 13. Jan 2019, 16:44

nicht unbedingt! Sollte aber dann horizontal weiter gehen da in der nächsten Zeile eine neue Peron kommt also: B6, B7, B8. . .
Excel 2010
Andreas D.
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 101
Registriert: 14. Jan 2008, 11:09
Wohnort: BSA

Re: Index und vergleich mit mehrere Treffer verarbeiten

Beitragvon steve1da » 13. Jan 2019, 16:47

Hola,

Code: Alles auswählen
=WENNFEHLER(INDEX($B$1:$E$1;AGGREGAT(15;6;SPALTE($B$1:$E$1)-1/($B2:$E2=0);SPALTE(A1)));"")

Gruß,
steve1da
Benutzeravatar
steve1da
Moderator
 
Beiträge: 28533
Registriert: 24. Sep 2003, 10:54

Re: Index und vergleich mit mehrere Treffer verarbeiten

Beitragvon Andreas D. » 13. Jan 2019, 19:08

Danke , ich versuche es gleich mal. . . . .würde die Formel natürlich auch gern verstehen aber "Aggregat" habe ich noch nie benutzt!. . . .ich probieren mal aus! . . . :roll: ja immer die blutigen Anfänger!
Andreas D.
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 101
Registriert: 14. Jan 2008, 11:09
Wohnort: BSA

Re: Index und vergleich mit mehrere Treffer verarbeiten

Beitragvon Andreas D. » 13. Jan 2019, 20:19

Danke steve1da,
deine Formel klappt in der Test.xis SUPER!

Aber wenn ich es meine Tabelle kopiere klappt etwas nicht, ich hätte dir gleich die richtige Tabelle senden sollen, da ich zu wenig Erfahrung mit diesen komplexen Tabellenfunktionen habe!
vielleicht könntest du mir nochmal auf die "SPRÜNGE" helfen!? Danke . . . . .ist eine Tabelle für die Feuerwehr
Formel soll in CD3 , CD4. usw. . .stehen
Der Anzeigebereich wäre nur $X$1:$BP$1
der Vorgabebereich wäre nur $X$3:$BP$3

zur Zeit beginnt die Formel mit: Lehrgang "GABC-Dekontamination P"
richtig wäre jedoch die erste mögliche Fortbildung: Fortbildung für Maschi. Fahrsicherheit ADAC usw. . . .

Sorry da fehlt mit einfach zu viel Input. . . .
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Andreas D.
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 101
Registriert: 14. Jan 2008, 11:09
Wohnort: BSA

Re: Index und vergleich mit mehrere Treffer verarbeiten

Beitragvon hiob » 13. Jan 2019, 23:00

Hallo, versuch mal so..:

Code: Alles auswählen
=WENNFEHLER(INDEX($X$1:$BP$1;AGGREGAT(15;6;SPALTE($X$1:$BP$1)-23/($X$3:$BP$3=0);SPALTE(A1)));"")


SPALTE(...) nach 15;6; muss mit 1 beginnen...
hiobs botschaft gespickt mit
halbgarem hintergrundwissen
Benutzeravatar
hiob
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 4892
Registriert: 14. Jun 2010, 09:36

Re: Index und vergleich mit mehrere Treffer verarbeiten

Beitragvon Andreas D. » 14. Jan 2019, 14:58

Danke es klappt......
1000 Dank für deine Hilfe...
Andreas D.
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 101
Registriert: 14. Jan 2008, 11:09
Wohnort: BSA


Zurück zu Excel Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot], Hajo_Zi, lupo1, Silverstream, TommyDerWalker und 17 Gäste