Veränderung zum Vormonat kennzeichnen

Moderator: ModerationP

Veränderung zum Vormonat kennzeichnen

Beitragvon noalts » 14. Feb 2019, 10:15

Hallo zusammen,

wie kann ich zwei Arbeitsblätter miteinander vergleichen und auf dem 2. Arbeitsblatt die veränderten Werte zum 1. Arbeitsblatt markieren?

Konkret habe ich im ersten AB eine Tabelle mit bezahlten Gebühren(Z2-Z177) für Dienstleistungen im Januar.
Im zweiten AB ist eineTabelle mit bezahlten Gebühren (Z2-Z179) für Dienstleistungen im Februar. Hier haben aber jetzt Leute gekündigt oder sich angemeldet, so dass die Zeilenzahl und auch die Position der Zeilen variieren.
Ich kann also nicht einfach die Gebührenspalten miteinander vergleichen. Um so die gesamte Zeile zu formatieren.(=$Z2<>'01'!$Z2)

Bin für Jede Hilfe dankbar.

Grüße

noalts
noalts
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 43
Registriert: 23. Apr 2015, 11:02

Re: Veränderung zum Vormonat kennzeichnen

Beitragvon steve1da » 14. Feb 2019, 10:18

Hola,

lade bitte eine Beispieldatei hoch (kein Bild).

Gruß,
steve1da
Benutzeravatar
steve1da
Moderator
 
Beiträge: 28535
Registriert: 24. Sep 2003, 10:54

Re: Veränderung zum Vormonat kennzeichnen

Beitragvon Ralf A » 14. Feb 2019, 10:23

Hi noalts,

bei einem vernünftigem Aufbau lässt sich das durchaus vergleichen. Z, Bsp. über eine Auftrags-, Rechnungs, oder Kundennummer mittels Verweisfunktionen und bedingter Formatierung. Aber bei Deiner pauschalen Beschreibung, ohne genaue Kenntnis Deiner Tabellen kann hier auch keine konkrete Antwort gegeben werden...
Ciao, Ralf
Der sicherste Ansatz für einen Irrtum ist der Glaube, alles im Griff zu haben.

Bild
Ralf A
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 332
Registriert: 17. Mär 2018, 11:47

Re: Veränderung zum Vormonat kennzeichnen

Beitragvon noalts » 14. Feb 2019, 11:25

Vielen Dank schon mal für die schnellen Rückmeldungen.

Hier die Beispieldatei.

VergleichsTabelle.xlsx


Schulze wird natürlich markiert, obwohl sich der Betrag nicht ändert.

Die Sortierung der Tabelle soll aber leider zwingend so aussehen auch im Hinblick auf 03 später...:)

Danke
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
noalts
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 43
Registriert: 23. Apr 2015, 11:02

Re: Veränderung zum Vormonat kennzeichnen

Beitragvon DerHoepp » 14. Feb 2019, 11:38

Hi,

Schulze wird natürlich markiert, obwohl sich der Betrag nicht ändert.

Warum? was ist die logik dahinter?

auch im Hinblick auf 03 später

Ich ahne, dass das ganze sowas wie Monatstabellen werden sollen. Richtig?

In dem Fall pack lieber alles in eine Tabelle, setze ein Monats / Datumskennzeichen in eine extra spalte und Werte mit einer Formel / einer Pivottabelle aus.

Viele Grüße
derHöpp
DerHoepp
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 7648
Registriert: 14. Mai 2013, 11:08

Re: Veränderung zum Vormonat kennzeichnen

Beitragvon HKindler » 14. Feb 2019, 11:52

Hi,

grundsätzlich stimme ich demHöpp zu!

Wenn du wieder besseren Wissens an der Struktur festhalten willst: Mach in 02 eine weitere Spalte "alte Gebühr", diese ist zwar nicht unbedingt notwendig, macht dir die Pflege und Kontrolle aber wesentlich einfacher. Wenn die Spalte dir nicht gefällt, kannst du sie ja ausblenden.
In die Spalte kommt die Formel =SVERWEIS([@Nummer];Tabelle1[[Nummer]:[Gebühr]];2;FALSCH). Damit hast du dir die alten Werte in die aktuelle Tabelle geholt.
Die Formel für die bedingte Formatierung ist nun =$C2<>$D2 (wenn D die neue Spalte ist). Damit werden aber nur Zeilen markiert, die wirklich unterschiedlich sind. Zeilen, bei denen kein Wert gefunden wird, also bei denen in "alte Gebühr" ein #NV steht, werden nicht gekennzeichnet. Soll dies auch geschehen, dann ändere die Formel in der bed.For. auf =WENNFEHLER(=$C2<>$D2;WAHR)

Achso: Das Ganze funktioniert natürlich nur, wenn die Spalte Nummer nur eindeutige Werte hat.

EDIT: letzte Formel korrigiert!
Zuletzt geändert von HKindler am 14. Feb 2019, 13:56, insgesamt 2-mal geändert.
Gruß,
Helmut

----------------------------
Windows 10 Enterprise (64 Bit) / Office 365 ProPlus (32 Bit)
Benutzeravatar
HKindler
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 2866
Registriert: 04. Jul 2013, 09:02

Re: Veränderung zum Vormonat kennzeichnen

Beitragvon noalts » 14. Feb 2019, 13:42

Super, Herr Höpp und HKindler, vielen Dank. :)

Pivotauswertungen sind in Arbeit, wird aber noch dauern.
Bis dahin werde ich die Hilfsspalten-Lösung verwenden.

Wie immer, beste Beratung hier.


Danke

Grüße

N
noalts
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 43
Registriert: 23. Apr 2015, 11:02

Re: Veränderung zum Vormonat kennzeichnen

Beitragvon HKindler » 14. Feb 2019, 13:57

Hi,

stelle gerade fest, dass ich in meiner letzten Formel noch einen Fehler hatte. Ich hatte das WAHR vergessen. Korrekt muss sie so lauten: =WENNFEHLER(=$C2<>$D2;WAHR)
Ich habe das oben mal korrigiert.
Gruß,
Helmut

----------------------------
Windows 10 Enterprise (64 Bit) / Office 365 ProPlus (32 Bit)
Benutzeravatar
HKindler
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 2866
Registriert: 04. Jul 2013, 09:02


Zurück zu Excel Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: Ivan 16, Maddin7, Mpro70, Trama und 31 Gäste