Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Die Suche hat 155 Ergebnisse ergeben.
Seite 1 von 11 Gehe zu Seite 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11  Weiter
Index
Autor Nachricht
  Thema: Bedingte Formatierung wird nicht automatisch aktualisiert 
HKindler

Antworten: 6
Aufrufe: 61

BeitragForum: Excel Formate   Verfasst am: 29. Apr 2014, 14:47   Titel: AW: Bedingte Formatierung wird nicht automatisch aktualisier Version: Office 2010
Hallo derhenry,

wahrscheinlich ist die Eigenschaft "EnableFormatConditionsCalculation" des betreffenden Tabellenblatts nicht auf True gesetzt. Entweder setzt du diese Eigenschaft im VBA-Editor unter Eigenschaften der Tabelle diese Eigenschaft auf True. Das Ganze muss nur einmalig für jedes Tabellenblatt genacht werden. Oder du verwendest folgendes Makro (auch nur einmalig):

Sub BedingteFormatierungHeilen()
'Setzt .EnableFormatConditionsCalculation auf True
'Beim Konvertieren von .xls nach .xlsx oder .xlsm wird dieses Flag nicht automatisch gesetzt.
'Dies führt dazu, dass bedingte Formatierungen zum Teil nicht richtig laufen.
'Hiermit wird dieser Zustand für die einzelnen Blätter dauerhaft aingestellt.
Dim ws As Worksheet, wb As Workbook
Dim i As Integer
Dim i2 As Integer
Dim Namen As String
Dim Namen2 As String
For Each wb In Workbooks
If Not (wb.Name = "PERSONL.XLS" Or wb.Name = "PERSONAL.XLSB") Then
If ( ...
  Thema: Excel Namen definiert, Namen löschen 
HKindler

Antworten: 11
Aufrufe: 154

BeitragForum: Excel Formate   Verfasst am: 22. Apr 2014, 11:08   Titel: AW: Excel Namen definiert, Namen löschen Version: Office 2011 (Mac)
Hi Verena,

OK, ist deine Entscheidung.

Du kannst übrigens die Namen auch mit dem Namensmanager von Excel selbst löschen. Allerdings - so weit ich weiss - ohne die Möglichkeit die Namen auch in Formeln zu ersetzen. Da müsste man sich dann selbst drum kümmern.
Dazu im Ribbon "Formeln" im Bereich "Definierte Namen" auf "Namens-Manager" klicken. Alle Namen auswählen, die gelöscht werden sollen und "löschen" auswählen. So geht es zumindest unter Windows, aber beim Mac sollte das gleich sein.
  Thema: Excel Namen definiert, Namen löschen 
HKindler

Antworten: 11
Aufrufe: 154

BeitragForum: Excel Formate   Verfasst am: 17. Apr 2014, 15:34   Titel: AW: Excel Namen definiert, Namen löschen Version: Office 2011 (Mac)
Hi Verena,

wenn du das Setup ausführen willst, dann musst du die Verarbeitung von Makros erlauben. Da ich die Mac-Version von Excel nicht kenne, musst du leider selbst nach der Einstelleung dafür suchen.
Unter Windows findet man diese unter Datei - Optionen - Sicherheitscenter.

Aber man muss das Setup gar nicht unbedingt ausführen. Es reicht die *.xla-Datei zu den Addins hinzu zu fügen. Bei Excel 2010 unter Windows findet man das unter Datei - Optionen - Add-Ins. In diesem Fenster ganz unten "Excel-Add-Ins" auswählen (ist normalerweise schon ausgewählt) und daneben auf "Gehe zu..." klicken. Im folgenden Fenster auf "Durchsuchen..." klicken und dann die *.xla-Datei suchen. Das war es dann schon.

Aufrufen kannst du den Namemanager mit "Strg-Umschalt-N" oder unter im Ribbon "Formeln" ganz rechts auf "Namemanager" klicken.

Zu deiner Frage, ob es das auch auf deutsch gibt: Ja! Ist in der Standard-Einstellung sogar aut ...
  Thema: Excel Namen definiert, Namen löschen 
HKindler

Antworten: 11
Aufrufe: 154

BeitragForum: Excel Formate   Verfasst am: 17. Apr 2014, 12:39   Titel: Re: AW: Excel Namen definiert, Namen löschen Version: Office 2011 (Mac)
Hi Verena,

Ich habe mir das Addis "NameManager" kurz bei YouToube angeschaut.
Ich glaube damit komme ich nicht weiter.

Glauben ist nicht wissen. Namemanager kann auch viele Namen auf einen Schlag löschen. Teste das Addin einfach einmal. Kostet doch nichts, außer vielleicht ein wenig Zeit. Aber glaube mir, diese Zeit sparst du locker wieder ein, sobald du ein wenig mit Namen arbeitest.
  Thema: Excel Namen definiert, Namen löschen 
HKindler

Antworten: 11
Aufrufe: 154

BeitragForum: Excel Formate   Verfasst am: 17. Apr 2014, 11:51   Titel: AW: Excel Namen definiert, Namen löschen Version: Office 2011 (Mac)
Hi Verena,

such mal nach dem Addin "NameManager" von JKP Application Development Service. Ist ein geniales Tool zum Verwalten von Namen in Excel und bietet unter anderem die Möglichkeit einen Namen zu löschen und dabei bei den Formeln, die den Namen benutzen diesen durch die entsprechende Referenz zu ersetzen.
  Thema: Endlos Verschatelte Formel verbessern 
HKindler

Antworten: 6
Aufrufe: 131

BeitragForum: Excel Formeln   Verfasst am: 14. Apr 2014, 14:44   Titel: AW: Endlos Verschatelte Formel verbessern Version: Office 2007
Hi Totte,

vielleicht hilft dir http://www.excelformeln.de/tips.html?welcher=84 weiter...
  Thema: Bedingte Formatierung für Excel Diagramme 
HKindler

Antworten: 4
Aufrufe: 92

BeitragForum: Excel Formate   Verfasst am: 14. März 2014, 10:03   Titel: AW: Bedingte Formatierung für Excel Diagramme Version: Office 2010
Hi Humpel,

wenn es sich um ein Säulendiagramm handelt, dann Rechtsklick auf eine der Säulen, "Datenreihen formatieren" auswählen, "Füllung" auswählen und anschließend den Haken bei "Invertieren, falls negativ" setzen. Jetzt kannst du die Farben für pos. und neg. Werte getrennt einstellen.
  Thema: Verknüpfung zweier Zellen ohne "zu verbinden" - ge 
HKindler

Antworten: 1
Aufrufe: 45

BeitragForum: Excel Formate   Verfasst am: 14. März 2014, 09:58   Titel: AW: Verknüpfung zweier Zellen ohne "zu verbinden" Version: Office 2010
Hi Tina,

einfach Spalte A und B markieren und dann sortieren nach Spalte A. Spalte B wird dann automatisch zusammen mit Spalte A sortiert. Die restlichen Spalten beleiben so wie sie sind.

Sollen alle Spalten sortiert werden, dann einfach die zu sortierenden Zeilen komplett markieren.
  Thema: Problem mit Reihenfolge in Dropdown bei Gültigkeitsliste 
HKindler

Antworten: 6
Aufrufe: 87

BeitragForum: Excel Formate   Verfasst am: 14. März 2014, 09:54   Titel: AW: Problem mit Reihenfolge in Dropdown bei Gültigkeitsliste Version: Office 2003
Hi Chakko,

ja, das ist das Problem. Excel markiert in der Dropdow-Liste automatisch den Eintrag, der schon in der Zelle steht. Ist diese noch leer und ein Leer-Eintrag in der Liste vorhanden, dann wird dieser markiert.

Es gibt damit zwei Lösungen dein Problem zu beheben:

1. Keine leeren Einträge in der Auswahlliste --> bei einer leeren Zelle wird der erste Eintrag markiert.
Vorteil: Verglichen mit Lösung 2 ist ein Eintrag mehr sofort sichtbar
Nachteil: Keine Reserve am Ende der Liste möglich, es sei denn, die leeren Einträge am Ende sind nicht wirklich leer, sondern enthalten z.B. ein Leerzeichen

2. Als ersten Eintrag ein leerer Eintrag in der Liste --> bei einer leeren Zelle wird der erste Eintrag markiert, da dieser dem Inhalt der Zelle entspricht.
Vorteil: Die Liste kann eine Reserve am Ende der Liste haben
Nachteil: Durch das leere Feld wird der erste Listenplatz belegt und es ist ein Eintrag weniger zu sehen ohne scrollen zu müssen.
  Thema: Anfänger - Code will nicht 
HKindler

Antworten: 7
Aufrufe: 75

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. März 2014, 11:39   Titel: AW: Anfänger - Code will nicht Version: Office 2010
Hallo Teddy,

also hier ist ja einiges im Argen!

Zunächst einmal ist die Angabe "L5:L" nicht gültig. Ich denke du meinst damit die Spalte L beginndend ab Zeile 5. Leider bietet Excel diese Art der Angabe nicht und du musst je nach Tabellengröße, also ob es sich um eine .xls oder .xlsm handelt, entweder "L5:L65538" oder "L5:L1048576"

Range.Value("xxx") gibt es nicht.

Du überprüfst ob "L5:Lxxx" den Wert 71 hat. Das funktioniert so auch nicht, du kannst immer nur einzelne Zellen und keine Bereiche mit einem Wert vergleichen.

Du weist "T5:Vxxx" den Wert 0 zu. Auch hier gilt das eben schon gesagte analog.

Was du willst ist wohl so etwas:

Private Sub Worksheet_Change(ByVal Target As Range)

If Target.CountLarge = 1 Then
If Not Intersect(Targe, Range("L:L") Is Nothing Then
If Target.Row >= 5 Then
If Target = 71 Then
Range(&quo ...
  Thema: Runden bei WENN DANN 
HKindler

Antworten: 3
Aufrufe: 41

BeitragForum: Excel Formeln   Verfasst am: 13. März 2014, 10:37   Titel: AW: Runden bei WENN DANN Version: Office 2003
Hi Heike,

stellst du dir das so vor?

 AB14003992388388ZelleFormelB1=WENN(REST(A1;10)=0;A1-1;A1)B2=WENN(REST(A2;10)=0;A2-1;A2)Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
  Thema: Zeilen zählen die 2 Bedingungen erfüllen 
HKindler

Antworten: 3
Aufrufe: 73

BeitragForum: Excel Formeln   Verfasst am: 26. Feb 2014, 10:05   Titel: AW: Zeilen zählen die 2 Bedingungen erfüllen Version: Office 2010
Hi Kaniee,

ab Excel 2007 funktioniert auch ZÄHLENWENNS. Ist mMn etwas einfacher zu verstehen als SUMMENPRODUKT, allerdings auch nicht so flexibel.

 DEFGHIJ1GeschlechtHaarfarbe   wm2mrot  blond203mbraun  braun114mschwarz  schwarz035wrot  rot116wblond     7mschwarz     8wbraun     9wblond     10mschwarz     ZelleFormelI2=ZÄHLENWENNS($D$2:$D$10;I$1;$E$2:$E$10;$H2)J2=ZÄHLENWENNS($D$2:$D$10;J$1;$E$2:$E$10;$H2)I3=ZÄHLENWENNS($D$2:$D$10;I$1;$E$2:$E$10;$H3)J3=ZÄHLENWENNS($D$2:$D$10;J$1;$E$2:$E$10;$H3)I4=ZÄHLENWENNS($D$2:$D$10;I$1;$E$2:$E$10;$H4)J4=ZÄHLENWENNS($D$2:$D$10;J$1;$E$2:$E$10;$H4)I5=ZÄHLENWENNS($D$2:$D$10;I$1;$E$2:$E$10;$H5)J5=ZÄHLENWENNS($D$2:$D$10;J$1;$E$2:$E$10;$H5)Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Bei Klaus-Dieter hat sich übrigens noch ein Fehler eingeschlichen. Statt =SUMMENPRODUKT(($D2:$D10=I$1)*($E2:$E10=$H2)) müsste es korrekt =SUMMENPRODUKT(($D2:$D$10=I$1)*($E2:$E$10=$H2)) lauten.
  Thema: Shapes mit bestimmter Name ansprechen 
HKindler

Antworten: 8
Aufrufe: 93

BeitragForum: Excel VBA (Makros)   Verfasst am: 25. Feb 2014, 11:14   Titel: AW: Shapes mit bestimmter Name ansprechen Version: Office 2007
Sehe gerade deinen letzten Post.

Du hast da immer noch mindestens eine Stolperfalle drin: Wenn dein Makro aus einem anderen Sheet als "PLCP" aufgerfuen wird, dann wird in Spalte "F:F" im aufrufenden Blatt gesucht. Also besser Set rng1 = wsLoop.Range("F:F").Find(strSearch, , xlValues, xlWhole) schreiben. Aber bei diesem Aufruf ist z.B. die SerachDirection nicht festgelegt und es wird die des letzten Aufrufs verwendet. Der letzte Aufruf von .Find() kann übrigens auch vom User selbst über die Such-Funktion des Menus ausgelöst worden sein! Zitat aus der Hilfe: Die Angaben für LookIn, LookAt, SearchOrder und MatchByte werden jedesmal gespeichert, wenn Sie diese Methode verwenden. Falls Sie beim nächsten Aufruf dieser Methode keine Werte für die Argumente angeben, werden die gespeicherten Werte verwendet. Die Angabe dieser Argumente ändert die Einstellungen im Dialogfeld Suchen, und eine Änderung der Einstellungen im Dialogfeld Suchen änd ...
  Thema: Shapes mit bestimmter Name ansprechen 
HKindler

Antworten: 8
Aufrufe: 93

BeitragForum: Excel VBA (Makros)   Verfasst am: 25. Feb 2014, 11:05   Titel: AW: Shapes mit bestimmter Name ansprechen Version: Office 2007
Hi Matt,

die Definition von Range.Find():

Range.Find(What, After, LookIn, LookAt, SearchOrder, SearchDirection, MatchCase, MatchByte, SearchFormat)

Du übergibst also "xlNext" als "LookIn". "xlNext" ist aber die SearchDirection. Das kann nicht funktionieren! Du musst also einige Kommas einfügen oder "SearchDirection:=" vor xlNext schreiben.

Außerdem würde in deinem Beispiel auch eventuell - ja nachdem, was in der letzten Suche gesucht wurde - "Scale_OP.100" beim Suchbegriff "Scale_OP.100_Risk" gefunden werden. Ich bezweifle, dass das beabsichtigt ist. Es fehlt also noch "LookAt:=xlWhole". Das ist der Grund, weshalb ich von .Find abrate bzw. man bei .Find immer(!) alle Parameter angeben sollte.
  Thema: Shapes mit bestimmter Name ansprechen 
HKindler

Antworten: 8
Aufrufe: 93

BeitragForum: Excel VBA (Makros)   Verfasst am: 20. Feb 2014, 13:35   Titel: AW: Shapes mit bestimmter Name ansprechen Version: Office 2007
Hi Matt,

leider kann ich dir hier nicht wirklich weiter helfen, sondern nur ein paar Denkanstöße geben.

Ich selbst verwende .Find sehr selten und versuche es immer zu umgehen. Da mir bei .Find schon einige seltsame Dinge passiert sind. So findet .Find z.B. nichts in ausgeblendeten Zellen. Man muss auch aufpassen, ob nicht irgendwelche Optionen vom User verstellt wurden. Es wird in einer Schleife immer wieder von vorne angefangen (man muss also selbst den Schleifenabbrauch bestimmen). Dies sind wahrscheinlich noch nicht alle Tücken, die .Find so bietet.
Mittlerweile verwende ich deshalb einfach eine Suchschleife. Aber Achtung! Erst alle Zellen in ein Datenfeld lesen, sonst wird das seeeehr langsam.

Wieso .Find nicht mit sShape.Name klar kommen soll, ist mir nicht klar. Bist du dir sicher, dass sShape.Name auch wirklich "Scale_Risk" zurück gibt?

Und noch eine Anmerkung: Wieso machst du auch in dieser Routine eine Schleife über alle Tabellenblätter? Du weist doch, ...
 
Seite 1 von 11 Gehe zu Seite 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11  Weiter
Gehe zu:  
Alle Zeiten sind
GMT + 1 Stunde

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Excel Tricks