Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Die Suche hat 155 Ergebnisse ergeben.
Seite 9 von 11 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11  Weiter
Index
Autor Nachricht
  Thema: bedingte Formatierung aktualisiert sich nicht 
HKindler

Antworten: 9
Aufrufe: 1742

BeitragForum: Excel Formate   Verfasst am: 01. Aug 2013, 17:04   Titel: AW: bedingte Formatierung aktualisiert sich nicht Version: Office 2010
Guter Tipp!
Habe eben eine Mappe umgestellt, bei der das ab und zu auftritt. Bin mal gespannt, ob es hilft.
  Thema: Bedingte Formatierung mit Ampel 
HKindler

Antworten: 4
Aufrufe: 375

BeitragForum: Excel Formate   Verfasst am: 01. Aug 2013, 16:29   Titel: AW: Bedingte Formatierung mit Ampel Version: Office 2007
Bei Excel 2010 kann man sich das einfach unter der Bedingten Formatierung zusammenklicken. Vielleicht geht das ja auch unter Excel 2007.

Falls nicht, ich hatte das unter Excel 2003 folgendermaßen gelöst:
Die Zelle in der die Ampel erscheinen soll wird mit der Schriftart "Webdings" formatiert und in die Zelle der Buchstabe "n" eingetragen.
Den Zellhintergrund und die Schriftfarbe nach Geschmack gestalten. Ich habe den Hintergrund immer Schwarz gemacht und die Zeichenfarbe Grau.
Die Spaltenbreite nach Lust und Laune festlegen.
Jetzt für die Zelle eine bedingte Formatierung festlegen. Steht deine Differenz in Zelle C1 und dein x ist 0, dann lauten die Bedingungen
1.Bedingung Formel "=C1<0" Format Schriftfarbe Rot
2.Bedingung Formel "=C1>=0" Format Schriftfarbe Grün
  Thema: Destination und .PasteSpecial 
HKindler

Antworten: 3
Aufrufe: 244

BeitragForum: Excel VBA (Makros)   Verfasst am: 31. Jul 2013, 16:39   Titel: AW: Destination und .PasteSpecial Version: Office 2010
Mal einge dumme Fragen:

Was sind Range("E1:F1:G1") bzw. Range("AF1:AG1:AH1:AI1") für seltsame Bereiche?
Diese Schreibweise kenne ich nicht! Ich würde gleich Range("E1:G1") und Range("AF1:AI1") schreiben.

Range("E1:G1"), Range("AF1:AI1").Copy funktioniert tatsächlich? Das .Copy wird also für beide Range durchgeführt?
  Thema: Auswertung aus verschiedenen Zeilen 
HKindler

Antworten: 11
Aufrufe: 92

BeitragForum: Excel Hilfe   Verfasst am: 31. Jul 2013, 16:20   Titel: AW: Auswertung aus verschiedenen Zeilen Version: Office 2007
Schau dir das bitte nochmals genauer an:

=SUMMENPRODUKT(('Datenquellen H1'!C3:C34=1)*(ISTZAHL('Datenquellen H1'!D3:AM3))*('Datenquellen H1'!D4:AM18))

'Datenquellen H1'!C3:C34=1
hier wird die Zeilenzahl auf die Zeilen 3:34, also auf 32 Zeilen festgelegt

ISTZAHL('Datenquellen H1'!D3:AM3)
hier wird die Spaltenzahl auf die Spalten D:AM, also auf 36 Spalten festgelegt

'Datenquellen H1'!D4:AM18)
und hier werden die Zeilen 4:18, und die Spalten D:AM also 15 Zeilen und 36 Spalten verwendet. Das geht gar nicht!
  Thema: Auswertung aus verschiedenen Zeilen 
HKindler

Antworten: 11
Aufrufe: 92

BeitragForum: Excel Hilfe   Verfasst am: 31. Jul 2013, 16:05   Titel: Re: AW: Auswertung aus verschiedenen Zeilen Version: Office 2007
Da die Daten in einer anderen Tabelle sind, habe ich so gemacht:

=SUMMENPRODUKT(('Datenquellen H1'!C3:C34=1)*(ISTZAHL('Datenquellen H1'!D3:AM3))*('Datenquellen H1'!D4:AM18))

Ergebnis ist wie #NV

Die fett markierten Teile passen nicht zusammen. Hier müssen die selben Zeilennummern stehen. Also entweder C4:C18 oder D3:AM34 oder allgemeiner Cx:Cy und Dx:AMy

Wie kann ich z.B. nach dem Montag in der KW1 sortieren bzw. zusammen rechnen lassen lassen?

Wenn ich mal annehme, dass dein Datenbereich von Zeile 4 bis Zeile 34 geht, dann so:

=SUMMENPRODUKT(('Datenquellen H1'!A4:A34="Mo")*('Datenquellen H1'!C4:C34=1)*(ISTZAHL('Datenquellen H1'!D3:AM3))*('Datenquellen H1'!D4:AM34))
  Thema: wenn dann 
HKindler

Antworten: 6
Aufrufe: 62

BeitragForum: Excel Formeln   Verfasst am: 31. Jul 2013, 12:31   Titel: AW: wenn dann Version: Office 2010
Die Wenn-Formel lautet formal
=WENN(Bedingung;Dann;Sonst)
Bei dir steht nur
=WENN(Bedingung;Dann)
Wenn du Sonst weg lässt, zeigt Excel dir den halt FALSCH an.
Richtig muss es heissen
=WENN((P1<-1000;'[11 TB Schnedler.xlsx]Aug'!P1;"")
Dann hast du deine leere Zelle.
  Thema: BEREICH.VERSCHIEBEN mit dynamischem Bezug 
HKindler

Antworten: 7
Aufrufe: 144

BeitragForum: Excel Formeln   Verfasst am: 31. Jul 2013, 09:15   Titel: AW: BEREICH.VERSCHIEBEN mit dynamischem Bezug Version: Office 2007
Hi StH,

sehe gerade, dass du Office 2007 verwendest. Dann kannst du auch eine der folgenden Formeln benutzen. Die sind etwas schneller als die Formeln mit SUMMENPRODUKT.

=SUMMENWENNS(A1:A8;B1:B8;MAX(B1;B2;B7;B8);C1:C8;MAX(C1;C2;C7;C8);D1:D8;"x")

bzw. mit den Hilfszelle E1 und F1

=SUMMENWENNS(A1:A8;B1:B8;E1;C1:C8;F1;D1:D8;"x")
  Thema: BEREICH.VERSCHIEBEN mit dynamischem Bezug 
HKindler

Antworten: 7
Aufrufe: 144

BeitragForum: Excel Formeln   Verfasst am: 30. Jul 2013, 13:28   Titel: AW: BEREICH.VERSCHIEBEN mit dynamischem Bezug Version: Office 2007
Mach eine Hilfsspalte, z.B. D und setzte hier in jede Zeile, die benutzt werden soll ein "x". Dann funktioniert folgenden Formel:

=SUMMENPRODUKT((B1:B8=MAX(B1;B2;B7;B8))*(C1:C8=MAX(C1;C2;C7;C8))*(D1:D8="x")*(A1:A8))

oder noch etwas pflegeleichter mit zwei weiteren Hilfszellen. Nehmen wir E1 und F1. In E1 kommt folgende Formel:

=MAX(WENN($D$1:$D$8="x";B1:B8))
Diese Formel mit CTRL-SHIFT-ENTER bzw. STRG-UMSCHALT-ENTER abschliessen! Jetzt die Formel nach F1 kopieren.

In eine beliebige Zelle kommt nun die Formel
=SUMMENPRODUKT((B1:B8=E1)*(C1:C8=F1)*(D1:D8="x")*(A1:A8))

Dies hat den Vorteil, dass jetzt auch die Maxwerte nur von den Zeilen mit "x" kommen.

Bei allen Formeln (auch denen von meinen Vorgängern!) musst du jedoch beachten, dass, wenn der Maxwert von B und C jewe ...
  Thema: Abfrage nach Excel-Version 
HKindler

Antworten: 2
Aufrufe: 86

BeitragForum: Excel VBA (Makros)   Verfasst am: 29. Jul 2013, 16:02   Titel: AW: Abfrage nach Excel-Version Version: Office 2003
Die Version erhältst du mit Application.Version

Excel 2010 hat z.B. die Version "14.0"
  Thema: Änderungen durch Makro ignorieren/nicht wg.Speicherung frage 
HKindler

Antworten: 3
Aufrufe: 88

BeitragForum: Excel VBA (Makros)   Verfasst am: 29. Jul 2013, 15:17   Titel: AW: Änderungen durch Makro ignorieren/nicht wg.Speicherung f Version: Office365
Dann wird aber gar nicht mehr gespeichert. Soll nur gespeichert werden, wenn vor dem Makroaufruf etwas geändert wurde dann so (ungetestet):


Sub DeinMakro()
Dim bolWBSaved as Boolean
'Weitere Dim-Deklarationen

bolWBSaved = ThisWorkbook.Saved

'Dein Makro

ThisWorkbook.Saved = bolWBSaved
ThisWorkbook.Close
End Sub


Statt ThisWorkbook kann man auch Workbooks("DeineDatei.xls") oder Workbooks("DeineDatei.xlsm") verwenden.
  Thema: Bitte nennt mir meinen Fehler....und löst mein Problem... 
HKindler

Antworten: 8
Aufrufe: 239

BeitragForum: Excel VBA (Makros)   Verfasst am: 15. Jul 2013, 12:13   Titel: AW: Bitte nennt mir meinen Fehler....und löst mein Problem.. Version: Office 2010
Wieso sollte meine Routine eine Abwandlung pro Tabellenblatt brauchen? Question

DU musst nur einmal die Min/Max Zeile festlegen. Wenn du das nicht willst und dir die Laufzeit Egal ist, dann funktioniert auch

Dim i as Long
For i = 1 to Cells.Rows.Count
If Cells(i,1)="006" or Cells(i,1)="016" then Range(Cells(i,2), Cells(i,4)).NumberFormat = "#,##0.0"
Next i

Dann werden halt alle Zeilen (je nach Excel-Version ca. 65.000 oder 1.000.000) eines Blattes abgeklappert. Ja ich weiß, das kann man auch noch weiter einschränken. Ich habe das allerdings nicht im Kopf.

Aber ich glaube dir immer noch nicht, dass ein einfaches Umwandeln des Zahlenformats die Zahlen sichtbar macht!!!
  Thema: Bitte nennt mir meinen Fehler....und löst mein Problem... 
HKindler

Antworten: 8
Aufrufe: 239

BeitragForum: Excel VBA (Makros)   Verfasst am: 15. Jul 2013, 11:30   Titel: AW: Bitte nennt mir meinen Fehler....und löst mein Problem.. Version: Office 2010
Genau das macht doch meine Routine und zwar von Zeile 1 bis 100. Brauchst du anderen Zeilen, dann einfach nur bei For i = 1 to 100 die Zahlenwerte entsprechend anpassen.

Allerdings habe ich dein eigentliches Problem immer noch nicht verstanden. Wieso steht da bei einem anderen Zahlenformat "*"? Ich kenne kein Zahlenformat, das aus einer Zahl "*" macht und beim Zuweisen eines anderen Formats dann plötzlich die richtige Zahl erscheint. Steht da nicht vielleicht doch "#"? Das würde darauf hinweisen, dass deine Spalten schlicht und ergreifend zu schmal sind.
  Thema: INDEX(VERGLEICH) Ergebnisse erst ab bestimmtem Wert - warum? 
HKindler

Antworten: 13
Aufrufe: 202

BeitragForum: Excel Formeln   Verfasst am: 15. Jul 2013, 11:18   Titel: AW: INDEX(VERGLEICH) Ergebnisse erst ab bestimmtem Wert - wa Version: Office 2007
Danke für die ausführliche Erläuterung!
  Thema: Bitte nennt mir meinen Fehler....und löst mein Problem... 
HKindler

Antworten: 8
Aufrufe: 239

BeitragForum: Excel VBA (Makros)   Verfasst am: 12. Jul 2013, 16:48   Titel: AW: Bitte nennt mir meinen Fehler....und löst mein Problem.. Version: Office 2010
Vielleicht so (ungetestet)

Dim i as Long
For i = 1 to 100
If Cells(i,1)="006" or Cells(i,1)="016" then Range(Cells(i,2), Cells(i,4)).NumberFormat = "#,##0.0"
next i
Die 1 und 100 als Start-/End-Zeile musst du halt entsprechend anpassen.
  Thema: INDEX(VERGLEICH) Ergebnisse erst ab bestimmtem Wert - warum? 
HKindler

Antworten: 13
Aufrufe: 202

BeitragForum: Excel Formeln   Verfasst am: 12. Jul 2013, 16:34   Titel: Re: AW: INDEX(VERGLEICH) Ergebnisse erst ab bestimmtem Wert Version: Office 2007
Hi,

und ohne Matrixformel geht es so

=($A$5:$A$16>=$B$1)*1*($A$5:$A$16)

Grüßli
Wieso funktioniert das? Wie rechnet Excel hier?
 
Seite 9 von 11 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11  Weiter
Gehe zu:  
Alle Zeiten sind
GMT + 1 Stunde

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: PHP Forum