Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Die Suche hat 155 Ergebnisse ergeben.
Seite 2 von 11 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11  Weiter
Index
Autor Nachricht
  Thema: Vereinheitlichung von Datumswerten 
HKindler

Antworten: 15
Aufrufe: 204

BeitragForum: Excel Formate   Verfasst am: 20. Feb 2014, 13:16   Titel: AW: Vereinheitlichung von Datumswerten Version: Office 2010
Das eben war ich. War nicht eingeloggt. Embarassed
  Thema: Minuten in stunden tage minuten sekunden umrechnen 
HKindler

Antworten: 2
Aufrufe: 66

BeitragForum: Excel Formeln   Verfasst am: 19. Feb 2014, 13:55   Titel: AW: Minuten in stunden tage minuten sekunden umrechnen Version: Office 2010
Und wenn es darüber hinaus geht dann:
=GANZZAHL(X/24/60) & TEXT(X/24/60;" hh:mm")
mit diesem Wert kann dann aber nicht weiter gerechnet werden, da es sich um reinen Text handelt.
  Thema: Vereinheitlichung von Datumswerten 
HKindler

Antworten: 15
Aufrufe: 204

BeitragForum: Excel Formate   Verfasst am: 19. Feb 2014, 10:13   Titel: AW: Vereinheitlichung von Datumswerten Version: Office 2010
Hi Luc,

wenn ich das richtig verstehe sieht deine Funktion TransFor() ungefähr so aus:
Function TransFor(Formel As String) As Variant
TransFor = Evaluate(Formel)
End Function
Zumindest kommt bei mir dann das richtige Ergebnis raus, wenn ich sie in einer Zelle mit =TransFor("datevalue("""&A1&""")") aufrufe wobei dann in A1 der Text "11/8/2014 11:00 PM" steht.
Ich verstehe jetzt nur noch nicht, wo genau der Unterschied zu meinem UDF_Datum wirklich liegt. Immerhin wird in obiger Kombination ja einfach ein datevalue("11/8/2014 11:00 PM") ausgeführt, was mein UDF_Datum doch auch macht. Question

Ansonsten ist die Idee von TransForm genial. Ich verwende bisher öfters solche "Einzeiler" wie UDF_Datum um einzelne Funktionen von VBA auch in Excel verfügbar zu machen.

Edit: Habe nochmals darüber nachgedacht Idea
Evaluate macht ja keine VBA-Funktion zugänglich, sondern führt "nur&quo ...
  Thema: Vereinheitlichung von Datumswerten 
HKindler

Antworten: 15
Aufrufe: 204

BeitragForum: Excel Formate   Verfasst am: 17. Feb 2014, 11:13   Titel: AW: Vereinheitlichung von Datumswerten Version: Office 2010
Hi Gregor,

du hast aber schon den Einwand von shift-del gesehen? Manchmal gibt UDF_Datum nicht das richtige Ergebnis zurück!

Aber damit funktioniert es (hoffentlich):
 ABCD11/28/2014 11:00:00 PM28.01.201428.01.201428.01.2014211/28/2014 11:00:00 PM28.11.201428.11.201428.11.201431/8/2014 11:00:00 PM08.01.201401.08.201408.01.2014411/8/2014 11:00:00 PM08.11.201411.08.201408.11.2014ZelleFormelC1=UDF_Datum(A1)D1=UDF_Datum2(A1)Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Hier die Funktion UDF_Datum2(). Das Einbageformat muss "M/T/J xxx" (xxx = beliebige Uhrzeit) sein.
Function UDF_Datum2(AmiDatum As String) As Date
Dim iMonat As Integer
Dim iTag As Integer
Dim iJahr As Integer
Dim vTemp As Variant
Dim vTemp2 As Variant
vTemp = Split(AmiDatum, "/")
vTemp2 = Split(vTemp(2), " ")
iMonat = CInt(vTemp(0))
iTag = CInt(vTemp(1))
iJahr = CInt(vTemp2(0 ...
  Thema: Vereinheitlichung von Datumswerten 
HKindler

Antworten: 15
Aufrufe: 204

BeitragForum: Excel Formate   Verfasst am: 14. Feb 2014, 16:28   Titel: AW: Vereinheitlichung von Datumswerten Version: Office 2010
Damit das auch mit zweistelliger Tageszahl und einstelliger Monatszahl funktioniert musst du alle TEIL(A1;3;2) durch TEIL(A1;SUCHEN("/";A1)+1;SUCHEN("/";A1;SUCHEN("/";A1)+1)-SUCHEN("/";A1)-1) ersetzen.

In VBA wäre das Ganze eleganter:
Function UDF_Datum(AmiDatum As String) As Date
UDF_Datum = DateValue(AmiDatum)
End Function
  Thema: Datum vergleichen 
HKindler

Antworten: 19
Aufrufe: 231

BeitragForum: Excel VBA (Makros)   Verfasst am: 14. Feb 2014, 14:16   Titel: AW: Datum vergleichen Version: Office 2010
Hi Castiral,

einige Dinge fallen mir als erstes auf:
- Seit wann gibt es einen 30.02.2014 (Zelle P3)?
- Wieso benutzt du in deiner Routine RotEinfärben() die Funktion DateDiff("d",...)? Eine einfache Subtraktion genügt!
- Wieso vergleichst du die Daten einer Zeile und nicht das Startdatum dieser Zeile und das Enddatum der vorhergehenden?
- Du prüfst dabei auch nicht, ob es sich um die selbe Artikelnummer handelt.

Zu deinem Problem mit Text und Datum (=Zahl) setz in deinem Makro vor Einfügen der Werte das Zellformat auf Datum und füge dann erst die Werte ein. Oder benutze Text in Spalten.

Edit: sehe jetzt erst deine Antwort.

Um das manuelle Text in Spalten zu automatisieren: Zeichne dein händisches Vorgehen mit dem Makrorecorder auf und setzte dies dann (angepasst) in dein Makro ein.

xlCalculationManual schaltet das automatische Rechnen von Excel aus. xlCalculationAutomatic entsprechend wieder ein. Der Effekt? Das Makro läuft schneller.
  Thema: Datum vergleichen 
HKindler

Antworten: 19
Aufrufe: 231

BeitragForum: Excel VBA (Makros)   Verfasst am: 14. Feb 2014, 09:53   Titel: AW: Datum vergleichen Version: Office 2010
Hallo Castiral,

wenn der 01.03.2014 als kleiner als der 28.02.2014 angesehen wird, dann handelt es sich mit Sicherheit nicht um ein Datum sondern um Text.

Außerdem muss ich Hansueli recht geben: solange du hier nicht mehr Preis gibst, am besten in Form einer Beispieldatei, kann dir hier wohl keiner weiter helfen.
  Thema: Shapes mit bestimmter Name ansprechen 
HKindler

Antworten: 8
Aufrufe: 93

BeitragForum: Excel VBA (Makros)   Verfasst am: 11. Feb 2014, 18:51   Titel: AW: Shapes mit bestimmter Name ansprechen Version: Office 2007
Du hast da eine for-each-Schleife zu viel drin und die über die Worksheets ist überflüssig. Außerdem fehlt ein "End If". Versuch mal folgendes (ungetestet):

Sub GetShapePropertiesSomeWs()
Dim sShapes As Shape, lLoop As Long
Worksheets("Summary").Range("A1:C1") = _
Array("Shape Name", "ID", "Sheet Name")
For each sShapes in Worksheets("PLCP")
if sShapes.Name like "Scale_*" then
lLoop = lLoop + 1
With sShapes
'Add shape properties
Worksheets("Summary").Cells(lLoop + 1, 1) = .Name
'Follow the same pattern for more
Worksheets("Summary").Cells(lLoop + 1, 3) = Parent.Name
Worksheets("Summary").Cells(lLoop + 1, 2) = sShapes.ID
End With
End If
Next sShapes

Worksheets& ...
  Thema: Datum vergleichen 
HKindler

Antworten: 19
Aufrufe: 231

BeitragForum: Excel VBA (Makros)   Verfasst am: 11. Feb 2014, 18:37   Titel: AW: Datum vergleichen Version: Office 2010
Geht doch immer noch mit bedingter Formatierung:

 ABCDEFGHIJKLMNOP1287             17.12.201328.02.20142288             31.12.201316.04.20143288             17.04.201430.06.20144600             29.01.201428.02.20145770             01.03.201430.04.20146850             09.01.201431.03.20147851             09.01.201428.02.20148852             23.12.201331.03.20149853             03.02.201431.03.201410856             21.01.201431.03.201411878             22.09.201304.02.2014121068             05.02.201431.03.2014131068             23.01.201431.03.2014141068             24.01.201431.03.2014151068             15.01.201431.03.2014161177             31.01.201410.02.2014171178             11.02.201428.02.2014181178             01.03.201418.03.2014191178             19.03.201430.04.2014201328             23.12.201328.02.2014211328             23.12.201331.03.2014221328             23.12.201302.03.2014231328             03.03.201430.04.2014241329             01.02.201428.02.2014251329         ...
  Thema: Fortlaufende Nummer in der Form Jahr-001 in VBA 
HKindler

Antworten: 5
Aufrufe: 90

BeitragForum: Excel Hilfe   Verfasst am: 11. Feb 2014, 16:41   Titel: AW: Fortlaufende Nummer in der Form Jahr-001 in VBA Version: Office 2007
Ich dachte das wäre aus meiner Antwort klar.

Ich glaube es bringt jetzt nichts, dir die paar Befehle ausführlich zu beschreiben. Du würdest daraus nicht wirklich etwas lernen.

Daher mein zweiter Tipp: fahre im VBA-Editor mit dem Cursor auf einen Befehl, denn du nicht verstehst. Jetzt drücke F1 und fang an zu lesen.

OK, bin jetzt doch nicht ganz so gemein Wink
Der Inhalt der Zelle wird mit den Befehlen Left(...) und Right(...) in zwei Teile zerlegt. Einmal in "2014-" und in den Rest. Die Ziffer 5 bei Left(...,5) sagt aus, dass die ersten 5 Buchstaben verwendet werden sollen. Der Ausdruck Len(...)-5 bei Right(...,Len(...)-5) sagt: Nimm so viele Buchstaben von Rechts, wie der Ausdruck Buchstaben hat, ziehe aber 5 davon ab. Sprich, nimm alles ausser den ersten 5 Buchstaben. Das ist jetzt zwar noch immer ein Text, aber dieser Text kann von VBA als Zahl interpretiert werden und somit kann man 1 dazu zählen. Wenn man es ganz sauber machen möchte, müsste man eigentlich ...
  Thema: Fortlaufende Nummer in der Form Jahr-001 in VBA 
HKindler

Antworten: 5
Aufrufe: 90

BeitragForum: Excel Hilfe   Verfasst am: 11. Feb 2014, 14:18   Titel: AW: Fortlaufende Nummer in der Form Jahr-001 in VBA Version: Office 2007
Hallo SEA,

als erstes ein Tipp: Schmeiss die Zeile On Error Goto ERR raus. Dann siehst du was passiert. Wink

Dein Code läuft bei der Zeile ActiveCell.Offset(1, 0) = ActiveCell + 1 in einen Fehler, da du versuchst zu einem Text die Zahl 1 zu addieren. Das funktioniert nun mal nicht. Dadurch springt dein Code jetzt direkt auf ERR und es passiert nichts weiter.

Nun zur Lösung deines Problems: Du musst aus dem Text wieder eine Zahl machen, damit du die 1 addieren kannst. Dies könnte z.B. so aussehen:
ActiveCell.Offset(1, 0) = Left(ActiveCell,5) & Right(ActiveCell,Len(ActiveCell)-5) + 1
  Thema: Uhrzeit 0:00 nicht anzeigen 
HKindler

Antworten: 7
Aufrufe: 117

BeitragForum: Excel Hilfe   Verfasst am: 10. Feb 2014, 17:52   Titel: AW: Uhrzeit 0:00 nicht anzeigen Version: Office 2010
Was soll den dies: Question=WENN(F5>E5;F5-E5;F5-E5)Da kannst du doch gleich das Wenn weg lassen!

Und so wie ich das sehe, hast du die Wenn-Formel eingeführt um auch Arbeitszeiten zu erfassen, die über Mitternacht hinausgehen. Dann wäre deine ursrüngliche Formel mit +1 =WENN(F5>E5;F5-E5;F5+1-E5) fast richtig. Sie muss nur =WENN(F5>=E5;F5-E5;F5+1-E5) lauten.

Beachte das >= beim Vergleich der Wenn-Formel!
  Thema: Tabelle mit Datum und nach Monatsende x Zeilen leer, dann .. 
HKindler

Antworten: 2
Aufrufe: 111

BeitragForum: Excel Formate   Verfasst am: 06. Feb 2014, 16:37   Titel: AW: Tabelle mit Datum und nach Monatsende x Zeilen leer, dan Version: Office 2003
Natürlich geht das:

 ABC124.02.20145 2   3   4   5   6   7   8   9   1024.02.20140FALSCH1125.02.20140FALSCH1226.02.20140FALSCH1327.02.20140FALSCH1428.02.20140FALSCH1528.02.20141WAHR1628.02.20142WAHR1728.02.20143WAHR1828.02.20144WAHR1928.02.20145WAHR2001.03.20146FALSCH2102.03.20140FALSCHZelleFormelA10=A1B10=WENN(MONAT(A9)<>MONAT(A9+1);B9+1;0)C10=WENN(UND(B10;B10<=$B$1);WAHR;FALSCH)A11=WENN(C11;A10;A10+1)B11=WENN(MONAT(A10)<>MONAT(A10+1);B10+1;0)C11=WENN(UND(B11;B11<=$B$1);WAHR;FALSCH)A12=WENN(C12;A11;A11+1)B12=WENN(MONAT(A11)<>MONAT(A11+1);B11+1;0)C12=WENN(UND(B12;B12<=$B$1);WAHR;FALSCH)A13=WENN(C13;A12;A12+1)B13=WENN(MONAT(A12)<>MONAT(A12+1);B12+1;0)C13=WENN(UND(B13;B13<=$B$1);WAHR;FALSCH)A14=WENN(C14;A13;A13+1)B14=WENN(MONAT(A13)<>MONAT(A13+1);B13+1;0)C14=WENN(UND(B14;B14<=$B$1);WAHR;FALSCH)A15=WENN(C15;A14;A14+1)B15=WENN(MONAT(A14)<>MONAT(A14+1);B14+1;0)C15=WENN(UND(B15;B15<=$B$1);WAHR;FALSCH)A16=WENN(C16;A15;A15+1)B16=WENN(MO ...
  Thema: gewichteter Mittelwert mit mehreren Bedingungen 
HKindler

Antworten: 3
Aufrufe: 67

BeitragForum: Excel Formeln   Verfasst am: 05. Feb 2014, 16:48   Titel: AW: gewichteter Mittelwert mit mehreren Bedingungen Version: Office 2010
Hallo JBa,

ich gehe mal davon aus, dass deine xxx_act als Namen definierte Bereiche sind. Wenn dem so ist, dann müssen diese Bereiche auch jeweils genau eine Spalte beinhalten, da du mit Sheet1!I:I und Sheet1!J:J feweils geanu eine Spalte ansprichst.
  Thema: Dropdown zeigt leere Felder an, muss nach oben scrollen 
HKindler

Antworten: 3
Aufrufe: 135

BeitragForum: Excel Formate   Verfasst am: 05. Feb 2014, 13:06   Titel: AW: Dropdown zeigt leere Felder an, muss nach oben scrollen Version: Office 2010
Hallo Tommy,

habe leider auch keine direkte Lösung für das Problem, aber einen kleinen Trick für dich: Lass die erste Zeile deiner Auswahlliste leer, also A1, B1 etc.
Excel springt dann beim Aufruf der Auswahl aus einer noch nicht gefüllten Zelle automatisch da hin. Es wird nämlich immer die erste Übereinstimmung der Auswahl mit der Zelle vorgewählt.
 
Seite 2 von 11 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11  Weiter
Gehe zu:  
Alle Zeiten sind
GMT + 1 Stunde

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML CSS