Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Die Suche hat 11580 Ergebnisse ergeben.
Seite 149 von 772 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7 ... 146, 147, 148, 149, 150, 151, 152 ... 766, 767, 768, 769, 770, 771, 772  Weiter
Index
Autor Nachricht
  Thema: Excel Makro Doppelte Zeilen Zählen 
Phelan XLPH

Antworten: 12
Aufrufe: 1120

BeitragForum: Excel VBA (Makros)   Verfasst am: 29. März 2012, 08:02   Titel: AW: Excel Makro Doppelte Zeilen Zählen Version: Office 2010
Weil es mich interessiert.
  Thema: Excel Makro Doppelte Zeilen Zählen 
Phelan XLPH

Antworten: 12
Aufrufe: 1120

BeitragForum: Excel VBA (Makros)   Verfasst am: 29. März 2012, 07:29   Titel: AW: Excel Makro Doppelte Zeilen Zählen Version: Office 2010
@Slowboarder

kannst du ein Beispiel hochladen?
  Thema: Next i in if-Schleife 
Phelan XLPH

Antworten: 9
Aufrufe: 434

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. März 2012, 16:44   Titel: AW: Next i in if-Schleife Version: Office 2010
...du musst die Formel in eine Zelle schreiben, als Matrixformel abschließen und
runterziehen.
  Thema: Next i in if-Schleife 
Phelan XLPH

Antworten: 9
Aufrufe: 434

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. März 2012, 16:20   Titel: AW: Next i in if-Schleife Version: Office 2010
Nimm die Formel zB in J1 und mit STRG+SHIFT+RETURN abschöießen (Matrixformel.).

=WENNFEHLER(KKLEINSTE(WENN(ZEILE($F$1:$F$26)=VERGLEICH($F$1:$F$26;$F$1:$F$26;0);$F$1:$F$26;"");ZEILE(A1));"-")
  Thema: Next i in if-Schleife 
Phelan XLPH

Antworten: 9
Aufrufe: 434

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. März 2012, 15:52   Titel: AW: Next i in if-Schleife Version: Office 2010
Was ist das Ziel?
  Thema: Autofill in 288er Schritte 
Phelan XLPH

Antworten: 3
Aufrufe: 200

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. März 2012, 14:19   Titel: AW: Autofill in 288er Schritte Version: Office 2003
was soll ich dir da erklären, ist doch nur die Bereich.Verschieben()-Formel?! Confused
  Thema: Problem beim Runden 
Phelan XLPH

Antworten: 16
Aufrufe: 933

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. März 2012, 14:11   Titel: AW: Problem beim Runden Version: Office 2010
Deswegen eher die VBA-Excel-Function verwenden:
WorksheetFunction.Round()
  Thema: Autofill in 288er Schritte 
Phelan XLPH

Antworten: 3
Aufrufe: 200

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. März 2012, 14:07   Titel: AW: Autofill in 288er Schritte Version: Office 2003
=MAX(BEREICH.VERSCHIEBEN($C$2:$E$289;288*(ZEILE()-2);3*(SPALTE()-19)))

Die Formel in S2 setzen, 5 Spalten nach rechts ziehen und 31 Zeilen nach unten.
  Thema: Problem beim Runden 
Phelan XLPH

Antworten: 16
Aufrufe: 933

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. März 2012, 13:48   Titel: AW: Problem beim Runden Version: Office 2010
Hinweis!!!!

per vba:

round(Zahl,anzahl der stellen hinterm komma)

Round() rundet kaufmännisch!!!

Sub Test()
MsgBox Round(5.35, 1)
MsgBox Round(5.45, 1)
End Sub
  Thema: Nur bestimmten Bereich von txt Datei importieren 
Phelan XLPH

Antworten: 5
Aufrufe: 293

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. März 2012, 08:10   Titel: AW: Nur bestimmten Bereich von txt Datei importieren Version: Office 2003
Ich habe schon sehr grosse Mühe Deine Mehrfachauswahl zu begreifen.
Die Mehrfachauswahl bezieht sich auf das Open-Dialog.

varZuÖffnendeDateien = Application.GetOpenFilename("Text-Dateien (*.txt), *.txt", _
Title:="Verzeichnisauswahl, erste Datei auswählen", MultiSelect:=True)

Damit kannst du mehrere Dateien auswählen mit STRG+Klick oder SHIFT+Klick,
oder alle mit STRG+A. Vorher kannst du die Textdateien im Open-Dialog noch sortieren.

aber wo ist die Unterebegrenzung zu finden?
If Val(sTextZeile) = 0 And blnLesen Then blnLesen = False: Exit Do

Da jede zu importierende Zeile mit einer Zahl anfägt, wird geprüft ob der Merker
blnLesen Wahr ist und ob Zeilenanfang keine Zahl ist [Val(...)=0]. Dann setze den
Merker zurück [blnLesen = False] und verlasse die Schleife [Exit Do].
  Thema: Nur bestimmten Bereich von txt Datei importieren 
Phelan XLPH

Antworten: 5
Aufrufe: 293

BeitragForum: Excel VBA (Makros)   Verfasst am: 27. März 2012, 22:40   Titel: AW: Nur bestimmten Bereich von txt Datei importieren Version: Office 2003
...mit Mehrfachauswahl.

Sub Alle_Textdateien()
Dim varZuÖffnendeDateien As Variant
Dim sTextZeile As String
Dim blnLesen As Boolean
Dim arWerte() As Variant
Dim i As Integer
Dim n As Integer
Dim varTmp As Variant

varZuÖffnendeDateien = Application.GetOpenFilename("Text-Dateien (*.txt), *.txt", _
Title:="Verzeichnisauswahl, erste Datei auswählen", MultiSelect:=True)
If Not IsArray(varZuÖffnendeDateien) Then Exit Sub

For i = 1 To UBound(varZuÖffnendeDateien)

Open varZuÖffnendeDateien(i) For Input As #1
Do While Not EOF(1)
Line Input #1, sTextZeile
If Val(sTextZeile) = 0 And blnLesen Then blnLesen = False: Exit Do
If blnLesen Then
varTmp = Split(Replace(sTextZeile, "=", ";"), ";")
n = n + 1 ...
  Thema: Programierung komplexer Summenproduktformeln mit Bedingungen 
Phelan XLPH

Antworten: 11
Aufrufe: 221

BeitragForum: Excel VBA (Makros)   Verfasst am: 27. März 2012, 19:41   Titel: AW: Programierung komplexer Summenproduktformeln mit Bedingu Version: Office 2003
Du musst konkreter werden.
  Thema: Tabelle in VBA - abhängig von eingegebenen Werten 
Phelan XLPH

Antworten: 4
Aufrufe: 332

BeitragForum: Excel VBA (Makros)   Verfasst am: 27. März 2012, 19:40   Titel: AW: Tabelle in VBA - abhängig von eingegebenen Werten Version: Office 2010
Ab welcher zeile soll der rahmen anfangen?
  Thema: ROW UP innerhlab eines Bereich 
Phelan XLPH

Antworten: 3
Aufrufe: 253

BeitragForum: Excel VBA (Makros)   Verfasst am: 27. März 2012, 19:33   Titel: AW: ROW UP innerhlab eines Bereich Version: Office 2003
Range("AG86").End(xlUp).Row
  Thema: goto Blattübergreifend 
Phelan XLPH

Antworten: 2
Aufrufe: 305

BeitragForum: Excel VBA (Makros)   Verfasst am: 27. März 2012, 18:10   Titel: AW: goto Blattübergreifend Version: Office XP (2002)
GoTo und das Ziel sind nicht auf ein Blatt.

...und das ist gut so, schlimm genug dass man innerhalb des Moduls hin - und herhopst.
 
Seite 149 von 772 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7 ... 146, 147, 148, 149, 150, 151, 152 ... 766, 767, 768, 769, 770, 771, 772  Weiter
Gehe zu:  
Alle Zeiten sind
GMT + 1 Stunde

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Project