Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Die Suche hat 155 Ergebnisse ergeben.
Seite 3 von 11 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11  Weiter
Index
Autor Nachricht
  Thema: Dropdown-Feld lässt "freie" Einträge zu 
HKindler

Antworten: 4
Aufrufe: 55

BeitragForum: Excel Formeln   Verfasst am: 30. Jan 2014, 10:08   Titel: AW: Dropdown-Feld lässt "freie" Einträge zu Version: Office 2010
Hast du zufällig einen Haken bei "Leere Zellen ignorieren" gesetzt und zusätzlich eine leere Zelle in deinem Listenbereich?

Dann sind nämlich beliebige Einträge möglich.
  Thema: Zeitwert aus Zelle auslesen 
HKindler

Antworten: 5
Aufrufe: 79

BeitragForum: Excel Formeln   Verfasst am: 29. Jan 2014, 18:16   Titel: AW: Zeitwert aus Zelle auslesen Version: Office 2010
Deine Zelle ist doch schon ein Zeitwert! Question

Ich zitiere einmal aus der deutschen Hilfe:

Wandelt eine als Text vorliegende Zeitangabe in eine fortlaufende Zahl um. Diese fortlaufende Zahl ist ein Wert im Bereich von 0 (Null) bis 0,99999999 und entspricht einer Uhrzeit von 0:00:00 (24:00:00) bis 23:59:59.

Wenn du nur die reine Uhrzeit aus A1 haben willst, dann in A2 die Formel
=A1-GANZZAHL(A1)
bzw. auf englisch
=A1-INT(A1)
und die Zelle dann als Uhrzeit formatieren.
  Thema: Summenprodukt an Filter anpassen 
HKindler

Antworten: 5
Aufrufe: 164

BeitragForum: Excel Formeln   Verfasst am: 29. Jan 2014, 17:58   Titel: AW: Summenprodukt an Filter anpassen Version: Office 2010
Also gut, dann halt doch noch die (ungetestete) Formel. Aber lies dir bitte trotzdem noch die Erläuterung in dem genannten Link durch. Wenn man die verstanden hatt, dann kann man viele Sachen analog lösen, so wie mit meiner zuerst geposteten Beispielformel, die einen Mittelwert eines Maßes von mehreren Chargen abhängig von dem Chargengewicht errechnet.

So hier die Formel:
=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("K"&ZEILE(19:67)));$K19:$K67;L19:L67)

oder

=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("K"&ZEILE(19:67)))*$K19:$K67*L19:L67)
Die zweite Variant ist geschickter, falls du noch Vergleichsbedingungen wie "in Spalte M soll ein X stehen" unterbringen willst. Diese Formel würde dann so lauten:

=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("K"&ZEILE(19:67)));(M19:M67="x")*1;$K19:$K67;L19&# ...
  Thema: Summenprodukt an Filter anpassen 
HKindler

Antworten: 5
Aufrufe: 164

BeitragForum: Excel Formeln   Verfasst am: 29. Jan 2014, 13:33   Titel: AW: Summenprodukt an Filter anpassen Version: Office 2010
Ehrlich gesagt bin ich dazu jetzt zu faul. Aber vielleciht hilft dir das weiter:
http://www.excelformeln.de/formeln.html?welcher=259
  Thema: If Abfrage: unültiger Bereich 
HKindler

Antworten: 7
Aufrufe: 67

BeitragForum: Excel VBA (Makros)   Verfasst am: 29. Jan 2014, 13:25   Titel: AW: If Abfrage: unültiger Bereich Version: Office 2010
1. Deine Wenn-Formel funktioniert, wenn du UND korrekt einsetzt. Es heißt nicht "Bedingung1 UND Bediungung2" sondern "UND(Bedingung1;Bedingung2)"

2. Zu VBA: Wenn du schon Konstanten definierst, dann verwende auch diese und keine Strings. Also nicht Worksheets("Tab1") sondern Worksheets(Tab1)
  Thema: Summenprodukt an Filter anpassen 
HKindler

Antworten: 5
Aufrufe: 164

BeitragForum: Excel Formeln   Verfasst am: 29. Jan 2014, 13:07   Titel: AW: Summenprodukt an Filter anpassen Version: Office 2010
Du musst in die Summenproduktformel noch TEILERGEBNIS(1xx;...) in Verbindung mit INDIREKT für den Zelbereich einbinden. Kann z.B. so aussehen (nicht erschrecken, sieht schlimmer aus als es ist)
=SUMMENPRODUKT(TEILERGEBNIS(109;INDIREKT(ADRESSE(ZEILE($11:$210);SPALTE($J$1))));TEILERGEBNIS(109;INDIREKT(ADRESSE(ZEILE($11:$210);SPALTE(CA$1)))))/SUMMENPRODUKT(TEILERGEBNIS(109;INDIREKT(ADRESSE(ZEILE($11:$210);SPALTE($J$1))));TEILERGEBNIS(102;INDIREKT(ADRESSE(ZEILE($11:$210);SPALTE(CA$1)))))
  Thema: SUMMEWENNS 
HKindler

Antworten: 4
Aufrufe: 84

BeitragForum: Excel Formeln   Verfasst am: 29. Jan 2014, 12:41   Titel: AW: SUMMEWENNS Version: Office 2007
Eigentlich müsste deine Formel mit den "*" funktionieren. Daher: Bist du dir sicher, dass das Datum als Text und nicht als echtes Datum eingetragen ist? Sollte es ein echtes Datum sein, dann müsste deine Formel so aussehen:
=SUMMEWENNS(Table_XXX_[Spalte A];Table_XXX_[Spalte B];B5;Table_XXX[Spalte C];">="&DATWERT("1.1.2013");Table_XXX[Spalte C];"<"&DATWERT("1.1.2014"))
  Thema: Bedingte Formatierung von Makro ableiten 
HKindler

Antworten: 1
Aufrufe: 75

BeitragForum: Excel Formate   Verfasst am: 29. Jan 2014, 11:31   Titel: AW: Bedingte Formatierung von Makro ableiten Version: Office 2010
Hi Mustangs,

das ist eigentlich ganz einfach:
Alle Zellen markieren, für die die Formatierung gelten soll. Unter "Bedingte Formatierung - Neue Regel..." die Zeile "Formel zur Ermittlung der zu formatierenden Zelle verwenden" auswählen. Im Feld "Werte formatieren, für die diese Formel wahr ist" gibst du nun =$C$8<$C$9 ein und suchst dir als Format die Schriftfarbe schwarz aus. Beachte die $-Zeichen in der Formel.
  Thema: Wenn n.i.O. angezeigt wird soll es rot sein 
HKindler

Antworten: 3
Aufrufe: 68

BeitragForum: Excel VBA (Makros)   Verfasst am: 23. Jan 2014, 18:31   Titel: AW: Wenn n.i.O. angezeigt wird soll es rot sein Version: Office 2010
Oder die entsprechende Zelle mit dem Format [="n.i.O."][rot];Standard versehen...
  Thema: festen Wert von Namen abziehen 
HKindler

Antworten: 6
Aufrufe: 76

BeitragForum: Excel Hilfe   Verfasst am: 23. Jan 2014, 17:41   Titel: AW: festen Wert von Namen abziehen Version: Office 2010
Wenn du schon Namen vergeben hast, dann vergib noch einen weiteren Namen. Angenomme dein bisheriger Name heist "Test", dann leg noch einen weiteren Namen "TestMinus2" an und hinterlege dort die Formel "=Test-2". Jetzt im Diagramm statt "Test" einfach "TestMinus2" verwenden.
  Thema: Hlfe zu WENN: WENN(X=0;"";X) 
HKindler

Antworten: 5
Aufrufe: 63

BeitragForum: Excel Formeln   Verfasst am: 23. Jan 2014, 17:26   Titel: AW: Hlfe zu WENN: WENN(X=0;"";X) Version: Office 2010
Oder mach es über das Zahlenformat der Tabelle:

Format: [=0]"#NV";Standard
  Thema: Zellbezug mit der Maus verschieben 
HKindler

Antworten: 11
Aufrufe: 172

BeitragForum: Excel Formeln   Verfasst am: 23. Jan 2014, 17:13   Titel: AW: Zellbezug mit der Maus verschieben Version: Office 2010
Leider habe ich für dein eigentliches Anliegen keine Lösung.

ABER:
Blickst du bei der Formel überhaupt noch durch? Shock
Ich würd hier ja mit einigen Hilfszellen arbeiten. Das wird dann übersichtlicher und auch schneller, da man sich einige VERGLEICH() sparen kann.

Also in eine Hilfszelle z.B. AA1 =VERGLEICH($J$7&$A$2&$A$3&$A10;'CER Cur'!$A$1:$A$14000;0) in AA2 dann =INDEX('CER Cur'!$A$1:$BB$14000;AA1;X$5) in AA3 =INDEX('CER Cur'!$A$1:$BB$14000;AA1;U$5) in AA4 dann nicht =((AA2)-(AA3))/(AA3) da hier einige überflüssige Klammern sind, sondern =(AA2-AA3)/AA3 und schon vereinfacht sich deine Formel zu =WENN(ISTFEHLER(WENN(AA4>1;">100%";WENN(AA4<-1;"<-100%";AA4)));;WENN(AA4>1;">100%";WENN(AA4<-1;"<-100%";AA4))) Und wenn ich jetzt keinen Fehler gemacht habe, dann erkennst du sehr schnell, dass das 2. Argument (Da ...
  Thema: Bereiche (Namensmanager) in Schleife 
HKindler

Antworten: 5
Aufrufe: 91

BeitragForum: Excel VBA (Makros)   Verfasst am: 23. Jan 2014, 11:29   Titel: AW: Bereiche (Namensmanager) in Schleife Version: Office 2010
Ich muss Klaus-Dieter recht geben: On Error Resume Next ist sehr mit Vorsicht zu genießen. Das erlebst du gerade selber. Deine Routine funktioniert nicht und du weißt nicht wieso. Lass das weg, und VBA zeigt dir, wo es scheitert.
Ich kann hier nur vermuten, was schief läuft. Es können mehrere Dinge passieren, such dir das passende aus Twisted Evil
Find findet keine Entsprechung
Bereich bekommt keinen Wert zugewiesen, da du versuchst einer Zahl den Inhalt von mehreren Zellen zuzuordnen
Names.Add scheitert weil Bereich kein String sondern eine Zahl ist
Names.Add scheitert weil es den Namen eventuell schon gibt
Viel Spaß beim debuggen

Weitere Anmerkungen:
Ich bezweifle, dass deine vielen .Find das richtige finden. Ich würde für jede zu suchende Zelle den .Find nur einmal ausführen.
Dim rngZelle as Range
...
set rngZelle = Cells.Find(strSucheK, , , xlWhole)
With rngZelle
DaFeldCol1 = .Column + 1
DaFeldRow1 = .Row
End With
Entsprechend nätürlich auch in der ...
  Thema: Prüfen ob Zelle leer ist und wenn nicht Text wiedergeben? 
HKindler

Antworten: 8
Aufrufe: 161

BeitragForum: Excel Formeln   Verfasst am: 22. Jan 2014, 22:14   Titel: AW: Prüfen ob Zelle leer ist und wenn nicht Text wiedergeben Version: Office 2007
Hi francine,

Wieso solltest du in der Sackgasse landen? Hast du die Formel ausprobiert? Die WENN sind jeweils getrennt und werden einzeln ausgewertet und dann verknüpft.
  Thema: Zellbezug mit der Maus verschieben 
HKindler

Antworten: 11
Aufrufe: 172

BeitragForum: Excel Formeln   Verfasst am: 22. Jan 2014, 17:53   Titel: AW: Zellbezug mit der Maus verschieben Version: Office 2010
Hi Topper5000

Nimm doch Suchen&Ersetzen.
Einfach den Bereich mit den zu ändernden Formeln mit der Maus markieren, Suchen&Ersetzen aufrufen, suchen nach "$C$7" ersetzen durch "$XYZ$123", "Alle Ersetzen" auswählen, fertig.
 
Seite 3 von 11 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11  Weiter
Gehe zu:  
Alle Zeiten sind
GMT + 1 Stunde

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Dreamweaver Forum