Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Die Suche hat 155 Ergebnisse ergeben.
Seite 4 von 11 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11  Weiter
Index
Autor Nachricht
  Thema: Excel Filter nach Monaten (J-F-M usw.) sortieren 
HKindler

Antworten: 2
Aufrufe: 71

BeitragForum: Excel Formate   Verfasst am: 22. Jan 2014, 17:46   Titel: AW: Excel Filter nach Monaten (J-F-M usw.) sortieren Version: Office 2007
Hi Daniel,

da gibt es leider keine Möglichkeit die Reihenfolge festzulegen.
Ich würde an deiner Stelle statt dem Text "Januar 2013" das Datum "1.1.2013" eingeben und die Ausgabe dieses Datums entsprechend formatieren.
Excel bietet dann im Autofilter gleich Gruppierungen nach Jahr/Monat/Tag oder auch "letzter Monat" etc. an.
  Thema: Prüfen ob Zelle leer ist und wenn nicht Text wiedergeben? 
HKindler

Antworten: 8
Aufrufe: 161

BeitragForum: Excel Formeln   Verfasst am: 22. Jan 2014, 14:24   Titel: AW: Prüfen ob Zelle leer ist und wenn nicht Text wiedergeben Version: Office 2007
Versuch es mal so (statt VERKETTEN habe ich "&" zwischen den zu verkettenden Teilen verwendet, halte ich für übersichtlicher):
=WENN('1.'!D6="";"";'1.'!D6&" / ")&WENN('1.'!D7="";"";'1.'!D7&" / ")&WENN('1.'!D8="";"";'1.'!D8&" / ")&WENN('1.'!D9="";"";'1.'!D9)
Beachte die veränderten Klammern!

Jetzt hast du nur noch das Problem, dass sich am Schluss ein " / " zu viel befindet, falls '1.'!D9 leer ist.
Das lässt sich am einfachsten über eine Hilfszelle lösen. Schreibe dazu die obige Formel in die Hilfszelle, z.B. A1 und dann in B1 folgende Formel:
=WENN(RECHTS(A1;3)=" / ";LINKS(A1;LÄNGE(A1)-3);A1)
Am Schluss dann Spalte A ausblenden.
  Thema: Zeitformat 
HKindler

Antworten: 5
Aufrufe: 340

BeitragForum: Excel Formate   Verfasst am: 15. Jan 2014, 11:10   Titel: AW: Zeitformat Version: Office 2007
Funktioniert dieses Format (ungetestet)?
"Tag" 0",("0"d" h"h)";@
  Thema: Summe mit Auswertung des Datums in mehreren Tabellen 
HKindler

Antworten: 1
Aufrufe: 34

BeitragForum: Excel Formeln   Verfasst am: 10. Jan 2014, 11:15   Titel: AW: Summe mit Auswertung des Datums in mehreren Tabellen Version: Office 2010
Hallo 7even,

schau dir mal die Funktion SUMMWENNS an.

Könnte dann so aussehen (ungetestet):

=SUMMEWENNS(H:H;I:I;"<=30.09.2007";I:I;">=01.10.2006")
  Thema: Summewenns: Monat filtern 
HKindler

Antworten: 10
Aufrufe: 174

BeitragForum: Excel Formeln   Verfasst am: 17. Dez 2013, 19:05   Titel: Sorry, Version: Office 2007
hatte mal wieder vergessen mich einzuloggen... Rolling Eyes
  Thema: Wenn Kalenderwoche 
HKindler

Antworten: 10
Aufrufe: 164

BeitragForum: Excel Formeln   Verfasst am: 16. Dez 2013, 17:47   Titel: AW: Wenn Kalenderwoche Version: Office 2010
Habe jetzt mal versucht, deine Tabelle nach zu bauen. Es sieht tatsächlich ao aus, dass die Funktion Kalenderwoche nicht damit klar kommt innerhalb einer Matrixformel zu stehen. Sad
Da wird dir wohl nichts anderes übrig bleiben, als mit einer Hilfsspalte im Blatt Daten zu arbeiten, bei der du die KW für jedes zugehörige Datum getrennt ausrechnest.
  Thema: Funktion liefert mir #Wert,ich mache was falsch 
HKindler

Antworten: 5
Aufrufe: 87

BeitragForum: Excel VBA (Makros)   Verfasst am: 16. Dez 2013, 17:33   Titel: AW: Funktion liefert mir #Wert,ich mache was falsch Version: Office 2010
Eine Möglichkeit sehe ich noch:
Übergib das ganze als String, zerpflücke den dann in VBA in die einzelnen Tabellenblätter und mach eine Schlaufe über diese. Ist aber nicht schön, da du dann auf alle Fälle wieder das Application.Volatile brauchst.

Und noch was: Wenn jemand die Reihenfolge der Tabellenblätter verschiebt, dann passen deine Formeln eventuell nicht mehr. Z.B. jemand verschiebt den Feb. hinter den März und lässt "Jan:Mrz!" rechnen, dann ist der Feb. jetzt nicht mehr dabei.
  Thema: Datumsformat konvertieren 
HKindler

Antworten: 10
Aufrufe: 96

BeitragForum: Excel Hilfe   Verfasst am: 16. Dez 2013, 17:24   Titel: Re: AW: Datumsformat konvertieren Version: Office 2010
Wie hast Du es geschafft, die Uhrzeit anzuzeigen?

http://abload.de/img/capture59dkt.png
Die Zellen benutzerdefinert formatieren mit "TT.MM.JJJJ hh:mm" zumindest beim deutschen Excel. Beim Englischen müsste es "dd.mm.yyyy hh:mm" heissen wobei ich mir hier mit der Groß-/Kleinschreibung nicht sicher bin...
OK, laut VBA-Hilfe müsste es auf englisch eigentlich "dd.mm.yyyy hh:nn" heissen.
  Thema: Datumsformat konvertieren 
HKindler

Antworten: 10
Aufrufe: 96

BeitragForum: Excel Hilfe   Verfasst am: 16. Dez 2013, 17:17   Titel: Re: AW: Datumsformat konvertieren Version: Office 2010
Hallo Helmut

Was ist das für ein Datumsformat:
dd/dm/yyyy h:mm;@
Gruss werni
Das muss wohl ein Fehler in Tab2Html sein. Müsste natürlich
dd/mm/yyyy h:mm;@
heißen

Tante Edit sagt:
sehe gerade ist kein Fehler in Tab2Html, sondern von mir Embarassed
Hatte ich falsch eingegeben
  Thema: Wenn Kalenderwoche 
HKindler

Antworten: 10
Aufrufe: 164

BeitragForum: Excel Formeln   Verfasst am: 16. Dez 2013, 17:09   Titel: Re: AW: Wenn Kalenderwoche Version: Office 2010
Bist du dir sicher dass mit $B5 und nicht mit $B$5 vergleichen willst?

Vom Wert bleibt es doch trotzdem der Gleiche oder?
B5 bleibt B5...oder sehe ich das falsch??
Aber nur solange du nicht anfängst die Formel zu ziehen oder zu kopieren!

Und bist du dir auch sicher, dass du KALENDERWOCHE(...,2) und nicht KALENDERWOCHE(...,21) meinst?

(...,21)?
wirklich jetzt?? Ich kenne nur 1 für die Ami-Kalenderwochen und 2 für die deutsche Variante.
2 war noch nie wirklich die deutsche Variante. 21 gibt es erst seit Excel 2007 und berechnet endlich die Kalenderwoche für Europa korrekt. Wenn dich das Thema Kalenderwoche näher interessiert, dann schlag mal bei Wikipedia nach. Es gibt da einige Unterschiede zwischen USA und EU, die allerdings nur in bestimmten Jahren ausschlaggebend sind.

Zu deinem eigentlichen Problem: Deine Formel scheint prinzipiell OK. Wie ist denn die Zelle B5 formatiert? Vielleicht als Text statt als Zahl?
  Thema: Name,Vorname -> Vorname Name, aber anfangs ohne Leerzeich 
HKindler

Antworten: 3
Aufrufe: 72

BeitragForum: Excel Formeln   Verfasst am: 16. Dez 2013, 16:58   Titel: AW: Name,Vorname -> Vorname Name, aber anfangs ohne Leerz Version: Office 2010
Sorry, die 2.Formel müsste lauten:
=WENN(ISTFEHLER(FINDEN(", ";G2;1));"";(RECHTS(G2;LÄNGE(G2)-FINDEN(", ";G2;1)-1)&" "&LINKS(G2;FINDEN(", ";G2;1)-1)))
und die 3.Formel funktioniert erst ab Excel 2007
  Thema: Datumsformat konvertieren 
HKindler

Antworten: 10
Aufrufe: 96

BeitragForum: Excel Hilfe   Verfasst am: 16. Dez 2013, 16:46   Titel: AW: Datumsformat konvertieren Version: Office 2010
Hmm, komisch, bei funktionierts. Versuch mal die angehängte Datei zu öffnen.
  Thema: Funktion liefert mir #Wert,ich mache was falsch 
HKindler

Antworten: 5
Aufrufe: 87

BeitragForum: Excel VBA (Makros)   Verfasst am: 16. Dez 2013, 16:37   Titel: AW: Funktion liefert mir #Wert,ich mache was falsch Version: Office 2010
Leider kann ich dir hier nicht vollständig helfen. Habe eben ein wenig herumprobiert und komme zum Ergebnis, dass es -zumindest mir- nicht möglich ist an VBA so etwas wie Tab1:Tab3!A1 zu übergeben. Hier springt bei mir noch nicht einmal der Debugger an, wenn ich Bereich As Range definiere. Definiere ich Bereich As Variant, dann hat Bereich nur einen Fehlerwert. Keine Ahnung wie man mehrere Tabellenblätter übergeben kann.

Ich würde dies im Augenblick so lösen:
Public Function Blaue(Bereich As Range) As Long
Dim objCell As Range
Dim i As Integer

For Each objCell In Bereich
If objCell.Value = "S" Then
Select Case objCell.Interior.ColorIndex
Case 8: i = 1 '<-hier alle Farb-IDx auflisten, bei denen gezählt werden soll
Case Else: i = 0
End Select
Blaue = Blaue + i
End If
Next

End Function
Und dann halt in der Tabelle=BLAUE(Tabelle1!A1:C10)+BLAUE(Tabelle2!A1:C10 ...
  Thema: Datumsformat konvertieren 
HKindler

Antworten: 10
Aufrufe: 96

BeitragForum: Excel Hilfe   Verfasst am: 16. Dez 2013, 16:00   Titel: AW: Datumsformat konvertieren Version: Office 2010
Sag doch gleich, dass du es auf englisch brauchst... Very Happy

 AB120120311080011.113.2012 8:00ZelleFormatWertA10201203110800B1dd/dm/yyyy h:mm;@11.03.2012 08:00:00ZelleFormelB1=DATE(LEFT(A1,4),MID(A1,5,2),MID(A1,7,2))+TIME(MID(A1,9,2),RIGHT(A1,2),0)Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
  Thema: Name,Vorname -> Vorname Name, aber anfangs ohne Leerzeich 
HKindler

Antworten: 3
Aufrufe: 72

BeitragForum: Excel Formeln   Verfasst am: 16. Dez 2013, 15:56   Titel: AW: Name,Vorname -> Vorname Name, aber anfangs ohne Leerz Version: Office 2010
Wie wäre es mit

=WENN(ISTFEHLER(RECHTS(G2;LÄNGE(G2)-FINDEN(", ";G2;1)-1)&" "&LINKS(G2;FINDEN(", ";G2;1)-1));"";(RECHTS(G2;LÄNGE(G2)-FINDEN(", ";G2;1)-1)&" "&LINKS(G2;FINDEN(", ";G2;1)-1)))
oder kürzer
=WENN(ISTFEHLER(FINDEN(", ";G2;1);"";(RECHTS(G2;LÄNGE(G2)-FINDEN(", ";G2;1))&" "&LINKS(G2;FINDEN(", ";G2;1)-1)))
oder noch kürzer
=WENNFEHLER(RECHTS(G2;LÄNGE(G2)-FINDEN(", ";G2;1)-1)&" "&LINKS(G2;FINDEN(", ";G2;1)-1));"")
 
Seite 4 von 11 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11  Weiter
Gehe zu:  
Alle Zeiten sind
GMT + 1 Stunde

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Excel-Formeln