Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Die Suche hat 155 Ergebnisse ergeben.
Seite 5 von 11 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11  Weiter
Index
Autor Nachricht
  Thema: Wenn Kalenderwoche 
HKindler

Antworten: 10
Aufrufe: 164

BeitragForum: Excel Formeln   Verfasst am: 16. Dez 2013, 15:49   Titel: AW: Wenn Kalenderwoche Version: Office 2010
Bist du dir sicher dass mit $B5 und nicht mit $B$5 vergleichen willst?
Und bist du dir auch sicher, dass du KALENDERWOCHE(...,2) und nicht KALENDERWOCHE(...,21) meinst?
  Thema: Funktion liefert mir #Wert,ich mache was falsch 
HKindler

Antworten: 5
Aufrufe: 87

BeitragForum: Excel VBA (Makros)   Verfasst am: 16. Dez 2013, 15:30   Titel: AW: Funktion liefert mir #Wert,ich mache was falsch Version: Office 2010
ACHTUNG! Ungetestet!

Eigentlich müsste es funktionieren, wenn du der Funktion mit =BLAUE(Jan:Mrz!A10:B30) aufrufst und die erste for each-Schleife weg lässt.

Das Application.Volatile ist dann überflüssig.

Du kannst WKS nicht mit einem String ("") vergleichen. Wenn schon, dann lautet die Bedingung If Not WKS Is Nothing Then
  Thema: Kompatibilität 
HKindler

Antworten: 15
Aufrufe: 135

BeitragForum: Excel Hilfe   Verfasst am: 16. Dez 2013, 15:22   Titel: AW: Kompatibilität Version: Office 2010
Zu deinem Verständnis:

Ursprünglich hatte ich gesagt:
=WENN(ISTFEHLER(DeineFormel);FehlerWert;DeineFormel)
völlig korrekt müsste die Formel also
=WENN(ISTFEHLER(SVERWEIS(H19;$BG$17:$BH$190;2;0)="diff");FALSCH;SVERWEIS(H19;$BG$17:$BH$190;2;0)="diff")
Da ein Fehler aber nur bei VERGLEICH(...) auftreten kann, habe ich das ="diff" weg gelassen.
  Thema: Kompatibilität 
HKindler

Antworten: 15
Aufrufe: 135

BeitragForum: Excel Hilfe   Verfasst am: 16. Dez 2013, 15:13   Titel: AW: Kompatibilität Version: Office 2010
Sorry, da fehlt noch eine Klammer vor dem ";FALSCH". Embarassed

=WENN(ISTFEHLER(SVERWEIS(H19;$BG$17:$BH$190;2;0));FALSCH;SVERWEIS(H19;$BG$17:$BH$190;2;0)="diff")
  Thema: Kompatibilität 
HKindler

Antworten: 15
Aufrufe: 135

BeitragForum: Excel Hilfe   Verfasst am: 16. Dez 2013, 14:43   Titel: AW: Kompatibilität Version: Office 2010
Natürlich geht =WENN(...):
 AB31140#DIV/0!520,5ZelleFormelB3=1/A3B4=1/A4B5=1/A5Zellebedingte Formatierung...FormatB31: =WENN(ISTFEHLER(B3);WAHR;FALSCH)abcB41: =WENN(ISTFEHLER(B4);WAHR;FALSCH)abcB51: =WENN(ISTFEHLER(B5);WAHR;FALSCH)abcDiese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Bitte lies die Beiträge genau. Deine Bedingung muss lauten:
=WENN(ISTFEHLER(SVERWEIS(H19;$BG$17:$BH$190;2;0);FALSCH;SVERWEIS(H19;$BG$17:$BH$190;2;0)="diff")
  Thema: Kompatibilität 
HKindler

Antworten: 15
Aufrufe: 135

BeitragForum: Excel Hilfe   Verfasst am: 16. Dez 2013, 14:32   Titel: AW: Kompatibilität Version: Office 2010
WENNFEHLER ist, so weit ich weiß, in Excel 2007 hinzu gekommen. Ersetzen kann man die ganz einfach:

=WENN(ISTFEHLER(deineFormel);FehlerWert;deineFormel)

Wird die Datei mit WENNFEHELER in einem Excel <2007 geöffnet, dann funktionert halt die bedingte Formatierung nicht. Mit der obigen Formel sollte alles in Ordnung sein - es sei denn, du verwendest mehr als 3 Bedingungen.
  Thema: Datumsformat konvertieren 
HKindler

Antworten: 10
Aufrufe: 96

BeitragForum: Excel Hilfe   Verfasst am: 16. Dez 2013, 14:24   Titel: AW: Datumsformat konvertieren Version: Office 2010
Versuch es mal so:

 AB120120311080011.113.2012 8:00ZelleFormatWertA10201203110800B1TT.TM.JJJJ h:mm;@11.03.2012 08:00:00ZelleFormelB1=DATUM(LINKS(A1;4);TEIL(A1;5;2);TEIL(A1;7;2))+ZEIT(TEIL(A1;9;2);RECHTS(A1;2);0)Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
  Thema: Kompatibilität 
HKindler

Antworten: 15
Aufrufe: 135

BeitragForum: Excel Hilfe   Verfasst am: 16. Dez 2013, 12:50   Titel: AW: Kompatibilität Version: Office 2010
Hi Taunusmann,

sollen wir raten was da schief läuft oder in die berühmte Kristallkugel schauen? Eine Beispieldatei wäre hier angebracht!

Mal so ins Blaue geraten: In der Spalte befindet sich ein bedingte Formatierung, die eine Funktion verwendet, die es in alten Excelversionen nicht gibt. Z.B. ISTFEHLER() oder ähnliches.
  Thema: If-Abfrage optimieren 
HKindler

Antworten: 10
Aufrufe: 138

BeitragForum: Excel VBA (Makros)   Verfasst am: 16. Dez 2013, 12:44   Titel: AW: If-Abfrage optimieren Version: Office 2010
Das muss .EntireRow.RemoveDuplicates .Column, xlNo heißen.
Außerdem muss der Bereich ab M2 und nicht ab M1 laufen.

Unter der Annahme, dass du mit 7 und 8 die Zahlen und nicht Strings "7" und "8" meinst, sieht die ganze Rourine dann so aus:

Sub x()
Dim wsGlob As Worksheet
Dim lngRow As Long

Set wsGlob = ActiveSheet
lngRow = Cells.SpecialCells(xlCellTypeLastCell).Row
wsGlob.Columns(13).Insert
With wsGlob.Range("M2:M" & lngRow)
.Formula = "=IF((L2=7)+(L2=8)+(L2=""E"")+(L2=""L"")+(L2=""N1""),0,Row())"
.Cells(1, 1).Value = 0
.EntireRow.RemoveDuplicates .Column, xlno
.ClearContents
End With
wsGlob.Columns(13).Delete
End Sub
  Thema: Summewenns: Monat filtern 
HKindler

Antworten: 10
Aufrufe: 174

BeitragForum: Excel Formeln   Verfasst am: 12. Dez 2013, 11:35   Titel: Re: AW: Summewenns: Monat filtern Version: Office 2007
Hi Matthias

ich bin nicht sicher, ob ich dich richtig verstehe. Meinst du es sollte sich nur auf eine Zelle beziehen, oder ?

Ja, bei einem Vergleich kann SUMIFS nur auf einen Wert und nicht auf eine Matrix vergleichen. Gibst du eine Matrix als Vergleichskriterium an, dann wird nur gegen den ersten Wert der Matrix verglichen. Willst du gegen die Einzelwerte der Matrix vergleichen, dann musst du das Ganze so schreiben:
{=SUM(IF(AND(Route3A!F:F=Workings!P:P,Route3A!E:E>=DATE(2013,11,1),Route3A!E:E<DATE(2013,12,1)),Route3A!Q:Q,0))}
Achtung Matrixformel! "{" "}" nicht mit eingeben, sondern Formel mit CTRL-SHIFT-ENTER abschließen.

oder auch so:
=SUMPRODUCT(Route3A!Q:Q*(Route3A!F:F=Workings!P:P)*(Route3A!E:E,">="&DATE(2013,11,1))*(Route3A!E:E,"<"&DATE(2013,12,1))
Ich habe hier gleich den ...
  Thema: Bedingte Formatierung mit Farbskala und Formeln 
HKindler

Antworten: 17
Aufrufe: 329

BeitragForum: Excel Formate   Verfasst am: 11. Dez 2013, 17:19   Titel: AW: Bedingte Formatierung mit Farbskala und Formeln Version: Office 2010
Danke Luc,

interessante Diskussion in dem Link. Wenn es auch meinen Ehrgeiz etwas übersteigt. Wenn ich die selbe Farbe in der Nachbarzelle haben will, dann verwende ich halt überall meine Funktion. Wink

Ein Posten deiner Fkt. ist nicht nötig. So wie sich das anhört übersteigt es meine Fähigkeiten diese hier zum Laufen zu bringen. Für das was ich will, nämlich einen schnellen optischen Überblick, ob meine Werte gut oder schlecht sind reicht mir meine Funktion aus.
  Thema: If-Abfrage optimieren 
HKindler

Antworten: 10
Aufrufe: 138

BeitragForum: Excel VBA (Makros)   Verfasst am: 11. Dez 2013, 13:02   Titel: AW: If-Abfrage optimieren Version: Office 2010
Habe gerade zu lange zum Antworten gebraucht und war deshalb nicht mehr eingeloggt. Außerdem gab es in der Zwischenzeit genügend andere Antworten...
  Thema: Summewenns: Monat filtern 
HKindler

Antworten: 10
Aufrufe: 174

BeitragForum: Excel Formeln   Verfasst am: 11. Dez 2013, 11:53   Titel: AW: Summewenns: Monat filtern Version: Office 2007
nur mal so auf die Schnelle:

hinter Route3A!F:F und Workings!PRazz fehlt jeweils die Vergleichsbedingung. Oder wolltest du jeden Wert von Route3A!F:F mit dem entsprechenden Wert in Workings!PRazz vergleichen? Das kann SUMIF nämlich nicht. Dazu müsstest du dann auf eine Matrix-Formel ausweichen.
  Thema: Bedingte Formatierung mit Farbskala und Formeln 
HKindler

Antworten: 17
Aufrufe: 329

BeitragForum: Excel Formate   Verfasst am: 11. Dez 2013, 11:32   Titel: AW: Bedingte Formatierung mit Farbskala und Formeln Version: Office 2010
Danke für das Kompliment. Embarassed

Nur mal so aus Neugierde, da ich dein FärbePGM und auch die Diskussion mit Gandalf nicht finden kann: wo finde ich dein FärbePGM bzw. die Diskussion? Hast du mal einen Link?

Die leichten Abweichungen sind mit Sicherheit Rundungsfehler. Oder du machst es etwas intelligenter als ich, denn ich verwende einen einfachen linearen Verlauf der einzelnen RGB-Werte.
  Thema: Bedingte Formatierung mit Farbskala und Formeln 
HKindler

Antworten: 17
Aufrufe: 329

BeitragForum: Excel Formate   Verfasst am: 10. Dez 2013, 18:21   Titel: AW: Bedingte Formatierung mit Farbskala und Formeln Version: Office 2010
Sorry, hatte mal wieder vergessen mich ein zu loggen...
 
Seite 5 von 11 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11  Weiter
Gehe zu:  
Alle Zeiten sind
GMT + 1 Stunde

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Project