Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Die Suche hat 11580 Ergebnisse ergeben.
Seite 421 von 772 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7 ... 418, 419, 420, 421, 422, 423, 424 ... 766, 767, 768, 769, 770, 771, 772  Weiter
Index
Autor Nachricht
  Thema: Zeilen löschen 
Phelan XLPH

Antworten: 12
Aufrufe: 327

BeitragForum: Excel VBA (Makros)   Verfasst am: 30. Aug 2010, 16:41   Titel: AW: Zeilen löschen Version: Office 2007
Der Kluge lernt, der Dummkopf erteilt gern Belehrungen. - Anton Tschechow

Sind deswegen alle Lehrer Dumköpfe? Cool
  Thema: Excel Prozess verschwindet nicht nach Schließen von Excel 
Phelan XLPH

Antworten: 20
Aufrufe: 3036

BeitragForum: Excel VBA (Makros)   Verfasst am: 30. Aug 2010, 16:36   Titel: AW: Excel Prozess verschwindet nicht nach Schließen von Exce Version: Office 2003
Ich sehe keinen Code, hat der sich hinter dem Hasen versteckt?
  Thema: Zeilen löschen 
Phelan XLPH

Antworten: 12
Aufrufe: 327

BeitragForum: Excel VBA (Makros)   Verfasst am: 30. Aug 2010, 16:26   Titel: AW: Zeilen löschen Version: Office 2007
@phelan: Bindung ? Na und ? Ich habs zwar aus Verständlichkeitsgründen ebenfalls so geschrieben, aber wirklich nötig oder entscheidend ist die Klammerung absolut nicht!

Entscheidender kann es nicht sein.

Das ist doch die Punkt-vor-Strich-Regel der Informatik
  Thema: Zeile ans Ende setzen 
Phelan XLPH

Antworten: 8
Aufrufe: 674

BeitragForum: Excel VBA (Makros)   Verfasst am: 30. Aug 2010, 16:14   Titel: AW: Zeiele ans Ende setzen Version: Office 2007
Notfall-Variante?

Ich finde es komplizierter un zeitaufwändiger alle kriterienentsprechende Zeilen
auszuschneiden und dann ans Ende anzufügen.

Können die 100% überschritten werden? Wenn nicht, dann ist es noch einfacher.
Dazu langt ein Einzeiler.

Wiedo willst du nicht sortieren?
  Thema: Zeilen löschen 
Phelan XLPH

Antworten: 12
Aufrufe: 327

BeitragForum: Excel VBA (Makros)   Verfasst am: 30. Aug 2010, 16:08   Titel: AW: Zeilen löschen Version: Office 2007
If (Cells(r, 3).Value=”München” Or Cells(r, 3).Value=”Frankfurt“) And Cells(r, 6)=”ausgebucht” Then Rows(I).Delete

Die Bindung des AND ist stärker als die des OR
  Thema: Zeile ans Ende setzen 
Phelan XLPH

Antworten: 8
Aufrufe: 674

BeitragForum: Excel VBA (Makros)   Verfasst am: 30. Aug 2010, 14:27   Titel: AW: Zeiele ans Ende setzen Version: Office 2007
Hallo,

wie wärs mit Sortieren?
  Thema: Environ 
Phelan XLPH

Antworten: 5
Aufrufe: 367

BeitragForum: Excel VBA (Makros)   Verfasst am: 30. Aug 2010, 13:09   Titel: AW: Environ Version: Office 2007
Hab ich mir schon gedacht, hätt selbst drauf kommen müssen.

Aber du weißt der Schweinehund und die vielen Bäume und kein Wald in Sicht usw.
  Thema: Environ 
Phelan XLPH

Antworten: 5
Aufrufe: 367

BeitragForum: Excel VBA (Makros)   Verfasst am: 30. Aug 2010, 12:19   Titel: AW: Environ Version: Office 2007
Oooooohhhh je, *schlagmichtot* !

Wie konnte ich nur Environ mit Evaluate verwechseln? War auch schon spät.

Aber dennoch erhalte ich den Fehler "#BEZUG":
Function Quersumme(rng As Range)
Quersumme = Evaluate("=SUM(1*MID(" & rng.Address & ",ROW(INDIRECT(""1:""&LEN(" & rng.Address & "))),1))")
End Function
  Thema: Environ 
Phelan XLPH

Antworten: 5
Aufrufe: 367

BeitragForum: Excel VBA (Makros)   Verfasst am: 30. Aug 2010, 00:47   Titel: Environ Version: Office 2007
Hallo,

Warum funktioniert folgende Quersummen-Formel im Environ nicht?

Function Quersumme(rng As Range)
Quersumme = Environ("=SUM(1*MID(" & rng.Address & ",ROW(INDIRECT(""1:""&LEN(" & rng.Address & "))),1))")
End Function
  Thema: Rechnen ergebniss bleibt 
Phelan XLPH

Antworten: 2
Aufrufe: 183

BeitragForum: Excel Formeln   Verfasst am: 29. Aug 2010, 07:42   Titel: AW: Rechnen ergebniss bleibt Version: Office 2007
Hallo,

hier mal eine Möglichkeit:

Tabelle1  ABCDE1SpenderBetragHilsspalteSpenderGesamt-Betrag2Max91Max143Hans61Hans354Hans4 Klaus95Klaus91Moritz216Max3 Fritz37Moritz41  8Max2   9Moritz9   10Hans15   11Moritz8   12Hans9   13Fritz31  14Hans1   Formeln der TabelleZelleFormelC2=WENN(ZÄHLENWENN($A$2:A2;A2)=1;1;"")D2{=WENN(ZEILE(A1)>ZÄHLENWENN($C$1:$C$10000;1);"";INDEX($A$1:$A$10000;KKLEINSTE(WENN($C$1:$C$10000=1;ZEILE($C$1:$C$10000));ZEILE(A1))))}E2=WENN(D2="";"";SUMMEWENN($A$1:$A$10000;D2;$B$1:$B$10000))C3=WENN(ZÄHLENWENN($A$2:A3;A3)=1;1;"")D3{=WENN(ZEILE(A2)>ZÄHLENWENN($C$1:$C$10000;1);"";INDEX($A$1:$A$10000;KKLEINSTE(WENN($C$1:$C$10000=1;ZEILE($C$1:$C$10000));ZEILE(A2))))}E3=WENN(D3="";"";SUMMEWENN($A$1:$A$10000;D3;$B$1:$B$10000))C4=WENN(ZÄHLENWENN($A$2:A4;A4)=1;1;"")D4{=WENN(ZEILE(A3)>ZÄHLENWENN($C$1:$C$10000;1);"";INDEX($A$1:$A$10000;KKLEINSTE(WENN($C$1:$C$10000=1;ZEILE($ ...
  Thema: Verständnisfrage ReguläreAusdrücke 
Phelan XLPH

Antworten: 19
Aufrufe: 708

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. Aug 2010, 16:13   Titel: AW: Verständnisfrage ReguläreAusdrücke Version: Office 2k (2000)
dito Smile
  Thema: Verständnisfrage ReguläreAusdrücke 
Phelan XLPH

Antworten: 19
Aufrufe: 708

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. Aug 2010, 15:04   Titel: AW: Verständnisfrage ReguläreAusdrücke Version: Office 2k (2000)
Mache das einmal am Anfang auf Ubound(x) und einmal am Ende mit preserve auf k

...versteh ich nicht. Confused


Nachtrag:

ich denke du meinst so:
Public Function ZiffernExtrahieren(txt As String)
Dim x() As Byte, i As Long
Dim y() As Byte, k As Long
x = StrConv(txt, vbFromUnicode)
ReDim y(UBound(x))
For i = 0 To UBound(x)
If x(i) >= 48 Then
If x(i) <= 57 Then
'ReDim Preserve y(k)
y(k) = x(i)
k = k + 1
End If
End If
Next
ReDim Preserve y(k - 1)
ZiffernExtrahieren = StrConv(y, vbUnicode)
End Function

ja ist etwas schneller.
  Thema: Sicherheitseinstellungen ändern 
Phelan XLPH

Antworten: 3
Aufrufe: 997

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. Aug 2010, 15:02   Titel: AW: Sicherheitseinstellungen ändern Version: Office 2007
Versuch es mal so:

Workbooks.Open Pfad, 0
  Thema: Was bedeutet """" 
Phelan XLPH

Antworten: 4
Aufrufe: 961

BeitragForum: Excel VBA (Makros)   Verfasst am: 27. Aug 2010, 23:46   Titel: AW: Was bedeutet """" Version: Office 2007
Wenn du Anführungszeichen in einem String darstellen möchtest musst
du den Anführungszeichen weitere Anführungszeichen voransetzen.

Bsp:
MsgBox """Hallo"""
Begrenzung des Strings
vorangestellte Anführungszeichen
sichtbare Anführungszeichen in Auswertung
  Thema: Range-Name per VBA setzen und bekommen 
Phelan XLPH

Antworten: 4
Aufrufe: 4929

BeitragForum: Excel VBA (Makros)   Verfasst am: 27. Aug 2010, 23:24   Titel: AW: Range-Name per VBA setzen und bekommen Version: Office 2003
Hallo,

Sub NamenHinzufuegen()
ThisWorkbook.Names.Add "Beispielzelle", Tabelle1.Range("B3")
End Sub

Sub NamenListen()
Dim n As Name, s As String
For Each n In ThisWorkbook.Names
s = s & vbLf & n.Name
Next
MsgBox s, , "BereichsNamen"
End Sub
 
Seite 421 von 772 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7 ... 418, 419, 420, 421, 422, 423, 424 ... 766, 767, 768, 769, 770, 771, 772  Weiter
Gehe zu:  
Alle Zeiten sind
GMT + 1 Stunde

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft-Excel Diagramme