Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Die Suche hat 11580 Ergebnisse ergeben.
Seite 478 von 772 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7 ... 475, 476, 477, 478, 479, 480, 481 ... 766, 767, 768, 769, 770, 771, 772  Weiter
Index
Autor Nachricht
  Thema: Bestimmte Spalten per Makro kopieren 
Phelan XLPH

Antworten: 13
Aufrufe: 446

BeitragForum: Excel VBA (Makros)   Verfasst am: 30. Mai 2010, 13:23   Titel: AW: Bestimmte Spalten per Makro kopieren Version: Office 2003
Nein! Hab vergessen den Kommentar zu überschreiben.

Such in der Hilfe nach "Filtern mit erweiterten Kriterien" und schau dir
da alle Beispiele für Kriterien an, damit du den Filter verstehst.

Also bei mir hat funktioniert.
  Thema: zählfunktion mit 3 bedingungen über mehrere spalten 
Phelan XLPH

Antworten: 1
Aufrufe: 1053

BeitragForum: Excel VBA (Makros)   Verfasst am: 29. Mai 2010, 02:34   Titel: AW: zählfunktion mit 3 bedingungen über mehrere spalten Version: Office 2003
Das kannst du auch als Formel haben in SpalteE:
=SUMMENPRODUKT(--(A2=0)*ODER((B2:D2<1);(B2:D2>3)))
  Thema: Zeiger auf Zeile in Textdatei 
Phelan XLPH

Antworten: 6
Aufrufe: 510

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. Mai 2010, 20:37   Titel: AW: Zeiger auf Zeile in Textdatei Version: Office 2003
oder so:

Sub ph2()
Dim fs, a, retstring, i As Long
Set fs = CreateObject("Scripting.FileSystemObject")
Set a = fs.OpenTextFile("d:\test\a100.txt", 1, False)
Do While a.AtEndOfStream <> True
If a.Line > 50000 Then _
retstring = a.ReadLine: Exit Do
a.SkipLine
Loop
a.Close
MsgBox retstring
End Sub
  Thema: Zeiger auf Zeile in Textdatei 
Phelan XLPH

Antworten: 6
Aufrufe: 510

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. Mai 2010, 17:50   Titel: AW: Zeiger auf Zeile in Textdatei Version: Office 2003
Hallo,

was besseres ist mir nicht eingefallen:

Sub ph()
Dim sPfad As String, i As Long
Dim Eingelesen As String, FF As Integer
Dim arr As Variant
sPfad = "d:\test\a100.txt" 'Anpassen
FF = FreeFile
Open sPfad For Input As #FF
Eingelesen = Input(LOF(FF), #FF)
Close #FF

arr = Split(Eingelesen, vbCrLf)

For i = 50000 To UBound(arr)
MsgBox arr(i)
Exit For
Next
End Sub
  Thema: Umwandeln von Werten einer Spalte zu einer Matrix 
Phelan XLPH

Antworten: 9
Aufrufe: 787

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. Mai 2010, 16:40   Titel: AW: Umwandeln von Werten einer Spalte zu einer Matrix Version: Office 2007
Willst du die Häufigkeit wissen oder wie, schnalls immer noch nicht?

Mach mal ein Beispiel (ohne Fehler). Damit ich daraus ein system erkennen kann.
  Thema: Bestimmte Spalten per Makro kopieren 
Phelan XLPH

Antworten: 13
Aufrufe: 446

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. Mai 2010, 16:20   Titel: AW: Bestimmte Spalten per Makro kopieren Version: Office 2003
With wkb.Worksheets("PAL") 'Anpassen ZielBlatt
.UsedRange.ClearContents
.Range("A1") = "VR" 'Anpassen ÜberschriftSpalte
.Range("A2") = "München" 'Anpassen SuchOrt
.Range("A3") = "München" 'Anpassen SuchOrt

.Range("B1") = "Faktura" 'Anpassen ÜberschriftSpalte
.Range("B2") = ">" & CLng(DateValue("01.01.2010")) 'Anpassen Datum
.Range("B2") = "=" 'Leer-Zellen

Set rngKrit = .Range("A1").CurrentRegion
Set rngCopy = .Range("A4")
End With
  Thema: Umwandeln von Werten einer Spalte zu einer Matrix 
Phelan XLPH

Antworten: 9
Aufrufe: 787

BeitragForum: Excel VBA (Makros)   Verfasst am: 28. Mai 2010, 15:22   Titel: AW: Umwandeln von Werten einer Spalte zu einer Matrix Version: Office 2007
Hallo,

versteh nicht ganz. Kannste genauer werden?
  Thema: Static und Lebendauer von Variablen innerhalb eines Moduls 
Phelan XLPH

Antworten: 12
Aufrufe: 319

BeitragForum: Excel VBA (Makros)   Verfasst am: 27. Mai 2010, 17:40   Titel: AW: Static und Lebendauer von Variablen innerhalb eines Modu Version: Office 2k (2000)
ersetze:
activesheet
durch:
Workscheets("DeineTabelle")
  Thema: Ranglisten-Feature 
Phelan XLPH

Antworten: 9
Aufrufe: 269

BeitragForum: Excel VBA (Makros)   Verfasst am: 27. Mai 2010, 13:49   Titel: AW: Ranglisten-Feature Version: Office 2003
Hallo,

Schau dir die Datei an, vielleicht hilft dir die weiter.
  Thema: Werte in Zellen ändern 
Phelan XLPH

Antworten: 12
Aufrufe: 271

BeitragForum: Excel VBA (Makros)   Verfasst am: 27. Mai 2010, 13:09   Titel: AW: Werte in Zellen ändern Version: Office 2003
Muss das VBA sein oder geht auch ne Formel:

Tabelle2  ABC1248925533872548938753036127kein Wert!7 612Formeln der TabelleZelleFormelC1=WENN(ISTFEHLER(INDEX($A$1:$A$6;B1));"kein Wert!";INDEX($A$1:$A$6;B1))C2=WENN(ISTFEHLER(INDEX($A$1:$A$6;B2));"kein Wert!";INDEX($A$1:$A$6;B2))C3=WENN(ISTFEHLER(INDEX($A$1:$A$6;B3));"kein Wert!";INDEX($A$1:$A$6;B3))C4=WENN(ISTFEHLER(INDEX($A$1:$A$6;B4));"kein Wert!";INDEX($A$1:$A$6;B4))C5=WENN(ISTFEHLER(INDEX($A$1:$A$6;B5));"kein Wert!";INDEX($A$1:$A$6;B5))C6=WENN(ISTFEHLER(INDEX($A$1:$A$6;B6));"kein Wert!";INDEX($A$1:$A$6;B6))C7=WENN(ISTFEHLER(INDEX($A$1:$A$6;B7));"kein Wert!";INDEX($A$1:$A$6;B7)) [url=http://www.office-loesung.de/ftopic91422_0_0_asc.php]Excel Jeanie Html

Beachte [B5] = Zeile 0. Kann eigentlich gar nicht entstehen oder?
  Thema: Text in Zeile mit VBA-Code "splitten" 
Phelan XLPH

Antworten: 17
Aufrufe: 2617

BeitragForum: Excel VBA (Makros)   Verfasst am: 27. Mai 2010, 12:47   Titel: AW: Text in Zeile mit VBA-Code "splitten" Version: Office 2007
Hallo,

Hab ne UDF gebastelt, ins StandardModul kopieren:
Function StringTrenn(Txt As String, pos As Integer)
Dim s As String
s = Replace(Replace(Replace(Replace(Replace(Txt, " -", " "), "(", ""), ")", ""), " ", "|"), "||", "|")
StringTrenn = Split(s, "|")(pos - 1)
End Function

Tabelle1  ABCDEFG1abcdef 2FrankreichMexiko4130Frankreich - Mexiko 4 -1 (3 - 0)Formeln der TabelleZelleFormelA2=StringTrenn($G$2;SPALTE())B2=StringTrenn($G$2;SPALTE())C2=StringTrenn($G$2;SPALTE())D2=StringTrenn($G$2;SPALTE())E2=StringTrenn($G$2;SPALTE())F2=StringTrenn($G$2;SPALTE()) [url=http://www.office-loesung.de/ftopic91422_0_0_asc.php]Excel Jeanie Html
  Thema: Werte in Zellen ändern 
Phelan XLPH

Antworten: 12
Aufrufe: 271

BeitragForum: Excel VBA (Makros)   Verfasst am: 26. Mai 2010, 14:48   Titel: AW: Werte in Zellen ändern Version: Office 2003
Sub ph()
Dim rngC As Range
For Each rngC In Range("A1:A10")
Select Case rngC
Case 20: rngC = 12
Case 22: rngC = 8
Case 58: rngC = 77
Case 12: rngC = 7
End Select
Next
End Sub
  Thema: Checkboxen in einer Dropdownliste 
Phelan XLPH

Antworten: 7
Aufrufe: 1799

BeitragForum: Excel VBA (Makros)   Verfasst am: 26. Mai 2010, 00:10   Titel: AW: Checkboxen in einer Dropdownliste Version: Office 2007
Hallo,

M.E. geht das nicht mit den gewöhnlichen Steuerelementen.
  Thema: Listenfeld ohne doppelte Einträge 
Phelan XLPH

Antworten: 4
Aufrufe: 1683

BeitragForum: Excel VBA (Makros)   Verfasst am: 25. Mai 2010, 23:54   Titel: AW: Listenfeld ohne doppelte Einträge Version: Office 2003
Hallo versuchs mal hiermit:

Sub ListfeldFuellen_Unikate_Sortiert()
Dim lbcf As ControlFormat
Dim a As Variant, arr As Variant
Dim Dic As Object

Set Dic = CreateObject("Scripting.Dictionary")

With Tabelle1
Set lbcf = .Shapes("DropDown 2").ControlFormat
arr = WorksheetFunction.Transpose( _
.Range("A2:A" & .Cells(.Rows.Count, 1).End(xlUp).Row))
End With

QSort arr, LBound(arr), UBound(arr)

lbcf.RemoveAllItems
For Each a In arr
If a <> "" Then _
If Not Dic.Exists(a) Then _
Dic(a) = 0: lbcf.AddItem a
Next

End Sub

Sub QSort(ByRef arr, low, hi)
Dim i, j, p
While low < hi
p = arr(hi)
i = low - 1
For j = low To hi - 1
If arr(j) <= p Then
i = i + 1
Swap arr, ...
  Thema: email gültigkeitsprüfung 
Phelan XLPH

Antworten: 11
Aufrufe: 1021

BeitragForum: Excel VBA (Makros)   Verfasst am: 25. Mai 2010, 23:14   Titel: AW: email gültigkeitsprüfung Version: Office 2003
Bin leider kein Hellseher, denn der Code funktioniert wie du es haben möchtest.
Musst schon mehr von deinem Code zeigen, damit ich seh was abgeändert wurde.
 
Seite 478 von 772 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7 ... 475, 476, 477, 478, 479, 480, 481 ... 766, 767, 768, 769, 770, 771, 772  Weiter
Gehe zu:  
Alle Zeiten sind
GMT + 1 Stunde

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Excel Tricks