Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Die Suche hat 1694 Ergebnisse ergeben.
Seite 6 von 113 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7, 8, 9 ... 107, 108, 109, 110, 111, 112, 113  Weiter
Index
Autor Nachricht
  Thema: "Der Remoreprozeduraufruf ist fehlgeschlagen"?? 
astern

Antworten: 12
Aufrufe: 358

BeitragForum: Access Programmierung / VBA   Verfasst am: 18. Nov 2012, 15:54   Titel: AW: "Der Remoreprozeduraufruf ist fehlgeschlagen"? Version: (keine Angabe möglich)
Ok, danke an arwe!
Dann wissen wir jetzt zwar nicht, warum Variante 2 nicht funktioniert - wir haben aber dank Nouba eine Lösung. Dann werde ich mich gleich daran machen, das in ADaMo einzuarbeiten und auf meinen Webseiten eine neue Version zum Download anbieten.
Trotzdem bin ich weiterhin daran interessiert zu erfahren, worin das Problem mit Variante 2 besteht. Hat da jemand einen Hinweis?

@Nouba: Dann ist das für mich ganz klar eine Entscheidung für DAO, denn SchnickSchnack brauche ich nicht. Ich bin mehr der "bodenständige Access-Handwerker" ;-)

MfG
A*
  Thema: Datenmodell, Beziehungen 
astern

Antworten: 32
Aufrufe: 1057

BeitragForum: Access Tabellen & Abfragen   Verfasst am: 18. Nov 2012, 15:47   Titel: Re: AW: Datenmodell, Beziehungen Version: Office 2010
Hallo!
Und genau da weiss ich nicht wie ich das realisieren soll.Da sind wir ja auch noch lange nicht. Denk an mein zweites Gebot!!
Das Datenmodell ist ja noch nicht komplett - oder!?
Du musst jetzt erst mal mit den "nackten Tabellen" arbeiten; Daten eingeben und sehen, ob Du alles, was nötig ist, in den vorhandenen Tabellen unterbringst! Wie das nachher auf dem Bildschirm in einem Formular erscheint, ist eine ganz andere Sache.

MfG
A*
  Thema: Datenmodell, Beziehungen 
astern

Antworten: 32
Aufrufe: 1057

BeitragForum: Access Tabellen & Abfragen   Verfasst am: 18. Nov 2012, 15:18   Titel: Re: AW: Datenmodell, Beziehungen Version: Office 2010
Hallo!
von mir aus gern!Damit die beiden ganz verschiedenen Themen hier nicht durcheinanderlaufen, habe ich ja den zweiten Thread angelegt. Dort habe ich jetzt auch die Version 2 der Test-DB hochgeladen. Bitte hole sie Dir und teste mal die beiden Varianten! Bitte antworte dann auch dort in dem anderen Thread!

Wenn ich in TblFertigung eine Schicht anlege, möchte ich dazu die Mischgutart auswählen und dann von welchem Mischwerk.Nein, so klappt das nicht! Die Logik ist eine andere:
Zu einer Fertigung gehört nicht eine Mischgutart, sondern ein Mischgut! Das ist eine Mischgutart von einem bestimmten Mischwerk. Du musst also

ZUERST die Tabellen tblMischwerk und tblMischgutart
DANN die Tabelle tblMischgut und
DANN erst die Tabelle tblFertigung

mit Daten füllen. Der letzte Schritt bedeutet dann, dass Du sagst: "Diese Fertigung erfolgt mit der Mischgutart X vom Mischwerk A" - und NICHT: "Diese Fertigung erfolgt mit der Mischgutart X"

In einem Formular sie ...
  Thema: "Der Remoreprozeduraufruf ist fehlgeschlagen"?? 
astern

Antworten: 12
Aufrufe: 358

BeitragForum: Access Programmierung / VBA   Verfasst am: 18. Nov 2012, 15:08   Titel: AW: "Der Remoreprozeduraufruf ist fehlgeschlagen"? Version: (keine Angabe möglich)
Hallo Nouba - danke!!
Ich habe Deinen DAO-Code (aus dem o.g. anderen Thread!) in meine Version 2 der "DBanlegen" übernommen und bitte alle, die das hier lesen, das mal zu testen.

Zu ADO: Ich habe von Anfang an immer DAO gelernt und benutzt. Dann war ich vor längerer Zeit schon mal drauf und dran, auf ADO umzusteigen, weil es so aussah, als würde Microsoft DAO eingehen lassen. Dann kam aber wieder eine neue Version von DAO und ich habe irgendwo gelesen, dass es wohl doch eine Zukunft hat. Darum bin ich erst mal bei DAO geblieben. Wie siehst Du denn das? Umstieg auf ADO? Beides benutzen? Oder ist sogar was ganz Neues in Aussicht??

MfG
A*
  Thema: Datenmodell, Beziehungen 
astern

Antworten: 32
Aufrufe: 1057

BeitragForum: Access Tabellen & Abfragen   Verfasst am: 18. Nov 2012, 11:29   Titel: AW: Datenmodell, Beziehungen Version: Office 2010
Hmm,
das ist sehr merkwürdig.
Ich habe dazu mal einen neuen Thread aufgemacht:
[url=http://www.office-loesung.de/ftopic560198_0_0_asc.php]"Der Remoreprozeduraufruf ist fehlgeschlagen"??

MfG
A*

@Nouba: Danke für den Tipp. Werde ich mal ausprobieren. Kannst Du mal ein komplettes Codebeispiel zum Anlegen einer DB mit VBA posten? Sonst muss ich erst wieder lange rumbasteln.
Aber trotzdem wundert es mich, dass mein Code meistens funktioniert, in diesem Fall aber nicht. Funktioniert denn meine Test-DB bei Dir?

Am aller-super-tollsten wäre folgendes: Nouba lädt eine verbesserte Version meiner "DBanlegen" hoch (aber bitte mit DAO-Technik - so radikal wollen dann doch nicht gleich sein ;-), arwe probiert sie bei sich aus und wenn das funktioniert, stelle ich auf meinen Webseiten gleich eine neue ADaMo-Version zur Verfügung. Kriegen wir das hin?
  Thema: "Der Remoreprozeduraufruf ist fehlgeschlagen"?? 
astern

Antworten: 12
Aufrufe: 358

BeitragForum: Access Programmierung / VBA   Verfasst am: 18. Nov 2012, 11:28   Titel: "Der Remoreprozeduraufruf ist fehlgeschlagen"?? Version: (keine Angabe möglich)
Hallo Leute!
Ich bin in einem anderen Thread: Die Frage: Kann mir jemand sagen, was die Ursache für die Fehlermeldung sein könnte?

Die Bitte: Ich habe den fraglichen Code aus ADaMo extrahiert und daraus eine kleine Beispiel-DB gebastelt, die man in dem o.g. Thread downloaden kann ("DBanlegen.zip"). Bitte holt Euch die DB und probiert sie aus. Dann würde ich mich sehr über Rückmeldungen freuen mit folgenden Infos:

Windows-Version: ...
Access-Version: ...
"kein Fehler" oder wenn Fehler, dann welche Meldung: ...

Danke schon mal im Voraus!
A*
  Thema: Datenmodell, Beziehungen 
astern

Antworten: 32
Aufrufe: 1057

BeitragForum: Access Tabellen & Abfragen   Verfasst am: 17. Nov 2012, 23:38   Titel: Re: AW: Datenmodell, Beziehungen Version: Office 2010
Nachdem ich auf "Tabelle anlegen" geklickt habe, kommt die Fehlermeldung wie im Anhang
Hmmm, daraus kann man natürlich GAR NICHTS entnehmen. Ich lade hier mal eine kleine Test-DB hoch. Darin ist der Code, den ich auch in ADaMo benutze. Ich würde Dich bitten, das mal auszuprobieren und mir zu sagen, was für eine Fehlermeldung kommt.

Danke!
A*

PS: Hallo derArb! Bin wieder mal kurz da - hab viel zu tun (u.a. Vorbereitung der vierten Auflage meines Buches ;-)) und leider nicht genug Zeit für's Forum ... soll aber irgendwann mal wieder besser werden ...
  Thema: Datenmodell, Beziehungen 
astern

Antworten: 32
Aufrufe: 1057

BeitragForum: Access Tabellen & Abfragen   Verfasst am: 17. Nov 2012, 22:22   Titel: Re: AW: Datenmodell, Beziehungen Version: Office 2010
Ich werde das heute Abend gleich noch mal testenDazu versuchst Du am besten, die Daten von realen Fällen in die Tabellen einzugeben und guckst mal, ob das hinkommt!
Leider ist die Anwendung beim Tabelleschreiben immer abgestürzt.Das habe ich noch nie gehört. Kannst Du mir dazu Genaueres sagen? Ich bin natürlich sehr daran interessiert, dass ADaMo zuverlässig funktioniert. Welche Access- und Windows-Versionen benutzt Du? Was passiert genau beim Absturz? Welche Fehlermeldung kommt in welcher Situation?

So, jetzt muss ich aber zurück an die Glotze, "Schlag den Raab" gucken ;-)
In der Werbepause guck' ich dann nochmal, ob Du was Neues geschrieben hast.

MfG
A*
  Thema: Datenmodell, Beziehungen 
astern

Antworten: 32
Aufrufe: 1057

BeitragForum: Access Tabellen & Abfragen   Verfasst am: 17. Nov 2012, 20:50   Titel: AW: Datenmodell, Beziehungen Version: Office 2010
So,
hier kommt ein erster Entwurf:

Zentrale Tabelle ist die tblFertigung; sie hält fest, dass in einem bestimmten Abschnitt eine bestimmte Schichtart mit einer bestimmten Mischgutart von einem bestimmten Fertigertyp hergestellt wird - mit einer bestimmten Geschwindigkeit.

Die Tabelle tblBauphase ist eine rekursive Tabelle. Sie enthält einen Fremdschlüssel auf sich selber ("tblBauphase_1"). Damit kannst Du Unterphasen in beliebiger Tiefe speichern (ist aber nur ein Gimmick - muss man nicht so machen!)

Die DB ist übrigens im alten .mdb-Format. Das wird hier gerne so gemacht, weil manche Leute noch mit Access 2003 arbeiten und die könnten sich das dann nicht ansehen. Du kannst das ja später in .accdb umwandeln.

Wenn Du an der DB was veränderst und sie wieder hochlädst, nenn sie bitte "Strassenbau-v02.mdb"!

Schau's Dir mal an!

MfG
A*
Hallo!
Mir ist da gerade noch ein Denkfehler aufgefallen: Die Fertigung erfolgt nicht mit einer Mischgutart, sonder ...
  Thema: Datenmodell, Beziehungen 
astern

Antworten: 32
Aufrufe: 1057

BeitragForum: Access Tabellen & Abfragen   Verfasst am: 17. Nov 2012, 20:25   Titel: Re: AW: Datenmodell, Beziehungen Version: Office 2010
Hallo!
Die Herstellung der Mischgute dauert unterschiedlich langeHängt das nur von der Mischgutart ab oder auch vom Mischwerk?
D.h. braucht u.U. Mischwerk A für die Herstellung der Mischgutart X länger als Mischwerk B?

MfG
A*
  Thema: Datenmodell, Beziehungen 
astern

Antworten: 32
Aufrufe: 1057

BeitragForum: Access Tabellen & Abfragen   Verfasst am: 17. Nov 2012, 19:16   Titel: AW: Datenmodell, Beziehungen Version: Office 2010
Hallo!
Du hast zumindest gegen mein 2. Gebot verstoßen - ob auch gegen das 1. weiß ich noch nicht. Dein Datenmodell ist ja nun schon ziemlich umfangreich; daher gibt es zwei Möglichkeiten:
(1) Du schmeißt alle Abfragen und Formulare weg und wir bringen erst mal das Datenmodell in Ordnung. Dafür müsstest Du AUSFÜHRLICH und für den Nicht-Eingeweihten VERSTÄNDLICH (d.h. ohne Fachchinesisch) Deine KOMPLETTE Problematik beschreiben.
(2) Du willst nur eine Antwort auf Deine konkrete Frage, die ja wohl nur 3-4 Tabellen betrifft. Auch dann müsstest Du die entsprechende Teilproblematik AUSFÜHRLICH und VERSTÄNDLICH beschreiben.
(z.B. Was ist eine Einbauschicht? Was verstehst Du unter der Einbaugeschwindigkeit? Wieso produzieren die Mischwerke pro Einbauschicht? usw. usw.)

Wichtig ist in jedem Fall: AUSFÜHRLICH - VERSTÄNDLICH - KOMPLETT!
Wenn ich beim Datenmodell behilflich sein soll, muss ich mich in die Problematik hineindenken können. Irgendwelche Probleme mit Formularen stehen jetzt ...
  Thema: Brauche hilfe bei einer UserForm 
astern

Antworten: 22
Aufrufe: 694

BeitragForum: Excel VBA (Makros)   Verfasst am: 21. Sep 2012, 20:33   Titel: Re: AW: Brauche hilfe bei einer UserForm Version: (keine Angabe möglich)
Ich hoffe Du verstehst was ich damit sagen möchte.
Ehrlich gesagt - nicht so richtig.
Das mit dem Scanner hattest Du bisher nicht erwähnt (oder ich hab's überlesen ...).
Am besten, Du beschreibst NOCHMAL VOLLSTÄNDIG was Du in welcher Reihenfolge machen willst und was Excel dabei tun soll. Dadurch, dass ich immer häppchenweise etwas Neues erfahre, reden wir ständig aneinander vorbei.

MfG
A*
  Thema: Button: Zeile einfügen 
astern

Antworten: 15
Aufrufe: 495

BeitragForum: Excel VBA (Makros)   Verfasst am: 21. Sep 2012, 19:53   Titel: AW: Button: Zeile einfügen Version: Office 2010
Hallo!
Auch von mir nochmal ein "Alle Achtung!"
Das ist echt beeindruckend programmiert!

MfG
A*
  Thema: Brauche hilfe bei einer UserForm 
astern

Antworten: 22
Aufrufe: 694

BeitragForum: Excel VBA (Makros)   Verfasst am: 21. Sep 2012, 16:04   Titel: AW: Brauche hilfe bei einer UserForm Version: (keine Angabe möglich)
Hallo!
Ich habe das Formular nochmal KOMPLETT überarbeitet.
Probier's mal aus!

MfG
A*
  Thema: Brauche hilfe bei einer UserForm 
astern

Antworten: 22
Aufrufe: 694

BeitragForum: Excel VBA (Makros)   Verfasst am: 21. Sep 2012, 10:29   Titel: Re: AW: Brauche hilfe bei einer UserForm Version: (keine Angabe möglich)
Hallo!
Ich habe es mal versucht zu ändern
Das kleine "v" im Dateinamen bedeutet "Version"! Wenn ich Dir eine Version 3 schicke und Du änderst etwas daran, dann ist es nicht mehr Version 3, sondern Version 4!

2. ... Wieder rum muss der Button Einlesen auch anklickbar sein damit der Lagerplatz in die Tabelle geschrieben wird das klappt nun auch schon.
Falsch! Der Button "Einlesen" dient dazu, die bisher noch NICHT erfasste Maschine als letzte Zeile der Liste anzufügen!
Nun soll aber die Meldung in der InfoBox stehen "Maschine Eingelagert"

Habe ich geändert.

3. ... Nun ist es so wenn ich nun auf den Button "Einlesen" klicke soll ... aber auch die Meldung in der InfoBox kommen "Maschine erfasst"
Habe ich geändert.

MfG
A*
 
Seite 6 von 113 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7, 8, 9 ... 107, 108, 109, 110, 111, 112, 113  Weiter
Gehe zu:  
Alle Zeiten sind
GMT + 1 Stunde

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: JavaScript